Tirerack
Use the following links to go directly to useful tirerack winter items: Tirerack Winter Tires. Gary's Winter Tire FAQ.
Using the links directly supports E90Post with tirerack sales commision!

  E90Post
 


TireRack

   PLEASE HELP SUPPORT E90POST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Wheels and Tires Forum Sponsored by The Tire Rack > HELP! TPMS malfunction not going away



Wheels and Tires forum Sponsored by The Tire Rack
Please help to directly support e90post by doing your tirerack shopping from the above link. For every sale made through the link, e90post gets sponsor support to keep the site alive. Disclaimer

Reply
 
Thread Tools Search this Thread
      01-03-2011, 12:57 AM   #1
jahmed78
First Lieutenant
jahmed78's Avatar
United_States
16
Rep
299
Posts

 
Drives: 2007 BMW e90 335i
Join Date: Oct 2010
Location: San Diego, CA

iTrader: (6)

HELP! TPMS malfunction not going away

I installed front lowering perches and put 5mm spacers in the rear. I now have a TPMS malfunction light, but not sure why. I tried resetting via i-drive to no avail. i also tried disconnecting the battery. still have the light and it says TPM malfunction. any ideas?
__________________
2007 335i e90 - black on black w/wood trim and iDrive

19" BMW M-Performance wheels, ST coilovers, m3 rep front bumper and skirts, CF Hamann rep diffuser, Remus Race quad exhaust, aFe DCI, LED angel eyes & DRL kit,
Appreciate 0
      01-03-2011, 01:52 AM   #2
Tag
Colonel
Tag's Avatar
United_States
113
Rep
2,626
Posts

 
Drives: bimmer
Join Date: Jan 2007
Location: CHICAGO

iTrader: (2)

Did you drive it for a little while after resetting it?
Appreciate 0
      01-03-2011, 01:59 AM   #3
jahmed78
First Lieutenant
jahmed78's Avatar
United_States
16
Rep
299
Posts

 
Drives: 2007 BMW e90 335i
Join Date: Oct 2010
Location: San Diego, CA

iTrader: (6)

Quote:
Originally Posted by tag824 View Post
Did you drive it for a little while after resetting it?
yup...drove for 5 mins, then reset again and drove for an hour. still there
__________________
2007 335i e90 - black on black w/wood trim and iDrive

19" BMW M-Performance wheels, ST coilovers, m3 rep front bumper and skirts, CF Hamann rep diffuser, Remus Race quad exhaust, aFe DCI, LED angel eyes & DRL kit,
Appreciate 0
      01-03-2011, 02:21 AM   #4
Tag
Colonel
Tag's Avatar
United_States
113
Rep
2,626
Posts

 
Drives: bimmer
Join Date: Jan 2007
Location: CHICAGO

iTrader: (2)

Try checking the pressure in all four tires tomorrow when they are cold and fill them up if needed then reset and see if that works. If you're still having issues I would take it in, hopefully you're still under warranty.

Only problem I can think of is you have a tire that's could have a slow leak or you have the wrong type of sensors in the wheels, but it doesn't sound like you changed your TPMS out.
Appreciate 0
      01-03-2011, 02:25 AM   #5
jahmed78
First Lieutenant
jahmed78's Avatar
United_States
16
Rep
299
Posts

 
Drives: 2007 BMW e90 335i
Join Date: Oct 2010
Location: San Diego, CA

iTrader: (6)

one of the valve stems is missing in the rear tire and the car was jacked up on its rears for two days...but when i checked pressure in the morning all the wheels were fine ~40psi. i guess i'll check again and get a valve stem cap tomorrow. hope its nothing big.
__________________
2007 335i e90 - black on black w/wood trim and iDrive

19" BMW M-Performance wheels, ST coilovers, m3 rep front bumper and skirts, CF Hamann rep diffuser, Remus Race quad exhaust, aFe DCI, LED angel eyes & DRL kit,
Appreciate 0
      01-03-2011, 09:39 AM   #6
ceb
NHTSA Nazi
21
Rep
1,979
Posts

 
Drives: 335ix
Join Date: Aug 2009
Location: MD

iTrader: (1)

IIRC, pre-2010 BMWs have a receiver in the fender (fender liner?) Could that have been damaged during your install?
Appreciate 0
      01-03-2011, 01:53 PM   #7
jahmed78
First Lieutenant
jahmed78's Avatar
United_States
16
Rep
299
Posts

 
Drives: 2007 BMW e90 335i
Join Date: Oct 2010
Location: San Diego, CA

iTrader: (6)

Quote:
Originally Posted by ceb View Post
IIRC, pre-2010 BMWs have a receiver in the fender (fender liner?) Could that have been damaged during your install?
ur a genius!

my friend who helped me apparently had loosened the fender liner and in the process unhooked the wire to this receiver. i always thought that thing was for fog lights! i was able to reset via i-drive once i hooked it back up this morning.

thanks!!! can always rely on the trusty e90post folks lol
__________________
2007 335i e90 - black on black w/wood trim and iDrive

19" BMW M-Performance wheels, ST coilovers, m3 rep front bumper and skirts, CF Hamann rep diffuser, Remus Race quad exhaust, aFe DCI, LED angel eyes & DRL kit,
Appreciate 0
      01-03-2011, 08:58 PM   #8
ceb
NHTSA Nazi
21
Rep
1,979
Posts

 
Drives: 335ix
Join Date: Aug 2009
Location: MD

iTrader: (1)

Quote:
Originally Posted by jahmed78 View Post
ur a genius!

my friend who helped me apparently had loosened the fender liner and in the process unhooked the wire to this receiver. i always thought that thing was for fog lights! i was able to reset via i-drive once i hooked it back up this morning.

thanks!!! can always rely on the trusty e90post folks lol
Woo-hoo. I was right for a change. I'm glad I could help.

2010 and newer versions use a different sensor and receiver. No more receivers at each corner.
Appreciate 0
      12-07-2011, 02:20 AM   #9
kennethpetro
Lieutenant
United_States
6
Rep
419
Posts

 
Drives: 2011 328i JB/Black Dakota
Join Date: Apr 2008
Location: North Jersey

iTrader: (2)

Quote:
Originally Posted by ceb View Post
Woo-hoo. I was right for a change. I'm glad I could help.

2010 and newer versions use a different sensor and receiver. No more receivers at each corner.
Do you know where the TPMS receiver(s) are located on a 2011 LCI E92? My TPMS has been malfunctioning ever since i installed my HID Fogs! I've tried to look for a sensor in the front bumper, but i wasn't able to find anything that remotely looked like a sensor....Help anyone????
__________________
2011 Jet Black 328i, 6-Speed Manual, Black Dakota Leather, Brushed Aluminum, Harmon Kardon w/ Surround Sound, Navi, BMW Apps, iPod & USB Adapter, BMW Assist w/ Bluetooth, Full LED Interior, 6000k HID Fogs, Matte Black Kidney Grills, M3 Lip Spoiler, ACS Roof Spoiler, 19" Beyern Black Mesh *19x8.5 front(ET40)* *19x9.5 rear(ET30)*
Appreciate 0
      06-20-2012, 11:16 PM   #10
ultraslan
Private First Class
2
Rep
129
Posts

 
Drives: 2007 BMW 335i
Join Date: Mar 2010
Location: Canada

iTrader: (0)

Where are the TPM receivers are located? I am having the same problem.. TPM malfunction wont go away .
Appreciate 0
      06-26-2012, 12:16 AM   #11
bavarianx
BimmerPost Supporting Vendor
bavarianx's Avatar
United_States
93
Rep
2,058
Posts


 
Drives: 2006 X5 4.4i
Join Date: Dec 2006
Location: Orange County, CA

iTrader: (18)

Send a message via AIM to bavarianx
Quote:
Originally Posted by ultraslan View Post
Where are the TPM receivers are located? I am having the same problem.. TPM malfunction wont go away .
on your car there is one in each fender, the fronts are on the front fender liner.
Appreciate 0
      06-29-2012, 12:11 AM   #12
ultraslan
Private First Class
2
Rep
129
Posts

 
Drives: 2007 BMW 335i
Join Date: Mar 2010
Location: Canada

iTrader: (0)

Quote:
Originally Posted by bavarianx View Post
on your car there is one in each fender, the fronts are on the front fender liner.
could you be more specific please. i am sorry if this is a stupid question, I am not that advanced with the cars. thanks
Appreciate 0
      06-29-2012, 11:55 AM   #13
beskone
Captain
beskone's Avatar
United_States
24
Rep
915
Posts

 
Drives: LeMans BLue e92 335i LCI
Join Date: Oct 2008
Location: Los Angeles, CA

iTrader: (2)

Garage List
2012 e92 335i LCI  [0.00]
2009 e92 328i  [5.00]
Quote:
Originally Posted by ultraslan View Post
could you be more specific please. i am sorry if this is a stupid question, I am not that advanced with the cars. thanks
+1 I'm having a TPMS issue and would love to know the exact positions of the sensors on a 2012 e92 LCI
__________________

e92 LCI LeMans Blue Saddle Brown Bamboo Anthracite Performance Grilles CF Performance Spoiler CF Performance Diffuser ACS Style Roof Spoiler LED Interior Lighting BMS Clutch Stop BMS Intake BMS CDV BMW Performance Exhaust ST V1 Coilovers Miro 111 Staggered More to come!
Appreciate 0
      07-01-2012, 07:43 PM   #14
ultraslan
Private First Class
2
Rep
129
Posts

 
Drives: 2007 BMW 335i
Join Date: Mar 2010
Location: Canada

iTrader: (0)

Quote:
Originally Posted by beskone View Post
+1 I'm having a TPMS issue and would love to know the exact positions of the sensors on a 2012 e92 LCI
have tried taking it to the dealer?
Appreciate 0
      07-01-2012, 08:22 PM   #15
mcpcolas
First Lieutenant
mcpcolas's Avatar
United_States
5
Rep
370
Posts

 
Drives: 2009 montego blue 335i xdrive
Join Date: Apr 2012
Location: new jersey

iTrader: (0)

Quote:
Originally Posted by ceb View Post
IIRC, pre-2010 BMWs have a receiver in the fender (fender liner?) Could that have been damaged during your install?
it's most definitely that ,i had HID fog light installed and the idiot who installed the fog put the ballast right next to the receiver. when my tpms malfunction warning came on and refused to reset, i took the car in for service. dealer told me the ballast for the fog got so hot that it melted the receiver, and that they wont replace it since it is cause by an aftermarket part. can i hold the shop reliable? and ask them to pay to get my car fix
Appreciate 0
      10-20-2012, 01:36 AM   #16
kgroschi
Lieutenant
kgroschi's Avatar
Germany
7
Rep
444
Posts

 
Drives: 08 M5 [GONE], now '09 E90 335i
Join Date: Feb 2012
Location: California, USA (Born in Munich, Germany)

iTrader: (0)

Also had my angel eye bulbs replaced with white angel eye lights and have the same issue.

Where and how exactly can I reconnect the system?

Thank you.
Appreciate 0
      10-21-2012, 12:54 PM   #17
6spdcoupe
Second Lieutenant
6spdcoupe's Avatar
United_States
2
Rep
250
Posts

 
Drives: '08 TBSS, '06 E55, '13 CX-9
Join Date: Nov 2009
Location: Central Jersey

iTrader: (1)

or just have it coded out. it's not all that helpful anyway. still need a gauge to fill it, might as well use a gauge to test it..
__________________

Kenwood DNN991HD >Helix DSP PRO
Brax Matrix MX4 ..Micro-Precision 7.16 MKIII/ Focal 33KX
Brax Matrix MX4 ..Dynaudio Esotar 110/430
Appreciate 0
      11-09-2012, 07:57 PM   #18
kgroschi
Lieutenant
kgroschi's Avatar
Germany
7
Rep
444
Posts

 
Drives: 08 M5 [GONE], now '09 E90 335i
Join Date: Feb 2012
Location: California, USA (Born in Munich, Germany)

iTrader: (0)

Do we have any more answers guys please? Also installed white angel eyes in my 09 E90 and have the malfunction now. What can I do to fix it?
Appreciate 0
      05-11-2014, 07:00 PM   #19
Kooshi3
Private First Class
2
Rep
167
Posts

 
Drives: '09 Jet Black 335i (E92)
Join Date: Nov 2013
Location: United States

iTrader: (7)

I wanted to bump this old thread.

I did a FMIC installation and when I put everything back together I started getting the TPM Malfunction error.

Referencing this thread I saw that many mentioned the possibility of the sensor plugs being loose so I took off the bumper today to test this. When I did, I saw that one was somewhat loose so I reattached it.

No fix. Disconnected both, reset the ecu then put them back in both. No fix.

Any ideas, could I have damaged the sensor in someway on the fender liners or is there anything I could be missing. Your help is greatly appreciated as I'm feeling right now not being able to figure this out.
Appreciate 0
Reply

Bookmarks

Tags
tpms

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:23 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST