E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Red car on lift and BRAKE light??



Reply
 
Thread Tools Search this Thread
      11-10-2012, 07:48 PM   #1
svg95gt
Private First Class
United_States
1

 
Drives: 2007 E90 ZSP
Join Date: Mar 2012
Location: Kansas City


Posts: 124
iTrader: (0)

Red car on lift and BRAKE light??

Got in my 07 335i today and got these warnings...
Doing some searches and found that it may be brake pads/fluid level. Is that accurate? How much is a brake job?
I bought the car 6 mo ago with new (appearing) rear rotors and the fronts looked worn, but not worn out. The front rotors do have a bit of lip from the pads wearing them down.
Since it's Saturday, is it safe to drive until I can get it in?

I've also been getting random yellow engine light that I attribute to the JB+ being installed (did the bypass and it comes up less often, but still comes on). Is there any correlation?

Thanks in advance for the help!
__________________
JB+, BMS DCI
Appreciate 0
      11-10-2012, 08:13 PM   #2
svg95gt
Private First Class
United_States
1

 
Drives: 2007 E90 ZSP
Join Date: Mar 2012
Location: Kansas City


Posts: 124
iTrader: (0)

Also, I've noticed some hesitation when at a stop light. Doesn't seem to matter if the the engine is warm or not or on a hill or not. I'm inclined to think SIB 24 03 08 would fix. Maybe just the hill control?
The brakes have also squeeked since day one. Drives me nuts. I asked when I had my oil changed a couple months ago and the SA said they were fine. Now I have a brake light???
__________________
JB+, BMS DCI
Appreciate 0
      11-11-2012, 05:39 AM   #3
Ethanderall
Private
0

 
Drives: 2006 325i
Join Date: Jan 2012
Location: Gold Coast, AU


Posts: 51
iTrader: (0)

I thought the red car on lift was the annual(?) inspection indicator?

The brake indicator kinda looks like (0) and the brake fluid level indicator shows similar but with a fluid in the centre.
Appreciate 0
      11-11-2012, 10:25 AM   #4
fravel
Captain
United_States
6

 
fravel's Avatar
 
Drives: Monaco Blue '06 330i
Join Date: Aug 2012
Location: The Nasti 'Nati


Posts: 646
iTrader: (0)

My car showed that one time because my brake sensor cable had been rubbing on the wheel and got torn
__________________
Appreciate 0
      11-11-2012, 12:07 PM   #5
mump
Second Lieutenant
United_States
2

 
mump's Avatar
 
Drives: '11 E93 335is/'01 986S/'13 F30
Join Date: Jul 2012
Location: Johnstown, PA


Posts: 296
iTrader: (5)

Quote:
Originally Posted by fravel View Post
My car showed that one time because my brake sensor cable had been rubbing on the wheel and got torn
Just fixed this today. Brake light means the sensor is tripped. For my wife's car, this happen a couple months ago, pads wore down and sensor exposed. For mine, sensor wire rubbed my wheel.

For the red car light, means you need service. Yellow means it is almost time.
Appreciate 0
      11-11-2012, 12:36 PM   #6
svg95gt
Private First Class
United_States
1

 
Drives: 2007 E90 ZSP
Join Date: Mar 2012
Location: Kansas City


Posts: 124
iTrader: (0)

I guess I am to assume since I never got a yellow light that something happened and both lights came on bc of it?
I've also been seeing that other pple have a pic/light of the front or rear when the pads are due. Mine does not. So I am assuming something with the sensor is wrong/broken.
__________________
JB+, BMS DCI
Appreciate 0
      11-11-2012, 12:39 PM   #7
mump
Second Lieutenant
United_States
2

 
mump's Avatar
 
Drives: '11 E93 335is/'01 986S/'13 F30
Join Date: Jul 2012
Location: Johnstown, PA


Posts: 296
iTrader: (5)

It was my rear sensor that was damaged but both my front and rear brakes that were showing on the display. Bought a new sensor, jacked up the car, replaced, and then reset my service light. Shut off the car, restarted. Light is now gone.
Appreciate 0
      11-11-2012, 12:44 PM   #8
svg95gt
Private First Class
United_States
1

 
Drives: 2007 E90 ZSP
Join Date: Mar 2012
Location: Kansas City


Posts: 124
iTrader: (0)

I'm sure mine could use new pads in the front and possibly new rotors...any ideas what the dealer would charge? I"m not afraid to do it myself, but if it's not horrible I'd just have them do it.

Thanks all!!!
__________________
JB+, BMS DCI
Appreciate 0
      11-11-2012, 12:47 PM   #9
idrift4wd
Brigadier General
44

 
Drives: Three Hundred and Thirty Five
Join Date: Jul 2010
Location: Yonkers NY


Posts: 3,373
iTrader: (0)

Garage List
2007 BMW  [3.50]
Quote:
Originally Posted by svg95gt View Post
I'm sure mine could use new pads in the front and possibly new rotors...any ideas what the dealer would charge? I"m not afraid to do it myself, but if it's not horrible I'd just have them do it.

Thanks all!!!
Too much. Where probably replacing a rear set by them you can do all four corners with performance brake products. (drilled/slotted rotors & Performance pads & racing brake fluid)
Appreciate 0
      11-11-2012, 12:49 PM   #10
svg95gt
Private First Class
United_States
1

 
Drives: 2007 E90 ZSP
Join Date: Mar 2012
Location: Kansas City


Posts: 124
iTrader: (0)

Quote:
Originally Posted by idrift4wd View Post
Too much. Where probably replacing a rear set by them you can do all four corners with performance brake products. (drilled/slotted rotors & Performance pads & racing brake fluid)
Where is a good place to get that stuff? Been looking for a while anyway. If it's that much I might as well just do it.
__________________
JB+, BMS DCI
Appreciate 0
      11-11-2012, 01:11 PM   #11
mump
Second Lieutenant
United_States
2

 
mump's Avatar
 
Drives: '11 E93 335is/'01 986S/'13 F30
Join Date: Jul 2012
Location: Johnstown, PA


Posts: 296
iTrader: (5)

There are a couple good vendors here.... Top gear solutions got me the stuff I wanted quick and well priced.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:38 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST