E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Stuttering under Acceleration



Reply
 
Thread Tools Search this Thread
      11-13-2012, 10:38 PM   #1
335i Pal
Second Lieutenant
United_States
15

 
335i Pal's Avatar
 
Drives: 335i Sedan
Join Date: Oct 2010
Location: Ohio


Posts: 284
iTrader: (1)

Stuttering under Acceleration

I have noticed under medium to slightly hard acceleration that my car stutters where it almost feels like small and quick speed bumps. It is not shaking the whole car by any means but I feel it mostly through the gas pedal. While WOT I do not feel anything. This happened both when I had my JB4 in and without.

I know it is hard to diagnose from just my description, but just wondering if anyone else has had a similar issue, not sure if it is an engine issue or possible a transmission issue.


2007 335i e90
JB4
BMS DCI
Not sure if important but new turbos under warranty.
__________________
335i E90 | BMS DCI | Black Matte Grill | JB4 | Logic 7 | Sport | Premium | Cold |
Appreciate 0
      11-13-2012, 10:52 PM   #2
Badboy8813
Private
3

 
Drives: f10 2012 550i
Join Date: Sep 2011
Location: Nashville


Posts: 74
iTrader: (1)

Quote:
Originally Posted by 335i Pal
I have noticed under medium to slightly hard acceleration that my car stutters where it almost feels like small and quick speed bumps. It is not shaking the whole car by any means but I feel it mostly through the gas pedal. While WOT I do not feel anything. This happened both when I had my JB4 in and without.

I know it is hard to diagnose from just my description, but just wondering if anyone else has had a similar issue, not sure if it is an engine issue or possible a transmission issue.


2007 335i e90
JB4
BMS DCI
Not sure if important but new turbos under warranty.
Sounds like its time for you to do the walnut shell blast. I had the same exact problem and it fixed it for me.
__________________
'12 F10 550i 20x9/20x10.5 BBS CH-R wheels, Brembo Big Brakes from Dinan, Dinan Air to Water Intercooler, Dinan Stage 3 Tune, H&R Springs, Carbon Fiber decklid, Black 550i badges, Black side badges, Black grill, Tinted windows, and Active Autowerke Exhaust
Appreciate 0
      11-13-2012, 11:35 PM   #3
335i Pal
Second Lieutenant
United_States
15

 
335i Pal's Avatar
 
Drives: 335i Sedan
Join Date: Oct 2010
Location: Ohio


Posts: 284
iTrader: (1)

Quote:
Originally Posted by Badboy8813 View Post
Sounds like its time for you to do the walnut shell blast. I had the same exact problem and it fixed it for me.
Didn't think of that, I figured it was some sort of transmission problem and figured it was time to change the fluid, especially since it never has been changed.
__________________
335i E90 | BMS DCI | Black Matte Grill | JB4 | Logic 7 | Sport | Premium | Cold |
Appreciate 0
      11-14-2012, 12:00 AM   #4
galahad05
Colonel
26

 
galahad05's Avatar
 
Drives: '07 335i e90
Join Date: Mar 2008
Location: Long Island NY


Posts: 2,504
iTrader: (0)

How many miles on the car? The intake valve carbon fouling, if it happens, often occurs around 50-60k miles.
__________________
Always laugh when you can. It is cheap medicine
--Lord Byron
Appreciate 0
      11-14-2012, 12:02 AM   #5
335i Pal
Second Lieutenant
United_States
15

 
335i Pal's Avatar
 
Drives: 335i Sedan
Join Date: Oct 2010
Location: Ohio


Posts: 284
iTrader: (1)

Quote:
Originally Posted by galahad05 View Post
How many miles on the car? The intake valve carbon fouling, if it happens, often occurs around 50-60k miles.
75,000 Miles
__________________
335i E90 | BMS DCI | Black Matte Grill | JB4 | Logic 7 | Sport | Premium | Cold |
Appreciate 0
      11-14-2012, 12:42 PM   #6
See5
Real Goon
United_States
17

 
See5's Avatar
 
Drives: Nothing
Join Date: Jul 2011
Location: Atlanta


Posts: 383
iTrader: (0)

I have the same thing. Replaced the spark plugs. No help. Pretty sure the intake ports need to be cleaned. I'm at 58K.

Last edited by See5; 11-14-2012 at 12:52 PM.
Appreciate 0
      11-14-2012, 01:02 PM   #7
335i Pal
Second Lieutenant
United_States
15

 
335i Pal's Avatar
 
Drives: 335i Sedan
Join Date: Oct 2010
Location: Ohio


Posts: 284
iTrader: (1)

Quote:
Originally Posted by See5 View Post
I have the same thing. Replaced the spark plugs. No help. Pretty sure the intake ports need to be cleaned. I'm at 58K.
Just did the plugs early summer, so sounds like intake cleaning it is, unless anyone else has a suggestion.


I know there is a DYI for the valve cleaning, is it pretty easy from other members prospective?
__________________
335i E90 | BMS DCI | Black Matte Grill | JB4 | Logic 7 | Sport | Premium | Cold |
Appreciate 0
      11-15-2012, 11:43 AM   #8
e90Luis
Private First Class
8

 
Drives: e92 335i
Join Date: Apr 2010
Location: Atlanta, GA


Posts: 181
iTrader: (1)

Quote:
Originally Posted by 335i Pal View Post
Just did the plugs early summer, so sounds like intake cleaning it is, unless anyone else has a suggestion.


I know there is a DYI for the valve cleaning, is it pretty easy from other members prospective?
Had the same problem at 48000 miles and had the walnut blasting and it seemed to have fixed the problem for a few days. I'm at 56000 miles now and the car was jerking under moderate acceleration again. Took it to the dealer and did an oil change and replaced the mechatronic sleeve since it was leaking. It looks like that might have fixed the problem.
Appreciate 0
      11-15-2012, 12:17 PM   #9
AndyR83
Major
43

 
AndyR83's Avatar
 
Drives: E92 335i FBO
Join Date: Oct 2011
Location: PA


Posts: 1,025
iTrader: (5)

I had this problem and it ended up being an oil filter that basically fell apart and was gunking up the works. New oil filter and an oil change fixed it.
Appreciate 0
      11-15-2012, 01:59 PM   #10
Braumin
First Lieutenant
9

 
Drives: 2009 335i xDrive Sedan
Join Date: Oct 2012
Location: Regina, SK, CAN


Posts: 321
iTrader: (0)

Back when I used to turn wrenches for a living, we had an intake cleaning system that you would mount on the throttle body, and it would inject a cleaning solution into the engine while it was running (think Carb Cleaner x 1000). It did a great job cleaning the intake manifold, and I assume the valves as well.

Has anyone tried this as preventative maintenance rather than waiting for the carbon build up to be a big enough problem to need a walnut blasting?
Appreciate 0
      11-15-2012, 02:00 PM   #11
iamblowfish
New Member
2

 
Drives: submarine
Join Date: Oct 2011
Location: somewhere on the beach


Posts: 5
iTrader: (0)

Quote:
Originally Posted by galahad05 View Post
How many miles on the car? The intake valve carbon fouling, if it happens, often occurs around 50-60k miles.
This
Have you tried Walnut Shell Blasting
Appreciate 0
      11-15-2012, 04:54 PM   #12
335i Pal
Second Lieutenant
United_States
15

 
335i Pal's Avatar
 
Drives: 335i Sedan
Join Date: Oct 2010
Location: Ohio


Posts: 284
iTrader: (1)

Quote:
Originally Posted by e90Luis View Post
Had the same problem at 48000 miles and had the walnut blasting and it seemed to have fixed the problem for a few days. I'm at 56000 miles now and the car was jerking under moderate acceleration again. Took it to the dealer and did an oil change and replaced the mechatronic sleeve since it was leaking. It looks like that might have fixed the problem.
I just had an oil change done just a couple months ago, but been thinking of doing a transmission oil change, but since the mech sleeve was just replaced 2 years ago I figured I was fine, might have to think again and just do it all.
__________________
335i E90 | BMS DCI | Black Matte Grill | JB4 | Logic 7 | Sport | Premium | Cold |
Appreciate 0
      11-15-2012, 04:56 PM   #13
captainslow
Private
6

 
Drives: 335xi
Join Date: Dec 2011
Location: earth


Posts: 69
iTrader: (0)

fuel injectors or valve cleaning needed
Appreciate 0
      11-15-2012, 05:00 PM   #14
335i Pal
Second Lieutenant
United_States
15

 
335i Pal's Avatar
 
Drives: 335i Sedan
Join Date: Oct 2010
Location: Ohio


Posts: 284
iTrader: (1)

Quote:
Originally Posted by captainslow View Post
fuel injectors or valve cleaning needed
Wouldn't fuel injectors hinder WOT as well? Only on medium acceleration.
__________________
335i E90 | BMS DCI | Black Matte Grill | JB4 | Logic 7 | Sport | Premium | Cold |
Appreciate 0
      11-15-2012, 05:11 PM   #15
captainslow
Private
6

 
Drives: 335xi
Join Date: Dec 2011
Location: earth


Posts: 69
iTrader: (0)

Quote:
Originally Posted by 335i Pal View Post
Wouldn't fuel injectors hinder WOT as well? Only on medium acceleration.
no. i had the exact same issue and it ended up being the fuel injectors
Appreciate 0
      11-15-2012, 05:33 PM   #16
335i Pal
Second Lieutenant
United_States
15

 
335i Pal's Avatar
 
Drives: 335i Sedan
Join Date: Oct 2010
Location: Ohio


Posts: 284
iTrader: (1)

^ Might have to look into this as well especially since I think that is cover under the fuel pump warranty.
__________________
335i E90 | BMS DCI | Black Matte Grill | JB4 | Logic 7 | Sport | Premium | Cold |
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:14 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST