E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > USA - Mid-Atlantic > Radio Stopped Working - Advice?



Reply
 
Thread Tools Search this Thread
      10-22-2012, 11:30 AM   #1
SE3P_to_E90
Banned
 
Drives: E90 Msport + E83 Msport
Join Date: Jun 2006
Location: MD

Posts: 3,035
iTrader: (29)

Send a message via AIM to SE3P_to_E90
Radio Stopped Working - Advice?

Hi guys, i'm having a bit of an interesting issue w/ my Radio and need some advice. A few months ago (6months ago), my radio went out. A month later, the radio started working again. Then, 3 mos ago, my headlight went out - along w/ the radio. Replaced the bulbs and everything, but the radio still doesn't work.

Everything looks as if it should work... the radio head unit turns on/off without issue, loads CD's, just no sound. Any recommendations? I've been driving without a radio for the past month... bimmers and their notorious electrical problems :/

Thanks in advance for your help.
SE3P_to_E90 is offline   United_States
0
Reply With Quote
      10-22-2012, 11:44 AM   #2
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,077
iTrader: (0)

Garage List
2006 330i  [2.83]
man this sucks! If I were you I would check fuses then disconnect battery for a minute or so and see if this reset the radio? Not an expert but it does not hurt to try. Good luck and keep us posted. Thanks
GoRomeo is offline  
0
Reply With Quote
      10-22-2012, 12:49 PM   #3
tmaung
CCA Member#: 439255
 
Drives: E92 335is
Join Date: Jun 2009
Location: Northern VA

Posts: 442
iTrader: (8)

Garage List
2011 BMW 335is  [0.00]
Quote:
Originally Posted by SE3P_to_E90 View Post
Hi guys, i'm having a bit of an interesting issue w/ my Radio and need some advice. A few months ago (6months ago), my radio went out. A month later, the radio started working again. Then, 3 mos ago, my headlight went out - along w/ the radio. Replaced the bulbs and everything, but the radio still doesn't work.

Everything looks as if it should work... the radio head unit turns on/off without issue, loads CD's, just no sound. Any recommendations? I've been driving without a radio for the past month... bimmers and their notorious electrical problems :/

Thanks in advance for your help.
Bad amp?
__________________
Current | 2011 E92 M3 - Mineral White, Black
Sold! | 2011 E92 335is - Titanium Silver, Black
Sold! | 2007 E92 335i - Space Gray, Black
Sold! | 2008 E90 M3 - Jerez Black, Fox Red
tmaung is offline   United_States
0
Reply With Quote
      10-22-2012, 02:05 PM   #4
SE3P_to_E90
Banned
 
Drives: E90 Msport + E83 Msport
Join Date: Jun 2006
Location: MD

Posts: 3,035
iTrader: (29)

Send a message via AIM to SE3P_to_E90
Quote:
Originally Posted by GoRomeo View Post
man this sucks! If I were you I would check fuses then disconnect battery for a minute or so and see if this reset the radio? Not an expert but it does not hurt to try. Good luck and keep us posted. Thanks
Any idea which fuses?

Quote:
Originally Posted by tmaung View Post
Bad amp?
I spoke with my mechanic at BMW Tischer, and from the sounds of it, he said i might just have to go ahead and replace the entire head unit... the strangest thing is, i've had this issue quite a few months back, the radio came back, and when my headlight bulb (halogen) went out, radio also went... any idea how I would check if the amp went bad?

I feel my wallet getting lighter already...
SE3P_to_E90 is offline   United_States
0
Reply With Quote
      10-22-2012, 02:10 PM   #5
SE3P_to_E90
Banned
 
Drives: E90 Msport + E83 Msport
Join Date: Jun 2006
Location: MD

Posts: 3,035
iTrader: (29)

Send a message via AIM to SE3P_to_E90
I'm not sure if this helps or clarifies anything... but my Cig lighter/charger (in the center armrest console) also stopped working... let the electrical issues pile up.
SE3P_to_E90 is offline   United_States
0
Reply With Quote
      10-22-2012, 03:11 PM   #6
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,077
iTrader: (0)

Garage List
2006 330i  [2.83]
check all fuses if possible. Also have you had any water leaks inside you car? Humidity could cause this maybe?
GoRomeo is offline  
0
Reply With Quote
      10-23-2012, 12:43 PM   #7
SE3P_to_E90
Banned
 
Drives: E90 Msport + E83 Msport
Join Date: Jun 2006
Location: MD

Posts: 3,035
iTrader: (29)

Send a message via AIM to SE3P_to_E90
^ no water leaks that I can think of... sometimes i drive w/ the windows cracked when it's raining, and a few water drops get in on the B-pillar, but nothing other than that... i always wipe it down once i'm stopped as well... I'll check all fuses this weekend... i can already tell this is going to be "fun"
SE3P_to_E90 is offline   United_States
0
Reply With Quote
      11-14-2012, 09:16 AM   #8
Cali FlyBoyZ
Private First Class
 
Cali FlyBoyZ's Avatar
 
Drives: 335i Coupe 6MT
Join Date: Dec 2011
Location: Washington DC

Posts: 141
iTrader: (2)

sounds exactly like the issues i had earlier this yr... i was screwing around with my tail light and didnt screw it back on tight enough. water seeped down and fried the amp. It would work then not work then just went out completely one day. See if a friend will let you swap to see if thats the issue.
__________________

e92/Jet Black/Coral Red/6MT
COBB 2+/AP FMIC/CPE CP/TIAL BOV/AR Catless DP
Cali FlyBoyZ is offline   United_States
0
Reply With Quote
      11-14-2012, 10:02 AM   #9
SE3P_to_E90
Banned
 
Drives: E90 Msport + E83 Msport
Join Date: Jun 2006
Location: MD

Posts: 3,035
iTrader: (29)

Send a message via AIM to SE3P_to_E90
Quote:
Originally Posted by Cali FlyBoyZ View Post
sounds exactly like the issues i had earlier this yr... i was screwing around with my tail light and didnt screw it back on tight enough. water seeped down and fried the amp. It would work then not work then just went out completely one day. See if a friend will let you swap to see if thats the issue.
Damn, i really hope this isn't the issue... I'll check the amp this weekend to see if water is the culprit. What did you end up doing, and what was the ($) damage?

Since i was shopping around for cars the past couple weekends, i didn't have a chance to check fuses either (since there's about 100 fuses to check). I'll make sure to do that (just in case) this weekend.
SE3P_to_E90 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:16 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST