E90Post
 


jb4store
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > problem...



Reply
 
Thread Tools Search this Thread
      11-09-2012, 11:29 AM   #1
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

problem...

good day everyone.

l tried searching but came up with nothing. last night i notices my seat belt assist was not working. i also notices that my windows from the drivers side and pass side were not going down, the power mirrors wont fold in and i cant adjust the rear view mirrors. if i hold my unlock button on the car remote the windows go down and i would have to use the key in the door handle to roll them back up. i can roll down the pass window from the pass side and bring it back up..

any idea what should i check? i already checked the window fuses
Appreciate 0
      11-09-2012, 03:39 PM   #2
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

anyone?
Appreciate 0
      11-09-2012, 04:49 PM   #3
jmb85
Second Lieutenant
United_States
2

 
jmb85's Avatar
 
Drives: 335i Coupe
Join Date: Sep 2012
Location: Jax NC


Posts: 215
iTrader: (4)

any codes? when you say you checked the fuses, did you actually test them or visually inspect them?
Appreciate 0
      11-10-2012, 03:02 PM   #4
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

No codes. I checked them with out running test.. It's weird cause last night I was driving to a friends house and everything started working.. When I left his house it wasn't working and when I got home it was working again. This morning I start the car and its no longer working. When I disconnect the master control on the door the seat belt assist starts to work.


Also forgot to add in that when I connect the master control I hear a clicking sound for about 15 secs ... I don't know where it's coming from..

Thanks
Appreciate 0
      11-10-2012, 10:25 PM   #5
jmb85
Second Lieutenant
United_States
2

 
jmb85's Avatar
 
Drives: 335i Coupe
Join Date: Sep 2012
Location: Jax NC


Posts: 215
iTrader: (4)

any water dmg?
Appreciate 0
      11-11-2012, 11:10 AM   #6
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

It snowed the other day and When I opened the door snow fell in the car but can that really be it?

Do you really think it could be a relay ? Car is a 08
Appreciate 0
      11-11-2012, 08:28 PM   #7
jmb85
Second Lieutenant
United_States
2

 
jmb85's Avatar
 
Drives: 335i Coupe
Join Date: Sep 2012
Location: Jax NC


Posts: 215
iTrader: (4)

idk man, open it up see what you find
Appreciate 0
      11-12-2012, 12:17 AM   #8
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

I did .. Nothing...
Appreciate 0
      11-12-2012, 01:03 AM   #9
snoozee
Second Lieutenant
3

 
Drives: 318i
Join Date: Mar 2012
Location: Singapore


Posts: 213
iTrader: (0)

when you did all the winding up/down of windows, adjustment of side mirrors, are you using the master window/mirror switch on the driver side?

if yes, most probably the switch pack is the cause. i had similiar symptons, side mirrors cannot fold/unfold when starting the car and works fine after driving for a while. tore open the switch pack and turned out the capacitors inside are leaking which is why the functions do not work when you first start the car since the leaking capacitors lose the charge and thus doesn't work. when you drive for a while, the capacitors get charged up again and thus everything works again.

the solution is either to replace the 3 capacitors inside the switch pack or just buy a new switch pack.

I ended up using my old switch pack (without mirror folding button) as my attempt at replacing the capacitors did not work well.

here's an image of how the capactitors looked like for my case.

Appreciate 0
      11-12-2012, 09:58 AM   #10
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

That's exactly what's going on... After a run it works.. Did your seat belt assist stop working as well? Where can I order a new switch pack ?
Appreciate 0
      11-12-2012, 11:11 AM   #11
snoozee
Second Lieutenant
3

 
Drives: 318i
Join Date: Mar 2012
Location: Singapore


Posts: 213
iTrader: (0)

I don't have seat belt assist. Check with your dealer or get a used one off eBay. Installation is just plug and play
Appreciate 0
      11-12-2012, 11:40 AM   #12
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

Will do.. So it's called a switch pack?
Appreciate 0
      11-12-2012, 07:09 PM   #13
snoozee
Second Lieutenant
3

 
Drives: 318i
Join Date: Mar 2012
Location: Singapore


Posts: 213
iTrader: (0)

Also known as master switch. Your dealer should know the part number for it. Should cost around 150 if I'm not wrong
Appreciate 0
      11-13-2012, 11:13 AM   #14
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

I will order it tonight. Soon as I get it I will let you guys know.
Appreciate 0
      11-15-2012, 06:50 PM   #15
vzmo335
Private
4

 
Drives: 2008 335i
Join Date: Jan 2011
Location: nyc


Posts: 83
iTrader: (0)

So the master switch came in and I changed it and we back to normal! Thanks for the help guys I really appreciate it!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:17 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST