E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Head count of VANOS replacement individuals



Reply
 
Thread Tools Search this Thread
      11-12-2012, 09:30 PM   #1
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

Head count of VANOS replacement individuals

I'm suspecting future VANOS's failure for my vehicle (12/07 build date), 69K miles, used M1 0w40 or Castrol 0w30

Symptoms:
1)Marbles in a can like noise during cold start in the interior of the car

2) "warble-warble" like noise at the top of the engine near the VANOS timing gear during the same conditions

3) repeated VANOS codes and CEL lights after WOT runs

I'm just gathering information from others. Please post if you've had a complete VANOS assembly replacement done, not VANOS solenoid-related stuff. Post your build date, type of oil, milage, and symptoms. I'm wanting to keep the thread alive for future buyers or current owners who may have the same issue. I guess no BMW is safe from VANOS issue's.
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-12-2012, 09:50 PM   #2
zanelefko
Lieutenant
zanelefko's Avatar
4
Rep
404
Posts

 
Drives: E92 335i
Join Date: Jan 2012
Location: So Fla

iTrader: (0)

I had to get a new vanos unit at 89k miles...wasn't cheap either

I used BMW oil
Symptoms were half engine light, no boost, marble like sounds
__________________
VRSF DP / DCI / JB4 / ETS FMIC / ETS Charge pipe / Tial BOV /
Appreciate 0
      11-13-2012, 07:15 PM   #3
m603
Second Lieutenant
m603's Avatar
5
Rep
295
Posts

 
Drives: avoiding pot holes
Join Date: Mar 2008
Location: NYC

iTrader: (1)

Quote:
Originally Posted by zanelefko View Post
I had to get a new vanos unit at 89k miles...wasn't cheap either

I used BMW oil
Symptoms were half engine light, no boost, marble like sounds
how much? I'm scared to find out...
Appreciate 0
      11-13-2012, 07:17 PM   #4
335xi Kevo
Lieutenant
335xi Kevo's Avatar
7
Rep
502
Posts

 
Drives: 2008 335xi
Join Date: Jan 2012
Location: CT

iTrader: (3)

vanos are super easy to swap theres a DIY here.
__________________
08' 335xi 6MT
Space Metallic Grey
Premium, Nav, Cold weather, Sport
Procede 2.5, DCI, Forge DV, PWM, Scoops, KW V1, ETS 5" FMIC, VRSF Downpipes, M3 Skirts
Appreciate 0
      11-13-2012, 09:30 PM   #5
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

Quote:
Originally Posted by 335xi Kevo View Post
vanos are super easy to swap theres a DIY here.
You may be confusing VANOS unit with VANOS solenoid, which are two completely different things
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-13-2012, 09:31 PM   #6
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

Quote:
Originally Posted by zanelefko View Post
I had to get a new vanos unit at 89k miles...wasn't cheap either

I used BMW oil
Symptoms were half engine light, no boost, marble like sounds
Thanks for the update. Did you have marbles-in-a-can noise at idle with a feather foot on the throttle too?
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-13-2012, 11:22 PM   #7
5soko
Brigadier General
5soko's Avatar
75
Rep
4,220
Posts

 
Drives: M5
Join Date: Aug 2007
Location: Brooklyn, NY

iTrader: (4)

My car is FBO and 28k miles.

When im inside the car, no music, I hear a very faint, like marbles griding or like a buzz sound at idle, and when I give slight partial throttle.

Is this vanos?
__________________
Current: ///M5 LCI with Evolve and RPi mods
Previous: E92 335i ||| FBO Heavy modded E90 LCI M-Sport 335i
Appreciate 0
      11-14-2012, 05:37 AM   #8
zanelefko
Lieutenant
zanelefko's Avatar
4
Rep
404
Posts

 
Drives: E92 335i
Join Date: Jan 2012
Location: So Fla

iTrader: (0)

Quote:
Originally Posted by m603
Quote:
Originally Posted by zanelefko View Post
I had to get a new vanos unit at 89k miles...wasn't cheap either

I used BMW oil
Symptoms were half engine light, no boost, marble like sounds
how much? I'm scared to find out...
It was almost 7 months ago now but I believe somewhere in the woods of 1800-2000$
__________________
VRSF DP / DCI / JB4 / ETS FMIC / ETS Charge pipe / Tial BOV /
Appreciate 0
      11-14-2012, 06:40 AM   #9
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

Quote:
Originally Posted by 5soko View Post
My car is FBO and 28k miles.

When im inside the car, no music, I hear a very faint, like marbles griding or like a buzz sound at idle, and when I give slight partial throttle.

Is this vanos?
is it a cycling buzzing noise? or is it constant?
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-16-2012, 12:23 AM   #10
5soko
Brigadier General
5soko's Avatar
75
Rep
4,220
Posts

 
Drives: M5
Join Date: Aug 2007
Location: Brooklyn, NY

iTrader: (4)

Quote:
Originally Posted by spool twice View Post
is it a cycling buzzing noise? or is it constant?
Yea its like a buzz buzz buzz buzz on and off on and off.. And then when I rev, it gets a lil louder and faster buzbuzbuzbuzbuzz..
__________________
Current: ///M5 LCI with Evolve and RPi mods
Previous: E92 335i ||| FBO Heavy modded E90 LCI M-Sport 335i
Appreciate 0
      11-16-2012, 06:55 AM   #11
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

Quote:
Originally Posted by 5soko View Post
Yea its like a buzz buzz buzz buzz on and off on and off.. And then when I rev, it gets a lil louder and faster buzbuzbuzbuzbuzz..
That's the sound i'm hearing too
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-16-2012, 07:59 AM   #12
BoostedE90
Lieutenant Colonel
BoostedE90's Avatar
United_States
27
Rep
1,673
Posts

 
Drives: e90 335i 6MT
Join Date: Nov 2007
Location: Tampa/Gainesville, FL

iTrader: (5)

VANOS Solenoid replacement: http://www.e90post.com/forums/showthread.php?t=486201
Appreciate 0
      11-16-2012, 08:42 AM   #13
trickcruiser
First Lieutenant
United_States
7
Rep
396
Posts

 
Drives: E82
Join Date: Jun 2010
Location: Cincinnati, OH

iTrader: (1)

What vanos codes are you getting? That will really help pinpoint the issue.

The sounds that you are hearing could be normal for direct injection. My 335i was noisy as hell and it always worried me. My 135i sounds the same as does my friends 335i. All of these cars have had the vanos solenoid's replaced. We were throwing vanos codes after hard pulls.
__________________

OLD Best - 503whp/517wtq - Best ET: 11.14 | Best MPH 127.46
Super RB Install & Flash Tuning By Turn In Concepts - http://turninconcepts.com/
Fueling - http://www.fuel-it.biz/
Appreciate 0
      11-16-2012, 09:29 AM   #14
5soko
Brigadier General
5soko's Avatar
75
Rep
4,220
Posts

 
Drives: M5
Join Date: Aug 2007
Location: Brooklyn, NY

iTrader: (4)

Quote:
Originally Posted by spool twice View Post
That's the sound i'm hearing too
Quote:
Originally Posted by trickcruiser View Post
What vanos codes are you getting? That will really help pinpoint the issue.

The sounds that you are hearing could be normal for direct injection. My 335i was noisy as hell and it always worried me. My 135i sounds the same as does my friends 335i. All of these cars have had the vanos solenoid's replaced. We were throwing vanos codes after hard pulls.
Im not getting any vanos codes.

Car has 28K miles, and the noise has been present for about 5-8K miles.
with the radio off, its an annoying whiring sound. whiring comes on strong, and then quiets down, comes back strong, quiets down, does this sound quickly and on going.
Im going to remove and clean my intake/exhaust solenoids with wd40 and compressed air, see if the sound goes away.

I have ruled out the DME fan inside the ECU box, and the boost solenoids, since my issue, the sound moves with RPM's in neutral.. So boost solenoids aren't rpm dependent, and these two should be making noise always, not sometimes, and not when warm only.
__________________
Current: ///M5 LCI with Evolve and RPi mods
Previous: E92 335i ||| FBO Heavy modded E90 LCI M-Sport 335i
Appreciate 0
      11-16-2012, 02:30 PM   #15
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
85
Rep
4,200
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
Are we talking about the VANOS solenoids here? If so, then count me in for 1 intake vanos solenoid dead at 28K miles. Replaced it in my own garage in under 30 minutes.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
      11-16-2012, 02:35 PM   #16
Elliott@DetailAddict
Brigadier General
United_States
81
Rep
4,448
Posts

 
Drives: E90
Join Date: May 2011
Location: Santa Clara, CA

iTrader: (0)

Replaced my solenoids via CPO warranty around 35k miles.
Appreciate 0
      11-16-2012, 02:37 PM   #17
joec500
Brigadier General
46
Rep
3,004
Posts

 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

iTrader: (10)

mine died at 20k miles.
__________________
2007 E92 6MT SGM: MusicarNW Level 2, Procede Rev 2.5, FFTEC/Vishnu LPFP with Flexfuel Sensor and Flash, M3 Offset V701's, WaveTrac LSD, Michelin PSS, Downpipes, M3 Control Arms, TCKline D/A Suspension, LCI Tail lights, Lux AE's, ER Charge Pipe, DCI's, Mtech Front and Rear, M3 Sideskirts, HPF Stage 1 Clutch
Appreciate 0
      11-16-2012, 02:39 PM   #18
MidwestGolfBum
Knower of all Things Useless
MidwestGolfBum's Avatar
North Korea
20
Rep
256
Posts

 
Drives: Space Grey E92s
Join Date: Jan 2011
Location: No Coast

iTrader: (0)

I had mine replaced around 40K under factory warranty, Been fine for the last 23K now.

07, always used BMW oil, same marble sound everybody else has been talking about.
Appreciate 0
      11-16-2012, 04:35 PM   #19
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

Quote:
Originally Posted by vasillalov View Post
Are we talking about the VANOS solenoids here? If so, then count me in for 1 intake vanos solenoid dead at 28K miles. Replaced it in my own garage in under 30 minutes.
How did you know it went bad? noise or codes?
Appreciate 0
      11-16-2012, 04:55 PM   #20
nOshi
bad man nuh fren fish
nOshi's Avatar
Jamaica
1
Rep
198
Posts

 
Drives: TiAg E90 335i
Join Date: Apr 2011
Location: Central FL

iTrader: (4)

Mine went when I was around 53k, exhaust side vanos solenoid. Threw a code for it under acceleration, which resulted in limp mode. Bought a replacement and has been good ever since.
__________________
TiAG E90 N54 335i | COBB | RB | FBO

Appreciate 0
      11-16-2012, 06:06 PM   #21
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

hey guys, strictly VANOS only, not VANOS solenoid. This noise is caused by the VANOS unit itself starting to fail.
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-17-2012, 01:22 PM   #22
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
85
Rep
4,200
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
Quote:
Originally Posted by 1LUMI View Post
How did you know it went bad? noise or codes?
Codes. At first the code was popping up every 3-4 months. Then it started happening more frequently. It got worse and I was getting the CEL almost once per week during normal city driving. So I bought one and replaced it.

No noises at all. Just went bad.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:06 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST