E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > '08 328i E90 Rough Idle, Vibrating & Shaking



Reply
 
Thread Tools Search this Thread
      11-20-2012, 05:07 AM   #23
Three_thirty_I
Captain
South Africa
12

 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa


Posts: 810
iTrader: (0)

Garage List
For rough and jumping idle on these cars, check this video!!



A faulty eccentric shaft sensor (Valvetronic position sensor) can cause this as shown above!
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Appreciate 0
      11-20-2012, 01:56 PM   #24
alexwhittemore
Lieutenant Colonel
23

 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles


Posts: 1,685
iTrader: (0)

Epically helpful!
Appreciate 0
      11-20-2012, 05:41 PM   #25
mjm22
Enlisted Member
0

 
Drives: 2007 328xi
Join Date: Dec 2010
Location: Long Island, NY


Posts: 35
iTrader: (0)

Was told today that it is most likely an ignition coil.
Appreciate 0
      11-21-2012, 12:30 AM   #26
manutdas11
EL JIMMY NEURON
United_States
13

 
manutdas11's Avatar
 
Drives: Jet Black E90
Join Date: Aug 2012
Location: in the Napa Valley/SJ...


Posts: 1,208
iTrader: (0)

Quote:
Originally Posted by Three_thirty_I View Post
For rough and jumping idle on these cars, check this video!!



A faulty eccentric shaft sensor (Valvetronic position sensor) can cause this as shown above!
Nice find. Thanks for that! I have a feeling that this may be my problem.
__________________
2007 Jet Black E90 328i
Thread: http://www.e90post.com/forums/showthread.php?t=825249
Instagram: manutd_as
Appreciate 0
      11-21-2012, 06:51 AM   #27
Three_thirty_I
Captain
South Africa
12

 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa


Posts: 810
iTrader: (0)

Garage List
No problem!! Hope you are able to get this sorted! Nothing worse than having an engine issue that is difficult to fix!
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Appreciate 0
      11-22-2012, 12:06 AM   #28
manutdas11
EL JIMMY NEURON
United_States
13

 
manutdas11's Avatar
 
Drives: Jet Black E90
Join Date: Aug 2012
Location: in the Napa Valley/SJ...


Posts: 1,208
iTrader: (0)

Quote:
Originally Posted by Three_thirty_I View Post
No problem!! Hope you are able to get this sorted! Nothing worse than having an engine issue that is difficult to fix!
Tell me about it! I've been in and out of the shop since last month and it's getting tiresome. Need to spend money on mods not maintenance!
__________________
2007 Jet Black E90 328i
Thread: http://www.e90post.com/forums/showthread.php?t=825249
Instagram: manutd_as
Appreciate 0
      11-22-2012, 09:35 AM   #29
Three_thirty_I
Captain
South Africa
12

 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa


Posts: 810
iTrader: (0)

Garage List
Quote:
Originally Posted by manutdas11 View Post
Tell me about it! I've been in and out of the shop since last month and it's getting tiresome. Need to spend money on mods not maintenance!
That's bad, but LOL, try this for size - been battling with a rattling noise since early this year when the car was still under motorplan. First thought the noise was the dual mass flywheel, then the agents claim that this is not the case but instead that the engine is pinging and needs software update. Problem not solved and eventually motorplan expired and so I am on my own with this unresolved problem. Replaced spark plugs and used injector cleaner, again no improvement, and cleaned the intake and exhaust Vanos solenoids. Then after lots and lots of searching and reading up read that this could be a DISA flap issue (one or both DISA flaps could be making this noise). Took the car back to the agents with this info and they insist that it's not the DISA flaps and that the engine is just pinging due to our fuel and is completely normal - such rubbish! Knock sensors are there for this reason and allows the engine to make very quick adjustments so that you ultimately never hear pinging.

Took the car to a specialist tuner and they ran their diagnostics live with the car being driven and were able to find a few strange things - engine running either running too cold or the temperature sensor from the radiator is not working properly, but they said that the noise that I am hearing is from the DISA flaps.

Just to clarify, this noise is not the typical hydraulic lifter noise and only does it when the car is driving (revving does not reproduce this) - the noise takes place from low to mid revs under moderate to high loads. Also there is a stumbling/hesitation at low revs.

So basically been battling with this for more than 6 - 7 months now!!!
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Appreciate 0
      11-22-2012, 12:09 PM   #30
manutdas11
EL JIMMY NEURON
United_States
13

 
manutdas11's Avatar
 
Drives: Jet Black E90
Join Date: Aug 2012
Location: in the Napa Valley/SJ...


Posts: 1,208
iTrader: (0)

Quote:
Originally Posted by Three_thirty_I View Post
That's bad, but LOL, try this for size - been battling with a rattling noise since early this year when the car was still under motorplan. First thought the noise was the dual mass flywheel, then the agents claim that this is not the case but instead that the engine is pinging and needs software update. Problem not solved and eventually motorplan expired and so I am on my own with this unresolved problem. Replaced spark plugs and used injector cleaner, again no improvement, and cleaned the intake and exhaust Vanos solenoids. Then after lots and lots of searching and reading up read that this could be a DISA flap issue (one or both DISA flaps could be making this noise). Took the car back to the agents with this info and they insist that it's not the DISA flaps and that the engine is just pinging due to our fuel and is completely normal - such rubbish! Knock sensors are there for this reason and allows the engine to make very quick adjustments so that you ultimately never hear pinging.

Took the car to a specialist tuner and they ran their diagnostics live with the car being driven and were able to find a few strange things - engine running either running too cold or the temperature sensor from the radiator is not working properly, but they said that the noise that I am hearing is from the DISA flaps.

Just to clarify, this noise is not the typical hydraulic lifter noise and only does it when the car is driving (revving does not reproduce this) - the noise takes place from low to mid revs under moderate to high loads. Also there is a stumbling/hesitation at low revs.

So basically been battling with this for more than 6 - 7 months now!!!
Wow, that is such rubbish! Are you going to get it fixed by the new tuner shop you went to?
__________________
2007 Jet Black E90 328i
Thread: http://www.e90post.com/forums/showthread.php?t=825249
Instagram: manutd_as
Appreciate 0
      11-22-2012, 12:24 PM   #31
Three_thirty_I
Captain
South Africa
12

 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa


Posts: 810
iTrader: (0)

Garage List
Quote:
Originally Posted by manutdas11 View Post
Wow, that is such rubbish! Are you going to get it fixed by the new tuner shop you went to?
Going to DIY and fit the DISA motors - wish me luck!
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Appreciate 0
      11-22-2012, 12:32 PM   #32
manutdas11
EL JIMMY NEURON
United_States
13

 
manutdas11's Avatar
 
Drives: Jet Black E90
Join Date: Aug 2012
Location: in the Napa Valley/SJ...


Posts: 1,208
iTrader: (0)

Quote:
Originally Posted by Three_thirty_I View Post
Going to DIY and fit the DISA motors - wish me luck!
Nice! Definitely Good Luck to you sir!
__________________
2007 Jet Black E90 328i
Thread: http://www.e90post.com/forums/showthread.php?t=825249
Instagram: manutd_as
Appreciate 0
      11-23-2012, 07:23 PM   #33
Three_thirty_I
Captain
South Africa
12

 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa


Posts: 810
iTrader: (0)

Garage List
Quote:
Originally Posted by manutdas11 View Post
Nice! Definitely Good Luck to you sir!
Thanks, will post about it once done!
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Appreciate 0
      11-24-2012, 12:49 AM   #34
manutdas11
EL JIMMY NEURON
United_States
13

 
manutdas11's Avatar
 
Drives: Jet Black E90
Join Date: Aug 2012
Location: in the Napa Valley/SJ...


Posts: 1,208
iTrader: (0)

Quote:
Originally Posted by Three_thirty_I View Post
Thanks, will post about it once done!
__________________
2007 Jet Black E90 328i
Thread: http://www.e90post.com/forums/showthread.php?t=825249
Instagram: manutd_as
Appreciate 0
      11-30-2012, 12:45 AM   #35
aesfah
Max Powers
8

 
Drives: E90 330i
Join Date: Mar 2009
Location: MoCo, MD


Posts: 270
iTrader: (0)

Any updates on the idle issues? Been having similar problems on my e90 330i w 85k. New plugs, air filter and even new MAF sensor. Car idles rough on cold start, rpm fluctuates, shuts off. Also hesitates when accelerating from dead stop.
Appreciate 0
      12-01-2012, 08:34 PM   #36
vanondemand
Banned
Canada
9

 
vanondemand's Avatar
 
Drives: E92 335i M/T
Join Date: Feb 2011
Location: Vancouver


Posts: 662
iTrader: (1)

Garage List
2007 335i  [0.00]
Once my car starting shaking violently and then it just died, Turns out it was my vanos solenoid, replaced and works just fine now
Appreciate 0
      12-02-2012, 02:40 AM   #37
moonsin
First Lieutenant
5

 
moonsin's Avatar
 
Drives: 08 E92 328xi
Join Date: Feb 2012
Location: NJ


Posts: 323
iTrader: (1)

My car would once in a while shake up on cold starts...i didnt really think much of it.....but last wednesday i had a little incident...(http://www.e90post.com/forums/showthread.php?t=775703) i just got my car back and it all seems to be fine now...might wanna check for oil build up on these
__________________

'08 BSM//SB PROGRESSION THREAD
Eibach Pro-Kit, ACS Style Roof Spoiler, trunk lip spoiler,Aero lip, blackout grill/reflector, 19" ST8, Lightwerkz Custom Headlights, Muffler Delete, coded etc etc
Appreciate 0
      12-07-2012, 09:29 PM   #38
sammk
Private First Class
2

 
Drives: 2008 328i Coupe
Join Date: Oct 2011
Location: Michigan


Posts: 173
iTrader: (1)

I know that idle instability could come from various different issues or a combination of issues but I recently got lucky and fixed the bouncy/rough idle on my '08 E92 328i with the N51 motor. If it helps anyone:

http://www.e90post.com/forums/showthread.php?t=778082

Good luck!
__________________
Appreciate 0
      12-14-2012, 02:46 PM   #39
kiwi29
Team iTouge
United_States
34

 
kiwi29's Avatar
 
Drives: 09 M-Tech 328i
Join Date: Jul 2011
Location: Long Beach, CA


Posts: 2,074
iTrader: (9)

This sounds like an amazingly stupid idea but check your motor and transmission mounts... this happened on my civic and when I replaced it, it was perfect lol it sounds stupid I know but it happens and makes your car vibrate very harsh. The bushings could be going bad over the years and there won't be any codes thrown as it is just a mount
__________________
Quote:
Originally Posted by The HACK View Post
I'm going to use a very simple analogy, I hope you'll understand.
Driving is like having sex.
It really is. You can read up all you want about how to please a woman, you can look at all the diagrams in the world, but just like the clitoris, you won't know what the hell an apex is before you actually find it.
Appreciate 0
      02-25-2013, 12:04 PM   #40
branmace
Private First Class
United_States
2

 
Drives: E90 330i
Join Date: Sep 2011
Location: SLC, UT


Posts: 102
iTrader: (0)

This goes out to all the drivers who, like me, tried to diagnose the engine 'vibration' problem at idling, low rpm, and very little but noticeable at higher rpm by reading this thread and was amazed by the responses found. It is fascinating how the general public is strong about their opinions without actually know of the diagnostic. So here it is my troubleshoot for the engine 'vibration' problem with service engine soon light 'ON':
- car has 80K miles
- RMP approximately 600
- cold start or not, engine 'vibration' present
- also while driving at low to high RPM approximately 4000-5000, vibration noticable
- I love this one: Went to the local parts store 'O'reilly auto parts' and tech plugged the OBDII diagnostic reader (free of charge at any of the above parts store) and read the code and the description "Cylinder 3 misfire"
- I came home, not that I did not trust the guy, swapped the ignition coil #3 with #1 and took back the car to O'reilly's.
- Got the same tech to do the diagnostic (he looked at me and said 'we just did that, didn't we?') and told him that I was troubleshooting the ignition coil
- OBDII diagnostic reader read "Cylinder #1 misfire"....VOILA, bad ignition coil (no oil on the ignition coil)
- Ordered one, replaced it, and no vibration
- Took the car back to O'reilly's and had tech plug the OBDII diagnostic reader (different tech). He mentioned no codes were displayed. Asked me my reason for heaving him diagnose my vehicle. Explained what happened above, he tried again to make sure all is well.....and it was. Hope this helps to those who search for answers...and here it is 'Have it diagnosed, BEFORE you start replacing parts that don't need to, while you still have not fixed the problem'

Last edited by branmace; 02-25-2013 at 12:08 PM. Reason: *mileage
Appreciate 0
      02-26-2013, 03:10 PM   #41
stoppy
Private
0

 
stoppy's Avatar
 
Drives: 2006 330i blk, Sport Pkg, 6spd
Join Date: Apr 2012
Location: Ontario


Posts: 57
iTrader: (3)

Quote:
Originally Posted by aesfah View Post
Any updates on the idle issues? Been having similar problems on my e90 330i w 85k. New plugs, air filter and even new MAF sensor. Car idles rough on cold start, rpm fluctuates, shuts off. Also hesitates when accelerating from dead stop.
I'd check this out:

http://www.e90post.com/forums/showthread.php?t=501907

I just fixed this issue, same type of symptoms on the same car (2006 330i N52)

Car runs like a champ now.
Appreciate 0
      05-01-2013, 08:30 AM   #42
328inewbie
New Member
0

 
328inewbie's Avatar
 
Drives: 09 BMW 328i
Join Date: Oct 2011
Location: United States


Posts: 5
iTrader: (0)

try this

http://www.e90post.com/forums/showthread.php?t=697252
__________________
God is good, all the time, he is good.
Appreciate 0
      05-22-2013, 12:23 PM   #43
Stupenal
Second Lieutenant
5

 
Drives: Mmm
Join Date: May 2009
Location: Socal


Posts: 257
iTrader: (9)

2009 128i
37k miles
Symptoms: at idle, the revs would barely move - maybe 50-100 rpms at most and it wouldn't always happen. However, you could feel like a "thump" as if a lump was passing through the engine and through the exhaust (i know it's not a lump passing through, but it feels like that). Engine rpm would slightly drop when this happens, and happens randomly. Can be felt in the engine and can also be slightly heard in exhaust. Happens when cold, happens when warmed up, happens most always at idle, sometimes worse than others. Doesn't miss during acceleration, pulls nice and smooth.

Final day of factory warranty, brought the car in for service. I pointed it out to the SA and luckily he felt it too. Just got a call from the SA that they diagnosed it as the valvetronic sensor (I'm assuming its the camshaft positioning sensor) needed replacing, so they're fixing that and also putting in a new valve cover gasket.

On my e36 m3, when the camshaft positioning sensor gave out, the symptoms were different in that the car felt damn slow. Engine idled smoother than the 128i and RPMS were also smooth, but there was a ton of power missing. Once the CPS was replaced, power came back. Different engines, different cars, but same part that gives out. Gotta love BMWs.

I'm hopefully picking up the car today, so I'll see if it fixed the problem.
Appreciate 0
      05-24-2013, 11:01 PM   #44
Stupenal
Second Lieutenant
5

 
Drives: Mmm
Join Date: May 2009
Location: Socal


Posts: 257
iTrader: (9)

Just an update - got the car back after another couple days at the dealership. Here's my cross post from the 1 series board

I look at the service invoice (all no charge thankfully under factory warranty) and their troubleshooting for the rough idle was pretty damn impressive. Here's all the steps they performed (after each step, the invoice documents "No change"):

1. Updated vehicle software.
2. Swapped 6 new ignition coils
3. Inspected spark plugs
4. Replaced eccentric shaft sensor
5. Smoke tested intake for leaks
6. Checked vanos function
7. Checked fuel pressure
8. Tested sample of gasoline and found no water/contaminants
9. Performed ethanol test and found 5% (????)
10. Filled injection flush container with fresh gas and ran through fuel rail
11. Installed 6 new spark plugs
12. Swapped injectors from known good car
13. Checked crankcase ventilation pressure
14. Increased idle speed
15. Performed compression and leakdown test (all cyl within range and good psi and within spec, good to know!)
16. Compared dme status requests to known good car
17. Unplugged MAF sensor
18. Checked cam timing
19. Swapped pre cat 02 sensors from known good car
20. Submitted PUMA case to BMWNA and instructed to try swapping post cat o2 sensors
21. Instructed to replace eccentric shaft.
22. Vehicle operating as designed at this time.

Here's what I learned - South Bay BMW (right down the street from me) has some competent mechanics in that if I were trying to diagnose a rough idle, I wouldve done everything they did. They threw the book at the problem, and if it weren't for BMWNA somehow knowing to check the eccentric shaft itself, I don't know if the problem would've ever been fixed.

Why I'm sharing this with everyone is in the hopes that in the future, if someone else has a rough idle, you now know the 21 different work steps that BMW mechanics perform to try and diagnose the exact problem. Hopefully you don't end up all the way down at #21 because the cost of the eccentric shaft itself is some $600. I don't even want to know how much the labor cost is to replace it. FYI - the sensor itself is also $360. Too bad they didn't leave in the new spark plugs, coil packs, o2 sensors, and injectors. That would've been a nice bonus.

The car is no longer under full warranty, but I still have extended maintenance and CPO. This would've been covered under CPO (I think) but I shudder thinking about what recourse I would've had had the car not been under warranty.

Hope this thread will help someone in the future who has the same symptoms.
Appreciate 0
Reply

Bookmarks

Tags
328i, e90, idle, rpm, vibration

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:26 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST