E90Post
 


Alpine HID
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY: Retrofitting a Professional HU with USB and Bluetooth



Comment
 
Tutorial Tools Search this Tutorial
Jose_JN's Avatar DIY: Retrofitting a Professional HU with USB and Bluetooth
How to install a Head Unit with buit-in USB and Bluetooth
Jose_JN
05-06-2012
Hi mates!

This time I am showing you how to identify and retrofit a new Professional Head Unit wit built-in USB and Bluetooth features on my e93 from 05/2007

The improvement is very high!
Now, I have an USB socket and I don't need my iPod anymore because the USB...
  #66  
By Jose_JN on 11-21-2012, 04:07 AM
Member reviews
Difficulty [ 1 = Difficult ]
100%100%100%
5
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
60%60%60%
3
Average 60%
Quote:
Originally Posted by woodpecka View Post
I tried to add $6nn, $6fl, $644, $620 to the VO,
FA_Write the CAS and FRM,
Process CAR / Code CAR (2 times)
SG_Reset or coding the 2URAD
This is wrong! Remove $644 from your VO. This is only for cars with UFL or MULF not for HU with Bluetooth built-in

I always use SG-Codieren instead of SG-Reset.
As you said, if you reset the ECU according to your VO, the HU should work properly with your equipment. This mean that the HU will lower its outputs adapting it to the HiFi system.
Furthermore, the equalizers will be adapted to your model (e90, e91, e92, e87...) because each car has its own settings.

Regards.
Last edited by Jose_JN; 11-21-2012 at 04:17 AM.
Reply With Quote
  #67  
By Jose_JN on 11-21-2012, 04:11 AM
Member reviews
Difficulty [ 1 = Difficult ]
100%100%100%
5
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
60%60%60%
3
Average 60%
Quote:
Originally Posted by QUiKSR20 View Post
Hey guys, I have read this whole thread and searched for a bunch of threads but still unsure.. If I have an 08 w/OEM HiFi.. I have bluetooth and sirius radio + the 10 speaker setup.

I want to add usb/ipod connectivity.

Is there anything else I need besides :

CODING
2010+ head unit w/bluetooth & usb built in
USB Plug + wire to connect to head unit?

Is that all I need or will that even work?

Thanks,
Daryl
Your case is a little bit complicated... You need an HU with sirius built-in, bluetooth built-in and USB built-in.

It could be difficult to find, but try it!
Maybe is better for you buy the I-Pod retrofit kit and install it (no USB but tou can manage your ipod like a CD-Changer)

Dont worry about optic fiber. HiFi System don't need it (unless you have Logic7 or individual audio...)

Regards.

PS: This is the HU you need:
http://www.ebay.com/itm/BMW-professi...0c4225&vxp=mtr
Last edited by Jose_JN; 11-21-2012 at 04:19 AM.
Reply With Quote
  #68  
By Jose_JN on 11-21-2012, 04:13 AM
Member reviews
Difficulty [ 1 = Difficult ]
100%100%100%
5
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
60%60%60%
3
Average 60%
Quote:
Originally Posted by 2002 View Post
Jose,

So, what do I need to add USB to my 2009 328i with Pro Audio Head Unit? It now has an AUX In in the console. All I want is to add the USB flash drive reader capability - no mic or Bluetooth for a phone.

Looks like I need to buy these part numbers:

84109237653 USB-Aux Socket
61119129360 Coaxial fakra wire for USB

Do I need to code the radio? If I do, what OBD unit, and what software for Win7?

Thanks for any help!
You need only the parts you said but you must code the HU.
Read the thread about how to code the car.
You need an OBD-USB interface and the BMW Standard Tools (NCS, Tool32, WinKPF)

Regards.
Reply With Quote
  #69  
By QUiKSR20 on 11-21-2012, 09:29 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by Jose_JN View Post
Your case is a little bit complicated... You need an HU with sirius built-in, bluetooth built-in and USB built-in.

It could be difficult to find, but try it!
Maybe is better for you buy the I-Pod retrofit kit and install it (no USB but tou can manage your ipod like a CD-Changer)

Dont worry about optic fiber. HiFi System don't need it (unless you have Logic7 or individual audio...)

Regards.

PS: This is the HU you need:
http://www.ebay.com/itm/BMW-professi...0c4225&vxp=mtr
Hello,

Thanks for taking the time to post the link, So with that unit I could add a usb port to my center console right for full ipod integration?

I was looking into the retrofit kit but If I can locate one of these head units id rather that.

Thanks,
Reply With Quote
  #70  
By 4EST on 11-21-2012, 09:37 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by woodpecka View Post
The sound was set for a normal business non-hifi. Our hifi needs a lower output so the sound was too loud. After the reset, all the sound setup is perfect.

It would be very nice if you can read and copy the default setup before doing a reset..I would like to know what were the values.

Yes I bought the same and notice the cost increaee on his last item...it's crazy!

Btw our radio is the new 2urad, not 2rad.
Yes, I'll read the setup once I install it. What exactly should I backup, only the FSW_PSW.TRC file?
Reply With Quote
  #71  
By woodpecka on 11-21-2012, 11:25 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by 4EST
Quote:
Originally Posted by woodpecka View Post
The sound was set for a normal business non-hifi. Our hifi needs a lower output so the sound was too loud. After the reset, all the sound setup is perfect.

It would be very nice if you can read and copy the default setup before doing a reset..I would like to know what were the values.

Yes I bought the same and notice the cost increaee on his last item...it's crazy!

Btw our radio is the new 2urad, not 2rad.
Yes, I'll read the setup once I install it. What exactly should I backup, only the FSW_PSW.TRC file?
[/quote]
Yes only the TRC file.
Reply With Quote
  #72  
By Jose_JN on 11-22-2012, 03:21 AM
Member reviews
Difficulty [ 1 = Difficult ]
100%100%100%
5
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
60%60%60%
3
Average 60%
Quote:
Originally Posted by QUiKSR20 View Post
Hello,

Thanks for taking the time to post the link, So with that unit I could add a usb port to my center console right for full ipod integration?

I was looking into the retrofit kit but If I can locate one of these head units id rather that.

Thanks,
Yes, with this unit you will have bluetooth, usb and ipod (a cable is needed for the iPod)

You have to code the HU after install it.

Regards
Reply With Quote
  #73  
By veekz on 11-22-2012, 09:07 AM
Member reviews
Difficulty [ 1 = Difficult ]
100%100%100%
5
Cost [ 1 = Expensive ]
40%40%40%
2
DIY Clarity [ 1 = Not clear ]
100%100%100%
5
Average 80%
Thanks for all the info Jose! Confirming this works on a 1/2007 build e90 with Logic 7.

Got the radio from seller carsequipment on ebay. Awesome guy btw, really helpful and packaging was excellent. Confirmed that the mic he sends is not the correct one to install in the FZD, it's a VW part so it does not snap into the correct place.

When purchasing from him, make sure you verify the type of radio you need as he has different professional radios. Because I have logic 7, I needed the optical connectors to power my speakers/amp.

My car has $640, but no BT, BMW Assist so no ULF, TCU. Just a default AUX port. Following the guide posted swapped radios, added $6nn; $6FL +KMP3 and +IPOD. I pulled the original .trc from the URAD before blowing everything away. Plugged in radio and it powered on fine, had all options but no sound. I pulled the current .trc and ran a compare and changed the lines one by one until I finally got sound. I changed each setting one by one to see what would happen. The asterisk marked settings is what finally gave me sound. If anyone is interested I have the working file VS the original, but in short I changed the following.. some are region dependent:

Original 2009+ settings
------------------------------------------------------------------------
COUNTRYCODE_RADIO_2
ece
VOLUME_STEPS_RADD22
r55
r60
RING_STATUS_20
nicht_aktiv
AUDIO_SYSTEM_RAD22
stereo
SPRACHE_SVS
deutsch
DAB_BAND_RAD
beide


Current Settings install in 2007
-----------------------------------
CODIERUNG_ERFOLGT
codierung_erfolgt
COUNTRYCODE_RADIO_2
us
VOLUME_STEPS_RAD22
e81
e90
e92
e93
r58
r59
RING_STATUS_20 * Sound came out after enabling this
aktiv
AUDIO_SYSTEM_RAD22
top_hifi = this variable is system dependent
SPRACHE_SVS
us
DAB_BAND_RAD
kein_band


Confirmed USB works with a USB stick, played music, adjusted volume from steering wheel, etc. Ordering mic from tischer and waiting to see. I think i need to get behind the dash and find the mic wire from the FZD and run it to the deck? As because I have $640 this is done already? Trying to find docs on this, can you shed any light on this Jose?
Reply With Quote
  #74  
By Jose_JN on 11-22-2012, 11:02 AM
Member reviews
Difficulty [ 1 = Difficult ]
100%100%100%
5
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
60%60%60%
3
Average 60%
Quote:
Originally Posted by veekz View Post
Thanks for all the info Jose! Confirming this works on a 1/2007 build e90 with Logic 7.

Got the radio from seller carsequipment on ebay. Awesome guy btw, really helpful and packaging was excellent. Confirmed that the mic he sends is not the correct one to install in the FZD, it's a VW part so it does not snap into the correct place.

When purchasing from him, make sure you verify the type of radio you need as he has different professional radios. Because I have logic 7, I needed the optical connectors to power my speakers/amp.

My car has $640, but no BT, BMW Assist so no ULF, TCU. Just a default AUX port. Following the guide posted swapped radios, added $6nn; $6FL +KMP3 and +IPOD. I pulled the original .trc from the URAD before blowing everything away. Plugged in radio and it powered on fine, had all options but no sound. I pulled the current .trc and ran a compare and changed the lines one by one until I finally got sound. I changed each setting one by one to see what would happen. The asterisk marked settings is what finally gave me sound. If anyone is interested I have the working file VS the original, but in short I changed the following.. some are region dependent:

Original 2009+ settings
------------------------------------------------------------------------
COUNTRYCODE_RADIO_2
ece
VOLUME_STEPS_RADD22
r55
r60
RING_STATUS_20
nicht_aktiv
AUDIO_SYSTEM_RAD22
stereo
SPRACHE_SVS
deutsch
DAB_BAND_RAD
beide


Current Settings install in 2007
-----------------------------------
CODIERUNG_ERFOLGT
codierung_erfolgt
COUNTRYCODE_RADIO_2
us
VOLUME_STEPS_RAD22
e81
e90
e92
e93
r58
r59
RING_STATUS_20 * Sound came out after enabling this
aktiv
AUDIO_SYSTEM_RAD22
top_hifi = this variable is system dependent
SPRACHE_SVS
us
DAB_BAND_RAD
kein_band


Confirmed USB works with a USB stick, played music, adjusted volume from steering wheel, etc. Ordering mic from tischer and waiting to see. I think i need to get behind the dash and find the mic wire from the FZD and run it to the deck? As because I have $640 this is done already? Trying to find docs on this, can you shed any light on this Jose?
Hi!

Nice to heard that!

If you have $640 option, you already have a wire from the FZD to the trunk. But you need a wire between the FZD and the HU so you have to install a new one (maybe you can try to find it near the feet area and cut it trying to reuse it)

Check this http://www.e90post.com/forums/attach...1&d=1124553149

Anyway, you need the mic.

Regards.

PS: I have paypal, donatives are welcome!
I am preparing other retrofits for the next month!
Reply With Quote
  #75  
By woodpecka on 11-22-2012, 11:57 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by veekz View Post
Thanks for all the info Jose! Confirming this works on a 1/2007 build e90 with Logic 7.

Got the radio from seller carsequipment on ebay. Awesome guy btw, really helpful and packaging was excellent. Confirmed that the mic he sends is not the correct one to install in the FZD, it's a VW part so it does not snap into the correct place.

When purchasing from him, make sure you verify the type of radio you need as he has different professional radios. Because I have logic 7, I needed the optical connectors to power my speakers/amp.

My car has $640, but no BT, BMW Assist so no ULF, TCU. Just a default AUX port. Following the guide posted swapped radios, added $6nn; $6FL +KMP3 and +IPOD. I pulled the original .trc from the URAD before blowing everything away. Plugged in radio and it powered on fine, had all options but no sound. I pulled the current .trc and ran a compare and changed the lines one by one until I finally got sound. I changed each setting one by one to see what would happen. The asterisk marked settings is what finally gave me sound. If anyone is interested I have the working file VS the original, but in short I changed the following.. some are region dependent:

Original 2009+ settings
------------------------------------------------------------------------
COUNTRYCODE_RADIO_2
ece
VOLUME_STEPS_RADD22
r55
r60
RING_STATUS_20
nicht_aktiv
AUDIO_SYSTEM_RAD22
stereo
SPRACHE_SVS
deutsch
DAB_BAND_RAD
beide


Current Settings install in 2007
-----------------------------------
CODIERUNG_ERFOLGT
codierung_erfolgt
COUNTRYCODE_RADIO_2
us
VOLUME_STEPS_RAD22
e81
e90
e92
e93
r58
r59
RING_STATUS_20 * Sound came out after enabling this
aktiv
AUDIO_SYSTEM_RAD22
top_hifi = this variable is system dependent
SPRACHE_SVS
us
DAB_BAND_RAD
kein_band


Confirmed USB works with a USB stick, played music, adjusted volume from steering wheel, etc. Ordering mic from tischer and waiting to see. I think i need to get behind the dash and find the mic wire from the FZD and run it to the deck? As because I have $640 this is done already? Trying to find docs on this, can you shed any light on this Jose?
Nice!!

Please can you share your TRC file? I can share mine too if needed.
Reply With Quote
  #76  
By veekz on 11-22-2012, 11:53 PM
Member reviews
Difficulty [ 1 = Difficult ]
100%100%100%
5
Cost [ 1 = Expensive ]
40%40%40%
2
DIY Clarity [ 1 = Not clear ]
100%100%100%
5
Average 80%
Quote:
Originally Posted by Jose_JN View Post
Hi!

Nice to heard that!

If you have $640 option, you already have a wire from the FZD to the trunk. But you need a wire between the FZD and the HU so you have to install a new one (maybe you can try to find it near the feet area and cut it trying to reuse it)

Check this http://www.e90post.com/forums/attach...1&d=1124553149

Anyway, you need the mic.

Regards.

PS: I have paypal, donatives are welcome!
I am preparing other retrofits for the next month!
I was hoping that plug X3564 wasn't a straight run to the trunk, and that it hopefully ran behind the glovebox, then another plug ran from there to the trunk. That way i could use pins/connectors to wire the mic without have to cut and splice. Maybe I can just rig the VW mic if i have to cut to make it work...

I'll donate! Your hardwork is helping alot of people and saving them the headache of finding a MULF and making it easier to get all those options, plus the new deck with the shiny knobs haha.
Reply With Quote
  #77  
By woodpecka on 11-23-2012, 11:32 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by veekz

I was hoping that plug X3564 wasn't a straight run to the trunk, and that it hopefully ran behind the glovebox, then another plug ran from there to the trunk. That way i could use pins/connectors to wire the mic without have to cut and splice. Maybe I can just rig the VW mic if i have to cut to make it work...

I'll donate! Your hardwork is helping alot of people and saving them the headache of finding a MULF and making it easier to get all those options, plus the new deck with the shiny knobs haha.
Have you tried the VW connector on the radio? Does it fit?
Last edited by woodpecka; 11-23-2012 at 07:11 PM.
Reply With Quote
  #78  
By alexwhittemore on 11-29-2012, 02:54 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
What is the fan menu on the new headunit?
Reply With Quote
  #79  
By 4EST on 11-29-2012, 09:37 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
I installed the radio, but I can't connect to it.

The error I get is:
COAPI-2020: no answer from ECU
IFH-0009: no response from controllunit

When I press process ECU, I can only choose 2RAD, and I think I should see there 2URAD. I think ncsexpert tries to connect to the old 2RAD I removed, but now instead there is 2URAD and this could be the reason

Any advice?
Last edited by 4EST; 11-29-2012 at 10:12 AM.
Reply With Quote
  #80  
By woodpecka on 11-29-2012, 12:04 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by 4EST
I installed the radio, but I can't connect to it.

The error I get is:
COAPI-2020: no answer from ECU
IFH-0009: no response from controllunit

When I press process ECU, I can only choose 2RAD, and I think I should see there 2URAD. I think ncsexpert tries to connect to the old 2RAD I removed, but now instead there is 2URAD and this could be the reason

Any advice?
Hi

I got the same access issue and fixed it by adding the right VO and updating the daten files to v47.
Reply With Quote
  #81  
By 4EST on 11-29-2012, 03:33 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
no, you had a different issue as I red, not this error.

I think this error is caused by the unit being very new and can't be coded with D-com, only MOST

However, I tried something else and:
1 - changed VO by adding 663, 6NN and 6FL
2 - did sg_reset and LOST bluetooth AND USB
3 - removed 6NN, sg_reset and I got back bluetooth and USB

So, job done so far.

I wonder if it's possible to get the phone to do voice recognition instead of the bluetooth voice commands?

and how do I change gong volume, it's so very loud that I will disable new gong if I can't find a way to lower it (I did lower it to min from audio menu, but still way too loud)
I also noticed gong is not influenced by volume button



Quote:
Originally Posted by Jose_JN View Post
Bluetooth:
Depending on the production date of your car, you could need (or not):
61138384550 x1 -> 12 pins Female Connector
61138387206 x1 -> Connector housing
But they only cost a few bucks.


For USB you still need:
61119129360 x1 -> Coaxial fakra wire for USB
84109237653 x1 -> USB/Aux Socket
This cost around 80 bucks

Regards.
My car is 09/09 so it turns out I do NOT need the 12 pins connector and housing
My big connector at the back of the radio already had the 12 pin connector (actually a double 12 pin connector) built into the big main plastic radio connector

So I only needed to insert the 2 pins and secure them

I also to my surprise discovered I had fiber optic connector at the back of the radio. Happily though, the new HU also came with fiber at the back

What does actually the fiber optic do? transport sound, data? does MOST run through it? Does it mean I have an sound amplifier somewhere else in the car?
Last edited by 4EST; 11-29-2012 at 03:39 PM.
Reply With Quote
  #82  
By alexwhittemore on 11-29-2012, 03:48 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by 4EST View Post
I also to my surprise discovered I had fiber optic connector at the back of the radio. Happily though, the new HU also came with fiber at the back

What does actually the fiber optic do? transport sound, data? does MOST run through it? Does it mean I have an sound amplifier somewhere else in the car?
MOST is a high throughput media bus, distributed over fiber optics and set up as a ring in the car (if you disconnect one MOST connector anywhere, you break the ring, which is the reason for needing to mess around with the distribution block). The Logic7 amp uses MOST for input (it has DACs onboard for audio output), the combox/MULF connect to the head unit via MOST, etc etc.
Reply With Quote
  #83  
By 4EST on 11-29-2012, 04:19 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
ok, so MOST is the bus, so I guess some newer ECUs like to be coded only using it.

Now if I have MOST cables at the back of the HU, I should have Logic7 too? Where should it be?

Also where is MOST diagnose port?
Reply With Quote
  #84  
By alexwhittemore on 11-29-2012, 04:36 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by 4EST View Post
ok, so MOST is the bus, so I guess some newer ECUs like to be coded only using it.
not REALLY - There's a MOST-CAN gateway device in the car that allows messages to be sent across the two busses back and forth, which in theory means you can program even a MOST-only 2URAD with a DCAN cable attached to the OBD-II port. But in practice, the only way that actually works reliably is if you have newer software and an OPS head, etc etc, expensive and mostly only applies to dealers.

EDIT: Keep in mind, the way you code BT or 6FL into the car is by editing your VO in (N)FRM and CAS, then resetting the head unit with an SG_RESET - that message is sent from your DCAN cable to the radio through the gateway. But then for whatever reason, my 2URAD won't respond to SG_CODIEREN or GET_CODED jobs from my particular installation of NCSEXPERT. Some people don't have that problem.

Quote:
Originally Posted by 4EST View Post
Now if I have MOST cables at the back of the HU, I should have Logic7 too? Where should it be?
No, I only meant that as an example of one thing that uses MOST. All the headunits (except maybe old Business units? is that what you had? I forget) have a MOST connection. You can tell if you have L7 by looking at the center vent trim in your dash - if there's a speaker grill in the middle and not just solid plastic, you have a center speaker and thus L7. That said, if you had L7 you'd almost certainly know it - it's not a cheap option (and gives you advanced EQ functions in the headunit and whatnot).

Quote:
Originally Posted by 4EST View Post
Also where is MOST diagnose port?
In the pedal trim, just to the right of the OBD-II connector. It's a little flush square you can pop out with a trim tool to get access to a MOST connector. As installed in the cover, the most connector is pointed to a terminator that just shorts the lines together to complete the ring. You won't really ever have a good reason to mess with this, though.
Reply With Quote
  #85  
By woodpecka on 11-29-2012, 06:57 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
I have a MOST hifi radio without L7 and I can do whatever I want since I use the latest version of nc-expert and daten file. Are you tried the v47? I use a cheap usb dcan cable and I bought this radio http://www.ebay.com/itm/BMW-professional-bluetooth-car-radio-CD-MP3-player-bluetooth-USB-optic-INPUT-/230879432199?pt=Car_Audio_Video&hash=item35c17c8e0 7&vxp=mtr

If you reset but didn't get the sound setup, there is something wrong in your coding setup. Maybe you don't have the choice to use a MOST cable with L7..
Reply With Quote
  #86  
By alexwhittemore on 11-29-2012, 08:47 PM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
Quote:
Originally Posted by woodpecka View Post
I have a MOST hifi radio without L7 and I can do whatever I want since I use the latest version of nc-expert and daten file. Are you tried the v47? I use a cheap usb dcan cable and I bought this radio http://www.ebay.com/itm/BMW-professi...7c8e07&vxp=mtr

If you reset but didn't get the sound setup, there is something wrong in your coding setup. Maybe you don't have the choice to use a MOST cable with L7..
Like I said, some can, some can't.
Reply With Quote
  #87  
By 4EST on 11-30-2012, 03:38 AM
Member reviews
Difficulty [ 1 = Difficult ]
20%20%20%
1
Cost [ 1 = Expensive ]
20%20%20%
1
DIY Clarity [ 1 = Not clear ]
20%20%20%
1
Average 20%
I had a professional radio.
I'm using v47.1, but woodpecka, it's not the daten's fault. I can't do some stuff even with tools32, I get same error when trying some functions. I think ediabas really can't connect to the HU sometimes for some functions, as alex says

I only coded VO into CAS, not into NFRM, but I think I did ok, because now voice commands language changed to english

I'dd like to know where to code car's VIN with tools32, but I can't find where
Reply With Quote
Comment

Bookmarks

Tutorial Tools Search this Tutorial
Search this Tutorial:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:10 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST