E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > unplugging vanos solenoids while engine running? Bad?



Reply
 
Thread Tools Search this Thread
      11-17-2012, 01:09 AM   #1
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

unplugging vanos solenoids while engine running? Bad?

So I want to narrow down if the marble sound I have coming thru my dash is the vanos solenoids. (noise is rpm dependent)

IF I unplug the intake and the exhaust solenoid while the engine is running during idle, is it harmful for the engine?

this way I can see if the noise stops? I know for sure its the vanos solenoids.
Appreciate 0
      11-17-2012, 01:10 AM   #2
AK 335i
Major
AK 335i's Avatar
14
Rep
1,294
Posts

 
Drives: black 335i E90
Join Date: Sep 2012
Location: boynton beach

iTrader: (0)

��
__________________
- Proven Power Tampa Built 6466 ST N54 6AT WR 711whp 637wtq -
Appreciate 0
      11-17-2012, 08:00 AM   #3
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

I wouldn't...
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-17-2012, 10:44 AM   #4
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

Might just take them out to clean them with carb cleaner and compressed air.. Then swap there original positions.
Appreciate 0
      11-18-2012, 02:54 PM   #5
cortega
Enlisted Member
0
Rep
39
Posts

 
Drives: 2008 335i coupe
Join Date: Mar 2010
Location: Puerto Rico

iTrader: (0)

I have the same marble sound at idle, do you have any codes? mine dont. Already cleaned both solenoids with compressed air with no change. Can it be just the solenoids?
Appreciate 0
      11-18-2012, 02:56 PM   #6
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

Quote:
Originally Posted by cortega View Post
I have the same marble sound at idle, do you have any codes? mine dont. Already cleaned both solenoids with compressed air with no change. Can it be just the solenoids?
Damn.. I was gonna clean them this week coming up, but since you did and no change then no reason to.

nope I get no codes.

Im gonna unplug the boost solenoids when I hear the sound and see if the sound goes away.
Appreciate 0
      11-18-2012, 02:59 PM   #7
cortega
Enlisted Member
0
Rep
39
Posts

 
Drives: 2008 335i coupe
Join Date: Mar 2010
Location: Puerto Rico

iTrader: (0)

I didn't swap the solenoids, if you want to try it.
Appreciate 0
      11-19-2012, 06:38 PM   #8
cortega
Enlisted Member
0
Rep
39
Posts

 
Drives: 2008 335i coupe
Join Date: Mar 2010
Location: Puerto Rico

iTrader: (0)

UPDATE

Cleaned with brake cleaner and swapped the solenoids. Before, I heard the marble sound right after starting up. Now, I started the car, no marble sound. Half hour later the sound came back but much much less than before. Maybe one or both solenoids are bad. I'm going to get at least one and swap them one at a time.
Appreciate 0
      11-19-2012, 06:39 PM   #9
AK 335i
Major
AK 335i's Avatar
14
Rep
1,294
Posts

 
Drives: black 335i E90
Join Date: Sep 2012
Location: boynton beach

iTrader: (0)

good luck
__________________
- Proven Power Tampa Built 6466 ST N54 6AT WR 711whp 637wtq -
Appreciate 0
      11-24-2012, 09:08 AM   #10
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

FWIW, I changed both of my solenoids this weekend. I accidentally started the car w/o plugging in the electrical connectors and the car ran fine, in fact, it was quite smooth, and the marbles in the can sound disappeared. It instantly flashed up a yellow half engine light though.

But when I plugged the connectors back in, the marble sound is still there, but substantially reduced. But I have a feeling that changing the solenoids isn't the issue of the marbles in a can noise because it still present.
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-24-2012, 11:02 AM   #11
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by spool twice View Post
FWIW, I changed both of my solenoids this weekend. I accidentally started the car w/o plugging in the electrical connectors and the car ran fine, in fact, it was quite smooth, and the marbles in the can sound disappeared. It instantly flashed up a yellow half engine light though.

But when I plugged the connectors back in, the marble sound is still there, but substantially reduced. But I have a feeling that changing the solenoids isn't the issue of the marbles in a can noise because it still present.
Its the tune and specific firmware...I had this issue with newer maps on the Procede...Went back to older maps and noise was gone..
__________________
917-939-4980 CODING E and F Series New York Area

Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:30 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST