E90Post
 


Alpine HID
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Ground loop question



Reply
 
Thread Tools Search this Thread
      11-25-2012, 02:22 PM   #1
joelc73
Private First Class
 
Drives: 2010 E90
Join Date: Mar 2010
Location: NY

Posts: 109
iTrader: (0)

Ground loop question

Hi all,

Can anyone help me with, what I believe, is a ground loop issue. I previously had an amp installed and never had any alternator whine. I just replaced the amp with two separate pieces of gear -- a dsp followed by an amp.

Now I have a whine when I accelerate.

I'm guessing it has something to do with the two units together since I didn't have it before with just the amp... Any help would be much appreciated!

The amp is a JL xd400/4. The dsp is a Memphis 6ix.


Untitled by acataldo, on Flickr
joelc73 is offline  
0
Reply With Quote
      11-25-2012, 02:32 PM   #2
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2012 E92 M3, 2014 528i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 10,573
iTrader: (15)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by joelc73 View Post
Hi all,

Can anyone help me with, what I believe, is a ground loop issue. I previously had an amp installed and never had any alternator whine. I just replaced the amp with two separate pieces of gear -- a dsp followed by an amp.

Now I have a whine when I accelerate.

I'm guessing it has something to do with the two units together since I didn't have it before with just the amp... Any help would be much appreciated!

The amp is a JL xd400/4. The dsp is a Memphis 6ix.


Untitled by acataldo, on Flickr
You need to physically separate the power lines from the RCA as much as you can. Also, try to make the ground cable as short as possible and connect it to the same ground point as the OEM amp used to be.
__________________
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: September ED
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
-2002 E46 330i Orient Blue/Natural Brown, 5MT: Gone
Technic is offline   United_States
0
Reply With Quote
      11-25-2012, 03:03 PM   #3
joelc73
Private First Class
 
Drives: 2010 E90
Join Date: Mar 2010
Location: NY

Posts: 109
iTrader: (0)

Thanks Technic.

Should the ground go from the deck to the DSP and then to the amp? Or should it go from the deck and then split and go to both the DSP and amp?
joelc73 is offline  
0
Reply With Quote
      11-25-2012, 10:54 PM   #4
joelc73
Private First Class
 
Drives: 2010 E90
Join Date: Mar 2010
Location: NY

Posts: 109
iTrader: (0)

OK - I did some more research. Should I be using a distribution block to get the power to both units? Also, do I need one for the ground wires?

Any help would be hugely appreciated!
joelc73 is offline  
0
Reply With Quote
      11-26-2012, 01:23 AM   #5
Gugs
Cynical
 
Gugs's Avatar
 
Drives: E92 JetBlack
Join Date: Jul 2012
Location: Long island

Posts: 422
iTrader: (1)

Its your cheap rca cables. Get better shielded ones
Gugs is offline   United_States
0
Reply With Quote
      11-26-2012, 12:05 PM   #6
joelc73
Private First Class
 
Drives: 2010 E90
Join Date: Mar 2010
Location: NY

Posts: 109
iTrader: (0)

Quote:
Originally Posted by Gugs View Post
Its your cheap rca cables. Get better shielded ones
Thanks. What should I buy?
joelc73 is offline  
0
Reply With Quote
      11-26-2012, 12:20 PM   #7
kaigoss69
Colonel
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 2,738
iTrader: (5)

Run the RCAs away from any power cables. Also, make sure the power cables do not come close to the RCA plugs at the amp.
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) AE SBP15
kaigoss69 is online now   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:07 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST