E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > iPhone 5/iOS6 - activate Siri over bluetooth?



Reply
 
Thread Tools Search this Thread
      11-26-2012, 05:13 PM   #1
hems77
Private First Class
 
Drives: E90 320d M Sport
Join Date: Jun 2009
Location: UK

Posts: 198
iTrader: (0)

iPhone 5/iOS6 - activate Siri over bluetooth?

Hi there

I have bluetooth in my car (no idrive) and works great for calls. I use a blackberry stereo gateway for streaming my music in the car.

Just got an iphone 5 recently and as it has Siri I wondered whether if anybody knows how you can activate/make it work with the bluetooth in the car? I've tried pressing the home on the phone when Siri comes up nothing happens with the bluetooth in the car. I googled around and other users have said pressing the home button does call up Siri over bluetooth. Could it be something that's changed in iOS6 that stops it working like this now??

I'd like to be able to use Siri over bluetooth to do simple stuff like read my messages and send messages or call people. Ideally pressing the home button on the phone or the phone button on the steering wheel to mute any music playing and activate Siri ready to accept a command.

Any ideas???

Thanks
hems77 is offline  
0
Reply With Quote
      11-26-2012, 06:07 PM   #2
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,600
iTrader: (0)

I've got an e90 with bluetooth/no iDrive. Using the home button to activate siri results in siri popping up, a moment (1.5, maybe 2 seconds) of delay while the phone brings up the handsfree interface with the car, then siri audio in/out routes over the handsfree (so using the car speakers and mic, regardless of whether the phone's plugged in via aux). Assuming you've got your phone and car properly paired, this should always be the case - I think siri always uses a handsfree device if one is connected, and I don't think you can set it otherwise (just looked on my own phone to see).

If that's not happening for you, but calls work fine, that seems odd. In settings>bluetooth, what devices are paired? Try "forget this device" for all of them, then re-pair the car and try again.
alexwhittemore is offline  
0
Reply With Quote
      11-27-2012, 05:12 AM   #3
hems77
Private First Class
 
Drives: E90 320d M Sport
Join Date: Jun 2009
Location: UK

Posts: 198
iTrader: (0)

Thanks

I double checked in the car again - no luck! Press the home button on the phone but nothing happens over the speakers in the car. When Siri comes up there is a little bluetooth icon next to it and it says it's connected to the car but I hear nothing.

I also did forget this device and paired it again, but didn't work!

What iPhone and iOS version do you have?
hems77 is offline  
0
Reply With Quote
      11-27-2012, 08:52 AM   #4
djbordie
Private
 
Drives: 2011 bmw 323i
Join Date: Oct 2012
Location: Ontario, Canada!

Posts: 85
iTrader: (0)

my iphone4s used to work no prob by pressing the home screen.

you should check your settings and make sure it works without the car using the home screen (although im sure you already did this)

next is the problem with the e90 and the type of blue tooth siri sends out. apparently its different than what calls are used for.

i know my samsung s3 s-voice doesnt work over BT e90 but the calls work perfect. Its because the calls are sent using basic bt mono i think. and siri and s-voice use some fancier bt

cant say for sure this is your problem, but it could be the case.

fix for me was installing an app that forced BT mono from s-voice
djbordie is offline  
0
Reply With Quote
      11-27-2012, 10:35 AM   #5
torifile
Private First Class
 
Drives: 335d
Join Date: May 2011
Location: Durham, NC

Posts: 119
iTrader: (0)

I bet the problem is that you've got the BT gateway connected. I get Siri over BT in my car but I don't use a BT gateway like you do. I don't know if the iPhone has multipoint BT tech allowing connections to more than one audio device at a time.
torifile is offline  
0
Reply With Quote
      11-27-2012, 11:12 AM   #6
hems77
Private First Class
 
Drives: E90 320d M Sport
Join Date: Jun 2009
Location: UK

Posts: 198
iTrader: (0)

I'll try it without the BB gateway connected - but don't think this is the problem.

iPhone does allow multiple devices to be connected via bluetooth - I have it connected to the car for calls all the time and to the BB gateway all the time for streaming music via the the AUX port.

what iPhone and iOS version do you have?

BTW my car is a 2007 E90 if that makes a difference??
hems77 is offline  
0
Reply With Quote
      11-27-2012, 11:50 AM   #7
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,600
iTrader: (0)

I don't think the profile Siri uses is the issue- there's A2DP and handsfree, where a2dp is high nitrate stereo and handsfree is high compression mono with a limited passband on top of that (~200-4kHz or something, which is what a traditional phone line uses too). Even when connected to my jambox (high quality a2dp) activating Siri switches over to the handsfree profile, which I think is required to use the device's mic.

Try clicking the BT logo when Siri comes up, selecting 'my iphone' as the audio device, then switching it back to the paired car.
alexwhittemore is offline  
0
Reply With Quote
      11-27-2012, 11:54 AM   #8
chumley
Captain
 
chumley's Avatar
 
Drives: 2009 335
Join Date: May 2009
Location: Naples, FL

Posts: 707
iTrader: (1)

Quote:
Originally Posted by torifile View Post
I bet the problem is that you've got the BT gateway connected. I get Siri over BT in my car but I don't use a BT gateway like you do. I don't know if the iPhone has multipoint BT tech allowing connections to more than one audio device at a time.
I kind of think this too. I've used it with both ios 5&6 with no problem. In fact, don't even take my phone out of my briefcase or pocket. I have a small iphone BT remote that has a home button mapped. I keep it on the console and can access Siri no matter where the phone is and it has always used speakers and mic.

(though other than dialing numbers, I don't find Siri very useful)

http://www.amazon.com/Satechi-MediaR...=iphone+remote
__________________


PROcede V5Rev3+Openflash stacked, PWM Meth, DCI, BMW PE, ETS FMIC, Koni's w/Swifts, Rogue, Powerflex, SWS8xi's, Alufelgen Hyperblacks, LUX V4
chumley is offline  
0
Reply With Quote
      11-27-2012, 04:46 PM   #9
hems77
Private First Class
 
Drives: E90 320d M Sport
Join Date: Jun 2009
Location: UK

Posts: 198
iTrader: (0)

I tried it with the BB gateway disconnected still doesn't work!

I noticed though - the phone is paired with the car when I press the home button on the phone to activate siri the little mic comes up and waits for a command... at this point I can say something - for example 'what time is it?' and this seems to be picked up from the mic in the car, then siri actually responds and I get feedback on the phone. But the car stereo does not mute and all this is not heard through the car speakers. Thought this was weird... it's connected but doesn't mute and come through the car speakers. Could it be a setting somewhere else or on the phone perhaps?? Do I need to change something else??
hems77 is offline  
0
Reply With Quote
      11-28-2012, 09:09 AM   #10
hems77
Private First Class
 
Drives: E90 320d M Sport
Join Date: Jun 2009
Location: UK

Posts: 198
iTrader: (0)

Been googling around a bit more to try and get this working in my car and found this - http://www.tornell.com/2012/06/in-io...from-your-car/

Is this true??
hems77 is offline  
0
Reply With Quote
      11-28-2012, 11:44 AM   #11
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,600
iTrader: (0)

Not universally. Siri works great over Bluetooth with my E90. Of course, there's no way to activate it from the car, which is a bummer.
alexwhittemore is offline  
0
Reply With Quote
      11-28-2012, 11:56 AM   #12
torifile
Private First Class
 
Drives: 335d
Join Date: May 2011
Location: Durham, NC

Posts: 119
iTrader: (0)

Quote:
Originally Posted by hems77 View Post
Been googling around a bit more to try and get this working in my car and found this - http://www.tornell.com/2012/06/in-io...from-your-car/

Is this true??
Not for me either. I haven't had a problem with it at all except when I had to use the stereo jack to play music through my speakers before I got a Lightning to 30-pin adapter. At that time, I had to manually select the BT connection in my car to get it to go through the speakers.
torifile is offline  
0
Reply With Quote
      11-29-2012, 03:46 PM   #13
PaddyMcGrath
Rollin' Coal
 
PaddyMcGrath's Avatar
 
Drives: 2006 320D M-Sport
Join Date: Nov 2011
Location: Ireland

Posts: 171
iTrader: (0)

Like yourself, I'm using a Blackberry Gateway connected to the AUX-IN under the centre arm rest. Once my iPhone 5 is connected to both the car & Blackberry Gateway, I have no issues listening to music over Bluetooth or commanding Siri after pressing the home button on the phone, once I'm tuned into the AUX mode on the radio. I'm pretty certain you won't be able to access - or at least hear Siri back - when listening to the radio or a CD however.
__________________
http://www.pmcgphotos.com/
2006 E90 M Sport | BSM | KW Variant 1 | BMW Performance | Style 95 | SSDD Motorsport | M Style | Kenwood | Lightwerkz | Hartge Japan
PaddyMcGrath is offline   Ireland
0
Reply With Quote
      11-29-2012, 03:57 PM   #14
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,600
iTrader: (0)

Quote:
Originally Posted by PaddyMcGrath View Post
I'm pretty certain you won't be able to access - or at least hear Siri back - when listening to the radio or a CD however.
If everything's working right, that's not true - as soon as the handsfree profile is called up by any paired device, the radio switches speakers over to the handsfree output and makes the car's mike the handsfree input. It doesn't matter what source the radio is set to, since (if everything's working right) siri isn't sending audio to the aux in, it's sending it over bluetooth handsfree. You can tell this is true if the siri audio quality is noticeably crappier - the handsfree profile has severely limited bandwidth.
alexwhittemore is offline  
0
Reply With Quote
      11-29-2012, 04:06 PM   #15
hems77
Private First Class
 
Drives: E90 320d M Sport
Join Date: Jun 2009
Location: UK

Posts: 198
iTrader: (0)

Quote:
Originally Posted by PaddyMcGrath View Post
Like yourself, I'm using a Blackberry Gateway connected to the AUX-IN under the centre arm rest. Once my iPhone 5 is connected to both the car & Blackberry Gateway, I have no issues listening to music over Bluetooth or commanding Siri after pressing the home button on the phone, once I'm tuned into the AUX mode on the radio. I'm pretty certain you won't be able to access - or at least hear Siri back - when listening to the radio or a CD however.
So your set-up is just like mine - BMW bluetooth and BB gateway and the iPhone is paired to both. But you say yours is working - wonder what I am doing wrong then? Must be a setting on the phone??

I also have no issues listening to music over bluetooth, just can't get Siri to come over bluetooth when I activate it from the home button on the iPhone.

Any ideas???
hems77 is offline  
0
Reply With Quote
      11-29-2012, 04:10 PM   #16
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,600
iTrader: (0)

Quote:
Originally Posted by hems77 View Post
So your set-up is just like mine - BMW bluetooth and BB gateway and the iPhone is paired to both. But you say yours is working - wonder what I am doing wrong then? Must be a setting on the phone??

I also have no issues listening to music over bluetooth, just can't get Siri to come over bluetooth when I activate it from the home button on the iPhone.

Any ideas???
Does the little audio device selector button appear next to the siri microphone when you activate it inside your car while paired?
alexwhittemore is offline  
0
Reply With Quote
      11-29-2012, 04:16 PM   #17
bryanz
New Member
 
Drives: 2009 e90
Join Date: Oct 2012
Location: california

Posts: 7
iTrader: (0)

The problem I'm having is that when I have music playing from my iPhone I can get Siri to come on over Bluetooth, but her voice and my reply get cut off part way through. It seems like it takes a second or two for Bluetooth to link up every time I press the home button, but it's a bit longer than Siri expects so she starts talking before the link is up, and drops the connection before I start speaking. Is anyone else having this problem?
bryanz is offline  
0
Reply With Quote
      11-29-2012, 04:28 PM   #18
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,600
iTrader: (0)

Quote:
Originally Posted by bryanz View Post
The problem I'm having is that when I have music playing from my iPhone I can get Siri to come on over Bluetooth, but her voice and my reply get cut off part way through. It seems like it takes a second or two for Bluetooth to link up every time I press the home button, but it's a bit longer than Siri expects so she starts talking before the link is up, and drops the connection before I start speaking. Is anyone else having this problem?
Yes, regularly. I don't think it's what you think, though. It happens when I'm plugged in via my lightning adapter and Y cable, and listening SPECIFICALLY to music stored ON MY iPHONE (notably NOT third party apps, like rdio and pandora).

When listening to iPhone music, I press siri, bluetooth takes over, she comes up, then halts and music begins playing again. I think this comes down to BMW's less-than-stellar implementation of iPod Accessory Protocol - siri comes up, but for some reason the head unit sends a 'play' signal immediately to the iPhone, causing siri to stop and music to begin again. Since it doesn't happen for me in third party apps, I can only assume that it's an annoying interaction between bits of iAP that only apply to the native iPhone music app and which BMW has issues with, and which other apps either don't implement or ignore or etc etc.

My workaround is twofold - first, I usually listen to music via Rdio, so the problem doesn't frequently bother me. Second, if I AM listening to the music app and it happens, I just use the source button on the wheel to switch to the radio, then activate siri - no "play" command gets resent (since the iPod interface is inactive) and siri has no problems working over BT.
alexwhittemore is offline  
0
Reply With Quote
      11-29-2012, 04:32 PM   #19
bryanz
New Member
 
Drives: 2009 e90
Join Date: Oct 2012
Location: california

Posts: 7
iTrader: (0)

Awesome, thanks Alex. I'll try that. BTW, I'm also using the Lightning adapter but with a no-name Y cable from eBay. Glad to hear I'm not missing anything with the official BMW Y cable.
bryanz is offline  
0
Reply With Quote
      11-29-2012, 04:36 PM   #20
PaddyMcGrath
Rollin' Coal
 
PaddyMcGrath's Avatar
 
Drives: 2006 320D M-Sport
Join Date: Nov 2011
Location: Ireland

Posts: 171
iTrader: (0)

Quote:
Originally Posted by hems77 View Post
So your set-up is just like mine - BMW bluetooth and BB gateway and the iPhone is paired to both. But you say yours is working - wonder what I am doing wrong then? Must be a setting on the phone??

I also have no issues listening to music over bluetooth, just can't get Siri to come over bluetooth when I activate it from the home button on the iPhone.

Any ideas???
I'll have a proper look again tomorrow, as I was literally only playing with it today for the first time. Thinking about it, I can't remember Siri talking back to me although it did respond in text on screen and responded to any commands ...

What version of iOS are you running? I'm on 6.0.1, it might be helpful if others who have it working tell us what version they're on?
__________________
http://www.pmcgphotos.com/
2006 E90 M Sport | BSM | KW Variant 1 | BMW Performance | Style 95 | SSDD Motorsport | M Style | Kenwood | Lightwerkz | Hartge Japan
PaddyMcGrath is offline   Ireland
0
Reply With Quote
      11-29-2012, 04:44 PM   #21
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,600
iTrader: (0)

Quote:
Originally Posted by bryanz View Post
Awesome, thanks Alex. I'll try that. BTW, I'm also using the Lightning adapter but with a no-name Y cable from eBay. Glad to hear I'm not missing anything with the official BMW Y cable.
I'm also using a no-name Y cable, so it's not a scientifically valid test . But then again, I have no reason (knowing personally what electronics are in the cable) to believe that you'd get a different result with an OEM cable - I'm quite sure this one comes down to the protocol implementation, not some connection issue.

Quote:
Originally Posted by PaddyMcGrath View Post
I
What version of iOS are you running? I'm on 6.0.1, it might be helpful if others who have it working tell us what version they're on?
I'm also 6.0.1, iPhone 5.
alexwhittemore is offline  
0
Reply With Quote
      11-29-2012, 05:18 PM   #22
hems77
Private First Class
 
Drives: E90 320d M Sport
Join Date: Jun 2009
Location: UK

Posts: 198
iTrader: (0)

Quote:
Originally Posted by alexwhittemore View Post
Does the little audio device selector button appear next to the siri microphone when you activate it inside your car while paired?
Yes I get the little bluetooth icon next to Siri when I activate it in the car - it's set to the car not the iPhone.

I am iOS 6.0.1 and iPhone 5.

Paddy - appreciate it if you could check, look forward to your feedback

Thanks for all the replies! Hope I can get it working on mine...
hems77 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:28 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST