E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Help Please. JB4



Reply
 
Thread Tools Search this Thread
      11-27-2012, 07:43 PM   #1
awesome82
Private
awesome82's Avatar
2
Rep
87
Posts

Drives: gtr
Join Date: May 2012
Location: long island ny

iTrader: (0)

Help Please. JB4

Current Mods

JB4 G5 board
DCI
Catless downpipe
Muffler delete
Charge Pipe w BOV

So i have a local muffler shop install my Catless downpipe and when they did they crossed the O2 sensors. as may of you know the car throws a code and starts running incredibly rough with this

I had the o2 sensors put back correctly and the car still doesnt run right ONLY WITH THE JB4 (any map it does the same thing)

with the JB4 off, the car runs great (throws a CEL i am assuming bc the catless dp) but runs great, slow but great

As soon as i up the JB4 on the CELS go away, and once the car goes into full boost, the car starts shaking and throws another cel. This happens on any map

Any ideas?

the car is at TKX currently and they are waiting for someone to come down and read the code
Appreciate 0
      11-27-2012, 07:47 PM   #2
MrRetep
First Lieutenant
MrRetep's Avatar
16
Rep
360
Posts

Drives: 435i M-Sport
Join Date: Jan 2012
Location: Irvine CA

iTrader: (3)

the JB4 can be used to read the codes. maybe a misfire?
Appreciate 0
      11-27-2012, 07:51 PM   #3
awesome82
Private
awesome82's Avatar
2
Rep
87
Posts

Drives: gtr
Join Date: May 2012
Location: long island ny

iTrader: (0)

Quote:
Originally Posted by MrRetep View Post
the JB4 can be used to read the codes. maybe a misfire?
i was thinking the same thing.. I guess i will have 2 call them tomorrow

I would think they would know that
Appreciate 0
      11-27-2012, 10:04 PM   #4
AK 335i
Major
AK 335i's Avatar
18
Rep
1,294
Posts

Drives: black 335i E90
Join Date: Sep 2012
Location: boynton beach

iTrader: (0)

__________________
- Proven Power Tampa Built 6466 ST N54 6AT WR 711whp 637wtq -
Appreciate 0
      11-27-2012, 10:11 PM   #5
Exzackt
Second Lieutenant
Exzackt's Avatar
United_States
3
Rep
256
Posts

Drives: n54 e92 335i/e39 540i6
Join Date: Feb 2012
Location: SF Bay

iTrader: (2)

Definitely sounds like a misfire.. When adding lbs of boost, parts that would often need to be replaced, because they were already on their way out. Try spark plugs first. Then ignition coils. If neither of these two then high pressure fuel pump or injectors. How smooth does your car idle? If rough than you might want to clean your intake valves.
__________________
2007 BSM 335i ZSP/ZPP l JB4 G5 ISO l E85 l BMS FLASH l METH l DCI l DPs l Twin BOVs l
Scoops l 18" Forgestar F14sl Koni Yellows l Swift Spec-R l GForce Rivals/Slicks l Quaife LSD

Last edited by Exzackt; 11-27-2012 at 11:47 PM.
Appreciate 0
      11-28-2012, 01:55 AM   #6
CHECKERED
ex deus machina
CHECKERED's Avatar
United_States
17
Rep
574
Posts

Drives: 335i E92, 05 Audi S4
Join Date: Oct 2012
Location: a Treacherous Canyon Road in SoCal

iTrader: (6)

I would like some clarification,
- The car had a JB4 installed and was running ok
-after downpipes install with incorrect O2’s runs bad
-O2 sensors corrected but still runs bad (how was it discovered that the O2 sensors were switched, it’s possible they were damaged and now need replacement)

You might need to do a hard rest of the DME by unplugging the battery overnight
__________________
Garage Queen: Audi S4 4.2L V8, Vortech Supercharger, Bilstein PSS9 Coilovers, Sway-bars, RS4 brakes and rear BBK, Fast Intentions - Full Exhaust, 505AWTQ 0-60: 3.8s
Daily Driver: E92 335i N54: JB4 G5 ISO29 w/BMS E85 Flash, quaife LSD, BMS Meth, AA 6 Sport IC, BMS Charge Pipe: 12.1@117mph(stock intake & exhaust, RFT)
Company Car: 991 GT3 RSR
Appreciate 0
      11-28-2012, 12:47 PM   #7
awesome82
Private
awesome82's Avatar
2
Rep
87
Posts

Drives: gtr
Join Date: May 2012
Location: long island ny

iTrader: (0)

Quote:
Originally Posted by CHECKERED View Post
I would like some clarification,
- The car had a JB4 installed and was running ok
-after downpipes install with incorrect O2’s runs bad
-O2 sensors corrected but still runs bad (how was it discovered that the O2 sensors were switched, it’s possible they were damaged and now need replacement)

You might need to do a hard rest of the DME by unplugging the battery overnight
-Yes Jb4 was in for several months and car ran great
-correct
-I went to autocature in NJ and they check the code and corrected the issue (the car ran fine with the jb4 off after this as prior the car ran like shit constantly)

I might add that it doesnt happen EVERY pull... id say 98% of the time

i am thinking it either

Bad o2 sensors from when they were switched (idk if they go bad)

or plugs and or coils.

Car has 45k on it and im sure were never changed (bought it used)
Appreciate 0
      11-28-2012, 12:51 PM   #8
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
335
Rep
20,277
Posts


Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Probably spark plugs if they are original.
Appreciate 0
      11-28-2012, 12:56 PM   #9
WilliamS
GoofBall
United_States
18
Rep
1,098
Posts

Drives: 2008 E92 N54 Xdrive
Join Date: Jun 2012
Location: Tampa, FL

iTrader: (2)

First you can reset all learned values by using Category 1 selection 7 will clear adaptations. Try that bcuase you might not be fueling properly due the air amounts. Are you 100% sure the 02's are in the right place. Turn off the Autoclear Check light codes. If you dont know if you have it on go to screen 1 and use option 4 and get out of the menu as normal when you use the track down button on your steering wheel.

Car idle do the 1/7 clear adaptations let it idle for a little bit. Go to map 4, which is factory boost but allows the JB4 to keep track of codes and such. Drive the car 10 miles, some boost some without. From there go to map 5 and drive again. If your still getting a stumble use the JB4 to figure out what codes. If it throws a code, use the JB4 to figure out what it did and why. If its a missfire use the cable to see what your long term and short term fuel trims are. As well note which cylinder the missfire was on.

Report back when your done.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:34 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST