E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > fan runs on extreme high at startup?



Reply
 
Thread Tools Search this Thread
      10-16-2011, 03:57 PM   #23
rxtasy
Private
 
Drives: Bmw
Join Date: May 2008
Location: Earth

Posts: 69
iTrader: (0)

btw- it does not come on the exact moment I start the car...about 1-3 minutes after it is running....this morning for example:

1. started car
2. pulled out of driveway
3. drove 2 blocks and then i could hear fan kick on highest level
4. this continued until i got on a major road and picked up speed then fan slows or shuts down
rxtasy is offline  
0
Reply With Quote
      10-21-2011, 02:27 PM   #24
rxtasy
Private
 
Drives: Bmw
Join Date: May 2008
Location: Earth

Posts: 69
iTrader: (0)

k, so i bought a peake fault code reader and this is the error. "2E82-electric coollant pump-shut down"

likely the coolant pump causing my fan issues?
rxtasy is offline  
0
Reply With Quote
      10-23-2011, 11:31 AM   #25
JamesM3M5
Some dude
 
Drives: E28 M5, E92 335i
Join Date: Sep 2011
Location: Northern VA

Posts: 1,664
iTrader: (0)

Quote:
Originally Posted by rxtasy View Post
k, so i bought a peake fault code reader and this is the error. "2E82-electric coollant pump-shut down"

likely the coolant pump causing my fan issues?
I was gonna say that. The free code scans you can get at your corner store are usually not able to see all of the BMW specific codes, which is why you didn't see anything until you checked with a Peake, which is designed specifically to read manufacturer specific codes.
__________________
RRT Racing
E92 335i/6MT Dinan Stage 3: intercooler, oil cooler, intake, flash, exhaust, LW dual-mass flywheel.
Vishnu PWM methanol custom trunk mount, Diffsonline 3-clutch Salisbury custom diff, Ohlins Road and Track coilovers, Vorshlag camber plates, much more...
E28 M5 w/ buncha stuff, R171 SLK350
JamesM3M5 is offline   United_States
0
Reply With Quote
      10-23-2011, 12:14 PM   #26
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by JamesM3M5 View Post
I was gonna say that. The free code scans you can get at your corner store are usually not able to see all of the BMW specific codes, which is why you didn't see anything until you checked with a Peake, which is designed specifically to read manufacturer specific codes.
All OBDII codes can be read with any scanner for engine faults.

Certain states need it for inspection.

They aren't labeled the same as BMW codes. They are P codes. BMW has they're own codes but each one of those codes will also have a P code matching it. There are very few codes that aren't matched to P codes.

You only need a BMW specific scanner for pulling codes through modules such as your FRM or CAS module which are only found in BMWs.
fdriller9 is offline   United_States
0
Reply With Quote
      11-27-2012, 01:48 PM   #27
eee_90
Private
 
Drives: soon to be e90
Join Date: May 2012
Location: boston

Posts: 86
iTrader: (1)

BUMP - I have this same issue experiencing it over the past few days. Did anyone determine was the final cause?
eee_90 is offline  
0
Reply With Quote
      11-27-2012, 02:29 PM   #28
Three_thirty_I
Captain
 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

Posts: 804
iTrader: (0)

Garage List
Quote:
Originally Posted by eee_90 View Post
BUMP - I have this same issue experiencing it over the past few days. Did anyone determine was the final cause?
This is what kills me! So many threads with issues, and then no real outcome or update!

I would say have the codes read and see if you can get live readings of the oil and coolant temperatures as well as the coolant from radiator temperature. There is a temperature sensor at the radiator and at the heat exchanger - maybe one of them is faulty and triggering the ECU to think that the fan needs to be running...
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03



Last edited by Three_thirty_I; 11-27-2012 at 03:11 PM.
Three_thirty_I is offline   South Africa
0
Reply With Quote
      11-27-2012, 02:42 PM   #29
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,164
iTrader: (0)

Garage List
2006 330i  [2.83]
I agree with post above. Check temp sensor before changing water pump. If the car is not overheating, its most likely a faulty sensor. Keep us posted.
GoRomeo is offline  
0
Reply With Quote
      12-01-2012, 12:10 AM   #30
E90cruisin
First Lieutenant
 
Drives: 330i
Join Date: Jan 2011
Location: Florida

Posts: 313
iTrader: (8)

Does anyone have part codes for these sensors? I have had this issue come up lately too. Lets make this thread the end of this issue.
E90cruisin is offline  
0
Reply With Quote
      12-01-2012, 08:33 AM   #31
Three_thirty_I
Captain
 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

Posts: 804
iTrader: (0)

Garage List
Quote:
Originally Posted by E90cruisin View Post
Does anyone have part codes for these sensors? I have had this issue come up lately too. Lets make this thread the end of this issue.
Best is to check RealOEM - insert the last 7 digits of your VIN number there and it will find your car and relevant parts etc...
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Three_thirty_I is offline   South Africa
0
Reply With Quote
      12-01-2012, 10:29 AM   #32
Casca
Captain
 
Drives: E90 6MT
Join Date: May 2010
Location: California

Posts: 618
iTrader: (0)

Will be doing my thermostat/pump, oil housing gasket, coolant flush/replacement, might as well change the auxiliary fan switch too.


http://www.ecstuning.com/BMW-E90-325...oling/ES34327/

Can't believe the OP got diagnosed fan replacement because it was working on start-up too fast. It's like, they just guess. Too bad it's not $$$ out of their pocket. If it was, you can bet they would be more thorough.
Casca is offline  
0
Reply With Quote
      12-01-2012, 10:44 AM   #33
E90cruisin
First Lieutenant
 
Drives: 330i
Join Date: Jan 2011
Location: Florida

Posts: 313
iTrader: (8)

Quote:
Originally Posted by Casca View Post
Will be doing my thermostat/pump, oil housing gasket, coolant flush/replacement, might as well change the auxiliary fan switch too.


http://www.ecstuning.com/BMW-E90-325...oling/ES34327/

Can't believe the OP got diagnosed fan replacement because it was working on start-up too fast. It's like, they just guess. Too bad it's not $$$ out of their pocket. If it was, you can bet they would be more thorough.
Are you having the same issue with the fan running on high?
E90cruisin is offline  
0
Reply With Quote
      12-01-2012, 06:28 PM   #34
Casca
Captain
 
Drives: E90 6MT
Join Date: May 2010
Location: California

Posts: 618
iTrader: (0)

Quote:
Originally Posted by E90cruisin View Post
Are you having the same issue with the fan running on high?
Yes, I have noticed it and thought it odd, but didn't think farther of it. Just assumed if something was wrong, I'd get an indication. For $20, I will replace it now since I gotta do coolant anyway.

There is also this

http://www.ecstuning.com/Search/13621433076/ES2091379/

Not sure if its for the same thing since p/n is the same except for the last number or it's two different things. Would assume two different things since from the pics, they don't like like they fit the same way. Haven't looked at IPB's on realoem to make sure of everything since I am not doing this till after the New Year.
Casca is offline  
0
Reply With Quote
      12-02-2012, 01:01 AM   #35
E90cruisin
First Lieutenant
 
Drives: 330i
Join Date: Jan 2011
Location: Florida

Posts: 313
iTrader: (8)

Quote:
Originally Posted by Casca View Post
Yes, I have noticed it and thought it odd, but didn't think farther of it. Just assumed if something was wrong, I'd get an indication. For $20, I will replace it now since I gotta do coolant anyway.

There is also this

http://www.ecstuning.com/Search/13621433076/ES2091379/

Not sure if its for the same thing since p/n is the same except for the last number or it's two different things. Would assume two different things since from the pics, they don't like like they fit the same way. Haven't looked at IPB's on realoem to make sure of everything since I am not doing this till after the New Year.
Well, the dreaded overheat light turned on today. Pump is dead. The fan running on high has been going on for a week. I would be prepared if I were you. I will report back.
E90cruisin is offline  
0
Reply With Quote
      12-04-2012, 01:04 AM   #36
rivera156
New Member
 
rivera156's Avatar
 
Drives: 2006 BMW 330i
Join Date: Feb 2012
Location: tampa, fl

Posts: 26
iTrader: (0)

Does anyone have a DIY link to change this sensor?
rivera156 is offline  
0
Reply With Quote
      12-18-2012, 10:40 PM   #37
E90cruisin
First Lieutenant
 
Drives: 330i
Join Date: Jan 2011
Location: Florida

Posts: 313
iTrader: (8)

Quote:
Originally Posted by E90cruisin View Post
Well, the dreaded overheat light turned on today. Pump is dead. The fan running on high has been going on for a week. I would be prepared if I were you. I will report back.
Pump replaced, along with thermostat. Fan no longer comes on!
E90cruisin is offline  
0
Reply With Quote
      12-21-2012, 01:45 PM   #38
B9M0W
First Lieutenant
 
B9M0W's Avatar
 
Drives: e90
Join Date: Dec 2011
Location: NJ

Posts: 350
iTrader: (0)

My only does it during the summer. Its annoying as hell!.
Ps. I just replaced my t-s like 3 months ago.
B9M0W is offline   United_States
0
Reply With Quote
      12-21-2012, 02:19 PM   #39
centexE9x
Private
 
Drives: e9x coupe
Join Date: Dec 2012
Location: austin

Posts: 54
iTrader: (0)

Quote:
Originally Posted by E90cruisin View Post
Pump replaced, along with thermostat. Fan no longer comes on!
On the tech side, usually a fan coming on full blast even on cold start does indicate a water pump failure/issue. Almost everyone I have seen will do this even cold started and when it comes in the shop usually have water pump speed/communication faults. Some people don't come in complaining of an overheat message either.
centexE9x is offline  
0
Reply With Quote
      12-24-2012, 11:45 PM   #40
E90cruisin
First Lieutenant
 
Drives: 330i
Join Date: Jan 2011
Location: Florida

Posts: 313
iTrader: (8)

Quote:
Originally Posted by centexE9x View Post
On the tech side, usually a fan coming on full blast even on cold start does indicate a water pump failure/issue. Almost everyone I have seen will do this even cold started and when it comes in the shop usually have water pump speed/communication faults. Some people don't come in complaining of an overheat message either.
If I was not worried about the pump to begin with, I wouldnt have thought about it. It was just odd that out of nowhere it started to do that.

It no longer comes on.
E90cruisin is offline  
0
Reply With Quote
      01-03-2013, 06:58 AM   #41
bodz
Registered
 
Drives: 318i se 2008 auto
Join Date: Dec 2012
Location: london

Posts: 2
iTrader: (0)

Unhappy engine cooling fan does not shut off

i need some help as my bmw 318i se 2008 engine cooling fan turns on after around 10-15 mins and does not turn off until i switch the engine off.

really anoying as its loud
previous owner told me that it needs a new waterpump but seems to be fine.
can some tell me were the temp sensor/switch is located?
thanks
bodz is offline  
0
Reply With Quote
      01-03-2013, 04:07 PM   #42
mthomas
Private First Class
 
Drives: 2006 330xi
Join Date: Feb 2010
Location: lNorth Shore, Lake Tahoe

Posts: 159
iTrader: (0)

Dont post here that much, but Geez!

Quote:
Originally Posted by bodz View Post
i need some help as my bmw 318i se 2008 engine cooling fan turns on after around 10-15 mins and does not turn off until i switch the engine off.

really anoying as its loud
previous owner told me that it needs a new waterpump but seems to be fine.
can some tell me were the temp sensor/switch is located?
thanks
I am sorry, but did you even read the thread that you just posted in?
mthomas is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:21 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST