E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Radio Bass & Treble reset on their own!!! HELP!!



Reply
 
Thread Tools Search this Thread
      03-08-2009, 11:29 AM   #1
LittleBlue
Second Lieutenant
United_States
2
Rep
234
Posts

 
Drives: 2006 325i
Join Date: Jul 2007
Location: U.S.A

iTrader: (0)

Send a message via Yahoo to LittleBlue
Radio Bass & Treble reset on their own!!! HELP!!

E90 Factory Radio Bass, Treble Settings reset after few days, any ideas? But stations presets stay in memory, myself and the dealer are confused, changed radion but same issue exists... I use the same FOB all the time.

Any ideas or suggestions?
Appreciate 0
      03-17-2009, 10:38 AM   #2
Aaron'z 2.5RS/WRX
New Member
1
Rep
26
Posts

 
Drives: 00' Impreza RS/WRX stage 3
Join Date: Mar 2009
Location: Hickagain

iTrader: (0)

Sounds like an internal issue Sir..

If the radio station presets are keeping in memory, the constant power to the unit is there and stable, but the section the goes to the settings may have a power issue..

All of them use a constant power (memory) and a switched power (turn on) the switched comes from the ignition, so it knows when there is someone in the car..

Sounds like you may have a intermitent solder connection inside somewhere...

Not sure, but just ideas..
__________________
Appreciate 0
      03-18-2009, 05:31 PM   #3
LittleBlue
Second Lieutenant
United_States
2
Rep
234
Posts

 
Drives: 2006 325i
Join Date: Jul 2007
Location: U.S.A

iTrader: (0)

Send a message via Yahoo to LittleBlue
Thanks for the input, but BMW agreed to change the unit and the issue still there.
Appreciate 0
      06-14-2010, 06:47 PM   #4
RickC37830
New Member
0
Rep
8
Posts

 
Drives: 2006 325i
Join Date: May 2010
Location: Oak Ridge, TN

iTrader: (0)

Mine does this too.
Appreciate 0
      06-14-2010, 07:56 PM   #5
VP Electricity
Brigadier General
VP Electricity's Avatar
United_States
68
Rep
3,181
Posts

 
Drives: E91 XDrive
Join Date: Jan 2008
Location: portland oregon

iTrader: (3)

I think that B=T will reset from one key to another - i.e., user personalization. Check this, and also check if you have source-dependent tone controls (i.e., they change based on the selected source).
__________________
Musicar Northwest - TOP 12 Retailer 2014
OE-Look Enclosures for F30/F80, F32/F82, and more!
Ask about our bolt-in audio upgrades for BMW.
Appreciate 0
      06-14-2010, 08:34 PM   #6
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,181
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by LittleBlue View Post
Thanks for the input, but BMW agreed to change the unit and the issue still there.
So the OEM HU was replaced and the issue is still there?

If so, there could be a glitch either in the Car and Key memory or your keyfob battery is getting weaker so it is sending somehow the wrong signal to that C&K module, making the OEM HU to reset like there is a new keyfob in the system.
Appreciate 0
      06-14-2010, 09:01 PM   #7
VP Electricity
Brigadier General
VP Electricity's Avatar
United_States
68
Rep
3,181
Posts

 
Drives: E91 XDrive
Join Date: Jan 2008
Location: portland oregon

iTrader: (3)

T, that was from Mar 2009...
__________________
Musicar Northwest - TOP 12 Retailer 2014
OE-Look Enclosures for F30/F80, F32/F82, and more!
Ask about our bolt-in audio upgrades for BMW.
Appreciate 0
      06-15-2010, 04:54 AM   #8
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,181
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by VP Electricity View Post
T, that was from Mar 2009...
Damn...
Appreciate 0
      08-19-2010, 11:36 PM   #9
steevysteve
06 e90
United_States
0
Rep
17
Posts

 
Drives: 2006 325i
Join Date: Jul 2010
Location: Boston, MA

iTrader: (0)

Garage List
2006 325i  [0.00]
I've noticed, even the music settings are set to each key, so if you are logging between two keys let's say, then there you may realize your problem
__________________
2006 325i Monaco Metallic Blue, Gray Leather, Sport Package, Cold Weather Package, 19" MMR GT1 staggered, Ice white angel eyes, blue carbon emblems, park assist, bluetooth
Appreciate 0
      01-18-2011, 10:55 AM   #10
LittleBlue
Second Lieutenant
United_States
2
Rep
234
Posts

 
Drives: 2006 325i
Join Date: Jul 2007
Location: U.S.A

iTrader: (0)

Send a message via Yahoo to LittleBlue
Sorry been away for a while, catching up on my replies .....

This was fixed by the dealer changing the antenna inthe trunk? Or they called the antenna connection or something, they say that was shorting out the radio causing it to reset.
Appreciate 0
      05-31-2012, 12:56 PM   #11
schneiderbro
Registered
0
Rep
1
Posts

 
Drives: 328i
Join Date: May 2012
Location: Baltimore

iTrader: (0)

I've resarched this issue for weeks and agree that it is an antenna related problem. Did they replace the antenna free of charge? My dealship quoted me $600 to replace the faulty antenna.
Appreciate 0
      06-10-2012, 01:11 AM   #12
michollock
New Member
1
Rep
18
Posts

 
Drives: 330i
Join Date: Sep 2011
Location: SF Bay Area

iTrader: (0)

I have the exact same issue and it drives me crazy! Does anyone have more info on this possible antenna shorting fix?
Appreciate 0
      06-21-2012, 08:48 AM   #13
LittleBlue
Second Lieutenant
United_States
2
Rep
234
Posts

 
Drives: 2006 325i
Join Date: Jul 2007
Location: U.S.A

iTrader: (0)

Send a message via Yahoo to LittleBlue
It was under warrantee at the time, and yes it was free for me.
Appreciate 0
      12-02-2012, 01:26 PM   #14
LittleBlue
Second Lieutenant
United_States
2
Rep
234
Posts

 
Drives: 2006 325i
Join Date: Jul 2007
Location: U.S.A

iTrader: (0)

Send a message via Yahoo to LittleBlue
Quote:
Originally Posted by schneiderbro
I've resarched this issue for weeks and agree that it is an antenna related problem. Did they replace the antenna free of charge? My dealship quoted me $600 to replace the faulty antenna.
Antenna in the rear change was covered under CPO, not sure what the cause was, it's been a while sorry .
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:10 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST