E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > ABS, Brake & TC lights on - HELP



Reply
 
Thread Tools Search this Thread
      12-03-2012, 10:52 AM   #1
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

ABS, Brake & TC lights on - HELP

Hi Guys,

I have the yellow brake, yellow ABS and yellow Traction Control light on since a few days now.

I have made some research and found a lot of people listing their issues but not their answers to their problems.
The JB4 doesn't read ABS codes so I went to Pepboys this mornings and here are the codes:

5D93 - Whell Speed Sensor LeftFront
5DE1 - Brake Pad Wear (RA N/Wrong)
5DF4 - Wiring Supply Voltage
5DF0 - Pump Unit Faulty
5DF1 - Pump Unit Plug Faulty

Car has new brakes since several months now (replaces sensors, pads and rotors) and the ABS light came on once just a few weeks ago and disappeared the next day. Now it has been on for 4 days. It went off after a re-start for a few minutes then came back on.

If it matters, cruise control is not working, and turning signal is working properly (stops after a turn).

Any help would be much appreciated. Thanks!
Attached Images
  
Appreciate 0
      12-04-2012, 11:10 PM   #2
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

Update: lights have come off for a few miles then came back up, did the same twice. Speedo also came to zero, stopped and restarted the car and all lights were gone, speedo was working. Lights came back in 30 miles later...
Appreciate 0
      12-04-2012, 11:46 PM   #3
Hooy
Colonel
Hooy's Avatar
50
Rep
2,765
Posts

 
Drives: 2008 328i Coupe
Join Date: Sep 2009
Location: Houston, TX

iTrader: (12)

Garage List
2008 E92 328  [2.50]
Search DSC Module. That needs to be replaced. Part is about $433 and requires ABS pump bleeding and programming from the dealer.

You can bypass the programming by reusing the controller part of the module, since it's the pump part that failed on you.
__________________
Appreciate 0
      12-05-2012, 12:09 AM   #4
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

Thanks man, would this explain the intermittent light and the speedo drop to zero? Do you know if a wheel sensor can trigger an ABS light and code for the pump and the connection?
Thanks
Appreciate 0
      12-05-2012, 01:37 AM   #5
Hooy
Colonel
Hooy's Avatar
50
Rep
2,765
Posts

 
Drives: 2008 328i Coupe
Join Date: Sep 2009
Location: Houston, TX

iTrader: (12)

Garage List
2008 E92 328  [2.50]
Quote:
Originally Posted by Gfabry View Post
Thanks man, would this explain the intermittent light and the speedo drop to zero? Do you know if a wheel sensor can trigger an ABS light and code for the pump and the connection?
Thanks
Okay I admit I did not actually read your thread and just looked at the picture.

The issues I had:

all the same lights. Never got codes read. CC/TC/ABS did not work.

The solution:

A common problem, but the dsc pump fails.



I don't know about the speedo or turn signal not working...
__________________
Appreciate 0
      12-05-2012, 07:14 AM   #6
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

Thanks I might have the same issue. Turning signal is working
Appreciate 0
      01-23-2013, 10:34 PM   #7
SCS15
Captain
SCS15's Avatar
8
Rep
743
Posts

 
Drives: E92 335i 6MT
Join Date: Feb 2011
Location: Westchester, NY

iTrader: (3)

Quote:
Originally Posted by Gfabry View Post
Hi Guys,

I have the yellow brake, yellow ABS and yellow Traction Control light on since a few days now.

I have made some research and found a lot of people listing their issues but not their answers to their problems.
The JB4 doesn't read ABS codes so I went to Pepboys this mornings and here are the codes:

5D93 - Whell Speed Sensor LeftFront
5DE1 - Brake Pad Wear (RA N/Wrong)
5DF4 - Wiring Supply Voltage
5DF0 - Pump Unit Faulty
5DF1 - Pump Unit Plug Faulty

Car has new brakes since several months now (replaces sensors, pads and rotors) and the ABS light came on once just a few weeks ago and disappeared the next day. Now it has been on for 4 days. It went off after a re-start for a few minutes then came back on.

If it matters, cruise control is not working, and turning signal is working properly (stops after a turn).

Any help would be much appreciated. Thanks!
Ever figure out what this was? Im having the same issue. Hoping it has to do with the wheel speed sensor because I had an 18" oem wheels up front and 19" wheels in rear for a few days after my 19" front cracked.

Anyone know where to get codes read for cheap or free? Not interested in going to dealer.
__________________
Car for sale http://www.e90post.com/forums/showthread.php?t=881526
JB4 G5 - Forge FMIC - VRSF V2 DP - Magnaflow 15529 Catback Exhaust - BMS Clutch Stop - BMS DCI - CDV Delete - Dinan Stage 3 Suspension - 19x8.5/10 Forgestar F14 Gloss Gunmetal - Michelin PSS - M-Sport Front & Rear - M3 Side Skirts - OEM M3 Decklid Spoiler - BMW Performance Grilles - ZHP Shift Knob - M-Sport Steering Wheel - M-Sport Door Sills
Appreciate 0
      01-23-2013, 10:45 PM   #8
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

It is supposed to be the ABS pump, common issue on our cars, I haven't changed it yet, got the code read again and only the pump code was there. Go to pepboys they will read the ABS codes for free it's part of their free diagnostic
Appreciate 0
      02-10-2013, 11:39 PM   #9
skeetx3
New Member
Philippines
0
Rep
21
Posts

 
Drives: e92 328i
Join Date: Aug 2010
Location: Waukegan, IL

iTrader: (0)

Same issue with all the same lights intermittently flashing, DSC, brake flashing red and yellow, traction control, my speedometer would bounce in and out, along with a few more lights on the dash I can't remember. Strange thing was that it would go in and out of nowhere. Took it to my Indy and I guess my alternator was bouncing from 12, 14, up to 16 volts While running which was causing all the lights to light up like a Xmas tree. Long story short problem fixed and no more rough idle either. Stays at 600 rpms now. Hopefully by now you've solved your issue though if not hope this helps.
Appreciate 0
      02-11-2013, 12:03 AM   #10
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

Quote:
Originally Posted by sbv328i
Same issue with all the same lights intermittently flashing, DSC, brake flashing red and yellow, traction control, my speedometer would bounce in and out, along with a few more lights on the dash I can't remember. Strange thing was that it would go in and out of nowhere. Took it to my Indy and I guess my alternator was bouncing from 12, 14, up to 16 volts While running which was causing all the lights to light up like a Xmas tree. Long story short problem fixed and no more rough idle either. Stays at 600 rpms now. Hopefully by now you've solved your issue though if not hope this helps.
Did you get your codes read? Any ABS codes? Thanks
Appreciate 0
      02-14-2013, 12:33 AM   #11
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

Ordered the pump on eBay and replaced the pump but kept my control unit as it is coded for my car. Followed the DIY and it is very easy, took 30min maximum and the ABS lights are now off, finally..
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:29 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST