E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Rough idle at cold start...



Reply
 
Thread Tools Search this Thread
      01-11-2011, 10:45 AM   #45
justice
Second Lieutenant
justice's Avatar
6
Rep
284
Posts

 
Drives: 2006 BMW 330i
Join Date: Mar 2008
Location: Phoenixville, PA

iTrader: (2)

Garage List
I've had the same problem with my car (2006 330i), but it only happens during the winter months when it's below freezing. Though this year was the first year that the SES light came on. I ordered the BT Tool and the code read Cylinder 1 misfire. After reading several posts about the injector being the culprit, I ran some injector cleaner through it and a couple tanks of top tier gas. The problem went away initially, but it started coming back again as the temperature gets closer to 0.

My plan is to just replace the injectors/coil and plugs in the spring. My car has 75,xxx on it now so it's probably about time. It's about $600 in parts and I'll do the work myself.

Parts from advance auto:

NGK Laser Iridium Spark Plugs $68.80
Holley Fuel Injectors $433.40
Autolite Professional Ignition Coil on Plug Boot $66.25

Total with free shipping: $568.45
__________________

330i Sport Package, 6spd, Terra interior.... suspension, wheels, and tint coming soon.

Last edited by justice; 01-11-2011 at 10:51 AM.
Appreciate 0
      01-14-2011, 04:53 PM   #46
tony176000
Second Lieutenant
United_States
4
Rep
244
Posts

 
Drives: 2007 328i
Join Date: Jan 2011
Location: Albuquerque, NM

iTrader: (0)

Any more info on this thread? I have an appointment in a week for my 328i 2007, no mods. It has the same symptoms you guys are mentioning here: rough idle with shuddering on cold start up. Have run some Techron, seems better, and definitely goes away after 15 seconds of running, but with 3 months left on warranty I'd like to get it fixed before doomsday. I'll update the results of my visit...
Appreciate 0
      01-25-2011, 01:58 PM   #47
tony176000
Second Lieutenant
United_States
4
Rep
244
Posts

 
Drives: 2007 328i
Join Date: Jan 2011
Location: Albuquerque, NM

iTrader: (0)

Update:
Dropped the 328 off this morning for the dreaded "N52 ticking" and the rough start up. SA asked about what gas I use:
Chevron 91 octane. I live in Albuquerque NM, we're at about 5500 to 7500 elevation, depending on what part of town. He said that above 4000 feet, with good quality gas, try the 88 octane (They sell 86, 88, and 91 here). The altitude will take care of the knock (especially in winter), with 91 tending to have slightly more ethanol which contributes to rough start up...Thoughts?
Appreciate 0
      01-25-2011, 11:56 PM   #48
Stucks
Major
Stucks's Avatar
United_States
22
Rep
1,476
Posts

 
Drives: 2008 E92 335i
Join Date: Oct 2010
Location: Montgomery County, MD

iTrader: (8)

My turn.

I had the same problem this morning. Upon start up in my garage (30 degrees Fahrenheit outside) I experienced shaking and misfiring. I backed it out of the garage, waited about 20 seconds to see if this would go away, and when it didn't, I turned the car off. Restarted, but it seemed non existent anymore. I drove around the neighborhood for a little bit and the car ran like normal. I drove it to work, parked it, and left it alone the whole day.

8 hours later, I came outside to go home, started it up and sure enough, misfiring just as bad as in the morning. I turned it off and let it sit for a couple of seconds, then restarted it. Upon restarting it, misfires and shaking continued. I let it sit for about 20 seconds again as it misfired away, and then the "service engine soon" light illuminated on the dash and stayed on. Turned it off again, and restarted. Upon this third start, it seemed much calmer and no misfiring. I drove it home and parked it in the garage. I am going to call my local bmw dealership sometime in the next day or two (very busy with work and crap) when I have time and make an appointment. As far as I know, my car has not had the injector recall done. My build date is 02/08, so I believe I am eligible. I am also stock for now (luckily, I have been waiting to mod until I get all the recalls done.)
__________________
Current: 2008 e92 335i coupe.
Previous: 2003 Honda Accord V6 coupe: AEM V2, zex 75 wet shot (sold)
Appreciate 0
      01-26-2011, 12:29 AM   #49
tony176000
Second Lieutenant
United_States
4
Rep
244
Posts

 
Drives: 2007 328i
Join Date: Jan 2011
Location: Albuquerque, NM

iTrader: (0)

Quote:
Originally Posted by Stucks View Post
I had the same problem this morning.
What type of gas do you use, and more importantly, what the hells is the injector recall??

Lifter tick, fuel pump failure, tranny implosion...service bulletins are one thing, but critical failures and recalls are another, sheesh.

Man, I'm only in with 15 posts on the forum and this is driving me crazy

Appreciate 0
      01-26-2011, 01:01 AM   #50
Stucks
Major
Stucks's Avatar
United_States
22
Rep
1,476
Posts

 
Drives: 2008 E92 335i
Join Date: Oct 2010
Location: Montgomery County, MD

iTrader: (8)

Quote:
Originally Posted by tony176000 View Post
What type of gas do you use, and more importantly, what the hells is the injector recall??
I did not have the same problem as you tony, I meant i have the same problem as the OP of this thread.

I use 93 octane, mostly from shell gas stations. The injector recall is one of the recalls initiated by bmw. It is for cars with the N54 twin turbo engine. If you have an N54 car manufactured between april 2007 and october 2008, you can take your car in, and they look at the injector part numbers. if any match up to the set they deemed as faulty, they either replace the specific injectors with updated ones, or just replace all 6 of them altogether. Its just like the hpfp recall. It was a december 2010 technical service bulletin.

"SI B13 14 10
Fuel Systems"
__________________
Current: 2008 e92 335i coupe.
Previous: 2003 Honda Accord V6 coupe: AEM V2, zex 75 wet shot (sold)
Appreciate 0
      01-26-2011, 06:47 PM   #51
tony176000
Second Lieutenant
United_States
4
Rep
244
Posts

 
Drives: 2007 328i
Join Date: Jan 2011
Location: Albuquerque, NM

iTrader: (0)

Ya actually that is the problem I am spekaing about here to: the rought start up and idle. Any thoughts on the whole lesser octane may be better for this at higher altitudes? Seems kinda strange that a hi-po car would perform better with a sub-standard fuel...
Appreciate 0
      04-30-2012, 02:08 PM   #52
jhbodle
Captain
jhbodle's Avatar
22
Rep
714
Posts

 
Drives: F82 M4 Coupe
Join Date: Mar 2005
Location: UK

iTrader: (0)

Garage List
Sorry to bring this thread back to life, but now my 2007 335i has a very rough idle when started from cold. It's gradually got worse over the last two weeks. The shaking goes away when the car is warm. The dealer can't find any codes logged - I plugged in my own code reader and that didn't see any codes either.

Would leaky injectors throw a code? Or what's the verdict of what causes this? My car is under BMW extended warranty but they can't find a fault!
__________________
F82 M4 Coupe
Previous: F20 125d M E92 335i M Ind E90 325i SE E46 318i SE E36 316i
Appreciate 0
      07-02-2012, 12:58 PM   #53
cdavi060
Private First Class
United_States
7
Rep
156
Posts

 
Drives: 2006 BMW 330i
Join Date: Mar 2012
Location: Virginia Beach, VA

iTrader: (3)

Garage List
2006 BMW 330i  [0.00]
i have the problem when i'm idling the RPMs drop below 500 and shakes and quickly jumps back up. Does this about 4-5 times but goes away once start driving. any one else have that problem too? solution?
Appreciate 0
      12-11-2012, 01:12 PM   #54
vertigo44
Private
2
Rep
80
Posts

 
Drives: 08 AW 335i Coupe
Join Date: Jan 2011
Location: VA

iTrader: (0)

I am having this exact issue. Cylinder 6 misfires when the temps are cold outside during first startup. I have replaced all Spark Plugs and Coils. Moving to injectors next. Vanos solenoids are fairly new so i'll save those for last.
Appreciate 0
      12-11-2012, 02:37 PM   #55
cleex024
Major
24
Rep
1,447
Posts

 
Drives: 2008 BMW 335i Coupe
Join Date: Mar 2011
Location: Woodbridge

iTrader: (2)

all this could be because you need your intakes valves cleaned. i just walnut shell cleaned someones car and his was rough idling all the time and after we did this it was perfect. no more stuttering.
__________________
Space Gray l 6MT l OSG LSD w/ VAC Race Diff Cover l Cobb e30 l Morr vs8.2 l UUC SSK w/ DSSR l VSRF Catless Dps l RPI Intercooler l CDV Removed l HID AE 8000k l ETS Catback l AST 5200 w/ Vorshlag Camber Plates l ER Dual Oil Coolers l Rear Camber and Toe Arms l K&N Drop In l Solid Tranny/Diff/Subframe Bushings l Bridgestone RE-11
Appreciate 0
      12-11-2012, 03:12 PM   #56
Beetroot
Registered
0
Rep
3
Posts

 
Drives: 09 E92 335i
Join Date: Nov 2012
Location: NJ

iTrader: (0)

I have a misfire as well on start up, warranty is up soon so I need to take it in for that.
Appreciate 0
      12-11-2012, 03:50 PM   #57
cleex024
Major
24
Rep
1,447
Posts

 
Drives: 2008 BMW 335i Coupe
Join Date: Mar 2011
Location: Woodbridge

iTrader: (2)

anyway anyone with at least 50,000 miles should should definitely get an intake cleaning done because when i did it at 40,000 miles it was extremely dirty and as soon as i did the cleaning the rough idle went away and it was completely smooth...not a single hiccup
__________________
Space Gray l 6MT l OSG LSD w/ VAC Race Diff Cover l Cobb e30 l Morr vs8.2 l UUC SSK w/ DSSR l VSRF Catless Dps l RPI Intercooler l CDV Removed l HID AE 8000k l ETS Catback l AST 5200 w/ Vorshlag Camber Plates l ER Dual Oil Coolers l Rear Camber and Toe Arms l K&N Drop In l Solid Tranny/Diff/Subframe Bushings l Bridgestone RE-11
Appreciate 0
      12-11-2012, 10:24 PM   #58
grandmos
New Member
0
Rep
6
Posts

 
Drives: '10 335xi
Join Date: Sep 2011
Location: Royal Oak, MI

iTrader: (0)

I had the same problem with my '10 335i. 56000 miles.
When the temperature dropped last september, the idle was rough at cold start, getting even more rough days after days to the point where my wife was scared to drive the car...

First trip to the dealer, they suggested an air intake clean which I did and paid. ($530)
That didn't completely fixed the issue, they changed also the 6 plugs + one injector. BMW took care of that cost, even being out of warranty (i don't have CPO).

Got my car back, it was running ok. After 2 days of cold start, the rough idle came back, in addition to the CEL turning on during hard acceleration.

I brought the car back to the dealer. They kept it for 2 weeks and changed the remaining 5 injectors, still covered by BMW.
Now, no more idle problem. The car runs great.

I think it's crazy that the injectors have to be changed at 50k. Is it the quality of gasoline we put in there ? I am wandering if in Europe they have the same problems.
Appreciate 0
      12-11-2012, 11:06 PM   #59
PA66400
Private First Class
Canada
2
Rep
117
Posts

 
Drives: 2008 335i Sedan
Join Date: Oct 2011
Location: Calgary, AB

iTrader: (0)

Quote:
Originally Posted by grandmos View Post
I had the same problem with my '10 335i. 56000 miles.
I am really disappointed to hear that this injector issue is affecting 2010 cars. My 2008 (which has piezo-electric, rather than the later, simpler solenoid injectors that you have) had the injectors replaced for the same really rough cold start. In Canada, BMW had no recall campaign that US owners enjoyed (the replacement is on our dollar). As far as I can learn, the issue that causes failure is poorer quality NA fuel, compared to EU fuels. Isn't the majority of thier market in NA, rather than the EU? Really disappointing that the direct injectors on much less expensive Janapanese and Ford vehicles are durable, as opposed to ours. Brilliant engineering and driving experience, but the durability of my 335i and its cost of repair leaves something to be desired, given its premium car status. So does the double standard BMW policies for the US market, versus Canada. I realize they are different companies (US vs. Canada) but the coroporate mother is the same.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:34 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST