E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > New brakes vibrate when hot



Reply
 
Thread Tools Search this Thread
      07-16-2012, 11:26 AM   #1
vasillalov
Mad Linux Guru On The Loose
 
vasillalov's Avatar
 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

Posts: 4,137
iTrader: (3)

Garage List
2008 335i E90  [4.00]
New brakes vibrate when hot

Ok folks,

I am having some weird issues with the new brakes that I've recently installed.

I've installed brand new OEM Zimmerman rotors on the front, PFC 08 pads and I did a brake fluid flush for good measure.

I followed the correct bed-in procedures. This is not the first time I am changing the brakes on the car, so I am highly confident that I know what I am doing.

During normal street driving the brakes are fine. Very grabby, very predictable and the performance is very very good.

Unfortunately, on the track, when they heat up a lot, they start vibrating. It's really weird and unnerving. As soon as they cool of, everything is fine. The HDPE instructor that rode with me told me that the pads are overheating, but I don't think so. They are rated to almost 2000F which at which temperature the rotors will be glowing yellow.

Any ideas what's going on here?
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine
vasillalov is offline   Bulgaria
0
Reply With Quote
      07-16-2012, 12:30 PM   #2
M-POWERED-
Private
 
Drives: 2008 e92 335Xi, F10 M5 soon...
Join Date: Jul 2010
Location: biggest in the world

Posts: 69
iTrader: (0)

I had a similar issue with Zimmermann rotors, however they were drilled. Switched back to OEMs, and its gone. May be also arm bushings. Usually two main reasons with our cars.
M-POWERED- is offline   Russian Federation
0
Reply With Quote
      07-16-2012, 01:37 PM   #3
vasillalov
Mad Linux Guru On The Loose
 
vasillalov's Avatar
 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

Posts: 4,137
iTrader: (3)

Garage List
2008 335i E90  [4.00]
I have a M3 control arms and tension rods installed less than 1000 miles. I've already been to one track event with those M3 bits and the older brakes. No vibration at that time. It's definitely related to the brakes. I'll try loosing up the rotor retaining screw a bit and re-torquing the wheels.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine
vasillalov is offline   Bulgaria
0
Reply With Quote
      07-16-2012, 02:04 PM   #4
M-POWERED-
Private
 
Drives: 2008 e92 335Xi, F10 M5 soon...
Join Date: Jul 2010
Location: biggest in the world

Posts: 69
iTrader: (0)

Than the issue is definitely connected with rotors based from my experience. As for brake pads, I had vibration only with with cool carbon pads (two times with two sets, compound were overheating). I have tried many different manufacturers, such as ferodo 2500-3000, pagid rs19, hawk hps and hp+, porterfield r4s, ate ceramics and had zero issues. On my local bmw forum, people with e60 had similar problems with Zimmermann rotors. Good luck fixing it.

Off topic, I am planning to order front and rear f30 perf brakes in august and try to make them work in september. Thinking of creating interesting post with lots of description...
M-POWERED- is offline   Russian Federation
0
Reply With Quote
      07-16-2012, 02:54 PM   #5
HifiSyd
Enlisted Member
 
HifiSyd's Avatar
 
Drives: 2007 335i Sedan
Join Date: Dec 2010
Location: Edmond, Ok.

Posts: 95
iTrader: (0)

I had the same high-speed vibration issue when braking when I replaced my pads (Akebono) and had my OEM rotors turned. I know BMW does not recommend turning the rotors, but they were within spec, so I had it done.

Anyway, i'm not sure if it was a result of the rotor turning, or my aggressive bed-in process, but turns out the right front rotor was warped. I replaced both front rotors with Z4 35i rotors and the vibration is GONE. Good luck.
__________________

2007 SGM e90 335i, Spt Pkg, Prem Pkg & Nav

Mods: JB4 G4-Map 5, BMS DCI, 19" Reps on Hk V12s, SupremePower Lowering Perches, BMS Angel Eyes, VSFR DP & 5" FMIC.
HifiSyd is offline   United_States
0
Reply With Quote
      12-11-2012, 09:52 AM   #6
franzzz
Lieutenant
 
franzzz's Avatar
 
Drives: 335i E92
Join Date: Feb 2010
Location: ITALY

Posts: 414
iTrader: (0)

Same problem on my 335i with zimmermann discs

vibration issue when braking from 70MPH to 40MPH after heavy usage

__________________
BMW F30 AHybrid 380cv JB&MPE - Liquid Blue - step 8m - Paddles - Navi prof - USB - DivX- DVD - bluetooth - Voice Control - Connected - Apps - Online - Traffic Info - Speed Limit Info - Veneto Beige Seat - Full PDC - Rear Cam - HID Fog - Roof - Antitheft - Servotronic - Adaptive M Sport - K&N Filter
franzzz is offline   Italy
0
Reply With Quote
      12-11-2012, 10:03 PM   #7
vasillalov
Mad Linux Guru On The Loose
 
vasillalov's Avatar
 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

Posts: 4,137
iTrader: (3)

Garage List
2008 335i E90  [4.00]
In my case it turned out to be incorrectly bedded brake pads. After one full day on the track, everything went back to normal.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine
vasillalov is offline   Bulgaria
0
Reply With Quote
      12-12-2012, 05:44 AM   #8
franzzz
Lieutenant
 
franzzz's Avatar
 
Drives: 335i E92
Join Date: Feb 2010
Location: ITALY

Posts: 414
iTrader: (0)

in my case I think I warped discs
__________________
BMW F30 AHybrid 380cv JB&MPE - Liquid Blue - step 8m - Paddles - Navi prof - USB - DivX- DVD - bluetooth - Voice Control - Connected - Apps - Online - Traffic Info - Speed Limit Info - Veneto Beige Seat - Full PDC - Rear Cam - HID Fog - Roof - Antitheft - Servotronic - Adaptive M Sport - K&N Filter
franzzz is offline   Italy
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:56 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST