E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Washer pump not working. Any ideas?



Reply
 
Thread Tools Search this Thread
      12-10-2012, 12:44 PM   #23
scottydog1979
New Member
England
0
Rep
10
Posts

 
Drives: bmw 320d e90
Join Date: Dec 2012
Location: west midlands

iTrader: (0)

The pump itself was quite easy to fit, to be honest the hardest part was removing and re fitting the inner arch. Make sure you have a small bucket to hand ready to catch any liquid that is in the washer bottle when you remove the old pump as it runs out quite quickly, apart from that it was all good. After market pump only cost me 15.00 too so cheap fix also.
Appreciate 0
      12-13-2012, 06:55 AM   #24
Havana
Private First Class
Havana's Avatar
2
Rep
140
Posts

 
Drives: E89
Join Date: Jul 2012
Location: Poolside

iTrader: (3)

My washers stopped working on my old E90, but they were just heavily clogged up. Stuck a pressure washer in the filler neck and out came a swamp of all kinds of what looked like plants?! Anyway hope you all get it sorted
Appreciate 0
      02-03-2013, 11:49 AM   #25
DarkEnigma
Second Lieutenant
DarkEnigma's Avatar
United Kingdom
5
Rep
222
Posts

 
Drives: BMW 320
Join Date: Jul 2012
Location: UK

iTrader: (0)

FIXED Bought a new pump - wasn't sure if it had broken or not but figured by the time I have the wheel off, arch liner and access to pump I might as well have one to hand if it was faulty.

Turned out, the pump was a funny colour in certain places... it was definitely not functioning properly... anyway, fitted new pump as per below and worked perfectly again. New pump on left, old on the right - reservoir draining in the background

Appreciate 0
      02-03-2013, 12:40 PM   #26
coopersim
Captain
coopersim's Avatar
United Kingdom
16
Rep
775
Posts

 
Drives: VW Lupo
Join Date: Apr 2009
Location: Berks

iTrader: (2)

Ah the satisfaction of a job well done
Appreciate 0
      02-04-2013, 04:15 PM   #27
rsmallwo
Captain
rsmallwo's Avatar
14
Rep
923
Posts

 
Drives: 335d
Join Date: Jan 2010
Location: hull

iTrader: (0)

if you guys want it to stop blocking up again after cleaning it out/replacing parts then u need to use the bmw screenwash. you can get a 20 litre load for 40quid ish. You might be able to get away with using stuff that works down to -46C when undiluted. Think aldi do a 5L bottle for 6 quid.

If you search this subject u will find what I say been backed up. I used to have this issue on my 130i for 3 yrs. Once I changed to ethanol/alcohol based stuff the issue never reappeared. Also, it works...no more frozen screenwash! (when diluted as required)
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:23 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST