E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > N55 Problems in the making?



Reply
 
Thread Tools Search this Thread
      12-30-2012, 10:01 PM   #1
jzingerman
Second Lieutenant
 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

Posts: 241
iTrader: (0)

N55 Problems in the making?

The car is a 2011 335 M sport with about 20000 miles with the JB4 Stage 2 w/ flex fuel wires and ISO firmware, BMS Intake, and AR 4" downpipe.

About two weeks ago I updated my jb4 to the ISO firmware and also installed the flex fuel wires. I filled up with a 40/60 mix of E85 and 91 at my local gas station, set my jb4 to map 5 and it seemed like everything was working fine for a few days. The car pulled so hard that it didn't even seem like I was in a 335 anymore. About a little less then a week after the install, I turned on my car after sitting for about 2 hours and it started revving on its own. As I began to move without touching the gas the car would continue to rev on its own and push itself. Is it possible that this is a result of the intake? I've seen a few posts saying that the intake affects the RPM's at idle. Is this true? Anyways, After a few minutes it stopped and everything seemed fine. Next day, the revs continued to bounce when starting the car and then would stop after a minute. On top of this, my SES light is on every single time I turn on the car and remains on for a few minutes. I figured that it was just coming on because I'm catless but mid way though drives it comes on and flashes on and off for about 30 seconds. I checked for codes and what I found was 2E4C and 2D0D. Oh, and the car is cranking when I turn it on.

2E4C: Exhaust gas flap, activation: Line disconnection
2D0D: Oxygen sensor heating before catalytic converter, activation: Line disconnection

The revs have been getting worse and worse and now are moving all the way up to 1800 rpm. When shifting it sounds like my car is constantly back firing as well.

Yesterday when I turned the car on after sitting outside for a night, as I pushed the brakes to put the car into drive, it randomly turned off on me as if it was stalling. I turned the car off waited a minute, turned it back on and it was fine. I went and did what I had to do and when I got back to my car, turned it on, and pressed on the brakes to turn it on, it stalled on me again. I waited a minute, turned the car back on and it was working fine again.

The entire day I drove with caution and with the jb4 off. Late at night while driving to the canyons to have some fun, I floored the car and I got an engine malfunction warning saying " Engine operating at reduced output. Possible to continue. Drive with caution. Have the system checked by the nearest BMW center." I checked my codes and the car showed 2E4C, 2D0D, and 2C57 (Charge-air pressure control, lower value: Boost pressure too low).

I'm brining my car in for service after the new year but in the mean time I'm wondering if anyone else has had these problems before and if they know what's happening with my car. Should I be concerned because I have been told that n55's are notorious for having problems. Could it be the E85 that is screwing me over? Please help me!!
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl

Last edited by jzingerman; 12-30-2012 at 11:53 PM.
jzingerman is offline   United_States
0
Reply With Quote
      12-30-2012, 10:23 PM   #2
CJ421
Brigadier General
 
CJ421's Avatar
 
Drives: 2011 E92 335i
Join Date: Feb 2011
Location: PA

Posts: 3,253
iTrader: (1)

Garage List
2011 BMW 335i  [4.66]
Did you upgrade the charge pipe? It's common the plastic stock one cracks with more than stock boost, possibly explaining the low boost pressure. I can't comment on the revving issues though.
__________________
2011 BMW E92 335i, 6MT, Le Mans blue - Quaife LSD, JRZ RS Pro, JRZ camber plates, Eibach ERS, full M3 susp, custom toe arms, Powergrid end-links, SS brake lines, brake ducting, Michelin PSS, UUC SSK, ETS FMIC, ER CP, Perf. Exhaust, VAC RSIK, Sparcos; work by VAC Motorsports in Philadelphia
CJ421 is offline   United_States
0
Reply With Quote
      12-30-2012, 10:31 PM   #3
jzingerman
Second Lieutenant
 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

Posts: 241
iTrader: (0)

Quote:
Originally Posted by CJ421 View Post
Did you upgrade the charge pipe? It's common the plastic stock one cracks with more than stock boost, possibly explaining the low boost pressure. I can't comment on the revving issues though.
Nope I was planning on upgrading it but many people have told me that it's unnecessary so I never ended up going through with it. I checked the chargepipe but I couldn't feel any cracks. Then again, I'm not too experienced with all of this so I could be wrong.
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
jzingerman is offline   United_States
0
Reply With Quote
      12-30-2012, 10:49 PM   #4
ejj
Private
 
Drives: 2014 428i
Join Date: Oct 2011
Location: MD

Posts: 65
iTrader: (0)

How did you turn the JB4 "off"? Just going to map 0 with the ISO firmware will cap boost at 7ish PSI, which will cause CELs at WOT. Terry documented this in the n54 ISO notes (referenced by the n55 notes).

Map 4 is stock boost levels with the n55 ISO.
ejj is offline   United_States
0
Reply With Quote
      12-30-2012, 11:04 PM   #5
jzingerman
Second Lieutenant
 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

Posts: 241
iTrader: (0)

Quote:
Originally Posted by ejj View Post
How did you turn the JB4 "off"? Just going to map 0 with the ISO firmware will cap boost at 7ish PSI, which will cause CELs at WOT. Terry documented this in the n54 ISO notes (referenced by the n55 notes).

Map 4 is stock boost levels with the n55 ISO.
I had no idea. I've just been putting it on map 0. So should I put it to map 4 then and see how it runs?
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
jzingerman is offline   United_States
0
Reply With Quote
      12-30-2012, 11:09 PM   #6
ejj
Private
 
Drives: 2014 428i
Join Date: Oct 2011
Location: MD

Posts: 65
iTrader: (0)

Quote:
Originally Posted by jzingerman
Quote:
Originally Posted by ejj View Post
How did you turn the JB4 "off"? Just going to map 0 with the ISO firmware will cap boost at 7ish PSI, which will cause CELs at WOT. Terry documented this in the n54 ISO notes (referenced by the n55 notes).

Map 4 is stock boost levels with the n55 ISO.
I had no idea. I've just been putting it on map 0. So should I put it to map 4 then and see how it runs?
I would. Your problem with the jb4 in map 0 sounds expected.

I don't think this helps you at all with the problem you had before that.
ejj is offline   United_States
0
Reply With Quote
      12-30-2012, 11:28 PM   #7
jzingerman
Second Lieutenant
 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

Posts: 241
iTrader: (0)

Quote:
Originally Posted by ejj View Post
I would. Your problem with the jb4 in map 0 sounds expected.

I don't think this helps you at all with the problem you had before that.
At least I figured out why the engine malfunction warning came on. Still gotta figure out why the car is revving on its own and stalled on me twice.
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
jzingerman is offline   United_States
0
Reply With Quote
      12-31-2012, 12:15 PM   #8
shockin330i
Brigadier General
 
Drives: blue
Join Date: Jan 2007
Location: f y'all, I'm from Texas (RGV)

Posts: 4,192
iTrader: (1)

Quote:
Originally Posted by jzingerman View Post
Nope I was planning on upgrading it but many people have told me that it's unnecessary so I never ended up going through with it. I checked the chargepipe but I couldn't feel any cracks. Then again, I'm not too experienced with all of this so I could be wrong.
Not sure who told you not to change your charge pipe but honestly, that should be one of the first things to upgrade. They are prone to cracking at the mouth.
__________________
ERnie 2011 AW/e90/n55 12.9@107.53mph
*N55 Moderator*
I'm crawling similar to a ant cuz I'm low to the earth
shockin330i is offline  
0
Reply With Quote
      12-31-2012, 12:37 PM   #9
Abear
Private First Class
 
Drives: 2011 335i
Join Date: Aug 2011
Location: Houston

Posts: 147
iTrader: (3)

Really the only way to check the charge pipe(which sounds like it might be the problem) would be to take it off.

I dont understand all the issues with the intake. Mine blew the clamp off and I didnt notice for about a week and I never had issues with idling.
Abear is offline  
0
Reply With Quote
      12-31-2012, 01:10 PM   #10
jzingerman
Second Lieutenant
 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

Posts: 241
iTrader: (0)

Quote:
Originally Posted by Abear View Post
Really the only way to check the charge pipe(which sounds like it might be the problem) would be to take it off.

I dont understand all the issues with the intake. Mine blew the clamp off and I didnt notice for about a week and I never had issues with idling.
So u have had problems with the intake in the past? Ill take it off today and see if the problem is resolved.
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
jzingerman is offline   United_States
0
Reply With Quote
      12-31-2012, 01:19 PM   #11
Abear
Private First Class
 
Drives: 2011 335i
Join Date: Aug 2011
Location: Houston

Posts: 147
iTrader: (3)

Quote:
Originally Posted by jzingerman View Post
So u have had problems with the intake in the past? Ill take it off today and see if the problem is resolved.
Thats the thing, I havent had problems. The clamp came off because I didnt tighten it enough, but like I said, even with the clamp being loose and air getting in past the air meter, I still had no problems with idling.
Abear is offline  
0
Reply With Quote
      12-31-2012, 01:22 PM   #12
jzingerman
Second Lieutenant
 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

Posts: 241
iTrader: (0)

Quote:
Originally Posted by Abear View Post
Thats the thing, I havent had problems. The clamp came off because I didnt tighten it enough, but like I said, even with the clamp being loose and air getting in past the air meter, I still had no problems with idling.
Ill take it off just incase and see if it helps. Still curious why the car would stall. It also stalled once two moths after I bought it and put on my kw v3's.
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
jzingerman is offline   United_States
0
Reply With Quote
      12-31-2012, 01:31 PM   #13
shockin330i
Brigadier General
 
Drives: blue
Join Date: Jan 2007
Location: f y'all, I'm from Texas (RGV)

Posts: 4,192
iTrader: (1)

Quote:
Originally Posted by jzingerman View Post
Ill take it off just incase and see if it helps. Still curious why the car would stall. It also stalled once two moths after I bought it and put on my kw v3's.
Check the charge pipe.
This is what I found when I popped the hood one day...
__________________
ERnie 2011 AW/e90/n55 12.9@107.53mph
*N55 Moderator*
I'm crawling similar to a ant cuz I'm low to the earth
shockin330i is offline  
0
Reply With Quote
      12-31-2012, 02:02 PM   #14
SRT14PimPin07
Captain
 
SRT14PimPin07's Avatar
 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

Posts: 899
iTrader: (2)

Hey bud, I have been having all of the same problems with you except for the stalling part. My RPM's used to fluctuate on start up as well, and it still does it every once in a while, but for the most part it stopped. What I did is I went to auto zone and bought fuel injector cleaner and mixed it with my gas and I only put chevron gas. That fixed the RPM fluctuating.

As for getting half engine malfunction in map 0, that I found out from terry is also normal. Your not supposed to use map 0 anymore unless your taking the car into the dealer.

As for the low boost code, I got that too, terry told me to do some logs and send it in to him. So I gotta do logs in map 1, 4, and 5. And send it to him, I would suggest you do the same. So he can make sure everything is working properly. Your other codes I believe are normal tuner codes.

Hope this helps!
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
SRT14PimPin07 is offline   Armenia
0
Reply With Quote
      12-31-2012, 02:44 PM   #15
Kalud
Lieutenant
 
Kalud's Avatar
 
Drives: e92 335i
Join Date: Jun 2010
Location: Canada

Posts: 582
iTrader: (0)

I cannot find the info right now, but I've read that there is a DME software update to solve the cold start rpm fluctuation and engine stalling.
Kalud is offline  
0
Reply With Quote
      12-31-2012, 06:47 PM   #16
518N55
Enlisted Member
 
Drives: 2011 335i coupe
Join Date: Mar 2012
Location: Upstate NY

Posts: 38
iTrader: (0)

Sounds like you got the map 0 thing figured out

Make sure you have ISO C version loaded. It helped with the Idol creep up when it is cold. Other than that i'd defiantly guess it is the charge pipe.. it also could be a plug issue too. I was having a few misfire/ses issues and plugs fixed everything for me.
518N55 is offline  
0
Reply With Quote
      01-01-2013, 10:52 AM   #17
madmanhiker
Lieutenant Colonel
 
madmanhiker's Avatar
 
Drives: '11 E92 335i
Join Date: Jul 2008
Location: Jacksonville, Fl

Posts: 1,546
iTrader: (3)

Garage List
Quote:
Originally Posted by jzingerman View Post
I have been told that n55's are notorious for having problems.
1. Who told you this? That is a crazy, baseless statement.

2. You are running JB4 Stage 2 with ISO, E85 and a CAI. Change the charge pipe, secure all fittings, (including the Jb4 harness itself - take connectors off/on as they have been known to collect condensation and produce errors).

The n55 has been extremely reliable; you need to tune/mod in careful steps. The modifications you have installed increased your stock boost from 8-11 psi (at WOT) to 14-18 psi! If you are still using the stock charge pipe, you are asking for trouble as it WILL crack.

Who ever told you to not swap that out is a flat out idiot - run from them and never seek their advice again.

good luck.
__________________
-madmanhiker jax,fl
madmanhiker is offline   United_States
0
Reply With Quote
      01-01-2013, 02:45 PM   #18
SRT14PimPin07
Captain
 
SRT14PimPin07's Avatar
 
Drives: BMW 335i Coupe
Join Date: Jun 2009
Location: Los Angeles

Posts: 899
iTrader: (2)

^ The man knows what he is saying! Get that Chargepipe ASAP!
__________________
2011 Alpine White E92 335i M-Sport N55 Engine
SRT14PimPin07 is offline   Armenia
0
Reply With Quote
      01-20-2013, 07:23 PM   #19
xnfsx
Lieutenant
 
Drives: 335i M-Sport
Join Date: Jan 2012
Location: NY

Posts: 554
iTrader: (3)

I got 2e4c, 2096, and 2c57.

I have an upgraded charge pipe I floored it a bit on map 0 and the cel came on. but why am I getting these codes? i need to get an inspection soon but I was told to go on map 0. Any help?
xnfsx is offline  
0
Reply With Quote
      01-20-2013, 08:08 PM   #20
jzingerman
Second Lieutenant
 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

Posts: 241
iTrader: (0)

Quote:
Originally Posted by xnfsx View Post
I got 2e4c, 2096, and 2c57.

I have an upgraded charge pipe I floored it a bit on map 0 and the cel came on. but why am I getting these codes? i need to get an inspection soon but I was told to go on map 0. Any help?
have you done the golf tee mod? i'm pretty sure thats where the 2e4c code comes from. For the flooring it in map 0 problem, have you upgraded to the ISO firmware? If so, map 0 is no longer a stock bypass map, your supposed to use map 4. Don't use map 0 anymore unless your taking the car into the dealer bc map 0 with the ISO firmware will cap boost at 7 PSI, which will cause CELs at WOT.
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
jzingerman is offline   United_States
0
Reply With Quote
      01-20-2013, 09:31 PM   #21
xnfsx
Lieutenant
 
Drives: 335i M-Sport
Join Date: Jan 2012
Location: NY

Posts: 554
iTrader: (3)

yea I fixed the golf tee mod. now for map 0 if I need an inspection, still map 4? or should I go map 0. I'm all catless dp and exhaust
xnfsx is offline  
0
Reply With Quote
      01-20-2013, 11:21 PM   #22
jzingerman
Second Lieutenant
 
Drives: 2011 Bmw 335i M sport
Join Date: Nov 2011
Location: Beverly Hills California

Posts: 241
iTrader: (0)

Quote:
Originally Posted by xnfsx View Post
yea I fixed the golf tee mod. now for map 0 if I need an inspection, still map 4? or should I go map 0. I'm all catless dp and exhaust
Yeah im all catless and all but is your dealer chill with all your mods? but yes for bringing your car for inspection use map 0 but when driving on the streets don't use map 0 because its no longer a stock bypass map. the stock map is now map 4 if upgraded the ISO firmware
__________________
2011 BMW 335i M Sport- Space Grey Metallic * Black Kidney Grills * Jb4 Stage 2 ISO * Injen Intake * AR 4" Downpipe * 19" VMR V710 * Michelin Pilot Super Sports 235/265 * KW V3 Coilovers * 8k Alpine Angel Eyes * Gloss Black Roof Vinyl
jzingerman is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:39 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST