E90Post
 


E92 Lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Transmission Problem?



Reply
 
Thread Tools Search this Thread
      12-31-2012, 01:51 AM   #1
jeeve.x
First Lieutenant
 
jeeve.x's Avatar
 
Drives: E90 335i
Join Date: Sep 2012
Location: San Diego

Posts: 395
iTrader: (1)

Transmission Problem?

Hey guys, so today I went to start my car and the Service Engine Soon light came on together with a flashing gear-like warning light, I am assuming it is the transmission.

I restarted the car a couple of times and on the second try, the gear warning light went off just the SES light stayed on. I tried to put the car in reverse but it would not move. So I restarted the car again, this time the SES light is still on but car moves.

I drove around the block slowly, seems to be working fine. I restarted the car and all went back to normal, no lights, nothing.

Does anyone have any idea what seems to be the problem? Does the temperature play a part? It was below freezing btw. Any help is greatly appreciated!
jeeve.x is offline  
0
Reply With Quote
      12-31-2012, 02:22 AM   #2
kfrazie1
Lieutenant
 
kfrazie1's Avatar
 
Drives: 335i
Join Date: Aug 2010
Location: NY

Posts: 463
iTrader: (4)

How many miles? at or mt? Is your battery good?
__________________
Montego Blue E90 335i
7" VRSF IC | OFT Tune | DCI | RB PCV | Secondary CAT Delete & CYBA 3.75" Tips | M3 Front | CSL Trunk | 19" LC Dyna Wheels
kfrazie1 is offline  
0
Reply With Quote
      12-31-2012, 09:58 AM   #3
BMWM.D.
Stupid Idiot
 
BMWM.D.'s Avatar
 
Drives: E90 335i & C6 Grand Sport
Join Date: May 2009
Location: Santa Barbara

Posts: 686
iTrader: (1)

Possibly low-voltage causing communication issues on the PT-CAN. Like stated above, how is your battery? Clock been resetting at all?
__________________
BMWM.D. is offline  
0
Reply With Quote
      12-31-2012, 03:11 PM   #4
jeeve.x
First Lieutenant
 
jeeve.x's Avatar
 
Drives: E90 335i
Join Date: Sep 2012
Location: San Diego

Posts: 395
iTrader: (1)

Quote:
Originally Posted by kfrazie1
How many miles? at or mt? Is your battery good?
It's an auto with 89k miles. No signs of a weak battery though. I have to double check on that. So it's most likely not a mechanical problem?
jeeve.x is offline  
0
Reply With Quote
      12-31-2012, 03:11 PM   #5
jeeve.x
First Lieutenant
 
jeeve.x's Avatar
 
Drives: E90 335i
Join Date: Sep 2012
Location: San Diego

Posts: 395
iTrader: (1)

Quote:
Originally Posted by BMWM.D.
Possibly low-voltage causing communication issues on the PT-CAN. Like stated above, how is your battery? Clock been resetting at all?
I have to check the battery. No I don't think the clock reset.
jeeve.x is offline  
0
Reply With Quote
      12-31-2012, 03:36 PM   #6
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,314
iTrader: (0)

Garage List
2006 330i  [2.83]
Yeah I would start by testing your battery since we ve seen low battery causes weird icon readings in dasboard. Especially with cold weather were you are. Keep us posted. That transmisson icon its scary.
GoRomeo is offline  
0
Reply With Quote
      12-31-2012, 06:30 PM   #7
jeeve.x
First Lieutenant
 
jeeve.x's Avatar
 
Drives: E90 335i
Join Date: Sep 2012
Location: San Diego

Posts: 395
iTrader: (1)

Quote:
Originally Posted by GoRomeo
Yeah I would start by testing your battery since we ve seen low battery causes weird icon readings in dasboard. Especially with cold weather were you are. Keep us posted. That transmisson icon its scary.
Thanks a lot guys. Will keep you posted
jeeve.x is offline  
0
Reply With Quote
      12-31-2012, 08:29 PM   #8
BMWM.D.
Stupid Idiot
 
BMWM.D.'s Avatar
 
Drives: E90 335i & C6 Grand Sport
Join Date: May 2009
Location: Santa Barbara

Posts: 686
iTrader: (1)

Quote:
Originally Posted by jeeve.x View Post
Thanks a lot guys. Will keep you posted
Yeah, the transmission warning isn't super common to see on these cars. Could be a lot of things, though.
__________________
BMWM.D. is offline  
0
Reply With Quote
      12-31-2012, 11:35 PM   #9
jeeve.x
First Lieutenant
 
jeeve.x's Avatar
 
Drives: E90 335i
Join Date: Sep 2012
Location: San Diego

Posts: 395
iTrader: (1)

Quote:
Originally Posted by BMWM.D.
Quote:
Originally Posted by jeeve.x View Post
Thanks a lot guys. Will keep you posted
Yeah, the transmission warning isn't super common to see on these cars. Could be a lot of things, though.
Couldn't find a shop today. But I have been driving around today with no lights no problems. However there was one single instance where I started from a red light and there was a major jerk going into second gear. Any thoughts?
jeeve.x is offline  
0
Reply With Quote
      01-01-2013, 02:49 PM   #10
kfrazie1
Lieutenant
 
kfrazie1's Avatar
 
Drives: 335i
Join Date: Aug 2010
Location: NY

Posts: 463
iTrader: (4)

Quote:
Originally Posted by jeeve.x View Post
Couldn't find a shop today. But I have been driving around today with no lights no problems. However there was one single instance where I started from a red light and there was a major jerk going into second gear. Any thoughts?
That jerk your felt is most likely software related if you still run the older MSD80 software. Very common. It happens when engine is cold and can not be reproduced in DS mode. I get the jerk often because I never bothered to update the software.

My recommendation is just to check the battery. I jumped my car once because battery died on me and when I restarted I had transmission light on and it locked up in 3rd gear. If battery voltage is low it can't supply all the auxiliary components and odd things start happening.
__________________
Montego Blue E90 335i
7" VRSF IC | OFT Tune | DCI | RB PCV | Secondary CAT Delete & CYBA 3.75" Tips | M3 Front | CSL Trunk | 19" LC Dyna Wheels
kfrazie1 is offline  
0
Reply With Quote
      01-15-2013, 10:25 PM   #11
kfrazie1
Lieutenant
 
kfrazie1's Avatar
 
Drives: 335i
Join Date: Aug 2010
Location: NY

Posts: 463
iTrader: (4)

Update on this?
__________________
Montego Blue E90 335i
7" VRSF IC | OFT Tune | DCI | RB PCV | Secondary CAT Delete & CYBA 3.75" Tips | M3 Front | CSL Trunk | 19" LC Dyna Wheels
kfrazie1 is offline  
0
Reply With Quote
      02-01-2013, 01:26 AM   #12
jeeve.x
First Lieutenant
 
jeeve.x's Avatar
 
Drives: E90 335i
Join Date: Sep 2012
Location: San Diego

Posts: 395
iTrader: (1)

Quote:
Originally Posted by kfrazie1
Update on this?
Been busy lately, didn't check the forums.

Well, the car has been running perfectly so far. No weird lights, no major jerks either. Hope it stays this way. I did not get the battery checked however.
jeeve.x is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
service engine soon, transmission, warning light

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:40 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST