E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Bad accelaration



Reply
 
Thread Tools Search this Thread
      12-29-2012, 01:59 PM   #1
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Bad accelaration

As per title says I had bad acceleration on my 325i n52b engine. Feels like jumping. I don't know better explanation. On idle engine runs smooth. I will gona plug in my dis. But maybe some one had an Idea what it can be.
lemonukas is offline  
0
Reply With Quote
      12-29-2012, 02:05 PM   #2
briers
Ben
 
briers's Avatar
 
Drives: XFR
Join Date: May 2010
Location: Midlands,UK

Posts: 1,971
iTrader: (0)

Is this a recent occurrence?

Sure it's not the traction control stepping in in this damp weather

I pulled a massive slide coming off a big roundabout today and getting power down is pretty unsettling
briers is offline   United Kingdom
0
Reply With Quote
      12-29-2012, 02:06 PM   #3
A_P
Lieutenant Colonel
 
Drives: E46 M3
Join Date: Mar 2012
Location: South East

Posts: 1,698
iTrader: (0)

This is way too vague bro.

At a guess could be anything from traction control kicking in.

Coil pack or spark plug misfire... check ur software for bad cylinder.
Fuel filters.
Fuel Pump.

Or a wild guess here but could be muscular spasms of your leg.
A_P is offline   United Kingdom
0
Reply With Quote
      12-29-2012, 03:02 PM   #4
shrink
Captain
 
shrink's Avatar
 
Drives: E90 325i SE
Join Date: Jun 2012
Location: Edinburgh (UK)

Posts: 752
iTrader: (2)

Many 325i suffer from a power dip at 3100rpm under full load, it's engine management related in the case and a software update can fix this. If you have steps in power all though the rev range or more kangaroo style antics at various speeds then you'll need to look elsewhere
shrink is offline   United Kingdom
0
Reply With Quote
      12-29-2012, 04:58 PM   #5
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Definetly not my leg or traction control
That's more like it like kangaroo stile at various speed. Slow or hard acceleration. I will try tomorrow to change my spark plugs if not raining.
I will try DIS to see if any faults thrown.
I cleaned VANOS about 300 miles ago because was misfiring and throwing VANOS jammed. After cleaning no issues with idle misfiring or cutting of engine.
lemonukas is offline  
0
Reply With Quote
      01-02-2013, 05:08 AM   #6
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Guys what do you think it's normal sound of my engine.
http://youtu.be/tLOeE7ZVtZ8
lemonukas is offline  
0
Reply With Quote
      01-02-2013, 06:20 AM   #7
dobbo99
Captain
 
Drives: e46 M3
Join Date: Jan 2011
Location: UK

Posts: 849
iTrader: (0)

is it at lower speeds, 1st and 2nd gear?
dobbo99 is offline  
0
Reply With Quote
      01-02-2013, 06:25 AM   #8
dobbo99
Captain
 
Drives: e46 M3
Join Date: Jan 2011
Location: UK

Posts: 849
iTrader: (0)

Quote:
Originally Posted by lemonukas View Post
Guys what do you think it's normal sound of my engine.
sounds like mine, bit tappety/metallic, but they seem to be like that.

find the DISA valve (search youtube or on this forum) and pull the plug on it, see if there is a difference in sound.
some can need a clean, or a replacement, which is a cheap fix.
dobbo99 is offline  
0
Reply With Quote
      01-02-2013, 06:53 AM   #9
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

I have bad accelaration on all gears but now notice that puff sound if I press gas pedal quick in makes than that sound.
lemonukas is offline  
0
Reply With Quote
      01-02-2013, 04:31 PM   #10
Dr Dave
Zummerzet Zyder Drinker!
 
Dr Dave's Avatar
 
Drives: '06 330D Le Mans Blue
Join Date: May 2009
Location: Somerset

Posts: 5,541
iTrader: (3)

Garage List
You need a diesel.
Dr Dave is offline   United Kingdom
0
Reply With Quote
      01-02-2013, 04:39 PM   #11
shrink
Captain
 
shrink's Avatar
 
Drives: E90 325i SE
Join Date: Jun 2012
Location: Edinburgh (UK)

Posts: 752
iTrader: (2)

Quote:
Originally Posted by Dr Dave View Post
You need a diesel.
Been there, done it... Not enough fun when driving hard, not such a nice sound and serious issues with stuff like turbos and dpf due to the fact I do lots of very short journeys each day.

I will be sticking with petrol for some time to come, albeit next time something in a v8 flavour
shrink is offline   United Kingdom
0
Reply With Quote
      01-02-2013, 04:45 PM   #12
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Quote:
Originally Posted by Dr Dave View Post
You need a diesel.
not for now. i had diesel car before and it put me away from them. long story
lemonukas is offline  
0
Reply With Quote
      01-02-2013, 04:58 PM   #13
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

ok i just logged in my DIS and i got that
DME- 2E69-Knock- sensor signal 2- Signal implausible- Fault currently not pressent
DME- 2A99 DME: Crankshaft- exhaust camshaft, reference - Value outside reference range- Fault currently not pressent
DME - 2A87 DME: Exhaust VANOS, mechanism- stiff; jammed mechanically- Fault currently not pressent

I thinking is VANOS gives me all that troble
lemonukas is offline  
0
Reply With Quote
      01-03-2013, 05:51 AM   #14
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Which one is VANOS exhaust solenoid?
Top or bottom one?
lemonukas is offline  
0
Reply With Quote
      01-06-2013, 12:42 PM   #15
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Update
Ok I changed my exhaust VANOS solenoid and oil on my car.
Went for test drive and I still can feel little bit of jumping on WOT but is improvement from what it was.
Checked with DIS and I still got 2E69 knock sensor signal 2 fault. When I asked BMW Luton it's said my car don't have one :
After is checked with his system. Tomorrow I will try to change spark plugs and I will see if any improvement.
Any suggestions?
lemonukas is offline  
0
Reply With Quote
      01-07-2013, 06:42 AM   #16
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Update:
Just changed spark plugs and car feels more respond from throttle but I only try only half of it. Later today I will try to push it more. Than plug my DIS and I will see if any more faults coming.
Have good day everyone
lemonukas is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:13 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST