E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > steering whining noise



Reply
 
Thread Tools Search this Thread
      01-16-2012, 06:41 PM   #1
335okc
Captain
 
335okc's Avatar
 
Drives: e90 335
Join Date: Feb 2011
Location: okc

Posts: 654
iTrader: (0)

steering whining noise

i got a faint whining noise when i turn the steering wheel (hot and cold car).
only happens when i'm parking or in the parking lot, 5-10mph.
just started yesterday, and sometimes with the whine, i feel very slight vibrations on the steering wheel itself.

my power steering fluid was low, so i brought it to my indy, and they topped it off.

what do you think would cause the whine? anybody ever experience this?

when i had my windows down, it almost feel like the whine is in the inside of the car, not the outside/engine compartment?
335okc is offline  
0
Reply With Quote
      02-02-2012, 12:59 PM   #2
Arriba
Registered
 
Drives: E91 2006 325i
Join Date: Feb 2011
Location: Sweden

Posts: 3
iTrader: (0)

Does it sound something like this?



In any case i have this problem aka kittens in the steering column squealing noise.

Any suggestions?
Arriba is offline   Sweden
0
Reply With Quote
      02-06-2012, 05:50 AM   #3
Arriba
Registered
 
Drives: E91 2006 325i
Join Date: Feb 2011
Location: Sweden

Posts: 3
iTrader: (0)

Bump...
Arriba is offline   Sweden
0
Reply With Quote
      02-06-2012, 11:36 AM   #4
335okc
Captain
 
335okc's Avatar
 
Drives: e90 335
Join Date: Feb 2011
Location: okc

Posts: 654
iTrader: (0)

mine was resolved by adding some more power steering fluid and some serious fingers crossing.
i can't watch videos so i can't really tell what yours sound like.
335okc is offline  
0
Reply With Quote
      02-06-2012, 01:54 PM   #5
Cba2m5
New Member
 
Drives: 2011 BMW 328i X-Drive
Join Date: Sep 2010
Location: Columbia, MO

Posts: 7
iTrader: (0)

This actually happened to me also. Took it to the dealership and at first they replaced some bearing in the alternator. Still made the noise so took it back and they then discovered low PS fluid which led back to a leaky hose at the pump. Thank you warranty!
Cba2m5 is offline  
0
Reply With Quote
      02-06-2012, 03:58 PM   #6
335okc
Captain
 
335okc's Avatar
 
Drives: e90 335
Join Date: Feb 2011
Location: okc

Posts: 654
iTrader: (0)

i hope i don't have leaky hose on the pump, it'll be a bitch to even check it.
335okc is offline  
0
Reply With Quote
      05-21-2012, 04:28 AM   #7
Kristofer
Registered
 
Drives: BMW 335 Convertible
Join Date: May 2012
Location: Sweden

Posts: 2
iTrader: (0)

Quote:
Originally Posted by Arriba View Post
Does it sound something like this?



In any case i have this problem aka kittens in the steering column squealing noise.

Any suggestions?
Hi

I'm experiencing the exact same problem on my 330i and the dealership is saying that they have to replace the power steering pump which on my car will cost 10 000 SEK or ~1386 USD since my car is equppied with Active Steering.

Did you find a solution for this sound or what action did your dealership recommend you?

Regards
Kristofer is offline   Sweden
0
Reply With Quote
      05-23-2012, 05:31 AM   #8
///Mposter
Macgyver
 
Drives: 2007 e92 335i
Join Date: Jun 2011
Location: Greensboring

Posts: 269
iTrader: (0)

I had mine in the shop for a week. They tried first oiling whatever mechanism that moved . Then they ordered some new bushings for the steering column. Then they just replaced the whole steering column /rack. I would have loved to find out what the actual problem / rubbing was. My squealing kittens only happened when turning to one side so they initially thought I was power steering or rack and pinion.
///Mposter is offline   United_States
0
Reply With Quote
      05-23-2012, 12:29 PM   #9
335okc
Captain
 
335okc's Avatar
 
Drives: e90 335
Join Date: Feb 2011
Location: okc

Posts: 654
iTrader: (0)

for what it's worth, thankfully mine went away when i topped of the power steering fluid.
335okc is offline  
0
Reply With Quote
      05-26-2012, 12:49 AM   #10
yokono_unit
Private
 
Drives: Alpine White e92 335i
Join Date: Jun 2011
Location: Kapolei, HI

Posts: 92
iTrader: (0)

I had this. They ended up changing my steering rack.
yokono_unit is offline  
0
Reply With Quote
      11-15-2012, 08:49 PM   #11
woodpecka
Captain
 
woodpecka's Avatar
 
Drives: E91
Join Date: May 2010
Location: Montreal

Posts: 995
iTrader: (2)

I had this and fixed it by putting some lubrifiant in between the moving and fix parts, behind the steering wheel.
woodpecka is offline   Canada
0
Reply With Quote
      11-17-2012, 06:47 PM   #12
ZachP51
Private First Class
 
ZachP51's Avatar
 
Drives: 2008 335i E92 2013 135is
Join Date: Oct 2012
Location: Orlando, Fl

Posts: 191
iTrader: (3)

Had the same issue. They ended up having to replace the entire steering column, one of the seals was leaking, my 08 has just 30k miles and my SA said he had never seen that issue with the e92 before.
ZachP51 is offline   United_States
0
Reply With Quote
      12-28-2012, 10:08 PM   #13
myfly335
Lieutenant
 
myfly335's Avatar
 
Drives: 2011 e90 sport pkg ALL BLACK
Join Date: Jul 2011
Location: Hicksville, New York

Posts: 493
iTrader: (4)

Garage List
2011 BMW 335  [0.00]
Send a message via AIM to myfly335
Quote:
Originally Posted by 335okc View Post
i got a faint whining noise when i turn the steering wheel (hot and cold car).
only happens when i'm parking or in the parking lot, 5-10mph.
just started yesterday, and sometimes with the whine, i feel very slight vibrations on the steering wheel itself.

my power steering fluid was low, so i brought it to my indy, and they topped it off.

what do you think would cause the whine? anybody ever experience this?

when i had my windows down, it almost feel like the whine is in the inside of the car, not the outside/engine compartment?



same is happing with me anybody find a fix only happens when i turn slow left or right my car is covered but i would like to know wht it is before i take it in
myfly335 is offline   United_States
0
Reply With Quote
      12-29-2012, 04:11 PM   #14
335okc
Captain
 
335okc's Avatar
 
Drives: e90 335
Join Date: Feb 2011
Location: okc

Posts: 654
iTrader: (0)

Quote:
Originally Posted by myfly335 View Post
same is happing with me anybody find a fix only happens when i turn slow left or right my car is covered but i would like to know wht it is before i take it in
my issue is coming back today. i checked the power steering fluid, and it's a little low again. FWIW, i don't think it has anything to do with power steering fluid level, but it fixed it last time for me, might be coincidental.
335okc is offline  
0
Reply With Quote
      12-29-2012, 08:40 PM   #15
myfly335
Lieutenant
 
myfly335's Avatar
 
Drives: 2011 e90 sport pkg ALL BLACK
Join Date: Jul 2011
Location: Hicksville, New York

Posts: 493
iTrader: (4)

Garage List
2011 BMW 335  [0.00]
Send a message via AIM to myfly335
Quote:
Originally Posted by 335okc View Post
my issue is coming back today. i checked the power steering fluid, and it's a little low again. FWIW, i don't think it has anything to do with power steering fluid level, but it fixed it last time for me, might be coincidental.
idk i see mine is not full also going o top it off and see what happens
myfly335 is offline   United_States
0
Reply With Quote
      01-03-2013, 04:07 PM   #16
335okc
Captain
 
335okc's Avatar
 
Drives: e90 335
Join Date: Feb 2011
Location: okc

Posts: 654
iTrader: (0)

my SA filled the PS fluid to the brim. now it's worse lol. i heard it's something about air trapped in the pump that cause the noise. i can't purge it for the life of me.
I probably have some leakage, i know my shop had to replace my pulley last year when it hit the subframe (common problem with motor mount apparently).
i wonder if it had affected my ps pump.
335okc is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:07 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST