E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Help installing PAC SWI-CAN2 and SWI-RC



Reply
 
Thread Tools Search this Thread
      01-07-2013, 09:02 AM   #1
Dannyboy
First Lieutenant
3

 
Drives: 2006 E90
Join Date: Dec 2012
Location: New Jersey


Posts: 312
iTrader: (0)

Help installing PAC SWI-CAN2 and SWI-RC

Hey like the title says I'm trying to install these on an 06 E90. I thought I had the wiring right but when I test fitted in the car with the aftermarket radio I couldnt get the led on the RC to light up.

I have toe CAN2 connected to the RC via the molex plug and the rc plugged to the Alpine with the 3mm plug. I wired the CAN2... the yellow to Constant the black to ground and the CAN + to what was labelled as CAN high on the oem harness and the CAN - to what was labelled as CAN low on the oem harness.

The radio powers up but not getting anything out of the PAC units, although I didnt have time to check with a multimeter.

If anyone has installed this let me know if I have the wiring right!

Thanks
Appreciate 0
      01-10-2013, 04:10 PM   #2
Dannyboy
First Lieutenant
3

 
Drives: 2006 E90
Join Date: Dec 2012
Location: New Jersey


Posts: 312
iTrader: (0)

If anyone is listening!!! I checked power with a meter and have 10 volts on ignition and 13 with the car on. The problem is the unit wont program. the led stays on all the time and doesnt blink when pushed!

Come on I'm sure someone has tried to hook this thing up! Frustrated.
Appreciate 0
      01-10-2013, 05:57 PM   #3
Dannyboy
First Lieutenant
3

 
Drives: 2006 E90
Join Date: Dec 2012
Location: New Jersey


Posts: 312
iTrader: (0)

So it turnsout the instructions from PAC suck! I even called their tech support and the guy was as clueless as I was! I was able to get it to work...the CAN wire info was recersed on their instructions and the rep was giving me the wrong number for my radio!
Appreciate 0
      05-28-2013, 06:08 AM   #4
anzgan
Registered
0

 
anzgan's Avatar
 
Drives: 2011 bmw 320d
Join Date: May 2013
Location: india


Posts: 1
iTrader: (0)

is it working now ?????
Appreciate 0
      05-28-2013, 07:10 AM   #5
Dannyboy
First Lieutenant
3

 
Drives: 2006 E90
Join Date: Dec 2012
Location: New Jersey


Posts: 312
iTrader: (0)

Yes it is.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:31 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST