E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > 335d e92-Sudden power loss on moterway!



Reply
 
Thread Tools Search this Thread
      01-13-2013, 07:46 AM   #1
mistikempire
First Lieutenant
mistikempire's Avatar
United Kingdom
8
Rep
306
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

335d e92-Sudden power loss on moterway!

I baught a 2008 e92 2 weeks ago an drove it on the moterway today for the first time, an after i put my foot down an went over around 60mph a light came on the dashboard (shown below) an then the car lost power, went into a limp mode, so pulled over, switch the car off an then on again, an it was fine, but then done the same problem again.
The light that come on the dash i believe is the automatic transmission light, has anyone experianced this problem or can help?
Attached Images
 
Appreciate 0
      01-13-2013, 09:28 AM   #2
Red_Bean_Bun
Captain
7
Rep
711
Posts

 
Drives: E92
Join Date: Nov 2009
Location: Wilmington, DE

iTrader: (2)

You need to have the codes pulled .....
Appreciate 0
      01-13-2013, 09:43 AM   #3
3s4u2
Beamer Mantic
3s4u2's Avatar
United_States
8
Rep
796
Posts

 
Drives: 2006 325i Prem
Join Date: Apr 2008
Location: Texas

iTrader: (0)

Quote:
Originally Posted by Red_Bean_Bun View Post
You need to have the codes pulled .....
+ 1 could be a control module, fluid level, temperature to high, etc.....

If you purchased from a dealer you should take it back and have them deal with it, I'm sure the UK has "lemon laws" in affect!
Appreciate 0
      01-13-2013, 12:31 PM   #4
adriang
Captain
adriang's Avatar
Canada
9
Rep
625
Posts

 
Drives: 2011 BMW 335d
Join Date: Feb 2012
Location: Nobleton

iTrader: (0)

Had a similar situation on a busy highway in Toronto with an x5 35d
The car needed to be towed to BMW because it wouldnt start (not even after jump start)...
It was fuel pump and sensor related in my situation. Covered under warranty but had a deductible of $50CAD.


Also battery was dead, so they replaced that for $700CAD
__________________
2011 BMW 335d
Appreciate 0
      01-13-2013, 12:35 PM   #5
John 070
Lieutenant General
157
Rep
11,516
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

Quote:
Originally Posted by adriang View Post
Had a similar situation on a busy highway in Toronto with an x5 35d
The car needed to be towed to BMW because it wouldnt start (not even after jump start)...
It was fuel pump and sensor related in my situation. Covered under warranty but had a deductible of $50CAD.


Also battery was dead, so they replaced that for $700CAD
$700 for the battery? Is it a lot more for diesels?
Appreciate 0
      01-13-2013, 12:42 PM   #6
adriang
Captain
adriang's Avatar
Canada
9
Rep
625
Posts

 
Drives: 2011 BMW 335d
Join Date: Feb 2012
Location: Nobleton

iTrader: (0)

with labour, coding and tax (forgot to mention)
__________________
2011 BMW 335d
Appreciate 0
      01-13-2013, 12:43 PM   #7
John 070
Lieutenant General
157
Rep
11,516
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

Quote:
Originally Posted by adriang View Post
with labour, coding and tax (forgot to mention)
In the States I paid $280 to the dealer in 2011, but I've seen higher on the forum...
Appreciate 0
      01-14-2013, 09:21 AM   #8
mistikempire
First Lieutenant
mistikempire's Avatar
United Kingdom
8
Rep
306
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

Ok guys, went to a mechanic today an got the car diagnosed.

the diagnostics test read:
4180 Turbine Control Flap activation

an then had other codes, 4222, 423, 4242, 4252 which were all related to the glow plug cylinder.

Does anyone have any experiance or info about the readings?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:49 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST