E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Help with brake/AbS warning light



Reply
 
Thread Tools Search this Thread
      01-13-2013, 09:54 AM   #1
y2khardtop
Enlisted Member
1

 
Drives: 530i
Join Date: Nov 2011
Location: United States


Posts: 35
iTrader: (0)

Help with brake/AbS warning light



So I and getting the red service indicator (car on lift) and a constant "brake" indicator. When I try and go into the service menu (Odor button trick) it just flashes ABS and kicks me out

I've searched online but can't determine a specific failure. My pads are good, my fluid is good, and my hill-hold is good

It's an 06' 330i manual trans

Thank you
Appreciate 0
      01-13-2013, 09:56 AM   #2
y2khardtop
Enlisted Member
1

 
Drives: 530i
Join Date: Nov 2011
Location: United States


Posts: 35
iTrader: (0)

https://www.dropbox.com/s/ke7vapr7xq...%2019%20AM.jpg
Appreciate 0
      01-15-2013, 11:58 PM   #3
y2khardtop
Enlisted Member
1

 
Drives: 530i
Join Date: Nov 2011
Location: United States


Posts: 35
iTrader: (0)

no one has a clue on this forum? Red "car on lift" illumined with "brake" lettering illuminated?? I think it's BS these codes don't show up on a standard OBD2 scanner!
Appreciate 0
      01-16-2013, 12:22 AM   #4
Kit523
Major General
Hong Kong
224

 
Kit523's Avatar
 
Drives: 2009 AW E90 M3
Join Date: Feb 2006
Location: B.C. Vancouver


Posts: 6,886
iTrader: (25)

try to look it up on your service manual and you might able to find out
Appreciate 0
      01-16-2013, 12:25 AM   #5
Kit523
Major General
Hong Kong
224

 
Kit523's Avatar
 
Drives: 2009 AW E90 M3
Join Date: Feb 2006
Location: B.C. Vancouver


Posts: 6,886
iTrader: (25)

http://www.e90post.com/goodiesforyou/indicators.jpg

this might able to help you
Appreciate 0
      01-16-2013, 12:37 AM   #6
y2khardtop
Enlisted Member
1

 
Drives: 530i
Join Date: Nov 2011
Location: United States


Posts: 35
iTrader: (0)

Thanks that's the type of info I need, but my warning isn't shown. I obviously don't have a service manual
Appreciate 0
      01-16-2013, 05:50 PM   #7
Kit523
Major General
Hong Kong
224

 
Kit523's Avatar
 
Drives: 2009 AW E90 M3
Join Date: Feb 2006
Location: B.C. Vancouver


Posts: 6,886
iTrader: (25)

Quote:
Originally Posted by y2khardtop View Post
Thanks that's the type of info I need, but my warning isn't shown. I obviously don't have a service manual
Did you see the link i posted? the upper right page has your light there.

it's upside down but print it out to look for it.

I found it that's why i posted it for you
Appreciate 0
      01-17-2013, 08:25 AM   #8
y2khardtop
Enlisted Member
1

 
Drives: 530i
Join Date: Nov 2011
Location: United States


Posts: 35
iTrader: (0)

I must have missed it, but I have a damaged brake pad sensor wire.it was not secured properly at the bleeder cap and was rubbing against the rim. I straight wired it like I have other models, and the code won't clear, so I ordered a new sensor for $7 on eBay.

Thanks
Appreciate 0
      01-17-2013, 08:28 AM   #9
y2khardtop
Enlisted Member
1

 
Drives: 530i
Join Date: Nov 2011
Location: United States


Posts: 35
iTrader: (0)

Hey kit523, sorry I missed that, I originally opened it on my phone and could only see half of the image.
Appreciate 0
      01-20-2013, 04:00 PM   #10
y2khardtop
Enlisted Member
1

 
Drives: 530i
Join Date: Nov 2011
Location: United States


Posts: 35
iTrader: (0)

so I just replaced the damaged pad sensor wire. I still have the "lift" warning and the brake lite, and when I attempt the reset trick (hold the odo button) I just get an "ABS" light after several seconds. Any idea before I go to a local shop to attempt a reset? Thanks!
Appreciate 0
      01-22-2013, 10:22 PM   #11
bigdnno98
Major
United_States
20

 
bigdnno98's Avatar
 
Drives: Saving $$ for an F82 M4 :0
Join Date: Jul 2011
Location: Clarksville, TN


Posts: 1,144
iTrader: (7)

Bump. My friend has this same issue. How do you reset the lights?
__________________
99 Eclipse GSX dyno numbers soon
12 Maxima Slow
03 EVO 8 600HP Sold
09 e92 335i 440hp Sold
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:51 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST