E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Just installed ST coilovers an got some issues.



Reply
 
Thread Tools Search this Thread
      01-19-2013, 12:04 PM   #1
E90 ME
Private First Class
United_States
3

 
E90 ME's Avatar
 
Drives: 08 E90 335i
Join Date: Jun 2011
Location: Johns Creek, GA


Posts: 156
iTrader: (3)

Just installed ST coilovers an got some issues.

Well here is my problem, I have an 08 E90 335i and I installed ST coils last night. While I was going for a test drive my steering was a little off center and that I know an alignment will fix. But whenever I get to 40-45 MPH the car starts wobbling like the wheels are really lose. Me and my buddy rechecked all of the bolt and they were pretty tight. When installing the coils we rechecked everything and all is fine. Will an off alignment cause this wobble? Any help and input would help.

Thanks
__________________
Instagram @e90_me // M3 Front // CF CSL Trunk // ST Coils // Style 95s // JB4 // Catless DP // AA Sport IC // AA Signature Exhaust // BMS DCI // Greddy BOVs // P3 Vent Gauge //
Appreciate 0
      01-19-2013, 02:13 PM   #2
Hierlevelz
Lieutenant
5

 
Drives: 11 AW E9X M
Join Date: Dec 2011
Location: ENYC


Posts: 509
iTrader: (6)

Got aftermarket rims with hub centric rings and or universal bolt patterns?
Appreciate 0
      01-20-2013, 09:30 AM   #3
E90 ME
Private First Class
United_States
3

 
E90 ME's Avatar
 
Drives: 08 E90 335i
Join Date: Jun 2011
Location: Johns Creek, GA


Posts: 156
iTrader: (3)

Got an alignment and it fixed everything.
__________________
Instagram @e90_me // M3 Front // CF CSL Trunk // ST Coils // Style 95s // JB4 // Catless DP // AA Sport IC // AA Signature Exhaust // BMS DCI // Greddy BOVs // P3 Vent Gauge //
Appreciate 0
      01-22-2013, 07:44 AM   #4
TC Kline Racing
BimmerPost Supporting Vendor
United_States
7


 
TC Kline Racing's Avatar
 
Drives: Many BMW's & Porsche's
Join Date: Mar 2012
Location: Columbus, OH & Santa Barbara, CA


Posts: 330
iTrader: (0)

Glad to hear, that is typically the problem.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:42 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST