E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Coding Cable Confirmation E92 01/07 Build Date



Reply
 
Thread Tools Search this Thread
      01-19-2013, 03:28 PM   #1
braveplayer3160
Enlisted Member
 
Drives: 328I Coupe
Join Date: Aug 2011
Location: LA

Posts: 44
iTrader: (1)

Coding Cable Confirmation E92 01/07 Build Date

Just wanted to give everyone some info on a less expensive cable that I purchased from Amazon that worked in coding my 01/2007 build date E92.

Here is the link:

http://www.amazon.com/gp/product/B00...ls_o09_s00_i00

The nice thing about this cable is that it's only $45.00 and is Prime eligible for those of us with Prime accounts that means that we get the cable w/ free 2 day shipping or $3.99 one day shipping.

To document I followed the tutorial here:

http://www.e90post.com/forums/showth...ghlight=coding

I used that along with lots of reading in the coding forum before I even attempted the coding process. But, nonetheless I was able to code without a problem.

Here is my setup that I used:

Amazon Cable (see link above)
Acer Aspire One D257
Windows 7 Professional (32 bit)
phil.harlow's Walk-through (see link above)
xxxjecxxx's Pdf: http://rapidshare.com/files/429875523/NCS_DIY.pdf

Now, from what i've read i think there is a difference with pins 7 & 8 on these OBD connectors that changed after 03/2007 (Again this is something that I thought I had read while scouring the coding forum but I didn't look into it much) and, as such I cannot confirm the cables functionality beyond that supposed cutoff (03/2007) but, for those of us with pre 03/2007 build dates I can confirm that this cable works as advertised.

If anyone has any questions about the cable in general you can shoot me a pm. Hope this helps.
braveplayer3160 is offline  
0
Reply With Quote
      01-19-2013, 08:05 PM   #2
BmerMeUp
Lieutenant
 
BmerMeUp's Avatar
 
Drives: Cinderella: 2008 E91 328xi
Join Date: Nov 2012
Location: Ontario

Posts: 435
iTrader: (0)

Looks identical to the one I finally got which works on my 11/07 build E91 also, except you saved $6 and about 57 days of shipping.
BmerMeUp is offline   Canada
0
Reply With Quote
      01-19-2013, 10:20 PM   #3
braveplayer3160
Enlisted Member
 
Drives: 328I Coupe
Join Date: Aug 2011
Location: LA

Posts: 44
iTrader: (1)

Yea. I just want to give some people here options and 100% confirmation of which cables people have purchased and if they worked 100%. If anyone wants to chime in and add cables that they've purchased from vendors other than the one recognized on the majority of the coding tutorials it might help to clear up any confusion. I would suggest posting build date of the vehicle and model.
braveplayer3160 is offline  
0
Reply With Quote
      01-21-2013, 05:02 PM   #4
blacknbean
Major
 
Drives: e92 335i
Join Date: Jul 2007
Location: SF

Posts: 1,027
iTrader: (2)

great post! been looking for a pre 03/07 cable that was verified. I have just ordered this. thanks again!
blacknbean is offline  
0
Reply With Quote
      01-21-2013, 08:23 PM   #5
braveplayer3160
Enlisted Member
 
Drives: 328I Coupe
Join Date: Aug 2011
Location: LA

Posts: 44
iTrader: (1)

No problem. Hopefully others will post with alternative cable confirmations and some info to help everyone out. Happy coding!
braveplayer3160 is offline  
0
Reply With Quote
      01-27-2013, 04:29 PM   #6
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,039
iTrader: (2)

I just ordered this cable for my 02/07 build and then found this thread. Thanks for the verification!
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      01-27-2013, 09:27 PM   #7
braveplayer3160
Enlisted Member
 
Drives: 328I Coupe
Join Date: Aug 2011
Location: LA

Posts: 44
iTrader: (1)

Quote:
Originally Posted by akotten View Post
I just ordered this cable for my 02/07 build and then found this thread. Thanks for the verification!
No problem! One word of advice, use the drivers that are linked on this site
(in the various 'how-to's') instead of those enclosed with the cable. Read, read, then read more before starting and everything will be golden
braveplayer3160 is offline  
0
Reply With Quote
      01-29-2013, 02:32 PM   #8
335DEE
Captain
 
335DEE's Avatar
 
Drives: 335d
Join Date: Feb 2009
Location: England

Posts: 734
iTrader: (1)

If you are in any doubt , check your OBD port. If pins 6 & 14 are missing , you can use the cheaper K-Line cable. ( BMW changed to CANBUS manufacture date 03/07)
335DEE is offline   England
0
Reply With Quote
      01-29-2013, 03:49 PM   #9
Ruhnie
Private
 
Ruhnie's Avatar
 
Drives: 2007 Jet Black E90 6MT
Join Date: Nov 2009
Location: Dallas

Posts: 72
iTrader: (0)

Quote:
Originally Posted by o0timbo0o View Post
If you are in any doubt , check your OBD port. If pins 6 & 14 are missing , you can use the cheaper K-Line cable. ( BMW changed to CANBUS manufacture date 03/07)
What do you mean by "missing" exactly? I just looked at my OBD port, and of the 16 ports, I can only see any kind of metal/pins inside of like 5 of them. My build date is 07/07 though, so do I just need to get the more expensive cable on ebay?
Ruhnie is offline  
0
Reply With Quote
      01-29-2013, 05:13 PM   #10
335DEE
Captain
 
335DEE's Avatar
 
Drives: 335d
Join Date: Feb 2009
Location: England

Posts: 734
iTrader: (1)

Use the pic below for pin numbering ( i think the number is actually stamped on the socket itself .. they are pretty small though !



335DEE is offline   England
0
Reply With Quote
      01-30-2013, 02:49 AM   #11
Hercnhawk
New Member
 
Drives: 2008 E90
Join Date: Oct 2011
Location: Roseville, CA

Posts: 18
iTrader: (0)

I decided to give this cable a try for my 10/07 built e90. Mine came with the white board and I'm disappointed to say I can't get it to work. I tried Phil Harlow's setup with the latest drivers. I tried the included programs and drivers. I tried on an XP laptop and on a Win 7 32 bit laptop. Couldn't get passed trying to communicate with the airbag. At least I got it with free shipping and I will be taking advantage of the free return to Amazon. One interesting observation, with the latest setup via Mr. Harlow the LED was green until I had it attempt commo with a module, then the LED would turn off. The only way to get it back on was to unplug it from the car and computer and plug it back in. With the included software and drivers the LED was orange until I plugged it into the car, then it would turn green. It stayed green during attempted module commo but still didn't work.
Hercnhawk is offline  
0
Reply With Quote
      01-30-2013, 04:36 PM   #12
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,039
iTrader: (2)

My computer automatically installed the drivers for it when I plugged it in. I setup the com port assignment stuff, but are these drivers good enough or do I need to install over them with what has been posted here?
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      01-30-2013, 07:36 PM   #13
J-Spec Dan
T R O L L
 
J-Spec Dan's Avatar
 
Drives: E90 330i
Join Date: May 2011
Location: C H I C A G O

Posts: 2,556
iTrader: (2)

Garage List
2006 E90 330i  [4.08]
nice find. you saved quite a bit from what i paid for for mine.
__________________
BMW CCA Member 483866

|Officially Official Build Thread|
Follow me on instagram: @jspecdan
J-Spec Dan is offline   United_States
0
Reply With Quote
      01-31-2013, 02:17 AM   #14
braveplayer3160
Enlisted Member
 
Drives: 328I Coupe
Join Date: Aug 2011
Location: LA

Posts: 44
iTrader: (1)

Quote:
Originally Posted by akotten View Post
My computer automatically installed the drivers for it when I plugged it in. I setup the com port assignment stuff, but are these drivers good enough or do I need to install over them with what has been posted here?
I used the drivers from the How-to before installing the cable but, if the ones that installed when you plugged the cable in work then just use them.
braveplayer3160 is offline  
0
Reply With Quote
      01-31-2013, 02:32 AM   #15
BLKLYZ
Colonel
 
BLKLYZ's Avatar
 
Drives: E90 M3 AW
Join Date: Aug 2010
Location: FT. Bragg, NC.

Posts: 2,337
iTrader: (13)

Garage List
2007 335i  [4.50]
Quote:
Originally Posted by akotten View Post
I just ordered this cable for my 02/07 build and then found this thread. Thanks for the verification!
Akotten, I also have a 02/07 Build e92. I just wanted to know if everything worked for you before I pull the trigger and buy this thing?
__________________
OSS AE's/LCI Tails/R1 Concepts C/D Rotors/ER CP/UR CAI/Vossen CV3's/H&R Sports/Koni Yellows/M3 bits
BLKLYZ is online now   United_States
0
Reply With Quote
      01-31-2013, 11:42 AM   #16
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,039
iTrader: (2)

Quote:
Originally Posted by braveplayer3160 View Post
I used the drivers from the How-to before installing the cable but, if the ones that installed when you plugged the cable in work then just use them.
Ok, I tried updating the drivers with those, it and just came back with already up to date.

Quote:
Originally Posted by BLKLYZ View Post
Akotten, I also have a 02/07 Build e92. I just wanted to know if everything worked for you before I pull the trigger and buy this thing?
Will do! My car is in the shop for some repairs. I might be getting new turbos/wastegates so it could be a while before I can test this.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      01-31-2013, 04:10 PM   #17
KwlAznKid
Colonel
 
KwlAznKid's Avatar
 
Drives: BMW/MERCEDES/PORSCHE
Join Date: Jun 2005
Location: LA/Irvine/Fremont, CA/ University of California San Diego Alum

Posts: 2,415
iTrader: (4)

sorry if this is a dumb question but what's the difference between the expensive ones and like this one?

http://www.ebay.com/itm/USB-to-OBDII...575826&vxp=mtr
__________________
BMW E92 328I /BMW E46 M3 /Mercedes Benz W209 CLK500 /BMW E92 335I(sold)/Porsche 996 911 C2(sold)/BMW E46 325CI(totaled)
KwlAznKid is offline  
0
Reply With Quote
      02-03-2013, 04:15 PM   #18
gdgraham
Private First Class
 
gdgraham's Avatar
 
Drives: 2007 328i Coupe
Join Date: Nov 2011
Location: Shell Knob, MO

Posts: 155
iTrader: (0)

Garage List
Purchased this cable after your post and it works great on my 2007 e92 (build date 07/06). Thanks!
gdgraham is offline   United_States
0
Reply With Quote
      02-07-2013, 06:32 PM   #19
blacknbean
Major
 
Drives: e92 335i
Join Date: Jul 2007
Location: SF

Posts: 1,027
iTrader: (2)

1/07 build and this cable works for me. biggest issue i had was the drivers. the ones that came with the cd did not work and also the windows 7 auto install drivers did not work. only the ones from the FTDI ftp worked. i also tried 3 different versions of INPA until i found one that worked the best. the others connected ok but were buggy to say the least.
blacknbean is offline  
0
Reply With Quote
      02-07-2013, 09:58 PM   #20
braveplayer3160
Enlisted Member
 
Drives: 328I Coupe
Join Date: Aug 2011
Location: LA

Posts: 44
iTrader: (1)

Quote:
Originally Posted by blacknbean View Post
1/07 build and this cable works for me. biggest issue i had was the drivers. the ones that came with the cd did not work and also the windows 7 auto install drivers did not work. only the ones from the FTDI ftp worked. i also tried 3 different versions of INPA until i found one that worked the best. the others connected ok but were buggy to say the least.
Thanks for the update. I suspect that many of the other potential coders problems are driver related more than most ever take into account. This is probably one of the most overlooked things that I think causes many people to give up on the coding and then they just say that the cable was bad and didnt work... Go figure.
braveplayer3160 is offline  
0
Reply With Quote
      02-08-2013, 02:06 PM   #21
Hercnhawk
New Member
 
Drives: 2008 E90
Join Date: Oct 2011
Location: Roseville, CA

Posts: 18
iTrader: (0)

Quote:
Originally Posted by braveplayer3160 View Post
Thanks for the update. I suspect that many of the other potential coders problems are driver related more than most ever take into account. This is probably one of the most overlooked things that I think causes many people to give up on the coding and then they just say that the cable was bad and didnt work... Go figure.
Drivers were definitely NOT the issue with the Amazon cable I received. I got a white circuit board version and attempted to use it on a laptop running XP with the drivers recommended here on e90post. I also attempted to use it on a Win 7 32 laptop with the drivers that Win 7 automatically loaded. After much effort nothing worked. A friend of mine ordered the same cable from the same Amazon vendor a week before me and got one with a green circuit board inside. I got a chance to try his cable a couple days ago and it worked flawlessly and instantly on both my XP setup and the Win 7 setup. On the products website on Amazon you can see the two versions in the pictures. The first pic with the cable on the CD is the white one I received that didn’t work. The third pic shows an up close pic of one with the green board like the one my friend received that worked on my setup.
Everyone’s situation is different. Some are doing everything right but have a bad cable while others have a good cable but don’t know what they’re doing.
Hercnhawk is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:47 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST