E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > 2006 325i Electrical Problem? Dealer AND Indy shop stumped



Reply
 
Thread Tools Search this Thread
      12-10-2012, 03:16 PM   #1
ClassOf2013
New Member
United_States
0
Rep
28
Posts

 
Drives: '06 ZSP 325i
Join Date: Apr 2011
Location: Wilmington, NC

iTrader: (0)

The car has always had gremlins show up every so often, but while I was driving last Friday after hitting 3k RPM the speedo and tachometer bounced up and down, warning lights cycled (ABS, Brake, icy road, DSC, ect) and the radio would stop playing for a few seconds.

After restarting the car, the key wouldn't come out of the dash and the car acted as if there was no power. I had to get the car jumped and while driving to the dealership, in addition to the other problems, the license plate lights were dimming.

Today I got a call and so far they aren't sure why the car is acting like it is. I was told to take the key out, they had to jump it again. As soon as they took the cables off the battery the car shut off. They want to continue to diagnose tomorrow, and I'm worried they will just start replacing random parts in an effort to fix it.

The battery was replaced about a year ago (holds a charge) and they checked the alternator already.

Hopefully you guys have some insight as to what the problem is! Thanks for your help.

Appreciate 0
      12-11-2012, 09:27 AM   #2
sebaNYC
Second Lieutenant
3
Rep
229
Posts

 
Drives: BMW 328xi
Join Date: Jan 2012
Location: New York

iTrader: (2)

thats sounds like the problem that i had, is the fusebox and the B+ cable (the one thats going from the battery to the fusebox.

i replaced them and problem solved.

check the fusebox, where is connected with the B+ cable, mine was already melted and burned out
Appreciate 0
      12-11-2012, 01:03 PM   #3
ClassOf2013
New Member
United_States
0
Rep
28
Posts

 
Drives: '06 ZSP 325i
Join Date: Apr 2011
Location: Wilmington, NC

iTrader: (0)

Thanks seba, they decided it's the alternator, even though when they checked that it was fine. The SA said that it's sending the battery the wrong charge or too low of a charge.

If that doesn't solve it, I'll run that suggestion by them.
Appreciate 0
      01-23-2013, 11:49 AM   #4
skeetx3
New Member
Philippines
0
Rep
21
Posts

 
Drives: e92 328i
Join Date: Aug 2010
Location: Waukegan, IL

iTrader: (0)

were they able to fix the issue?

I'm having the same issue with all the different flashing lights on the dash and the needle cutting in and out while at speed. I also notice that the engine start/stop button back light will flash in and out too with what sounds like a clicking sound whenever it happens. Just wondering if they were able to find out what it was for you.
Appreciate 0
      01-23-2013, 11:30 PM   #5
overkill1125
Captain
overkill1125's Avatar
Canada
16
Rep
667
Posts

 
Drives: 2013 328i xdrive
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (4)

I had a similar problem. Not exactly what you described but something weird. The problem was whenever my headlights would turn on, my radio would stop working. It turned out to be my junction box that was defective. Replaced and problem solved.

Now I'm having this other weird problem is that whenever I leave my windows lock button off, my rear passenger side window would come down automatically without notice. It does not come down everytime but will do so often if I have that locked button off. But if its on (windows lock) green light then my window would never come down on its own. Dealer never figured that one out.
Appreciate 0
      01-23-2013, 11:33 PM   #6
onebadmofo
Banned
Russian Federation
54
Rep
2,394
Posts

 
Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

Quote:
Originally Posted by overkill1125 View Post
I had a similar problem. Not exactly what you described but something weird. The problem was whenever my headlights would turn on, my radio would stop working. It turned out to be my junction box that was defective. Replaced and problem solved.

Now I'm having this other weird problem is that whenever I leave my windows lock button off, my rear passenger side window would come down automatically without notice. It does not come down everytime but will do so often if I have that locked button off. But if its on (windows lock) green light then my window would never come down on its own. Dealer never figured that one out.
Sounds like switch on that door is shorting out? With windows lock the switch is obviously disabled, that's why window isn't going down.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:41 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST