E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > backfireing and Spitting Flames! No fuel? Limp mode.



Reply
 
Thread Tools Search this Thread
      01-05-2013, 05:04 PM   #1
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
backfireing and Spitting Flames! No fuel? Limp mode.

i broke my axle a week ago and finally got it fixed.
long story short. now anytime i give it any sort of gas it starts i guess misfireing or it feels like its cutting off. recently when i gas it 100% throttle. or even 50% i guess it starts back fireing then according to my friends its shooting flames then i have to restart the car. it drives perfectly fine. until i give it some gas. i went from a high mix of 70/30... e85/93. to straight 93. methnol dosnt help either. i also went out last night and abused the backfireing lol any one that tailgated me i just gave it a bit fo gass it backfired and spat smoke and flames with loUd gunshot noises i even had people scared and pulled over!! it was a friday night me and my buddies were bored..
and so i broke my secondary cats now i just need to get my cats cut i have dropped my exhaust just looking for a welder.
i also replaced the Low pressure fuel sensor with no dice.

my mods are FBO,RBs, G5 ISO, Bms flash, walboro, MEth cm14.
turbos, Injectors, plugs, coils only have 200 miles on them and the intake valves are sparkeling.

i did some logs (attached) before it started backfireing with the e85 and thy are attached in the zip file. it look like my low fuel pressure is fine but the high pressure is dropping like a rock.. thats with the meth spraying but it doesnt make sense that the backfireing is happening.. im confused AF

and any help/advice would be appreciated.
i wanna just replace the HPFP and see but i dont wanna play that guessing game cuz of $$ im using my wavetrac LSD fund.

these are the codes im getting.

Name:  photo.jpg
Views: 546
Size:  214.6 KB
Attached Files
File Type: zip Logs.zip (7.5 KB, 28 views)

Last edited by sammy_0559; 01-06-2013 at 09:13 AM.
sammy_0559 is offline   United_States
0
Reply With Quote
      01-05-2013, 05:33 PM   #2
rismo
Captain
 
Drives: BMW E92 335
Join Date: Jul 2008
Location: Europe

Posts: 840
iTrader: (0)

HPFP on his way to heaven uhmm I mean the other place, hell....
Check also if the codes can be O2 sensor related... e90post/google....
__________________
BMW 335 E92 08 - Full options - RIP
BMW 335 E92 09 - Full options - DKG - Procede Rev 3 - Vishnu Meth and Chargepipe - Forge Diverter Valves - Vishnu Flex Fuel Kit- AR Catless DP - Afe Intake - Helix IC - Ar Oil Cooler - PPK Water Cooler - M3 Suspension - JRZ RS1 Shocks - Eibach Pro Springs - Drexler LSD - BMW IS Exhaust - EBC Yellow Brake Pads - Stainless Steel Brake Lines - M101 Wheels - Michelin PSS - M-Tech Body - M-Strutbar
rismo is offline  
0
Reply With Quote
      01-05-2013, 05:37 PM   #3
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by rismo View Post
HPFP on his way to heaven uhmm I mean the other place, hell....
Check also if the codes can be O2 sensor related... e90post/google....
LOL i searched trust me couldnt find the same exact issue, thanks for your input
Dealer wont touch my car when they see the CPE charge pipe and meth they were like GTFO.

Last edited by sammy_0559; 01-05-2013 at 05:43 PM.
sammy_0559 is offline   United_States
0
Reply With Quote
      01-06-2013, 02:18 AM   #4
Evil///M
Professional Hitman
 
Drives: 335i Street. E36 M3 Track.
Join Date: Feb 2011
Location: 719/856

Posts: 529
iTrader: (6)

Garage List
2007 335i  [4.25]
Flamethrower mod. I want.
__________________
Evil///M is offline   United_States
0
Reply With Quote
      01-06-2013, 08:18 AM   #5
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by Evil///M View Post
Flamethrower mod. I want.
thanks for your awesome input!
sammy_0559 is offline   United_States
0
Reply With Quote
      01-06-2013, 08:25 AM   #6
rismo
Captain
 
Drives: BMW E92 335
Join Date: Jul 2008
Location: Europe

Posts: 840
iTrader: (0)

http://www.e90post.com/forums/showthread.php?t=555468
__________________
BMW 335 E92 08 - Full options - RIP
BMW 335 E92 09 - Full options - DKG - Procede Rev 3 - Vishnu Meth and Chargepipe - Forge Diverter Valves - Vishnu Flex Fuel Kit- AR Catless DP - Afe Intake - Helix IC - Ar Oil Cooler - PPK Water Cooler - M3 Suspension - JRZ RS1 Shocks - Eibach Pro Springs - Drexler LSD - BMW IS Exhaust - EBC Yellow Brake Pads - Stainless Steel Brake Lines - M101 Wheels - Michelin PSS - M-Tech Body - M-Strutbar
rismo is offline  
0
Reply With Quote
      01-06-2013, 08:32 AM   #7
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by rismo View Post
i would ignore the cat codes, the secondaries are the one i broke and i have removed all my tunes for trouble shooting. i still have kittyless downpipes. that where the two codes came from. I'm ignoring those. but i pull my walboro LPFP and its installed correctly
i dunno i guess the HPFP is whats screwed

found this last night
http://www.e90post.com/forums/showthread.php?t=617913

according to Vase330 i think i fried my motor..
sammy_0559 is offline   United_States
0
Reply With Quote
      01-06-2013, 08:40 AM   #8
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

Posts: 18,278
iTrader: (5)

Send a message via Yahoo to cn555ic
I had the same exact symptoms. Loud backfire and same codes. 29f3 and the 29dc. My issue was the LP sensor. Since you changed that out it couldn't be the issue right! Did u check with INPA to see if the sensor that u replaced is indeed working. Read the value for it on measurement block 6.
__________________
917-939-4980 CODING E and F Series New York Area

cn555ic is offline   United_States
0
Reply With Quote
      01-06-2013, 08:52 AM   #9
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by cn555ic View Post
I had the same exact symptoms. Loud backfire and same codes. 29f3 and the 29dc. My issue was the LP sensor. Since you changed that out it couldn't be the issue right! Did u check with INPA to see if the sensor that u replaced is indeed working. Read the value for it on measurement block 6.
i will do that today, thanks you. i actually read your thread thats the reason i replaced the LPFS, to read the value the car has to be running correct?
the exhaust is dropped it sounds louder than Camed vette, i will install the exhaust today, then try inpa. will update back here soon

Edit: now where the heck did i put that cable
sammy_0559 is offline   United_States
0
Reply With Quote
      01-06-2013, 08:52 AM   #10
neilvosko
Major
 
neilvosko's Avatar
 
Drives: 335i e92 FBO
Join Date: Dec 2011
Location: miami

Posts: 1,398
iTrader: (16)

It's def fueling issues, you are left with either the pressure regulator in the tank on the drivers side or the dreAded hpfp.
neilvosko is offline   United_States
0
Reply With Quote
      01-06-2013, 08:57 AM   #11
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by neilvosko View Post
It's def fueling issues, you are left with either the pressure regulator in the tank on the drivers side or the dreAded hpfp.
im guessing the pressure regulator, needs the tank to be dropped?
sammy_0559 is offline   United_States
0
Reply With Quote
      01-06-2013, 09:05 AM   #12
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

Posts: 18,278
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by sammy_0559 View Post
i will do that today, thanks you. i actually read your thread thats the reason i replaced the LPFS, to read the value the car has to be running correct?
the exhaust is dropped it sounds louder than Camed vette, i will install the exhaust today, then try inpa. will update back here soon

Edit: now where the heck did i put that cable
Yes the car has to be running and make sure the Jb tune is set to map 0. If you feel uncomfortable using the program. Download team viewer and I will Help u navigate to it. What you described was the same exact shit my car was going through. The backfire was like a shotgun. I could replicate it anytime I floored the car. Scared the shit out of people. The reading of the sensor should hover around 5000 HpA.
__________________
917-939-4980 CODING E and F Series New York Area

cn555ic is offline   United_States
0
Reply With Quote
      01-06-2013, 09:10 AM   #13
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by cn555ic View Post
Yes the car has to be running and make sure the Jb tune is set to map 0. If you feel uncomfortable using the program. Download team viewer and I will Help u navigate to it. What you described was the same exact shit my car was going through. The backfire was like a shotgun. I could replicate it anytime I floored the car. Scared the shit out of people. The reading of the sensor should hover around 5000 HpA.
man you are the best! I'm just looking for the cable in my room somewhere i moved so I'm digging through boxes, anyways once i get the exhaust in i will let you know I'm about to remove the secondaries cuz they are trash. i used it to code my injectors but that about all I've ever used it for. if you were local id buy you lunch
sammy_0559 is offline   United_States
0
Reply With Quote
      01-06-2013, 09:30 AM   #14
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

Posts: 18,278
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by sammy_0559 View Post
man you are the best! I'm just looking for the cable in my room somewhere i moved so I'm digging through boxes, anyways once i get the exhaust in i will let you know I'm about to remove the secondaries cuz they are trash. i used it to code my injectors but that about all I've ever used it for. if you were local id buy you lunch
I could help you later on in the afternoon around 3 or 4pm...I am in New York. Text me when your ready to do this....My cell number is on my sig
__________________
917-939-4980 CODING E and F Series New York Area

cn555ic is offline   United_States
0
Reply With Quote
      01-06-2013, 11:25 AM   #15
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by cn555ic View Post
I could help you later on in the afternoon around 3 or 4pm...I am in New York. Text me when your ready to do this....My cell number is on my sig
thanks buddy will do!
sammy_0559 is offline   United_States
0
Reply With Quote
      01-26-2013, 12:06 PM   #16
kollegga
Enlisted Member
 
Drives: 1
Join Date: May 2012
Location: d

Posts: 33
iTrader: (0)

any updates?!
kollegga is offline  
0
Reply With Quote
      01-26-2013, 03:52 PM   #17
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by kollegga View Post
any updates?!
Pulled the walboro out again to check it out and my fuel line had a hugeee split in it. haha and i was loosing fuel i guess.

But then blew my transmission 2 days later
Attached Images
 
sammy_0559 is offline   United_States
0
Reply With Quote
      01-26-2013, 04:53 PM   #18
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,323
iTrader: (0)

Huge issue, just fix it cheap..
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      01-26-2013, 05:08 PM   #19
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

Posts: 18,278
iTrader: (5)

Send a message via Yahoo to cn555ic
Damn where did all that fuel leak into?? You didn't smell it. Well then again that LPFP metal cover does have a gasket around it so if it was sealed tightly it would not allow any vapors to travel into cabin area
__________________
917-939-4980 CODING E and F Series New York Area

cn555ic is offline   United_States
0
Reply With Quote
      01-26-2013, 05:24 PM   #20
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,946
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
Quote:
Originally Posted by enrita View Post
Huge issue, just fix it cheap..
I just replaced the line as soon as i saw it lol

Quote:
Originally Posted by cn555ic View Post
Damn where did all that fuel leak into?? You didn't smell it. Well then again that LPFP metal cover does have a gasket around it so if it was sealed tightly it would not allow any vapors to travel into cabin area
it was in the tank. it was the line from the walboro lpfp to the regulator. it just split. but i fixed it then 2days later i was doing some logs then my transmission took a dump :/
sammy_0559 is offline   United_States
0
Reply With Quote
      01-26-2013, 05:29 PM   #21
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

Posts: 18,278
iTrader: (5)

Send a message via Yahoo to cn555ic
Damn I had no idea you were using 70/30 mix of e85. Damn.
__________________
917-939-4980 CODING E and F Series New York Area

cn555ic is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:05 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST