E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > Rear window heater not working



Reply
 
Thread Tools Search this Thread
      12-08-2008, 03:43 AM   #1
threethirty
Second Lieutenant
United Kingdom
5
Rep
204
Posts

 
Drives: BMW 330i M Sport Saloon 2006
Join Date: Sep 2007
Location: East Sussex, UK

iTrader: (0)

Rear window heater not working

Hi,

Done a search but couldn't find anything.

My rear windscreen heater has stopped working. The button on the climate control still lights up, but the back windscreen is not clearing.

Motor is still under warranty but a real pain to take it in.

Has anyone else had this? Could it be a fuse that I can replace myself?

Cheers,
__________________
BMW 330i M Sport Saloon - 06 plate - Le Mans Blue
Appreciate 0
      12-08-2008, 05:20 AM   #2
dxb335d
The Tarmac Terrorist
dxb335d's Avatar
England
381
Rep
29,288
Posts

 
Drives: E46 M3 CS
Join Date: Mar 2007
Location: ''Fandango Towers''

iTrader: (3)

Garage List
Could be buddy, not sure where the fuses are located on the E9X. Anyone know?
__________________
M3 gone .... But I now have a M3 CS
Appreciate 0
      12-08-2008, 09:25 AM   #3
PhilR
Second Lieutenant
PhilR's Avatar
United Kingdom
3
Rep
283
Posts

 
Drives: E93 330d M Sport Auto
Join Date: Mar 2008
Location: Teesside / Surrey

iTrader: (0)

Garage List
Threethirty, if it works like the wing mirror demister it may only activate when below a certain temp, unlesse the auto wipers are actually turned on too.

There are certain temp paremeters controlling the level of heating applied without the auto wipers on etc.

I had this issue with wing mirrors not clearing and sure enough I needed to activate the auto wipers for it to kick in.

This may be the same for the rear demister?
Appreciate 0
      12-08-2008, 09:56 AM   #4
I335
Brigadier General
I335's Avatar
59
Rep
4,251
Posts

 
Drives: '08 335i Coupe
Join Date: Jan 2008
Location: New England

iTrader: (11)

^ Don't think so. It should turn on whenever the button is pressed. Sounds like a fuse to me.
Appreciate 0
      12-08-2008, 10:06 AM   #5
dxb335d
The Tarmac Terrorist
dxb335d's Avatar
England
381
Rep
29,288
Posts

 
Drives: E46 M3 CS
Join Date: Mar 2007
Location: ''Fandango Towers''

iTrader: (3)

Garage List
Nah, the rear window element dimister is triggered by the switch and will heat up at any time.
__________________
M3 gone .... But I now have a M3 CS
Appreciate 0
      12-08-2008, 10:59 AM   #6
threethirty
Second Lieutenant
United Kingdom
5
Rep
204
Posts

 
Drives: BMW 330i M Sport Saloon 2006
Join Date: Sep 2007
Location: East Sussex, UK

iTrader: (0)

Thanks all. Will check the fuses (when I have worked out where they are).

If that doesn't fix it I will see if Cooper Tunbridge Wells will collect the car to save me the hassle of fighting through Christmas shopping traffic ;-(
__________________
BMW 330i M Sport Saloon - 06 plate - Le Mans Blue
Appreciate 0
      12-08-2008, 02:18 PM   #7
pinman
New Member
0
Rep
25
Posts

 
Drives: BMW 330i M Sport
Join Date: Dec 2007
Location: Hertfordshire

iTrader: (0)

Mine is at the stealer at this time for the same fault, also my IDrive
display takes up to 15 sec. to come on sometimes.

Had a call today, and it seems that they could be connected.

There is a lead between the battery and the computer with a sensor, and this
lead is telling the computer that the battery is only 30% (it's not, it is actually
85%), so with this the computer shuts off the heated rear window, and
the screen to save power, when the engine is running it tells the screen
to come on, but it tells the heated screen to go off as there isn't enough
power??.

Will tell you what happens tomorrow when the new lead is fitted.
Appreciate 0
      12-10-2008, 12:56 PM   #8
pinman
New Member
0
Rep
25
Posts

 
Drives: BMW 330i M Sport
Join Date: Dec 2007
Location: Hertfordshire

iTrader: (0)

Got the car back today (had a Mini One on loan, very impressed), and the
result is the IBS (Intelligent Battery Sensor), the IBS is in a lead and this
looks like it was the problem.

The lead was telling the computer that the battery was only 30% charged
and that it needed to switch stuff off to save power.

Was great to drive the 330i again.

Gazza
Appreciate 0
      01-15-2009, 12:43 PM   #9
threethirty
Second Lieutenant
United Kingdom
5
Rep
204
Posts

 
Drives: BMW 330i M Sport Saloon 2006
Join Date: Sep 2007
Location: East Sussex, UK

iTrader: (0)

Car was examined by dealer today.

PINMAN - spot on! I gave them the information above and they totally agreed this was the problem. They said it was the first time a customer had self-diagnosed such a thing!

Part is on order and being replaced under warranty next week.

Nice one.
__________________
BMW 330i M Sport Saloon - 06 plate - Le Mans Blue
Appreciate 0
      12-14-2012, 02:48 AM   #10
Scotty335i
New Member
0
Rep
17
Posts

 
Drives: 335i Coupe
Join Date: May 2012
Location: Wigan, England, UK.

iTrader: (0)

how much did the new sensor/lead cost? replacement easy?
__________________
If in doubt, flat out!
Appreciate 0
      01-28-2013, 07:08 PM   #11
GoRomeo
Colonel
GoRomeo's Avatar
26
Rep
2,367
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Quote:
Originally Posted by pinman View Post
Got the car back today (had a Mini One on loan, very impressed), and the
result is the IBS (Intelligent Battery Sensor), the IBS is in a lead and this
looks like it was the problem.

The lead was telling the computer that the battery was only 30% charged
and that it needed to switch stuff off to save power.

Was great to drive the 330i again.

Gazza
Hi there can you give us the outcome on this? my rear defroster does not work. The light turns on but does not clear the rear window. Can you tell us more about this IBS sensor? Thanks in advance!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:21 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST