E90Post
 


Alpine HID
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Knocking sound



Reply
 
Thread Tools Search this Thread
      01-28-2013, 04:57 PM   #1
muzzammil15
Slurpee anyone?
 
Drives: 07 White 335i
Join Date: Dec 2011
Location: VA beach

Posts: 597
iTrader: (3)

Send a message via MSN to muzzammil15
Knocking sound

Ever since its been very cold, I get a weird noise when I start the car in the morning. When it is cold, I get a knocking sound on the driver side of the engine, below the intake manifold. This only happen when the car is cold, and the idle is sitting at 600 rpm. As I rev the engine a little bit the sound goes away and when the idle settle. The sound comes back, until the car warms up to normal temperature. The sound is like a rod is knocking, I have no codes, or any cel. Anyone else have this issue? I did some search, and did not find a clear answer. The car drives perfect with no issues. Any help would be great, thanks!
__________________
Ghetto mods central!!

muzzammil15 is offline   United_States
0
Reply With Quote
      01-28-2013, 06:53 PM   #2
n54gte
First Lieutenant
 
Drives: 07 335i
Join Date: Jun 2012
Location: CA

Posts: 359
iTrader: (0)

http://www.e90post.com/forums/showthread.php?t=13504...
n54gte is offline  
0
Reply With Quote
      01-29-2013, 01:03 AM   #3
BMWN54tech
Private
 
BMWN54tech's Avatar
 
Drives: e92 335.
Join Date: Dec 2012
Location: USA

Posts: 62
iTrader: (0)

Lifter tick. Although its more common on the N52, it does happen on N54 engines. Removing the camshafts and replacing the lifters is the fix. If you were more local I could help you out better.
__________________
BMW master tech

2010 E92 335i 6-speed 25k miles. - For sale.
1989 E30 325i coupe 5-speed DD
BMWN54tech is offline  
0
Reply With Quote
      01-29-2013, 01:49 AM   #4
muzzammil15
Slurpee anyone?
 
Drives: 07 White 335i
Join Date: Dec 2011
Location: VA beach

Posts: 597
iTrader: (3)

Send a message via MSN to muzzammil15
Quote:
Originally Posted by BMWN54tech View Post
Lifter tick. Although its more common on the N52, it does happen on N54 engines. Removing the camshafts and replacing the lifters is the fix. If you were more local I could help you out better.
Would this be covered under CPO warranty? I will go talk to the dealer. I had a similar sound before, and it turned out to be a loose TQ converter bolt. It was not torque down right. I wonder if it is the same thing, but I will mention the lifter issue to them.
__________________
Ghetto mods central!!

muzzammil15 is offline   United_States
0
Reply With Quote
      01-29-2013, 10:57 PM   #5
335xi Kevo
Lieutenant
 
335xi Kevo's Avatar
 
Drives: 2008 335xi
Join Date: Jan 2012
Location: CT

Posts: 502
iTrader: (3)

I have the same thing. The ticking of the injectors and the knock of an unknown cause. I brought it into the dealer and they said it was the purge valve, and was considered normal however I think it's worse. It's already there for them to hear on a cold start, ill return with my results.
__________________
08' 335xi 6MT
Space Metallic Grey
Premium, Nav, Cold weather, Sport
Procede 2.5, DCI, Forge DV, PWM, Scoops, KW V1, ETS 5" FMIC, VRSF Downpipes, M3 Skirts
335xi Kevo is offline  
0
Reply With Quote
      01-29-2013, 11:02 PM   #6
335xi Kevo
Lieutenant
 
335xi Kevo's Avatar
 
Drives: 2008 335xi
Join Date: Jan 2012
Location: CT

Posts: 502
iTrader: (3)

http://www.youtube.com/watch?v=kZF7t6bcysQ

same exact sound as my motor.
__________________
08' 335xi 6MT
Space Metallic Grey
Premium, Nav, Cold weather, Sport
Procede 2.5, DCI, Forge DV, PWM, Scoops, KW V1, ETS 5" FMIC, VRSF Downpipes, M3 Skirts
335xi Kevo is offline  
0
Reply With Quote
      01-29-2013, 11:25 PM   #7
themyst
Major General
 
themyst's Avatar
 
Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

Posts: 6,598
iTrader: (8)

Send a message via AIM to themyst
My car ticks when the engine is still cold. Goes away pretty quick when it's warm. It's almost non-existent in the summer. Had the same noise on two N54s.
__________________
E90 LCI N54 6AT
themyst is offline   South Korea
0
Reply With Quote
      01-29-2013, 11:35 PM   #8
335xi Kevo
Lieutenant
 
335xi Kevo's Avatar
 
Drives: 2008 335xi
Join Date: Jan 2012
Location: CT

Posts: 502
iTrader: (3)

Quote:
Originally Posted by themyst
My car ticks when the engine is still cold. Goes away pretty quick when it's warm. It's almost non-existent in the summer. Had the same noise on two N54s.
Tick is normal, it's an underlying knock like in the YouTube video.
__________________
08' 335xi 6MT
Space Metallic Grey
Premium, Nav, Cold weather, Sport
Procede 2.5, DCI, Forge DV, PWM, Scoops, KW V1, ETS 5" FMIC, VRSF Downpipes, M3 Skirts
335xi Kevo is offline  
0
Reply With Quote
      01-30-2013, 01:22 AM   #9
muzzammil15
Slurpee anyone?
 
Drives: 07 White 335i
Join Date: Dec 2011
Location: VA beach

Posts: 597
iTrader: (3)

Send a message via MSN to muzzammil15
Quote:
Originally Posted by 335xi Kevo View Post
I have the same thing. The ticking of the injectors and the knock of an unknown cause. I brought it into the dealer and they said it was the purge valve, and was considered normal however I think it's worse. It's already there for them to hear on a cold start, ill return with my results.
Your knock is louder than mine, but I am still curious to know what is causing it. I will be taking my car into the dealer tomorrow and see what happens.
__________________
Ghetto mods central!!

muzzammil15 is offline   United_States
0
Reply With Quote
      01-30-2013, 01:05 PM   #10
335xi Kevo
Lieutenant
 
335xi Kevo's Avatar
 
Drives: 2008 335xi
Join Date: Jan 2012
Location: CT

Posts: 502
iTrader: (3)

Any word yet? My SA hasn't gotten back to me.
__________________
08' 335xi 6MT
Space Metallic Grey
Premium, Nav, Cold weather, Sport
Procede 2.5, DCI, Forge DV, PWM, Scoops, KW V1, ETS 5" FMIC, VRSF Downpipes, M3 Skirts
335xi Kevo is offline  
0
Reply With Quote
      01-30-2013, 03:09 PM   #11
muzzammil15
Slurpee anyone?
 
Drives: 07 White 335i
Join Date: Dec 2011
Location: VA beach

Posts: 597
iTrader: (3)

Send a message via MSN to muzzammil15
Quote:
Originally Posted by 335xi Kevo View Post
Any word yet? My SA hasn't gotten back to me.
I have an appointment on the 11th, that is the soonest they can get me in. One thing I noticed was, it is warm outside today and the knocking did not last as long as it would before. I had this similar knock sound in the past, and it turned out to be a loose torque converter bolt. They torqued it down correctly and the knocking sound went away. However when it got really cold out, the knocking came back.
__________________
Ghetto mods central!!

muzzammil15 is offline   United_States
0
Reply With Quote
      01-30-2013, 05:03 PM   #12
335xi Kevo
Lieutenant
 
335xi Kevo's Avatar
 
Drives: 2008 335xi
Join Date: Jan 2012
Location: CT

Posts: 502
iTrader: (3)

Quote:
Originally Posted by muzzammil15
Quote:
Originally Posted by 335xi Kevo View Post
Any word yet? My SA hasn't gotten back to me.
I have an appointment on the 11th, that is the soonest they can get me in. One thing I noticed was, it is warm outside today and the knocking did not last as long as it would before. I had this similar knock sound in the past, and it turned out to be a loose torque converter bolt. They torqued it down correctly and the knocking sound went away. However when it got really cold out, the knocking came back.
They're going through mine now. Unfortunately I'm 6MT.
__________________
08' 335xi 6MT
Space Metallic Grey
Premium, Nav, Cold weather, Sport
Procede 2.5, DCI, Forge DV, PWM, Scoops, KW V1, ETS 5" FMIC, VRSF Downpipes, M3 Skirts
335xi Kevo is offline  
0
Reply With Quote
      01-30-2013, 07:00 PM   #13
muzzammil15
Slurpee anyone?
 
Drives: 07 White 335i
Join Date: Dec 2011
Location: VA beach

Posts: 597
iTrader: (3)

Send a message via MSN to muzzammil15
After coming home from work this morning, I left my car outside (always garaged when home). After letting it sit outside for 5-6hours, I started it and let the idle settle at 600 rpm and the knock sound showed up. By the time i finished saying WTF the sound went away. The knock sound was there for maybe 3 seconds. After that she sounded perfect. I am starting to think, the sound is due to very cold weather. Today it was 70* so I am thinking in warm weather the knock sound will go away. This knock started when the temperature went below 40 degrees here.
__________________
Ghetto mods central!!

muzzammil15 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:32 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST