E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > ABS light on...pls help



Reply
 
Thread Tools Search this Thread
      07-16-2012, 10:03 AM   #23
cc_bavarian
First Lieutenant
Hong Kong
6

 
cc_bavarian's Avatar
 
Drives: 2007+ E90 330i
Join Date: Nov 2010
Location: Hong Kong


Posts: 316
iTrader: (0)

Garage List
2007 E90 330i  [0.00]
Quote:
Originally Posted by jclariel View Post
typical problem for 07 335i DSC unit which is acknowledged by bmw dealer...seems the pump is dead thus you need the whole unit i.e. Hydro unit DSC the more expensive one...
Has BMW NA acknowledged this as well or just your local BMW dealer?

Quote:
Originally Posted by Will@PRS View Post
9/10 times it is the DSC Unit. Are you in the US? If you are pm me the last 7 of your vin and I can get you a price on the unit.
Thanks Will but unfortunately I'm in Hong Kong and presume would need a Euro spec part.

The bmw dealer here has not acknowledge this issue but may be able to claim the part with BMW HK but not on cars greater than 4 years.
From what I've been reading and searching on the internet, it seems to be a known problem. Why hasn't BMW issue a recall???
Appreciate 0
      07-16-2012, 09:35 PM   #24
jclariel
Private
2

 
Drives: 335i
Join Date: Oct 2011
Location: New York


Posts: 78
iTrader: (0)

Quote:
Originally Posted by cc_bavarian View Post
Has BMW NA acknowledged this as well or just your local BMW dealer?



Thanks Will but unfortunately I'm in Hong Kong and presume would need a Euro spec part.

The bmw dealer here has not acknowledge this issue but may be able to claim the part with BMW HK but not on cars greater than 4 years.
From what I've been reading and searching on the internet, it seems to be a known problem. Why hasn't BMW issue a recall???
acknowledged by HK dealer actually...to be exact, by their former employees....no symphathy in HK. Dude, it is HK...sorry...
Appreciate 0
      07-26-2012, 02:03 AM   #25
cc_bavarian
First Lieutenant
Hong Kong
6

 
cc_bavarian's Avatar
 
Drives: 2007+ E90 330i
Join Date: Nov 2010
Location: Hong Kong


Posts: 316
iTrader: (0)

Garage List
2007 E90 330i  [0.00]
Quote:
Originally Posted by jclariel View Post
acknowledged by HK dealer actually...to be exact, by their former employees....no symphathy in HK. Dude, it is HK...sorry...
Are you able to share his contact info? My dealer here needs proof that this is happening outside of HK as well. They are asking over US$6,xxx for the parts and labour.
Appreciate 0
      07-27-2012, 12:58 PM   #26
jclariel
Private
2

 
Drives: 335i
Join Date: Oct 2011
Location: New York


Posts: 78
iTrader: (0)

Quote:
Originally Posted by cc_bavarian View Post
Are you able to share his contact info? My dealer here needs proof that this is happening outside of HK as well. They are asking over US$6,xxx for the parts and labour.
My car is in HK. But HK dealer won't acknowledge anything. Come on this is in HK. You gonna buy your own unit and install it somewhere else. Total shall be less than 25k HK$. I can help you buy the unit from Germany. And it carries 2 yrs warrenty. It cost 20k HKD. And I can introduce an garage which will charge you less than 3k HKD for installation and coding.

pm me if you want.
Appreciate 0
      07-27-2012, 09:02 PM   #27
monkawekrue
Brigadier General
United_States
35

 
Drives: e46 M3 AW/f25 X3 AW
Join Date: Aug 2010
Location: DUPONT, WA


Posts: 3,169
iTrader: (2)

Garage List
damn dude. I'm reading this thread and getting scared now.

same issue, ABS light came on as well as the TPMS sensor (which i don't have TPMS on my wheels anymore). ABS is now engaged and i can't start my car. WTF! going to call my insurance company to see about getting my car towed to the dealer to get this crap checked out.


2007 e90, 58,000~
__________________
Appreciate 0
      07-28-2012, 11:47 AM   #28
monkawekrue
Brigadier General
United_States
35

 
Drives: e46 M3 AW/f25 X3 AW
Join Date: Aug 2010
Location: DUPONT, WA


Posts: 3,169
iTrader: (2)

Garage List
so turned out it was just a dead battery like most people have issues with. got it replaced and codes deleted. too easy.
__________________
Appreciate 0
      07-31-2012, 08:03 AM   #29
jclariel
Private
2

 
Drives: 335i
Join Date: Oct 2011
Location: New York


Posts: 78
iTrader: (0)

Quote:
Originally Posted by monkawekrue View Post
so turned out it was just a dead battery like most people have issues with. got it replaced and codes deleted. too easy.
Lucky you are! Well, ABS pump faulty won't cause engine start failure..
Appreciate 0
      08-01-2012, 11:23 AM   #30
Hunter51092
Major
United_States
18

 
Hunter51092's Avatar
 
Drives: Bmw
Join Date: Aug 2011
Location: Miami


Posts: 1,284
iTrader: (0)

Garage List
2008 BMW  [0.00]
I been having the same lights for a while, diagnosed it with a scanner
pump unit faulty
pump unit plug faulty

now i have to have this Replaced ! how much are you guys being charged.

Electric water pump About $500?
Appreciate 0
      08-17-2012, 12:27 AM   #31
jclariel
Private
2

 
Drives: 335i
Join Date: Oct 2011
Location: New York


Posts: 78
iTrader: (0)

Quote:
Originally Posted by Hunter51092 View Post
I been having the same lights for a while, diagnosed it with a scanner
pump unit faulty
pump unit plug faulty

now i have to have this Replaced ! how much are you guys being charged.

Electric water pump About $500?
Unfortunately,it is not referring to water pump. it is about abs pump. around 2k USD....
Appreciate 0
      09-08-2012, 04:54 PM   #32
MiniMotoMan
New Member
0

 
Drives: '07 335i
Join Date: Jun 2010
Location: Central Florida


Posts: 24
iTrader: (0)

me too

I just had this happen to my 07 e90, getting off the highway when everthing lite up. I have the BavTech tool but I cant access anything ABS related, and it pisses me off! Why have the tool if they dont offer something as simple as ABS info! ABS has been around for awhile and I cant access it?

So I tried my actron OBDII scanner and it says no codes but my dash is light up with brake and ABS warnings.

How did you guys find an error code? Im way out of warranty so I need help to get to the bottom of this.
Appreciate 0
      09-21-2012, 03:39 PM   #33
adubey
Private First Class
1

 
Drives: 2006 330i
Join Date: Jan 2012
Location: Canada


Posts: 120
iTrader: (0)

Oh man add another one to the list - I had my Warning Light, TPMS Failure Light, DSC Failure Light and ABS all come on together a couple weeks back and go off after I turned off the car. Took it into the dealer and they said it was a faulty connection on a negative cable. I was driving again last night and now they remain on....

I was in a front end collision a month ago and this might be related to that and the subsequent repairs / alignment done by the dealer. Hoping its a steering wheel sensor....
__________________
2006 BMW 330i
Appreciate 0
      11-20-2012, 11:39 PM   #34
HoustonBMWClub
Second Lieutenant
4

 
Drives: BMW
Join Date: Nov 2011
Location: Houston


Posts: 215
iTrader: (0)

Damn, I was sucking it up as a hydro unit failure, now there may be hope it is only a wheel sensor.

It has been on and off in the past few weeks but now it is basically on for good =(

'07 335i e93 with 30k miles on it. FML.
__________________
From houston? You should be on here then!
www.houstonbmwclub.com/forums
Appreciate 0
      11-28-2012, 07:12 PM   #35
jclariel
Private
2

 
Drives: 335i
Join Date: Oct 2011
Location: New York


Posts: 78
iTrader: (0)

Quote:
Originally Posted by HoustonBMWClub View Post
Damn, I was sucking it up as a hydro unit failure, now there may be hope it is only a wheel sensor.

It has been on and off in the past few weeks but now it is basically on for good =(

'07 335i e93 with 30k miles on it. FML.
well, common issue for 07 car. good luck bro
Appreciate 0
      11-29-2012, 11:59 PM   #36
Z&M Auto
United_States
1

 
Z&M Auto's Avatar
 
Drives: 2008 BMW 335i
Join Date: Sep 2012
Location: Wayne, NJ


Posts: 24
iTrader: (0)

Had this issue at 39k miles, dealer replaced TCU and hydro-pump. Issue came back at 49,550 miles. My lazy self did not get a chance to get it into the dealer until 50,000+.....long story short, car was flagged due to parts supposedly found....

Anywho, got them to check it out under the two year parts replacement free of charge. Claimed the pump was ok but it was the SAS. Couldn't prove for sure if it was the SAS without digging deeper and charging me $180/hour. I said no thank you, as the entire service dept at my dealer is highly incompetent.

Moving on, the DSC/ABS lights would come and go. Most recently, I noticed its almost timed precisely to come on the same exact time after driving the car. It happens randomly, but at the same point during the same drive every time.

FWIW, I enjoy driving with no traction, makes for a very fun drive on summers during the winter. Will be tearing it apart to get to the root of the problem. Oh, its a 08 335i coupe 6SPD just passed 83k.
Appreciate 0
      01-29-2013, 08:30 PM   #37
rkmm3
Private
2

 
Drives: 2008 BMW 335i E90
Join Date: Sep 2011
Location: SoFlo


Posts: 87
iTrader: (0)

I had this problem and it was fixed after i cleaned the wheel speed sensors on the left side of my car front and back with water and a lil soap.

the lights went away after i started rolling forward about ~8.5948 feet

I didnt have to lift the car just turned the wheel and for the back got up underneath it.

allen key to do remove them.

I have an E90 335i 2008

this was useful:

See item 7 below for front:
http://www.realoem.com/bmw/showparts...94&hg=31&fg=10

See item 20 below for rear:
http://www.realoem.com/bmw/showparts...30&hg=33&fg=30
__________________
2002 BMW M3 6mt coupe sold
2004 BMW M3 6mt coupe
2008 BMW 335i e90
Appreciate 0
      05-31-2013, 08:28 AM   #38
NolaE93
Enlisted Member
0

 
NolaE93's Avatar
 
Drives: 2008 E93 335i AW/Coral
Join Date: Feb 2012
Location: New Orleans


Posts: 38
iTrader: (0)

I have been having the same lights come on and off for a couple months and nobody could diagnose it until I had to bring it in to the dealership.
They said the dsc pump was faulty and quoted me $3500.
This is the second system failure in one year that was quoted at around $3000.

That is insane that a car with under 50000 miles would have two major failures within a year.

Did BMW resurrect british-leylands to do their electrical on these cars?
Appreciate 0
      05-31-2013, 10:01 AM   #39
e90pilot
Freight Dawg
United_States
40

 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA


Posts: 2,109
iTrader: (3)

Quote:
Originally Posted by NolaE93 View Post
I have been having the same lights come on and off for a couple months and nobody could diagnose it until I had to bring it in to the dealership.
They said the dsc pump was faulty and quoted me $3500.
This is the second system failure in one year that was quoted at around $3000.

That is insane that a car with under 50000 miles would have two major failures within a year.

Did BMW resurrect british-leylands to do their electrical on these cars?
LOL! But, no they've always been that bad.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
Appreciate 0
      01-28-2014, 11:52 AM   #40
-TARBY-
Private First Class
England
1

 
-TARBY-'s Avatar
 
Drives: 07 330d M Sport Saloon 6 Speed
Join Date: Jun 2012
Location: Orpington


Posts: 168
iTrader: (0)

Hi Guys.. This still happens regular over here..

Mine has just gone pop too.... ABS, DSC warning etc

Interesting what you guys say about wheel sensors, steering angle sensor and the battery..

Here in the UK I am looking at a very expense job to replace the DSC Unit (2000+labour) or a repair job (400) or I tackle the sensors and the battery to eliminate these first.

My post on this is here:

http://www.e90post.com/forums/showthread.php?t=934971
__________________
2007(07) : e90 - 330d - M Sport - Saloon - 6 Speed
Appreciate 0
      05-12-2014, 06:49 AM   #41
matthatchett
Private
0

 
matthatchett's Avatar
 
Drives: 2006 BMW 325i
Join Date: Apr 2013
Location: Columbus, Indiana


Posts: 69
iTrader: (0)

I know this thread is a little old but I need some help! I am having a very similar (if not the same) issue. The only difference is the DSC light comes on and actually slows down the car for a split second. The ABS and BRAKE light do not come on unless I disengage the DSC. It happens with and without cruise control, on the highway and on city streets. Any ideas?
Appreciate 0
      07-23-2014, 10:13 AM   #42
Tegs4tugs
First Lieutenant
United_States
3

 
Tegs4tugs's Avatar
 
Drives: BMW E90 33?i | 90 Integra B20
Join Date: Apr 2008
Location: Westchester County, NY


Posts: 389
iTrader: (1)

Quote:
Originally Posted by ACEE View Post
hey I had this same problem and when it was checked the battery was bad...It was reading 10 volts and it dropped to 8 volts with load test. For some unknown reason when the battery is going dead these are the first indicators that pop up malfunction warnings that pop up. Only cost me a new battery and reprogramming

http://www.e90post.com/forums/showthread.php?t=709653
Just wanted to post my experience and thanks to this guy ACEE. I had this problem last week with dsc, brake and abs warning light came on last week so immediately got worried and started thinking about how expensive this is gonna be. So I started researching these errors online and came across a number of post including this one but I just replaced my battery 3 months ago so it couldn't be. I decided to just replace it just to make sure as it was still under full warranty and then I noticed while putting in the new battery that my battery terminal was crossed threaded so it seems the last time I replaced the battery the terminal was not tight enough. I was able to replace the screw and of course a new battery under warranty and so far no errors anymore. So IMO I would suggest testing battery and connections first as it could be that simple.
__________________

|33?i e90|Platinum Silver black leather w aluminum trim|6spd|Sport Packege|Premium Package|Mtec v3|Rockford Fosgate Subs and Amps|
|2000 integra DC4|Silver Gray int|5spd|B20 Motor|
When you turn your car on does it return the favor
Appreciate 0
      08-23-2014, 09:02 AM   #43
JarvJ
Registered
0

 
Drives: 2007 330i M Sport Coupe
Join Date: Aug 2014
Location: Cornwall UK


Posts: 2
iTrader: (0)

Exclamation DSC Hyrdaulic pump fault

I've had the same issues on my 07, 330ci M Sport, ABS, DSC warning lights on and off. Just had the Hydro pump replaced at the dealers, cost over 2000..The dealer did say that it's a common fault, but not enough for a recall... The strange thing is, it only started after I had a brake fluid service at the dealership....the dealer says it's a coincidence, but I'm not sure as the pump is right next to the master cylinder, and the brake fluid operates the pump.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:21 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST