E90Post
 


 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Walnut blasting.... What symptom?



Reply
 
Thread Tools Search this Thread
      01-29-2013, 09:57 PM   #1
DarkNemesis
Captain
Canada
14
Rep
851
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Walnut blasting.... What symptom?

If you had a walnut blasting done.
Ie cleaned out your intake ports.

What symptoms did you have?
Did you have any misfires?
Did your car jerk lightly during light acceleration?
Did you do anything else other than the walnut blast, even if you think it is unrelated?

Just trying to get a consensus on other people's issues.

Thx in advance
DN
Appreciate 0
      01-29-2013, 10:02 PM   #2
ndukyh
The Tanzanian
ndukyh's Avatar
8
Rep
477
Posts

 
Drives: 2 feet (for now)
Join Date: Jan 2012
Location: Boston, MA

iTrader: (8)

Now I'm confused. Didn't you ask the same question in a separate post - http://www.e90post.com/forums/showthread.php?t=792810

Why the new thread?
Appreciate 0
      01-30-2013, 12:00 AM   #3
DarkNemesis
Captain
Canada
14
Rep
851
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Quote:
Originally Posted by ndukyh
Now I'm confused. Didn't you ask the same question in a separate post - http://www.e90post.com/forums/showthread.php?t=792810

Why the new thread?
Cause my issue is jerking like a misfire that does not get a code.
As If the car loses power for a 0.5 sec then normal.

Multiple threads suggest injector changing to updated once.

Dealer and some here state a common solution of walnut blasting.

So 1 person stated his issue in the last thread.
Some asked me to search for it.
Believe me, I have search everywhere including n54.

Commonly people state the buildup as a common issue, and we just have to deal with it, when it comes up....great...I am good with that.

But my is at the stealership, and I don't want to pay for a diagnostic and walnut blast cost if it does not solve my issue, hence, why I feel, people should know, and me...
Wtf, is the issues related to carbon build up.
Symptoms.

Sorry if I asked again.
Don't feel it was answered.
DN
Appreciate 0
      01-30-2013, 08:49 AM   #4
335BBS
Brigadier General
Canada
42
Rep
3,607
Posts

 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

iTrader: (0)

Quote:
Originally Posted by DarkNemesis View Post
Cause my issue is jerking like a misfire that does not get a code.
As If the car loses power for a 0.5 sec then normal.

Multiple threads suggest injector changing to updated once.

Dealer and some here state a common solution of walnut blasting.

So 1 person stated his issue in the last thread.
Some asked me to search for it.
Believe me, I have search everywhere including n54.

Commonly people state the buildup as a common issue, and we just have to deal with it, when it comes up....great...I am good with that.

But my is at the stealership, and I don't want to pay for a diagnostic and walnut blast cost if it does not solve my issue, hence, why I feel, people should know, and me...
Wtf, is the issues related to carbon build up.
Symptoms.

Sorry if I asked again.
Don't feel it was answered.
DN
Trust your dealer/indy. If they do walnut and it doesnt solve anything then talk to them. You obviously arent going to get a straight answer here.
Appreciate 0
      01-30-2013, 08:57 AM   #5
MrQuickR1
Second Lieutenant
MrQuickR1's Avatar
4
Rep
284
Posts

 
Drives: 2011 328i
Join Date: Jan 2012
Location: NJ

iTrader: (0)

Not sure if this really helps but.... http://www.girardsautorepair.com/sit...rbon%20Out.pdf
Appreciate 0
      01-30-2013, 10:27 AM   #6
Blackhawk36
Lieutenant
Blackhawk36's Avatar
United_States
6
Rep
537
Posts

 
Drives: 2007 335i 6MT No iDrive
Join Date: May 2009
Location: MD

iTrader: (0)

If your car has more than 80k km, based on your symptoms, especially with no code, you need the walnut blast. Find and indy or a group buy and you will save 50%. Here in the states it runs about $400 from and indy and $800-900 at the dealers.
Appreciate 0
      01-30-2013, 10:46 AM   #7
Rookie83
First Lieutenant
Rookie83's Avatar
6
Rep
380
Posts

 
Drives: 2009 335i 6mt cpe
Join Date: May 2011
Location: DFW

iTrader: (1)

http://www.e90post.com/forums/showthread.php?t=631829

Dont know if that helps or not but im dealing with the same issue. just had the walnut blasting done last weekend and i still get a slight misfire at idle so im going to try plugs next.

if i were you i would go ahead and do the walnut blasting though, that might fix/help your issue but if not its still a good maintenance that should be performed and you will definately feel a difference.

shop around for the service too because i feel really bad for all of you people paying $400 and up for it lol. got mine done for almost half of that
Appreciate 0
      01-30-2013, 11:16 AM   #8
Blubaron79
Colonel
Blubaron79's Avatar
25
Rep
2,022
Posts

 
Drives: '14 435 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

The biggest symptom I had was a hesitation when I was in 6th gear and accelerating at highway speeds.
__________________
'14 435 XDrive: Mineral Grey, MSport, 19's, Coral Leather, Alum. Trim, Every option (except Active Cruise), MPPK, black grille, clear bra.

335 xDrive on order. (needed a 4 door for work..)
Appreciate 0
      01-30-2013, 12:17 PM   #9
335BBS
Brigadier General
Canada
42
Rep
3,607
Posts

 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

iTrader: (0)

Quote:
Originally Posted by Blubaron79 View Post
The biggest symptom I had was a hesitation when I was in 6th gear and accelerating at highway speeds.
This is BRUTAL. A car with so few miles on it needing an $800 service?
Appreciate 0
      01-30-2013, 12:22 PM   #10
gtaccord
Major
United_States
13
Rep
1,099
Posts

 
Drives: 2009 BMW 335xi
Join Date: Feb 2012
Location: Maryland

iTrader: (7)

Garage List
Just do the walnut blasting. In my car the symptom was smoothness or lack there of and I would get this strange hesitation (almost like a misfire) in 5th and 6th gear under load (going up a hill at highway speeds). After I did the cleaning all that went away. It was like a different car.
Appreciate 0
      01-30-2013, 01:59 PM   #11
gulshan
Private
0
Rep
75
Posts

 
Drives: e92-n54
Join Date: Jan 2012
Location: chicago

iTrader: (0)

I would not bother with walnut cleaning below 60k miles. Try the cheap possible fixes first. Run bottle of Techron on a full tank of 93Octane. (link), get new oem spark plugs..
Appreciate 0
      01-30-2013, 03:09 PM   #12
jakobv84
Private First Class
United_States
1
Rep
184
Posts

 
Drives: 2009 E60 525xi
Join Date: Oct 2009
Location: Copenhagen, Denmark

iTrader: (1)

Garage List
2007 E90 335i  [0.00]
I was having misfires when Cobb was on. Walnut blasting and replaced plugs at the same time fixed it. Don't know/care which part fixed it it runs much, much better now.
__________________
'09 525xi | Comfort Access, Moonroof, Softclose, PDC, CIC upgraded

'07 335i E90 (sold) // '03 Porsche Boxster (sold) // '07 Alfa Romeo GT 2.0 (sold) // '06 325i E90 (stolen) // '99 Alfa Romeo 156 (sold)
Appreciate 0
      01-30-2013, 03:21 PM   #13
smallseafishie
Lieutenant Colonel
21
Rep
1,738
Posts

 
Drives: AW 07 e92 335i + AW 11 X5 35d
Join Date: Jun 2007
Location: Atlanta GA

iTrader: (12)

Garage List
2007 E92 335i  [0.00]
I'm at 69k miles and I just started getting the hesitation.

Intake valve DIY here I come (brush and spray).

I think I'm going to go ahead and get a OCC too to prevent this mess from happening again.
Appreciate 0
      01-30-2013, 03:41 PM   #14
Blackhawk36
Lieutenant
Blackhawk36's Avatar
United_States
6
Rep
537
Posts

 
Drives: 2007 335i 6MT No iDrive
Join Date: May 2009
Location: MD

iTrader: (0)

Quote:
Originally Posted by gtaccord View Post
Just do the walnut blasting. In my car the symptom was smoothness or lack there of and I would get this strange hesitation (almost like a misfire) in 5th and 6th gear under load (going up a hill at highway speeds). After I did the cleaning all that went away. It was like a different car.
+1
Appreciate 0
      01-30-2013, 03:43 PM   #15
DarkNemesis
Captain
Canada
14
Rep
851
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

So there it is.
2 people saying they had light hesitation on light acceleration uphill or 5 and 6th gear.

Guess 800 at dealer is what I am paying for.
Guess every 40k is on also...

Anyone know a shop in Vancouver, Bc, Canada, other than dealer?

Regards.
And thank you to all.
DN
Appreciate 0
      01-30-2013, 03:48 PM   #16
335BBS
Brigadier General
Canada
42
Rep
3,607
Posts

 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

iTrader: (0)

Quote:
Originally Posted by DarkNemesis View Post
So there it is.
2 people saying they had light hesitation on light acceleration uphill or 5 and 6th gear.

Guess 800 at dealer is what I am paying for.
Guess every 40k is on also...

Anyone know a shop in Vancouver, Bc, Canada, other than dealer?

Regards.
And thank you to all.
DN
Thats exactly what I had at about 75,000 kms.
Appreciate 0
      01-30-2013, 03:50 PM   #17
335BBS
Brigadier General
Canada
42
Rep
3,607
Posts

 
Drives: 2009 335 coupe.
Join Date: Jan 2010
Location: Toronto, Ontario

iTrader: (0)

Quote:
Originally Posted by gulshan View Post
I would not bother with walnut cleaning below 60k miles. Try the cheap possible fixes first. Run bottle of Techron on a full tank of 93Octane. (link), get new oem spark plugs..
93 octane will affect nothing.
Appreciate 0
      01-30-2013, 04:23 PM   #18
Blackhawk36
Lieutenant
Blackhawk36's Avatar
United_States
6
Rep
537
Posts

 
Drives: 2007 335i 6MT No iDrive
Join Date: May 2009
Location: MD

iTrader: (0)

Quote:
Originally Posted by DarkNemesis View Post
So there it is.
2 people saying they had light hesitation on light acceleration uphill or 5 and 6th gear.

Guess 800 at dealer is what I am paying for.
Guess every 40k is on also...

Anyone know a shop in Vancouver, Bc, Canada, other than dealer?

Regards.
And thank you to all.
DN
$800 USD. There isn't any GST/PST, etc. here.
Appreciate 0
      01-30-2013, 05:00 PM   #19
jakobv84
Private First Class
United_States
1
Rep
184
Posts

 
Drives: 2009 E60 525xi
Join Date: Oct 2009
Location: Copenhagen, Denmark

iTrader: (1)

Garage List
2007 E90 335i  [0.00]
Just to rub it in I paid $300 as part of a group buy. Not sure I would've forked over $800 with as little hesitation and trying other things first...
__________________
'09 525xi | Comfort Access, Moonroof, Softclose, PDC, CIC upgraded

'07 335i E90 (sold) // '03 Porsche Boxster (sold) // '07 Alfa Romeo GT 2.0 (sold) // '06 325i E90 (stolen) // '99 Alfa Romeo 156 (sold)
Appreciate 0
      01-30-2013, 06:47 PM   #20
DarkNemesis
Captain
Canada
14
Rep
851
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

800 USD?
I am pay 4 hours labour at 143.88 per hour.
Plus
1 hour diagnostic.
So 5 hours + HST which is 12%.
Total 805.

Could not find any shop local that would do it cheaper.

DN
Appreciate 0
      01-30-2013, 07:43 PM   #21
ndukyh
The Tanzanian
ndukyh's Avatar
8
Rep
477
Posts

 
Drives: 2 feet (for now)
Join Date: Jan 2012
Location: Boston, MA

iTrader: (8)

So I got mine covered under CPO. Took it in to dealer for oil service and told my SA about the hesitation in 6th and also jerking that I was having when in 1st and 2nd gear. They checked it out and said spark plugs needed changing (which I had to pay for). After they did that they said they test drove and said it still had issues so they checked intakes. My SA called me later and told me that it has an "impressive" amount of carbon buildup and that they are contacting BMW to see if they can cover it. Supposedly BMW wanted a fuel sample to ensure I was using the right fuel but my SA said he somehow got around sending a fuel sample (I use 93 but from Sam's Club). Then he said they agreed to cover it (still have no idea why but I didn't ask too many questions) and told me to stop using Sam's Club fuel and stick to top tier places. When I got the car back it felt so much better. No hesitation in 6th and the jerking is gone. Dunno if it was the plugs or the cleaning but according to dealer it was the cleaning.
Appreciate 0
      01-30-2013, 08:00 PM   #22
ken1137
Brigadier General
ken1137's Avatar
United_States
41
Rep
3,697
Posts

 
Drives: a slow 2009 e90 335i
Join Date: Jun 2011
Location: Chicago

iTrader: (7)

Garage List
2009 e90 335i  [3.20]
I would change the plugs (stnd maintenance for the N54 is 45K mi) and check coil packs at same time. Then walnut blast if it is not resolved. GL.
__________________

BMWCCA member
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:40 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST