E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > p29eo (mixture control) on only 93oct



Reply
 
Thread Tools Search this Thread
      02-02-2013, 05:05 PM   #1
skatenc123
Captain
skatenc123's Avatar
6
Rep
648
Posts

 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

iTrader: (1)

p29eo (mixture control) on only 93oct

ok so doing so pulls with a friend last night. I started getting misfires followed by SES light and pulled the codes.

p29d2 (misfire #6), p29d0 (misfire #4) p29cc (misfire multiple) *plugs*

p2aaf(fuel pump plausibility(seems sorta normal on cobb and it come up for me every now and then with no other problems))

p29eo (mixture control) this is the one im confused about. seems most people get this running e85 blends but im on 93oct only. never put e85 in. any insight on this one?
Appreciate 0
      02-02-2013, 05:19 PM   #2
Fully_Bolted
Banned
6
Rep
443
Posts

 
Drives: E92 335i
Join Date: Sep 2012
Location: USA

iTrader: (0)

Are you running meth? Check your fuel trims.
Appreciate 0
      02-02-2013, 05:19 PM   #3
themyst
Major General
themyst's Avatar
South Korea
86
Rep
6,602
Posts

 
Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

iTrader: (8)

Send a message via AIM to themyst
Do you have an external downpipe fix installed?
__________________
E90 LCI N54 6AT
Appreciate 0
      02-02-2013, 05:25 PM   #4
skatenc123
Captain
skatenc123's Avatar
6
Rep
648
Posts

 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

iTrader: (1)

Quote:
Originally Posted by Fully_Bolted View Post
Are you running meth? Check your fuel trims.
nope no meth.
Appreciate 0
      02-02-2013, 05:26 PM   #5
skatenc123
Captain
skatenc123's Avatar
6
Rep
648
Posts

 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

iTrader: (1)

Quote:
Originally Posted by themyst View Post
Do you have an external downpipe fix installed?
nope. just cobb. no dp fix.as cobb depresses the code.
Appreciate 0
      02-02-2013, 07:28 PM   #6
jyeah
Private First Class
2
Rep
196
Posts

 
Drives: 2010 BMW 335i
Join Date: Jun 2012
Location: Los Angeles

iTrader: (3)

So I had P2AAF before too and it turns out it's the fuel pump sensor. Then I also saw P29E0 after I installed a DP, but I'm still not sure what's causing that.
Appreciate 0
      02-02-2013, 07:37 PM   #7
skatenc123
Captain
skatenc123's Avatar
6
Rep
648
Posts

 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

iTrader: (1)

Quote:
Originally Posted by jyeah View Post
So I had P2AAF before too and it turns out it's the fuel pump sensor. Then I also saw P29E0 after I installed a DP, but I'm still not sure what's causing that.
yea ive had the p2aaf pretty much everytime ive checked for codes so i just ignore it. but after doing some more pulls tonight with no misfires (didnt go into full boost)but im still getting p29e0 ( mixture control ).
Appreciate 0
      02-02-2013, 07:46 PM   #8
jyeah
Private First Class
2
Rep
196
Posts

 
Drives: 2010 BMW 335i
Join Date: Jun 2012
Location: Los Angeles

iTrader: (3)

Quote:
Originally Posted by skatenc123 View Post
yea ive had the p2aaf pretty much everytime ive checked for codes so i just ignore it. but after doing some more pulls tonight with no misfires (didnt go into full boost)but im still getting p29e0 ( mixture control ).
I also had Cobb Stage 2 flashed at the time and it would not suppress the code and would still give me an SES light.

I uninstalled cobb and the code went away for 1000 miles until I did a 3rd gear pull and then I saw the code right after the pull and it wouldn't go away.

I'm thinking it might be the injectors in my case, but I'm going to try a spark plug swap first and see.
Appreciate 0
      02-02-2013, 08:27 PM   #9
skatenc123
Captain
skatenc123's Avatar
6
Rep
648
Posts

 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

iTrader: (1)

im planning on doing spark plugs this week. and most likely doing injectors too.
Appreciate 0
      02-04-2013, 07:37 PM   #10
slostjoe
NEWBICON
United_States
4
Rep
306
Posts

 
Drives: E92 335i
Join Date: Jul 2012
Location: Springfield, MO

iTrader: (6)

I have recently been having fuel mixture codes as well.
__________________
2013 Race Red GT500 708whp
www.cmsmotorsports.com
Appreciate 0
      02-04-2013, 07:44 PM   #11
skatenc123
Captain
skatenc123's Avatar
6
Rep
648
Posts

 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

iTrader: (1)

Quote:
Originally Posted by slostjoe View Post
I have recently been having fuel mixture codes as well.
have you noticed any ill effects? e85 mix? meth? any other codes?
Appreciate 0
      02-04-2013, 09:35 PM   #12
dfv2
Lieutenant
dfv2's Avatar
United_States
7
Rep
474
Posts

 
Drives: 2009 CTS-V
Join Date: Apr 2010
Location: Upstate NY

iTrader: (3)

Quote:
Originally Posted by slostjoe View Post
I have recently been having fuel mixture codes as well.
Same, and have been ever since going back on winter 93 octane (w/ OTS map) from a e85 blend.
__________________
//ecg//
Appreciate 0
      11-15-2013, 01:05 AM   #13
Jeffman
Lieutenant
Jeffman's Avatar
5
Rep
442
Posts

 
Drives: 2008 335xi E90
Join Date: Jul 2010
Location: Somewhere in America

iTrader: (1)

Garage List
Quote:
Originally Posted by dfv2 View Post
Same, and have been ever since going back on winter 93 octane (w/ OTS map) from a e85 blend.
I reviving this thread as I'm experience similar issues. Now that it is cold here in the morning (32F / 0C) I'm getting repeated p29E0 codes and and one p0171 (lean) code. Anybody know why this happens with a colde engine?
__________________
Cobb ATR Self-Tuned E40 Map | Helix IC | BMS DCI | BMS Thermostat Delete | CP-E Charge Pipe | Forge DV | Apex Arc-8 Hyper Silver | Michelin PSS | Alpina B3 TCU Flash | KW-V1 Coilovers | Lux Angel Eyes | CF Kidneys | Scoops | Rockford Fosgate P300-2 | Earthquake SWS-8xi | iStreamer DAC | "Keep On A Rockin' Me Baby!"
Appreciate 0
      11-15-2013, 03:59 PM   #14
tampaturbom3
Enlisted Member
0
Rep
35
Posts

 
Drives: 2010 335 ix AT, CLS 55 AMG
Join Date: Mar 2012
Location: Tampa,FL

iTrader: (0)

I got it yesterday at about 1500 rpm and part throttle, cruising. I'm e40 on stock FP
__________________
Tommy
2010 335 ix Msport AT
Proceed on "0" map, OTF, DCI, VSRF DP's
Appreciate 0
      11-15-2013, 04:32 PM   #15
danniexi
Colonel
danniexi's Avatar
South Korea
31
Rep
2,092
Posts

 
Drives: 2008 AW E92 335xi
Join Date: May 2008
Location: NJ

iTrader: (14)

Been chasing after this code for a year already... P9E0/P9E1 (fuel mixture codes 1&2)... sometimes accompanied by 0174 codes. Only happens during cruising speed (60-70MPH, constant throttle at 2K rpm).

These codes started happening after replacing injectors and spark plugs. Since then I replaced the pre-cat O2 sensors, got rid of the O2 sims, and stepped away from E85 and only on 93 octane. Im confused.
Appreciate 0
      11-19-2013, 03:14 PM   #16
georgelb
nsomneeak
georgelb's Avatar
United_States
4
Rep
485
Posts

 
Drives: E92 RB 335i
Join Date: Apr 2010
Location: DFW, TX

iTrader: (3)

Garage List
2007 335i  [4.00]
I've gotten the fuel mixture code a few times now, the first time in mid-October and the second time yesterday. The car is otherwise running fine/strong, pro-tuned for 93 no meth. I just assumed it was the winter blend fuels, but haven't sent anything to Cobb about it yet.
__________________

RB Turbos w/ N20 TMAP Sensor | 93 Octane Protune by Cobb Plano | Alpina TCU Flash | BMS DCI | STETT CP | Forge DVs | Helix FMIC | CP-E Catted DPs | Walbro 450 | RB PCV | M3 Control Arms | M3 Subframe Bushings | Defiv Lockdown Kit | Cool Carbon Pads | BBS CH | Conti DWS
Hixson BMW of Monroe, LA - Shady Dealer | Got E85? Make sure you have it right.
Appreciate 0
      12-23-2013, 10:52 AM   #17
loweredram
First Lieutenant
6
Rep
314
Posts

 
Drives: 07 bmw 335i sedan
Join Date: Oct 2010
Location: ca

iTrader: (2)

Hate to bring this thread up again. Has anyone found an answer yet? I was running cobb OTS e30 with FBO catted downpipes and one day I decided to check codes and up pop the 29E0 and 29E1 code. Sometimes i get the ses but car runs fine. I switched back to straight 91 and cobb stage 2 +fmic sport and Im still getting them. I installed the updated injectors, new plugs, and coils about a year ago but never had codes until a few months after running e85. I was thinking the pre cat o2 sensors since I haven't changed them yet and they are factory originals(my car is an 07 61k).
Appreciate 0
      04-14-2014, 08:15 PM   #18
Jeffman
Lieutenant
Jeffman's Avatar
5
Rep
442
Posts

 
Drives: 2008 335xi E90
Join Date: Jul 2010
Location: Somewhere in America

iTrader: (1)

Garage List
Quote:
Originally Posted by loweredram View Post
Hate to bring this thread up again. Has anyone found an answer yet? I was running cobb OTS e30 with FBO catted downpipes and one day I decided to check codes and up pop the 29E0 and 29E1 code. Sometimes i get the ses but car runs fine. I switched back to straight 91 and cobb stage 2 +fmic sport and Im still getting them. I installed the updated injectors, new plugs, and coils about a year ago but never had codes until a few months after running e85. I was thinking the pre cat o2 sensors since I haven't changed them yet and they are factory originals(my car is an 07 61k).
I've been having similar issues. Just flashed E30 from PTF now that we have warm weather again. First day while adaptations are readjusting I saw multiple 29e0 codes, a few 29e1. And then one p0171 (lean) which tripped the SES light. Next day fewer codes. Yesterday and today none. Also my STFTs are pegging 34 during WOT (same on 93 using my PTF map). No misfires - ever. No other codes except for once a year fuel pump plausibility code. Otherwise car feels fine. Anybody have ideas what's going on? O2 sensors?
__________________
Cobb ATR Self-Tuned E40 Map | Helix IC | BMS DCI | BMS Thermostat Delete | CP-E Charge Pipe | Forge DV | Apex Arc-8 Hyper Silver | Michelin PSS | Alpina B3 TCU Flash | KW-V1 Coilovers | Lux Angel Eyes | CF Kidneys | Scoops | Rockford Fosgate P300-2 | Earthquake SWS-8xi | iStreamer DAC | "Keep On A Rockin' Me Baby!"
Appreciate 0
      04-14-2014, 08:41 PM   #19
georgelb
nsomneeak
georgelb's Avatar
United_States
4
Rep
485
Posts

 
Drives: E92 RB 335i
Join Date: Apr 2010
Location: DFW, TX

iTrader: (3)

Garage List
2007 335i  [4.00]
Quote:
Originally Posted by loweredram View Post
Hate to bring this thread up again. Has anyone found an answer yet? I was running cobb OTS e30 with FBO catted downpipes and one day I decided to check codes and up pop the 29E0 and 29E1 code. Sometimes i get the ses but car runs fine. I switched back to straight 91 and cobb stage 2 +fmic sport and Im still getting them. I installed the updated injectors, new plugs, and coils about a year ago but never had codes until a few months after running e85. I was thinking the pre cat o2 sensors since I haven't changed them yet and they are factory originals(my car is an 07 61k).

I think it's just fuel not up to par with the tune. I stopped getting it during the winter when I switched back to Shell from Quik Trip; Quik Trip is top tier, but a lot cheaper than Shell. I got the code again on a recent road trip when I had to fill up at a Shell station that only had 92, and no 93; I have a 93 octane pro tune.
__________________

RB Turbos w/ N20 TMAP Sensor | 93 Octane Protune by Cobb Plano | Alpina TCU Flash | BMS DCI | STETT CP | Forge DVs | Helix FMIC | CP-E Catted DPs | Walbro 450 | RB PCV | M3 Control Arms | M3 Subframe Bushings | Defiv Lockdown Kit | Cool Carbon Pads | BBS CH | Conti DWS
Hixson BMW of Monroe, LA - Shady Dealer | Got E85? Make sure you have it right.
Appreciate 0
      08-14-2014, 05:58 PM   #20
N54CherryHill
bOrN To DiE
2
Rep
268
Posts

 
Drives: 2007 335i E92
Join Date: Apr 2013
Location: South Jersey

iTrader: (0)

Just got those P29E0-1 codes today guys probably its from E85 mix :/ I run E30 map a lot lately thats why. I guess time to go back to 93 again :/
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:38 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST