E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Codes 2A82 / 3100 CEL



Reply
 
Thread Tools Search this Thread
      02-12-2013, 07:50 PM   #1
gatoracer
Private First Class
 
gatoracer's Avatar
 
Drives: '07 335i MT
Join Date: Apr 2012
Location: Jax, FL

Posts: 106
iTrader: (1)

Codes 2A82 / 3100 CEL

Was driving to work today and car went into limp mode. I had already driven 25 miles and was just about to work. I was sitting at idle and started pulling away from the stop light and the CEL came up (half yellow engine). I got to work, parked the car and restarted after work w/o any issues. Also no CEL on my 20+ mile trip back home. As an aside, I did top off my oil this morning. It was a little low, a quarter way up between the min and max lines. I topped it off and the oil is now reading up to the max line. I'm not sure if this would have contributed to the CEL.
I did some research and from my understanding the codes are related to the camshaft/VANOS. I noticed a service bulletin out (SI B11 02 08) regarding the camshafts. The bulletin states the the work is covered under a "new car warranty." The car is not new and is out of warranty. Has anyone heard of the dealer doing the work on a car that is not "new", but still covered? Or is it best to take it to an indy?
Thanks.
__________________

Last edited by gatoracer; 02-12-2013 at 07:57 PM. Reason: added info
gatoracer is offline   United_States
0
Reply With Quote
      02-12-2013, 08:50 PM   #2
BMWM.D.
Stupid Idiot
 
BMWM.D.'s Avatar
 
Drives: E90 335i & C6 Grand Sport
Join Date: May 2009
Location: Santa Barbara

Posts: 686
iTrader: (1)

That 2A82 fault is a Vanos code, and is USUALLY caused by a bad Vanos solenoid. I say usually, because sometimes there is wear on the camshaft bearing ledge that causes a loss of oil supply to the Vanos units that can cause the same fault code / symptoms.

This is one of the reasons I believe in changing the oil on my N54 cars much earlier than BMW recommends. How many miles on your car? How's it been maintained?
__________________
BMWM.D. is offline  
0
Reply With Quote
      02-13-2013, 12:06 PM   #3
gatoracer
Private First Class
 
gatoracer's Avatar
 
Drives: '07 335i MT
Join Date: Apr 2012
Location: Jax, FL

Posts: 106
iTrader: (1)

Quote:
Originally Posted by BMWM.D. View Post
That 2A82 fault is a Vanos code, and is USUALLY caused by a bad Vanos solenoid. I say usually, because sometimes there is wear on the camshaft bearing ledge that causes a loss of oil supply to the Vanos units that can cause the same fault code / symptoms.

This is one of the reasons I believe in changing the oil on my N54 cars much earlier than BMW recommends. How many miles on your car? How's it been maintained?
I have been changing it every 5K miles, using Mobil 1. But I have only had the car for 10 months. The car has 95K miles on it. I had the dealer pull the maint records before I bought the car and the car had been getting regular service at the dealer. I did a little research and I have seen recommendations to change the VANOS solenoids at 100k-120K. I found a DIY here to change at least the one on the top of the motor. $110 for the part, I may just do it as preventative myself. I hope there isn't any abnormal wear on the camshaft bearing ledge.

Thanks for the feedback.
__________________
gatoracer is offline   United_States
0
Reply With Quote
      04-27-2013, 04:41 PM   #4
vqpro2
Private First Class
 
vqpro2's Avatar
 
Drives: Black ex. red in. navi sport p
Join Date: May 2009
Location: New York City

Posts: 196
iTrader: (0)

vanos

so what became of this problem what was the fix
vqpro2 is offline  
0
Reply With Quote
      04-28-2013, 07:52 AM   #5
gatoracer
Private First Class
 
gatoracer's Avatar
 
Drives: '07 335i MT
Join Date: Apr 2012
Location: Jax, FL

Posts: 106
iTrader: (1)

Quote:
Originally Posted by vqpro2 View Post
so what became of this problem what was the fix
I just cleaned the intake solenoid. Used the DIY on the site. Haven't had the code pop up since.
__________________
gatoracer is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:56 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST