E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Half Engine check Light with Codes using DIS v57



Reply
 
Thread Tools Search this Thread
      02-18-2013, 07:52 PM   #1
DarkNemesis
Captain
Canada
16
Rep
859
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Half Engine check Light with Codes using DIS v57

Hi All,

I have the slight jerking or loss of Power for about 15 min of any initial drive.
Dealer said to walnut blast it, so I did.
I have to admit, this fix about 80% of the jerking.
Now it is clearly in the begining of any drive.
ex: either cold or normal hot temp.
shut car off, go into store buy a pack.
car off for approx 5-10 min.
start driving and under any type of acceleration, car jerks as if, Power is losing, then comming back repeatly unless I feather the gas pedal.
No codes ever, untill yesterday.

was in WA. stoped for a pack of smokes, and enter destination into my iphone for a new address 18 miles away.

I5 (interstate) was 30 sec away.
Got on it, traveling 120 km/hr.

about 3 min into drive, ...Half engine check like and Limp Mode displayed on my idrive.

Got home, and scanned my car using my laptop K+DCan cable and DIS v57.

Please see attached screen captures - 2 pages but here is what i got.
Now I am not sure if my Jerking issue is related or not.
Can someone point me in the right direction of fault?

Car is 2007 335i Sedan.
Built Date Sept of 2006.
Attached Images
  
Appreciate 0
      02-18-2013, 08:00 PM   #2
onebadmofo
Banned
Russian Federation
54
Rep
2,394
Posts

 
Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

Clean VANOS solenoids. Google how to do it.
Appreciate 0
      02-18-2013, 08:22 PM   #3
DJtoad
Lieutenant
United_States
8
Rep
416
Posts

 
Drives: 2010 535i M Sport
Join Date: May 2008
Location: Ellicott City, MD

iTrader: (1)

Almost all of those are battery/power-related. How old is your battery and have you verified that all of the battery connections are tight?
__________________
2010 535i M Sport - Platinum Gray/Dakota Black/Anthracite Bamboo
Premium, Value, Cold Weather, Sport Auto, Navigation, Satellite, Logic 7, Comfort Access, Park Distance, Fold Down Rear Seats, Heated Rear Seats, Rear Side Airbags, JB4 G5 ISO, BMS DCIs, BMS OCC, Proform Clear Bra, LUX H8 LED angel eyes
Appreciate 0
      02-18-2013, 08:34 PM   #4
DarkNemesis
Captain
Canada
16
Rep
859
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Only good advice can come from OneBadMoFo.
LoL
Anyone Gota link to a DIY for N54?

DN
Appreciate 0
      02-18-2013, 08:38 PM   #5
DarkNemesis
Captain
Canada
16
Rep
859
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Quote:
Originally Posted by DJtoad
Almost all of those are battery/power-related. How old is your battery and have you verified that all of the battery connections are tight?
The Battery connections are solid.
Dealer stated, that when battery was changed, they did not enter the new battery into the ECM.

Planning on doing it myself, but havn't got around to it.
Just Been too busy, but not forgotten.

DN
Appreciate 0
      02-19-2013, 12:05 PM   #6
DarkNemesis
Captain
Canada
16
Rep
859
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

What are the symptoms of vanos solenoid going out?

DN
Appreciate 0
      02-19-2013, 01:36 PM   #7
ctuna
Brigadier General
45
Rep
4,334
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Fix your battery problem first.

Fix your battery problem first.
As a low battery can cause all kinds of false errors with the electronics
of which these cars have in abundance . Then clear the errors and do
a another pass with DIS57.
Also there what are the dates on the error's most of this could be stored codes from before the battery change.
Appreciate 0
      02-19-2013, 02:53 PM   #8
DarkNemesis
Captain
Canada
16
Rep
859
Posts

 
Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Quote:
Originally Posted by ctuna
Fix your battery problem first.
As a low battery can cause all kinds of false errors with the electronics
of which these cars have in abundance . Then clear the errors and do
a another pass with DIS57.
Also there what are the dates on the error's most of this could be stored codes from before the battery change.
Ctuna, the battery codes were there before I owned this car.
The rest are recent like with 2 weeks tops.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:28 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST