E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > please help, changed front pads, now have problem(s)



Reply
 
Thread Tools Search this Thread
      02-17-2013, 05:56 PM   #1
mlifxs
Diamond Geezer
mlifxs's Avatar
24
Rep
1,791
Posts

 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

iTrader: (3)

Garage List
please help, changed front pads, now have problem(s)

********
Edit: Figured it out. Siphoned off some brake fluid out of the reservoir, kept pumping the brakes until they were stable enough to drive the car, did the bedding process. Brake pedal seems fine now.

Got rid of the brake light after more searching and reading. Had to carefully dismember the connection of the old sensor to the car. Put new sensor on and just tied it up without putting it on the pad as I'd rather not do this again. Reset the light, everything's okay now.


********
Changed my front pads for the first time, at 106k miles.

Have at least one problem:

a. After finishing, started car, immediately got the red car on the lift warning light, after it went away, small "brake" light stays on on the dashboard.

b. I've tried pumping my brakes, though I still cannot get a firm and stable pedal. It will quickly get firm as I pump but pedal will eventually slowly give. Thinking this means "bleed the brakes"? Pumped for a few minutes with no improvement. Not driving the car for now.

The following two things did not go as I anticipated during the pad change.
1. I had some overflow from the brake reservoir when I changed the second pad (left reservoir cap on, my bad?)
2. I tried to replace the sensor, and as I attempted to disconnect where the sensor connects with car wiring, the car wiring side of the connection began to break in my hands...so, I decided to leave the old sensor connected to the car wiring, but not the pad (it has not broken its second wire yet, I changed pads early) and twist tie it up.

So.....wondering...
does my pedal pressure issue in b. indicate I need to bleed brakes?
does my warning light indicate a problem with the sensor? If yes, any suggestions on how to proceed?

thanks for any advice or comments here.

Last edited by mlifxs; 02-18-2013 at 12:43 PM. Reason: problem solved
Appreciate 0
      02-20-2013, 06:35 PM   #2
kkashanchi
Second Lieutenant
kkashanchi's Avatar
3
Rep
237
Posts

 
Drives: 2008 e90 335i
Join Date: Feb 2012
Location: Irvine

iTrader: (-1)

How did you get rid of the brake light that stayed on? The red one. Did you just replace the sensor?
Appreciate 0
      02-20-2013, 06:46 PM   #3
mlifxs
Diamond Geezer
mlifxs's Avatar
24
Rep
1,791
Posts

 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

iTrader: (3)

Garage List
Quote:
Originally Posted by kkashanchi View Post
How did you get rid of the brake light that stayed on? The red one. Did you just replace the sensor?
Replaced sensor but didn't install it on the pad. Just tied it up securely to the fender well, behind the strut.

Once that was done, went through the service reset process.
http://www.e90post.com/forums/showthread.php?t=51049

Light disappeared
Appreciate 0
      02-22-2013, 02:24 AM   #4
kkashanchi
Second Lieutenant
kkashanchi's Avatar
3
Rep
237
Posts

 
Drives: 2008 e90 335i
Join Date: Feb 2012
Location: Irvine

iTrader: (-1)

Quote:
Originally Posted by mlifxs View Post
Replaced sensor but didn't install it on the pad. Just tied it up securely to the fender well, behind the strut.

Once that was done, went through the service reset process.
http://www.e90post.com/forums/showthread.php?t=51049

Light disappeared

thanks
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:29 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST