E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > 07 BMW 335i Navigation screen restarting over and over



Reply
 
Thread Tools Search this Thread
      05-24-2012, 06:13 PM   #1
jules203
Registered
1
Rep
3
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2012
Location: Vancouver, BC

iTrader: (0)

07 BMW 335i Navigation screen restarting over and over

Hey everyone

My problem just started today the Navigation screen keeps restarting over and over again. It comes up with the BMW symbol for a few seconds then goes black screen then it does it all over again.

I tried pulling the power on the battery maybe it would reset something but that didn't work.

Then I tried that hard reset by pressing both eject buttons and the volume button at the same time but that didn't work at all

Any help from anyone with the same problem?

Thanks
Appreciate 0
      05-25-2012, 05:42 PM   #2
jules203
Registered
1
Rep
3
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2012
Location: Vancouver, BC

iTrader: (0)

Update:

I pulled the fuses to the whole navigation unit and kept the driver side door open so the residual battery on the navigation would die out hoping this would give the unit a hard reset.

After waiting about 30 mins I put the fuses back in and put the key into my car, the BMW splash screen came up and I was able to eject the NAV CD but it went blank again. Now the splash screen doesnt even come up just a blank white screen which goes to black over and over again.

Any thoughts anyone?
Appreciate 0
      06-03-2012, 12:32 AM   #3
tom3tom3
New Member
0
Rep
18
Posts

 
Drives: e93
Join Date: May 2012
Location: LA

iTrader: (0)

I have a similar problem but mine works when it's cold temp. Only does that when it's hot.

Some ppl say I need to update the ccc ( the stereo)
Some say I need to change it

The ccc cost 900 at the dealer and it needs to be programmed to the car which is like an other 200

Ima try to find out if its an easy fix or do I have to replace it I'll let you know when I find out anything
Appreciate 0
      06-06-2012, 04:11 AM   #4
jules203
Registered
1
Rep
3
Posts

 
Drives: 2007 BMW 335i Sedan
Join Date: May 2012
Location: Vancouver, BC

iTrader: (0)

Update #2: tool to dealership and they told me I have to replace my CCC unit and they are quoting me $2200.

Probably gonna find my own CCC unit and replace.

Anyone know any good sites online?
Appreciate 0
      06-06-2012, 01:23 PM   #5
tom3tom3
New Member
0
Rep
18
Posts

 
Drives: e93
Join Date: May 2012
Location: LA

iTrader: (0)

Thats a rip off its 900 list price on the part. try a different dealer an it's like 200 for the coding

Or on eBay the used ones are like 500 get it and then try it if it works great ... But if the sound is not their when u snap it in you need to take it to the dealer and get it coded for your car
Appreciate 0
      06-18-2012, 11:00 AM   #6
d_dot
4 * General
d_dot's Avatar
United_States
16
Rep
646
Posts

 
Drives: F12 M6,Audi R8 Lambo Gallardo
Join Date: Dec 2007
Location: Tri-State

iTrader: (0)

Send a message via AIM to d_dot
This just happened to me this am. WTF. any ideas besides going to the stealership?
__________________
Nissan GT-R (Sold) E92 M3 + 335 (sold) F10 535 (sold) When Driving Nice Whips It Helps To Have Nice Kix!
Appreciate 0
      06-18-2012, 12:19 PM   #7
oshusttoley
Captain
7
Rep
678
Posts

 
Drives: 2008 335i sedan
Join Date: Mar 2012
Location: New Jersey

iTrader: (0)

my navi jammed and is stuck on the entertainment screen and i cant use anyting on idrove. it all froze, and still frozen after turning car on and off!
__________________
// JB4 ISO // Running Meth // Full FBO // E85 user //
Appreciate 0
      02-16-2013, 12:06 PM   #8
Moja
Private
Moja's Avatar
0
Rep
85
Posts

 
Drives: 2008 335i Coupe 6MT Dinan
Join Date: Jan 2010
Location: San Marcos, Texas, USA

iTrader: (0)

Mine started doing the exact same thing yesterday. I can't eject the Nav CD, operate the audio system, nothing.

Can anybody who originally posted comment on what they ultimately did (and paid) to fix it? This one seems way out of my DIY realm.

Thanks,

CAB

Quote:
Originally Posted by jules203 View Post
Hey everyone

My problem just started today the Navigation screen keeps restarting over and over again. It comes up with the BMW symbol for a few seconds then goes black screen then it does it all over again.

I tried pulling the power on the battery maybe it would reset something but that didn't work.

Then I tried that hard reset by pressing both eject buttons and the volume button at the same time but that didn't work at all

Any help from anyone with the same problem?

Thanks
Appreciate 0
      02-17-2013, 02:32 PM   #9
pweber84
Banned
pweber84's Avatar
Germany
4
Rep
347
Posts

 
Drives: BMW 330d e91
Join Date: Jan 2013
Location: Berlin, Germany / PL, Posen

iTrader: (2)

Send a message via Skype™ to pweber84
This is problem with the chipset in one of the CCC modules. The chpiset shoould be reballed.
It is possible to repair, I don't know where in your country, but maybe try internet.
In the meantime you can try to put out CCC device from your car, open it (few screws) and heat it using hair dryers.
Appreciate 0
      02-20-2013, 09:24 PM   #10
Moja
Private
Moja's Avatar
0
Rep
85
Posts

 
Drives: 2008 335i Coupe 6MT Dinan
Join Date: Jan 2010
Location: San Marcos, Texas, USA

iTrader: (0)

I used the suggestion above of holding both eject buttons and the volume button at the same time - it did indeed "reboot" it if you will, but just into the same exact pattern that it's been in all along. I did manage to eject the Nav DVD, however it had no effect on the situation.

In lieu of giving BMW $135 just to tell me it's hosed, I think I'm going to go the CIC mod route. It's expensive, but people are raving about theirs and if I'm going to spend 1100 anyway, I might as well double up and increase the enjoyment I get out of the car.
Appreciate 0
      02-22-2013, 11:42 AM   #11
Webdirk
Registered
0
Rep
3
Posts

 
Drives: 2008 E92
Join Date: Oct 2012
Location: Munich, Germany

iTrader: (0)

Not too long back, I had alike problem with my CCC; it was freezing all the time and sometime screen turned black. I went to the dealer and he gave me a price of 1450EURO for the replacement. I was considering buying on ebay another CCC for less, but decided not to. If CCCs are failing all the time, who can promise me that the "new" CIC from ebay will work? If it will work, how long it will be before it starts failing too?
I decided to be safe, pay a little bit more and replace my CCC with CIC (bought from Bimmer Retrofit, they are some of the sponsors on this site) and I love the new system. I will be writing a post soon about my experience - look for it, and I hope it will help you!
Appreciate 0
      02-22-2013, 11:32 PM   #12
Moja
Private
Moja's Avatar
0
Rep
85
Posts

 
Drives: 2008 335i Coupe 6MT Dinan
Join Date: Jan 2010
Location: San Marcos, Texas, USA

iTrader: (0)

Quote:
Originally Posted by Webdirk View Post
I decided to be safe, pay a little bit more and replace my CCC with CIC (bought from Bimmer Retrofit, they are some of the sponsors on this site) and I love the new system. I will be writing a post soon about my experience - look for it, and I hope it will help you!
Looking forward to seeing that! Will you reply to this thread and link to the new one?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:49 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST