E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Setting up Laptop for coding



Reply
 
Thread Tools Search this Thread
      01-28-2013, 05:48 PM   #23
peeti
Second Lieutenant
 
peeti's Avatar
 
Drives: 2011 M3 e90
Join Date: Apr 2012
Location: Chicagoland

Posts: 221
iTrader: (1)

Rich - please send link for VM if you would. I started building my own on VM Fusion (Mac) and am stuck on getting updated daten files. Frustrated. Grateful in advance!
Cheers
peeti is offline  
0
Reply With Quote
      02-01-2013, 11:54 PM   #24
adriang
Lieutenant
 
Drives: 2011 BMW 335d
Join Date: Feb 2012
Location: Nobleton

Posts: 543
iTrader: (0)

perhaps someone could upload rich's setup to an uploading site?

still havent gotten past my errors that I've had from the past...
__________________
2011 BMW 335d
adriang is offline   Canada
0
Reply With Quote
      02-02-2013, 09:33 AM   #25
Transporter88
Registered
 
Drives: e46
Join Date: Jan 2013
Location: Köln

Posts: 3
iTrader: (0)

does anyone know how to delete an error message?
Transporter88 is offline  
0
Reply With Quote
      02-05-2013, 08:34 PM   #26
mot
Banned
 
Drives: e92 AW M3 6MT
Join Date: Oct 2010
Location: Bay Area, California

Posts: 941
iTrader: (8)

Rich,

Can we get that link to your VM?

Tia!
mot is offline   United_States
0
Reply With Quote
      02-13-2013, 07:23 PM   #27
SharkBait
Second Lieutenant
 
Drives: 2010 E92 335i
Join Date: Jan 2013
Location: Lost Angeles

Posts: 297
iTrader: (0)

Garage List
Quote:
Originally Posted by mot View Post
Rich,

Can we get that link to your VM?

Tia!
Would also appreciate a copy if still available! Got VMWare already set up on my MBA but only a Win7 VM at the moment. Thx!
SharkBait is offline  
0
Reply With Quote
      02-15-2013, 06:12 AM   #28
pweber84
Banned
 
pweber84's Avatar
 
Drives: BMW 330d e91
Join Date: Jan 2013
Location: Berlin, Germany / PL, Posen

Posts: 347
iTrader: (2)

Send a message via Skype™ to pweber84
What you guys exactly need?
I have INPA, NCS Exper, Winkfp working in Windows 7 64 bit.
It's peace of cake to install it.
pweber84 is offline   Germany
0
Reply With Quote
      02-19-2013, 08:01 AM   #29
david.c.kay1
New Member
 
Drives: 2007 BW 335i (Crimson Red)
Join Date: Feb 2013
Location: Ramstein, Germany

Posts: 12
iTrader: (0)

I've got the software packages installed on my netbook, but now I need to find the right cable to plugin to my E90. Its a 2007 335i with a build date of 03/07. I know this is right when BMW switched the connectors. Does anyone know, or have any suggestions for identifying which one I should get?
david.c.kay1 is offline  
0
Reply With Quote
      02-19-2013, 09:02 PM   #30
koolit
Private
 
koolit's Avatar
 
Drives: 2010 E90
Join Date: Apr 2011
Location: SoCal

Posts: 60
iTrader: (0)

Quote:
Originally Posted by david.c.kay1 View Post
I've got the software packages installed on my netbook, but now I need to find the right cable to plugin to my E90. Its a 2007 335i with a build date of 03/07. I know this is right when BMW switched the connectors. Does anyone know, or have any suggestions for identifying which one I should get?
At some point last year I got so bored and read 100+ pages here. Although I am not into coding scheme yet.
http://www.e90post.com/forums/showthread.php?t=451145

I swear, in there they talked about the right cable to use for your car. Sorry my memory is not that good to recall what page you have to look at.
koolit is offline  
0
Reply With Quote
      02-20-2013, 03:52 AM   #31
Tronner
Second Lieutenant
 
Drives: 2008 335xi
Join Date: Sep 2010
Location: Centennial, CO

Posts: 204
iTrader: (2)

Quote:
Originally Posted by Ducati848R View Post
Can anyone help me get past this error:
In INPA

APILNIT: ERROR #135
API-0015 HOST COMMUNICATION ERROR
API INITIALZATION ERROR
NO API CALLS POSSIBLE!
Any help would be great.

Thanks
I am getting a very similar error as well:
ERROR #126
API - 0006 ACCESS DENIED
API INITIALIZATION ERROR
NO API CALLS POSSIBLE!

I am trying to get INPA to connect via a Windows 8 machine running VM Lite XP virtual machine. It recognizes the USB cable in the virtual machine but throws this code when attempting to connect to INPA.

Can anyone help?
Tronner is offline  
0
Reply With Quote
      02-20-2013, 11:14 PM   #32
Tronner
Second Lieutenant
 
Drives: 2008 335xi
Join Date: Sep 2010
Location: Centennial, CO

Posts: 204
iTrader: (2)

Quote:
Originally Posted by Tronner View Post
I am getting a very similar error as well:
ERROR #126
API - 0006 ACCESS DENIED
API INITIALIZATION ERROR
NO API CALLS POSSIBLE!

I am trying to get INPA to connect via a Windows 8 machine running VM Lite XP virtual machine. It recognizes the USB cable in the virtual machine but throws this code when attempting to connect to INPA.

Can anyone help?
So I got past this point, and I'm able to get both battery and ignition lights to turn on in INPA. It says RUNNING until I go into E90 / Engine / and click on MSD 80. Then is says STOPPED. Can anyone help?
Tronner is offline  
0
Reply With Quote
      02-20-2013, 11:34 PM   #33
Tronner
Second Lieutenant
 
Drives: 2008 335xi
Join Date: Sep 2010
Location: Centennial, CO

Posts: 204
iTrader: (2)

So this is really weird. I just plugged my cable into my laptop without being connected to the vehicle. The VM recognized the cable / USB then I opened INPA and both battery and ignition indicators are black???

I have used my cable to code successfully before when I had an XP machine, but can't get it to work now on a VM with this laptop.
Tronner is offline  
0
Reply With Quote
      02-21-2013, 05:21 AM   #34
pweber84
Banned
 
pweber84's Avatar
 
Drives: BMW 330d e91
Join Date: Jan 2013
Location: Berlin, Germany / PL, Posen

Posts: 347
iTrader: (2)

Send a message via Skype™ to pweber84
Quote:
Originally Posted by david.c.kay1 View Post
I've got the software packages installed on my netbook, but now I need to find the right cable to plugin to my E90. Its a 2007 335i with a build date of 03/07. I know this is right when BMW switched the connectors. Does anyone know, or have any suggestions for identifying which one I should get?
This one will fit your car:

http://www.ebay.de/itm/BMW-Ediabas-I...item337f3d55fb
pweber84 is offline   Germany
0
Reply With Quote
      02-21-2013, 05:23 AM   #35
pweber84
Banned
 
pweber84's Avatar
 
Drives: BMW 330d e91
Join Date: Jan 2013
Location: Berlin, Germany / PL, Posen

Posts: 347
iTrader: (2)

Send a message via Skype™ to pweber84
Quote:
Originally Posted by Tronner View Post
So this is really weird. I just plugged my cable into my laptop without being connected to the vehicle. The VM recognized the cable / USB then I opened INPA and both battery and ignition indicators are black???

I have used my cable to code successfully before when I had an XP machine, but can't get it to work now on a VM with this laptop.
Which interface you use? Send me the link.

I can give you the newest INPA working on Windows 7/8 64 bit. No VM needed.
pweber84 is offline   Germany
0
Reply With Quote
      02-21-2013, 07:43 AM   #36
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,255
iTrader: (5)

Send a message via Yahoo to cn555ic
INPA works but NCSexpert is not working as I tried to get the 64 but functioning.
__________________

Coding E and F New York 917-939-4980
cn555ic is online now   United_States
0
Reply With Quote
      02-21-2013, 08:44 AM   #37
pweber84
Banned
 
pweber84's Avatar
 
Drives: BMW 330d e91
Join Date: Jan 2013
Location: Berlin, Germany / PL, Posen

Posts: 347
iTrader: (2)

Send a message via Skype™ to pweber84
Quote:
Originally Posted by cn555ic View Post
INPA works but NCSexpert is not working as I tried to get the 64 but functioning.
NCS Exper working as well !
pweber84 is offline   Germany
0
Reply With Quote
      02-21-2013, 10:10 AM   #38
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,255
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by ******84 View Post
NCS Exper working as well !
When you get to the point of read individual ECU, there is no F4 to select it...So how is it working fine??? Please show a pic of this working.
__________________

Coding E and F New York 917-939-4980
cn555ic is online now   United_States
0
Reply With Quote
      02-21-2013, 10:17 AM   #39
pweber84
Banned
 
pweber84's Avatar
 
Drives: BMW 330d e91
Join Date: Jan 2013
Location: Berlin, Germany / PL, Posen

Posts: 347
iTrader: (2)

Send a message via Skype™ to pweber84
You're wrong, everything is working, of course you can choose each ECU. You want a print screen? I'm telling you that all is working perfectly.
pweber84 is offline   Germany
0
Reply With Quote
      02-21-2013, 10:37 AM   #40
icuc4coding
Banned
 
Drives: 2012 X5, 2012 MINI ALL4S
Join Date: Jan 2013
Location: Madison, WI

Posts: 16
iTrader: (1)

Quote:
Originally Posted by ******84
You're wrong, everything is working, of course you can choose each ECU. You want a print screen? I'm telling you that all is working perfectly.
Did you make any changes after the installation? It is not working me either.

I don't see the Read ECU button at all.
icuc4coding is offline   United_States
0
Reply With Quote
      02-21-2013, 11:10 AM   #41
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,255
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by ******84 View Post
You're wrong, everything is working, of course you can choose each ECU. You want a print screen? I'm telling you that all is working perfectly.
Listen I am not saying you dont have it, but a screen shot of it would be nice because I am no novice coder and I didnt get mine working...A screen shot of choosing individual ECU modules like CAS/ NFRM/CIC etc...I am curious to see these pics of a tab for Read ECU

Anyhow I still like the older version better!
__________________

Coding E and F New York 917-939-4980
cn555ic is online now   United_States
0
Reply With Quote
      02-21-2013, 12:55 PM   #42
pweber84
Banned
 
pweber84's Avatar
 
Drives: BMW 330d e91
Join Date: Jan 2013
Location: Berlin, Germany / PL, Posen

Posts: 347
iTrader: (2)

Send a message via Skype™ to pweber84
Viola:


pweber84 is offline   Germany
0
Reply With Quote
      02-21-2013, 01:42 PM   #43
pweber84
Banned
 
pweber84's Avatar
 
Drives: BMW 330d e91
Join Date: Jan 2013
Location: Berlin, Germany / PL, Posen

Posts: 347
iTrader: (2)

Send a message via Skype™ to pweber84
Quote:
Originally Posted by icuc4coding View Post
Did you make any changes after the installation? It is not working me either.

I don't see the Read ECU button at all.
No I did not. Which version of NCS exper you have?
pweber84 is offline   Germany
0
Reply With Quote
      02-21-2013, 01:45 PM   #44
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,255
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by ******84 View Post
Viola:


Nice...Good job in getting it working. Do you have English version too?
__________________

Coding E and F New York 917-939-4980
cn555ic is online now   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:34 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST