E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > USA - Northwest > 2008 335i 50k miles drives like shit.



Reply
 
Thread Tools Search this Thread
      02-19-2013, 08:05 PM   #1
thientien
New Member
 
Drives: 2008 335i Blue
Join Date: Apr 2012
Location: Everett, WA

Posts: 25
iTrader: (0)

2008 335i 50k miles drives like shit.

Hi people,

I got a 2008 335i auto with sport package and it drives like shit. I don't know what's the problem, but most of the time at complete stop like stop light or accelerating from rest, it's very slow. I have to rev it very hard, like above 2k rpm to get it to speed, and take like 2 to 3 seconds to get above 25mph. No code display on the car dash. At 50k miles, I think I need new spark plugs, but this problem has been on for a long time. Some time the car is very responsive, can get to 30mph very quick, but most of the time is slow. I do have a JB+ and Dual Cone Intake. Any advice is greatly appreciated.
thientien is online now  
0
Reply With Quote
      02-19-2013, 08:13 PM   #2
asdflkijd
Aberry is a scammer
 
asdflkijd's Avatar
 
Drives: SGM E92 335i, AM E90 335i
Join Date: Jun 2007
Location: Seattle, WA

Posts: 5,503
iTrader: (14)

Garage List
In need of a software update maybe?
asdflkijd is offline   South Korea
0
Reply With Quote
      02-19-2013, 09:45 PM   #3
jonnylin1
Lieutenant Colonel
 
Drives: 2008 AW e92 335i
Join Date: Oct 2011
Location: PNW

Posts: 1,664
iTrader: (1)

I really don't want to sound like a douche, but you are sure that you are not on the eco map from JB+ right? The one that turns the turbos off.

With no codes or anything it feels like the problem originates from the tune/map. Try reflashing the map?

And this problem just recently all the sudden occurred?
__________________


Never low enough.

IG: Jonnylin11
jonnylin1 is offline  
0
Reply With Quote
      02-19-2013, 09:59 PM   #4
atown88
Major
 
atown88's Avatar
 
Drives: e90
Join Date: Apr 2010
Location: Seattle

Posts: 1,442
iTrader: (0)

Quote:
Originally Posted by jonnylin1 View Post
I really don't want to sound like a douche, but you are sure that you are not on the eco map from JB+ right? The one that turns the turbos off.

With no codes or anything it feels like the problem originates from the tune/map. Try reflashing the map?

And this problem just recently all the sudden occurred?
Which is ironic because I feel like the turbos will actually boost MPG.
atown88 is offline   United_States
0
Reply With Quote
      02-20-2013, 12:57 AM   #5
thientien
New Member
 
Drives: 2008 335i Blue
Join Date: Apr 2012
Location: Everett, WA

Posts: 25
iTrader: (0)

no, JB+ is set at middle. is a long problem that's why i bought the JB+, but doesnt' seems to fix the problem. I'm planning to bring it to BMW of Seattle for them to look at this week while changing my oil. It's been over a year.
thientien is online now  
0
Reply With Quote
      02-20-2013, 12:58 AM   #6
///M3NACE
Banned
 
///M3NACE's Avatar
 
Drives: E36 M3, E36 Vert , E90 N52
Join Date: Oct 2006
Location: Downers Grove, IL

Posts: 3,907
iTrader: (5)

Thats how 335i's drive.
///M3NACE is offline  
0
Reply With Quote
      02-20-2013, 09:09 AM   #7
hookandpull
Lieutenant
 
Drives: 2008 335i Sedan
Join Date: Dec 2012
Location: Seattle WA

Posts: 574
iTrader: (2)

If the spark plugs were consistently bad enough to make the car miss to the point where it drove like complete ass you'd be getting codes for misfires.
__________________
19" DPE GT7's, BMS DCI, AA 3" catless downpipes, AE catless catback, JB4 G5, ETS 7" FMIC, AR Charpipe with dual -10 meth injector bungs, HFS4 Aquamist meth kit, Alpina TCU flash, M3 pedals, LED interior kit...
hookandpull is offline  
0
Reply With Quote
      02-21-2013, 05:42 AM   #8
///3dkn
Keeping it Gangster
 
///3dkn's Avatar
 
Drives: 2011 E90 M3 ZCP
Join Date: Jan 2012
Location: Pacific Northwest

Posts: 613
iTrader: (4)

^this
///3dkn is offline   United_States
0
Reply With Quote
      02-21-2013, 12:32 PM   #9
thientien
New Member
 
Drives: 2008 335i Blue
Join Date: Apr 2012
Location: Everett, WA

Posts: 25
iTrader: (0)

Thanks guys, I got no idea, may be I wasn't pushing the pedal hard enough. Will drop it at the dealer soon for them to look at still under CPO warranty.
thientien is online now  
0
Reply With Quote
      02-21-2013, 02:33 PM   #10
asdflkijd
Aberry is a scammer
 
asdflkijd's Avatar
 
Drives: SGM E92 335i, AM E90 335i
Join Date: Jun 2007
Location: Seattle, WA

Posts: 5,503
iTrader: (14)

Garage List
Quote:
Originally Posted by thientien View Post
I'm planning to bring it to BMW of Seattle for them to look at this week while changing my oil. It's been over a year.
What??? It's been over a year since you've changed your oil??????
asdflkijd is offline   South Korea
0
Reply With Quote
      02-21-2013, 02:51 PM   #11
tigermack
OPN DIFF
 
tigermack's Avatar
 
Drives: 06' 330i MT TiAg
Join Date: Oct 2012
Location: Pacific Ocean

Posts: 1,274
iTrader: (11)

Garage List
Send a message via AIM to tigermack
Over a year oil change... uhhhhhhhhhhhhhhhhhhhh...
__________________
M-tech front\Hartge CF lip\blacklines\M3 wheel\BMW P.E.\BMS powerbox\ST coils\BBS GT4

e36 - racecar - SCCA STX #188

Autocross vids https://www.youtube.com/user/tigermack
tigermack is offline   Hong Kong
0
Reply With Quote
      02-21-2013, 03:56 PM   #12
Transfer
Lieutenant Colonel
 
Transfer's Avatar
 
Drives: SQ5, X1
Join Date: Mar 2010
Location: Seattle, WA

Posts: 1,676
iTrader: (0)




Quote:
Originally Posted by ihsanshaik View Post
Thats how 335i's drive.
I lol'd
Transfer is offline   United_States
0
Reply With Quote
      02-21-2013, 05:00 PM   #13
Wedge1967
Banned
 
Drives: '07 e92 AT Sport Montego Blue
Join Date: Sep 2011
Location: Portland, OR

Posts: 2,172
iTrader: (3)

We have a flash for that.
Wedge1967 is offline   United_States
0
Reply With Quote
      02-21-2013, 07:25 PM   #14
thientien
New Member
 
Drives: 2008 335i Blue
Join Date: Apr 2012
Location: Everett, WA

Posts: 25
iTrader: (0)

Quote:
Originally Posted by asdflkijd View Post
What??? It's been over a year since you've changed your oil??????
Oh no, last oil change was 5k miles ago, about 6 months. the Drive like shit is over a year.
thientien is online now  
0
Reply With Quote
      02-21-2013, 07:43 PM   #15
///3dkn
Keeping it Gangster
 
///3dkn's Avatar
 
Drives: 2011 E90 M3 ZCP
Join Date: Jan 2012
Location: Pacific Northwest

Posts: 613
iTrader: (4)

Depending on where you go, it's been debated how many times, you might have to disconnect your JB chip and put it back to stock before bringing it to your dealer.
///3dkn is offline   United_States
0
Reply With Quote
      02-21-2013, 07:52 PM   #16
hookandpull
Lieutenant
 
Drives: 2008 335i Sedan
Join Date: Dec 2012
Location: Seattle WA

Posts: 574
iTrader: (2)

^^^ This ... I would do that no matter where you go.
hookandpull is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:45 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST