E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Air conditioning problems help please!



Reply
 
Thread Tools Search this Thread
      03-17-2011, 08:07 PM   #1
jc328
New Member
United_States
0

 
Drives: 328i
Join Date: Feb 2011
Location: Miami


Posts: 23
iTrader: (0)

Air conditioning problems help please!

Hello everyone! i just got a CPO 328i about a month ago so i'm still new to bimmers although i've always wanted one ever since i was a kid. anyway, here is my problem, my AC takes an unusually long time to cool when i turn the car on in the morning or in the afternoon after work. It blows warm air and takes about 10-15 mins before the air starts to cool. it only does this when the car has been parked for a long time but doesn't happen when you drive multiple trips with all the turning on and off of the engine. i already took it to the dealer twice and they said that there is nothing wrong with my AC but it's really noticeable compared to the loaner car that they gave me. is there something i'm missing? or is it really normal for a bmw to take that long to cool up? can anybody suggest what steps i should take to find out how to resolve my problem? any help would be greatly appreciated!
Appreciate 0
      03-18-2011, 05:30 AM   #2
ENINTY
Banned
50

 
Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia


Posts: 3,415
iTrader: (0)

If the AC has been checked out and it has the proper level of freon in it and is running at the spec pressure then I think your problem my be how you are operating it. Set the system to auto. Then make sure the dash vent temperature blending wheel is set to the blue side (all the way to the right). If you don't know what the blending wheel is, it is the wheel in the center of the dashboard just below the hazard button and the doors lock button. If it is set on warm, it will blend heated air in with the AC and make the system seem like it is not working.
Appreciate 0
      03-18-2011, 08:08 AM   #3
jc328
New Member
United_States
0

 
Drives: 328i
Join Date: Feb 2011
Location: Miami


Posts: 23
iTrader: (0)

The blending wheel is always set to the blue/cold side so i don't think that is the issue. is it more advisable to just use the auto feature? because i normally set the aircon manually. i feel like im taking care of the compressor by not letting it run at max during cold start. i don't mind waiting for the cabin to cool its just that there is not even a hint of cold air coming from my vents until it decides to cool 10mins later.

thanks for the response btw.
Appreciate 0
      02-21-2013, 04:51 PM   #4
kcornwell
New Member
0

 
Drives: 2006 E90 330i
Join Date: Sep 2012
Location: Destin FL


Posts: 10
iTrader: (0)

Did this ever get resolved? If so how?

Thanks,
KC
Appreciate 0
      02-21-2013, 05:37 PM   #5
nate5ks
Captain
United_States
8

 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL


Posts: 620
iTrader: (0)

If the hi and lo side pressure, condenser fan, blower motor, and environmental controls all check good and there are no binds in the lines or other components it could be that the freon is contaminated with air and moisture and is not cooling as efficiently as it should. Maybe getting it flushed and replacing the receiver/drier would help.
Appreciate 0
      02-22-2013, 05:52 PM   #6
kcornwell
New Member
0

 
Drives: 2006 E90 330i
Join Date: Sep 2012
Location: Destin FL


Posts: 10
iTrader: (0)

The air conditioner works perfectly after the engine has warmed up (when the engine radiator coolant temp is 70C or greater) . After the engine is hot, no problems with a/c.

Weird.


Btw, im a HVAC/R guy and understand the refrigeration cycle.

What I need is a complete control circuit diagram and order of operations technical manual.
Appreciate 0
      07-16-2013, 09:24 AM   #7
pedrobmw
New Member
0

 
pedrobmw's Avatar
 
Drives: 2007 BMW 328xi
Join Date: Jul 2013
Location: Western MA


Posts: 9
iTrader: (0)

This seems to be the same issue posted on this thread:

http://www.e90post.com/forums/showthread.php?t=853788

Any solutions yet?
Appreciate 0
      07-16-2013, 10:09 AM   #8
Socom
BMWCCA since '03
United_States
68

 
Drives: 2015 435i
Join Date: May 2005
Location: Atl.


Posts: 5,310
iTrader: (0)

Quote:
Originally Posted by kcornwell View Post
The air conditioner works perfectly after the engine has warmed up (when the engine radiator coolant temp is 70C or greater) . After the engine is hot, no problems with a/c.

Weird.


Btw, im a HVAC/R guy and understand the refrigeration cycle.

What I need is a complete control circuit diagram and order of operations technical manual.
How well does it cool while running under MAX? Does the compressor engage?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:30 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST