E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > power steering flush => rough idle in R



Reply
 
Thread Tools Search this Thread
      03-02-2013, 06:51 PM   #1
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 240
iTrader: (3)

[solved] power steering flush => rough idle in R

Hey,

I just did a power steering flush, and changed the reservoir. I had trouble pulling out the cables, so I fiddled with it for maybe an hour before finally removing it, and connecting the new one. After that I put back the engine filter, reconnected the MAF sensor, then started the car.

Some how the car vibrated a lot and the idle rpm jumps a bit when in reverse!

I had rough idles before, but more intermittent, now it's sort of become deterministic! Any ideas?

Thanks,
D

Last edited by dylim; 03-07-2013 at 12:26 AM.
dylim is offline  
0
Reply With Quote
      03-02-2013, 07:10 PM   #2
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 240
iTrader: (3)

Not sure how the intake duct connection to the intake filter housing should be:

The intake duct has two notches (dots are empty spaces):
____----|
.........0.|
-----___|

The intake filter housing has two holes, should go over the notches:

..|--____
..|.0
..|__-----
____|
^^^^
this is the lip

But the intake filter housing connection has a lip, and some space in between... Should the lip be outside, i.e. below the intake duct? Or should it be inside the intake duct?

When I put the lip outside, the connection seems very loose. When the lip is inside, it's tighter.

Judging from that, I think the lip was inside before - an indy shop replaced my air filter last year and might have connected it wrongly. Which way should it be, and could an air leak cause rough idle in R?
dylim is offline  
0
Reply With Quote
      03-02-2013, 07:29 PM   #3
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 240
iTrader: (3)

A clearer pic here
http://parts.bmwofsouthatlanta.com/s...ssembly=255907
dylim is offline  
0
Reply With Quote
      03-07-2013, 12:26 AM   #4
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 240
iTrader: (3)

Problem solved...
dylim is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:04 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST