E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Rough Idle, stumbling rpms



Reply
 
Thread Tools Search this Thread
      03-06-2013, 01:11 PM   #199
AWD Addict
Chief Executive
AWD Addict's Avatar
36
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by SDSUDons View Post
AWD Addict, any luck? I've had mine in the shop so many times and gotten the same, "we cant find anything wrong" except I KNOW something is wrong. Started right when I changed the plugs. I used to wrench on cars myself at a hot rod shop, and between that and driving the car every day, I know when something is wrong. I read the whole forum and noticed that it seems everyone has tried something that would logically make sense, but to no avail. Something to add, I noticed a slight lack of power while driving, at all speeds. Also, the gas mileage seems to have taken a noticeable hit. I was averaging around 450 miles per tank, and now I am getting about 300 since the spark plug change/random rough idle. You notice that? LOVE the fact that it doesnt throw codes either.

Side note, I have been recording data for the rough idle and comparing it to the normal idle. I am going to have a few trusted mechanics around town look at it as well and see if they can wrap their heads around it. Let me know if you have any updates. Thanks!
Been working on it with my independent mechanic now that I'm out of warranty. THe answer is no. I can tell you it's a miniature misfire though, as it's worse when my plugs are bad.

I'm inclined to believe its just something that's a part of the car at this point, coincident with the other finicky elements like injectors, coil packs and plugs. I think this car is just a very fine tuned vehicle with very little margin for error given the amount of technology used for its operation.

I think we should all be changing plugs every 20k miles (minimum, if you're tuned, less). I'm at almost 20k since mine were done, and I've noticed my mileage is down too. I'm about to get them swapped. I'll record a couple tanks and report back if that's in fact related.
Appreciate 0
      03-06-2013, 04:21 PM   #200
SDSUDons
Registered
0
Rep
4
Posts

 
Drives: 2006 325i
Join Date: Jun 2012
Location: Sacramento

iTrader: (0)

Garage List
2006 325i  [0.00]
I agree. It seemed odd that the problem started immediately after changing the plugs, even when using the exact same BMW plugs, but maybe they had it dialed in just right. I am about 2k past my change of plugs and recently just took the car in to get the software update (I am 2 years removed from warranty) and paid to see if that would help as the SA suggested it would, along with my Indy Mechanic, who worked for BMW for 35 years. It actually made the problem worse. Now I feel it on the freeway slightly and it is much worse when starting the car warm. It will hunt between 500-900 RPM and almost feels like it is going to stall. This car ran smooth for years, so I'm not inclined to agree that it is just the car. However, you, myself, and many others have tried numerous solutions without any luck. I prefer to change plugs around that same mileage also. Not a big cost, and doesn't hurt anything, I guess except for when it gives your car a random rough idle with no code...

I forget, did you ever try that reset of adaptation that was recommended by causing the car to throw a misfire code?
Appreciate 0
      03-07-2013, 12:53 PM   #201
AWD Addict
Chief Executive
AWD Addict's Avatar
36
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
Yes. I think the adaptation reset helped for a little while, but it wasn't a real fix.
Appreciate 0
      03-21-2013, 03:44 PM   #202
E92ML
Captain
E92ML's Avatar
United_States
13
Rep
871
Posts

 
Drives: E92 2008 335xi Coupe
Join Date: May 2011
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by AWD Addict View Post
Yes. I think the adaptation reset helped for a little while, but it wasn't a real fix.
Do you know if replacing the throttle body will fix the problem?
__________________

Performance: JB4 ECU, CP-E DP's, WW BMS Meth Kit, AR meth elbow, BMS DCI, AFE Intake Scoops,
Exterior: Enkruez 19" H8R, H&R Spacers, Aero Lip, Tint, ACS Roof Spoiler, HID AE's, HID Fogs, Black Grills, Sport Pedals
Appreciate 0
      03-28-2013, 09:25 AM   #203
mike281
Private
0
Rep
51
Posts

 
Drives: 2007 335i coupe
Join Date: Apr 2008
Location: Boston, MA

iTrader: (0)

Add me to the list too. Mine isn't just when cold and never comes close to stalling yet, but definetly worse with the lower idle with a/c off. My car has been through hell the last few years from blown turbos to a siezed motor (all not under warranty thank god I own a shop). Mine started when i did the motor swap (which I did new plugs along with other things) so I figured it had something to do with all of that. I've been driving myself crazy trying to figure it out. I'm kind of glad to hear I'm not the only one, but at the same time pissed at BMW that they haven't fixed it yet for anyone.
Appreciate 0
      03-29-2013, 09:54 AM   #204
SpeedCC
Enlisted Member
United_States
0
Rep
35
Posts

 
Drives: 335xi
Join Date: Mar 2012
Location: Burlington,VT

iTrader: (1)

Quote:
Originally Posted by AWD Addict View Post
Been working on it with my independent mechanic now that I'm out of warranty. THe answer is no. I can tell you it's a miniature misfire though, as it's worse when my plugs are bad.

I'm inclined to believe its just something that's a part of the car at this point, coincident with the other finicky elements like injectors, coil packs and plugs. I think this car is just a very fine tuned vehicle with very little margin for error given the amount of technology used for its operation.

I think we should all be changing plugs every 20k miles (minimum, if you're tuned, less). I'm at almost 20k since mine were done, and I've noticed my mileage is down too. I'm about to get them swapped. I'll record a couple tanks and report back if that's in fact related.
I'll venture to say that finicky in the N54 engine you speak of comes predominantly from the carbon build up on the intake valves. I finally got around to walnut blasting mine out last night and believe this picture speaks perfectly to the majority of direct injection turbo engines that run rough or misfire.
48k miles, all 6 cylinders were complete shit, pic is at the start and then during the blasting process of one of the cylinders, not the finished outcome but eye-opening to say the least.
Attached Images
 
Appreciate 0
      03-30-2013, 10:24 AM   #205
Antti
New Member
0
Rep
14
Posts

 
Drives: BMW
Join Date: Feb 2013
Location: Finland

iTrader: (0)

Hey, new owner of a 330i e90 lci 2009 with 119300km reporting in with a problem.
Ive noticed rough idle and car is shaking alot when idle, check engine light comes on very often. Once when it was cold I even noticed jerking while driving.

I took a video of it, at 45 seconds something happens when the rpms jump up to 1k and the check engine light comes on. Last time I tried starting again 3 times and the engine light always came on.

Any ideas what the problem could be?
Appreciate 0
      04-03-2013, 12:00 PM   #206
Antti
New Member
0
Rep
14
Posts

 
Drives: BMW
Join Date: Feb 2013
Location: Finland

iTrader: (0)

Quote:
Originally Posted by Antti View Post
Any ideas what the problem could be?
Ill answer to myself then, cylinders 4-5-6 needed new injectors+plugs.
All ignition coils changed due to bmw campaign
Thank god I have a warranty so I have to pay only 10%
Appreciate 0
      04-12-2013, 09:10 AM   #207
Antti
New Member
0
Rep
14
Posts

 
Drives: BMW
Join Date: Feb 2013
Location: Finland

iTrader: (0)

And the problem is back again, god damnit why didnt they change all 6 injectors+plugs
Appreciate 0
      04-12-2013, 09:45 AM   #208
AWD Addict
Chief Executive
AWD Addict's Avatar
36
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
Gotta do them all. My stealership tried to nickel and dime it, and I made such an obnoxious stink about it, they finally did all the injectors and plugs.
Appreciate 0
      04-15-2013, 11:20 AM   #209
Antti
New Member
0
Rep
14
Posts

 
Drives: BMW
Join Date: Feb 2013
Location: Finland

iTrader: (0)

Quote:
Originally Posted by AWD Addict View Post
Gotta do them all. My stealership tried to nickel and dime it, and I made such an obnoxious stink about it, they finally did all the injectors and plugs.
Yeah, I just spoke with the repair guy and he said the parts are so expensive so they just do what the tester says is the problem.. First repair was 1207$ total, lets see how much the second repair makes.
I hope they find the final solution tomorrow.
If I hadnt paid for this extra warranty Id be in deep shit right now with upcoming repair costs exceeding 2000$
Appreciate 0
      04-16-2013, 10:25 AM   #210
Antti
New Member
0
Rep
14
Posts

 
Drives: BMW
Join Date: Feb 2013
Location: Finland

iTrader: (0)

Today all the rest of the injectors+plugs were changed and for the first time ever since ive owned the car for 1 month the car runs perfect from a cold start.
total cost of repairs 2296$..
Appreciate 0
      04-16-2013, 10:33 AM   #211
Wedge1967
Banned
United_States
25
Rep
2,172
Posts

 
Drives: '07 e92 AT Sport Montego Blue
Join Date: Sep 2011
Location: Portland, OR

iTrader: (3)

The first time I had issue my injector failure and the dealership replaced an entire bank. I have the same issue again and you can tell it's an injector at startup when you can smell the raw fuel and you have misfires. Lucky for me I still have CPO and the car is going in for service this week.
Appreciate 0
      04-16-2013, 10:36 AM   #212
Wedge1967
Banned
United_States
25
Rep
2,172
Posts

 
Drives: '07 e92 AT Sport Montego Blue
Join Date: Sep 2011
Location: Portland, OR

iTrader: (3)

Quote:
Originally Posted by Antti View Post
Hey, new owner of a 330i e90 lci 2009 with 119300km reporting in with a problem.
Ive noticed rough idle and car is shaking alot when idle, check engine light comes on very often. Once when it was cold I even noticed jerking while driving.

I took a video of it, at 45 seconds something happens when the rpms jump up to 1k and the check engine light comes on. Last time I tried starting again 3 times and the engine light always came on.

Any ideas what the problem could be?
Injector issue. When you start the car cold, does it small like raw fuel from the exhaust? Good luck.
Appreciate 0
      04-16-2013, 01:47 PM   #213
Antti
New Member
0
Rep
14
Posts

 
Drives: BMW
Join Date: Feb 2013
Location: Finland

iTrader: (0)

Quote:
Originally Posted by Wedge1967 View Post
Injector issue. When you start the car cold, does it small like raw fuel from the exhaust? Good luck.
Your right about the fuel smell, one time when i started it in the garage it had a strong fuel smell. Also the end of my exhaust is black, im figuring it had something to do with my problem.
But its all fixed now, changing injectors and plugs worked.
Appreciate 0
      04-16-2013, 05:49 PM   #214
Wedge1967
Banned
United_States
25
Rep
2,172
Posts

 
Drives: '07 e92 AT Sport Montego Blue
Join Date: Sep 2011
Location: Portland, OR

iTrader: (3)

Quote:
Originally Posted by Antti View Post
Your right about the fuel smell, one time when i started it in the garage it had a strong fuel smell. Also the end of my exhaust is black, im figuring it had something to do with my problem.
But its all fixed now, changing injectors and plugs worked.
Good deal... Yeah, I'm on my second set of injectors. When they go they slowly flood the engine with fuel and the car will run rough cold, but smoothes out as the car warms up. Only issue is the injectors just keep getting worse over time. Plugs are always a safe bet depending on milage but they normally don't cause misfires at idle. Glad to hear everything is working.
Appreciate 0
      04-24-2013, 08:03 AM   #215
AWD Addict
Chief Executive
AWD Addict's Avatar
36
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by Wedge1967 View Post
The first time I had issue my injector failure and the dealership replaced an entire bank. I have the same issue again and you can tell it's an injector at startup when you can smell the raw fuel and you have misfires. Lucky for me I still have CPO and the car is going in for service this week.
That's a leaking injector. Not uncommon in this vehicle.
Appreciate 0
      05-01-2013, 06:36 PM   #216
drjekl
Captain
11
Rep
788
Posts

 
Drives: E92 335i
Join Date: Jan 2013
Location: Oz

iTrader: (0)

I don't have a rough idle with the tacho jumping around but it has an intermittent rough idle where for a split second it feels like it is going to stall then it catches itself.

I have an issue at low speeds in 4th or 5th gear doing around 1500/2000 RPM where the car hunts and stumbles..

The car had a full service 8 months ago (all fluids and filters and plugs) and I'm 6 MT with 70k kms/44k miles.

I'm going to replace my coils and plugs myself then take the car to the dealer so bmw can check the injectors to see if they fall under the campaign.
Appreciate 0
      05-12-2013, 10:57 PM   #217
R.G.
Lieutenant
R.G.'s Avatar
6
Rep
588
Posts

 
Drives: 2010 335i
Join Date: Jan 2013
Location: In my sub conscious

iTrader: (9)

Drove to Cali from Nevada this weekend. Stopped and filled up at a chevron in Baker. Got to LA and when I woke up the next morning car was stumbling BADLY and threw a CEL on a cylinder 5 misfire. I'm confident the gas has something to do with it. I use Chevron occasionally in Nevada and never had this problem but I'm sure something was up with that stations gas.
I know it sounds crazy but try using a different gas station then you normally do. Worth a try considering all the other effort

Edit: Also worth noting is that thru that entire tank of gas I was having idle problems even after oil temps where at 240
Since going thru that tank and filling up at the Shell I normally do idle problems went away
__________________
Cobb*FSR E40 Pro tune*Dinan IC*Dinan CAI*Dinan Strut Tower*Dinan camber plates*Dinan control arm bushings*MS Catless*ER Chargepipe*Tial BOV*Custom dual 2.5" exhaust w/Vibrant race mid cats & resonaters*Vishnu Walbro 455 Inline kit*BMS OCC*Alpina Trans flash*Misc coding*RB PCV*Megan racing toe arms*M3 subframe bushings*Carbon vented hood*Carbon trunk*Carbon grills*DD rear bumper*Race valances*Vorsteiner carbon front lip*M3 Steering wheel w/DCT paddles*M3 Guages*M3 Side Skirts*Carbon side splitters*Volk RE30s
Appreciate 0
      05-14-2013, 05:32 PM   #218
AWD Addict
Chief Executive
AWD Addict's Avatar
36
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by E92ML View Post
Do you know if replacing the throttle body will fix the problem?
Someone here reported they had similar symptoms, and it ended up being a cracked TB. I'll have my mechanic look at it next time I'm in there.
Appreciate 0
      05-15-2013, 08:47 PM   #219
kalamokid
Private First Class
3
Rep
170
Posts

 
Drives: 335i Coupe
Join Date: Jan 2012
Location: Toronto

iTrader: (0)

hey everyone. 08 335. 62k km. hpfp replaced before I owned the car. plugs changed at 45k km. feeling same problems. one new issue is in the morning on a cold start when the rpm bumps up and settles it almost feels like its going to stall as it dropa below 500 rpm. also. how do I know that I am misfiring? im not throwing any codes. thanks!
Appreciate 0
      05-25-2013, 10:47 AM   #220
tinnsoldaten
Captain
tinnsoldaten's Avatar
Norway
6
Rep
685
Posts

 
Drives: e92 335i coupe
Join Date: Dec 2008
Location: Bergen

iTrader: (1)

I think I might have a issue there ... I can see little oilwaste in that area.

PVC and cylinder # 6




Quote:
Originally Posted by reiss91 View Post
Had a car come in to the dealer with a rough idle during cold start. Turns out his valve cover was cracked near the pcv part. Not likely but worth checking if yours is cracked
__________________
Vargas S2 turbos|VAC S3 Cylinder head|RR DPs|RR MPs|Supersprint X pipe|Remus Quad Sport mufflers|aFe Stage 2 Si with scoops|Forge DVs|ER CP|BMS meth elbow|Aquamist HFS-4|Walbro 450 E85 LPFP|AA FMIC|BMS OCC|Cobb stage2+ agressive FMIC LT|P3 Boost Gauge|JIC CROSS Competition Coilvers|M3 sways F/R+ Ground control endlinks|Vorsteiner v303 19"|Michelin PS2 sport|Quaife LSD|Vorsteiner V35 CF hood|CF CLS trunk|Duke Dynamics quad diffusor
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:12 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST