E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Canada > Passenger airbag light was intermittent, now on all the time



Reply
 
Thread Tools Search this Thread
      03-15-2013, 04:54 PM   #1
dassub
0
Captain
 
dassub's Avatar
 
Drives: '06 325i 6MT
Join Date: May 2009
Location: Toronto

Posts: 751
iTrader: (1)

Garage List
Passenger airbag light was intermittent, now on all the time

I've had the passenger airbag light come and go, but now it's on all the time, and I'm getting the red airbag warning on the dash.

I wish this happened during the original warranty, or CPO warranty, but those expired on me a while ago now.

I forgot what the quote from the dealer was, but I think it was over $1000 to do, possibly approaching $2000.. I can't remember.. it was while I was already paying $1500 for the eccentric shaft sensor replacement, so I wasn't about to approve another costly repair.

Any experience with this outside of warranty? Any alternate locations to take it? I've been quoted around $500 for just the part alone, without install or code reset.
dassub is offline   Canada
Appreciate 0
Reply With Quote
      03-16-2013, 08:37 AM   #2
playground
0
Second Lieutenant
 
Drives: E90 ///M3
Join Date: Jan 2013
Location: Causeway Bay & North York

Posts: 272
iTrader: (0)

Quote:
Originally Posted by dassub View Post
I've had the passenger airbag light come and go, but now it's on all the time, and I'm getting the red airbag warning on the dash.

I wish this happened during the original warranty, or CPO warranty, but those expired on me a while ago now.

I forgot what the quote from the dealer was, but I think it was over $1000 to do, possibly approaching $2000.. I can't remember.. it was while I was already paying $1500 for the eccentric shaft sensor replacement, so I wasn't about to approve another costly repair.

Any experience with this outside of warranty? Any alternate locations to take it? I've been quoted around $500 for just the part alone, without install or code reset.
Most of the time a simple software update and reset of the error checks will fix this issue. The sensor contacts cleaned with some contact cleaner.
__________________
LAPTORR|ESS|GruppeM|BILSTEIN|BBS
playground is offline   Hong Kong
Appreciate 0
Reply With Quote
      03-16-2013, 02:15 PM   #3
dassub
0
Captain
 
dassub's Avatar
 
Drives: '06 325i 6MT
Join Date: May 2009
Location: Toronto

Posts: 751
iTrader: (1)

Garage List
Quote:
Originally Posted by playground View Post
Most of the time a simple software update and reset of the error checks will fix this issue. The sensor contacts cleaned with some contact cleaner.
I unplugged it, contacts looked good.. plugged it back in. I'll see if it helps. I'm starting to consider the bypass module they sell on eBay.
dassub is offline   Canada
Appreciate 0
Reply With Quote
      03-17-2013, 01:41 AM   #4
playground
0
Second Lieutenant
 
Drives: E90 ///M3
Join Date: Jan 2013
Location: Causeway Bay & North York

Posts: 272
iTrader: (0)

Quote:
Originally Posted by dassub View Post
I unplugged it, contacts looked good.. plugged it back in. I'll see if it helps. I'm starting to consider the bypass module they sell on eBay.
I would recommend you to have the software updated. It will get rid of that error most of the time. You probably just have a buggy year of software loaded on the car, and haven't done updates since the car was last delivered. I don't recommend those eBay modules as it would be potentially unsafe.
__________________
LAPTORR|ESS|GruppeM|BILSTEIN|BBS
playground is offline   Hong Kong
Appreciate 0
Reply With Quote
      03-17-2013, 08:58 AM   #5
dassub
0
Captain
 
dassub's Avatar
 
Drives: '06 325i 6MT
Join Date: May 2009
Location: Toronto

Posts: 751
iTrader: (1)

Garage List
Quote:
Originally Posted by playground View Post
I would recommend you to have the software updated. It will get rid of that error most of the time. You probably just have a buggy year of software loaded on the car, and haven't done updates since the car was last delivered. I don't recommend those eBay modules as it would be potentially unsafe.
Thanks for the advice. I actually have a recent software update on my car. When I had my alarm installed at the dealer last year, they had to do an entire update, as the tech said the software was very old.
dassub is offline   Canada
Appreciate 0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:59 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST