E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Single 2a99 Fault Code



Reply
 
Thread Tools Search this Thread
      02-22-2013, 10:19 AM   #1
Snyperx
Lieutenant
 
Drives: 2006 BMW 325i
Join Date: Oct 2011
Location: Stoughon, WI

Posts: 506
iTrader: (3)

Garage List
2006 BMW 325i  [0.00]
Question Single 2a99 Fault Code

I decided to scan my car for codes just because and ended up discovering that a 2a99 code was being stored. In reading this forum it seems this is related to the VANOS solenoid. From my understanding I should be able to just clean the solenoids and swap correct? The car still seems to be starting and running fine. Any other things I should be looking into? To be honest after I looked up the code I about had a heart attack.
__________________
Regards,
SnyperX

Last edited by Snyperx; 02-23-2013 at 10:46 AM.
Snyperx is offline   United_States
0
Reply With Quote
      02-22-2013, 01:08 PM   #2
Volasko
Major
 
Volasko's Avatar
 
Drives: 2006 E90 330i BSM 6MT ZSP
Join Date: Dec 2010
Location: Toronto

Posts: 1,082
iTrader: (2)

Garage List
No need for a heart attack, it is one of the easiest DIY's you can do. I would just pull both solenoids out, spray them down with MAF cleaner and blow them dry with compressed air. Make sure you mark them so you know you are actually swapping them and reinstall them. Drive for a few days and see if you still pull an error code. If you do find an error code (probably about the intake cameshaft now that you swapped it) just buy a new solenoid and install your self. I had a solenoid that after cleaning two times would still throw codes so I just put in a new one and the car is running as good as new. It is about $150 from the dealer and about 15 min of your time to install.

Some symptoms are uneven idle and reduced power especially around 3k when the vanos system kicks in to adjust the valve timing.

Last edited by Volasko; 02-22-2013 at 01:17 PM.
Volasko is offline   Canada
0
Reply With Quote
      02-22-2013, 01:53 PM   #3
Snyperx
Lieutenant
 
Drives: 2006 BMW 325i
Join Date: Oct 2011
Location: Stoughon, WI

Posts: 506
iTrader: (3)

Garage List
2006 BMW 325i  [0.00]
Quote:
Originally Posted by Volasko View Post
Some symptoms are uneven idle and reduced power especially around 3k when the vanos system kicks in to adjust the valve timing.
Doesn't seem like the car is driving any different, though I will say it seems to idle a bit rough when I first start it up, but smooths out after a couple minutes. No other codes or CEL lights. I did already plan on pulling and cleaning the solenoids. If I end up buying one I should be able to get them for about $100 each online.
__________________
Regards,
SnyperX

Last edited by Snyperx; 02-22-2013 at 02:48 PM.
Snyperx is offline   United_States
0
Reply With Quote
      02-25-2013, 11:59 AM   #4
Snyperx
Lieutenant
 
Drives: 2006 BMW 325i
Join Date: Oct 2011
Location: Stoughon, WI

Posts: 506
iTrader: (3)

Garage List
2006 BMW 325i  [0.00]
UPDATE: I cleared the 2a99 code using my Peake scan tool and so far the code has not come back. Maybe it was a fluke? I still plan on pulling, cleaning, swapping the VANOS solenoids though. It is still puzzling why that code was getting stored though.
__________________
Regards,
SnyperX

Last edited by Snyperx; 02-28-2013 at 01:45 PM.
Snyperx is offline   United_States
0
Reply With Quote
      03-01-2013, 10:16 AM   #5
Snyperx
Lieutenant
 
Drives: 2006 BMW 325i
Join Date: Oct 2011
Location: Stoughon, WI

Posts: 506
iTrader: (3)

Garage List
2006 BMW 325i  [0.00]
UPDATE 2: I got on the gas a few times last night coming home from work and this morning did a quick scan and the 2A99 code was back. I have yet to get a CEL/SES light though. Guess I will be cleaning the solenoids this weekend.
__________________
Regards,
SnyperX
Snyperx is offline   United_States
0
Reply With Quote
      03-23-2013, 05:18 PM   #6
Snyperx
Lieutenant
 
Drives: 2006 BMW 325i
Join Date: Oct 2011
Location: Stoughon, WI

Posts: 506
iTrader: (3)

Garage List
2006 BMW 325i  [0.00]
UPDATE 3: Cleaned solenoids and swapped location a couple weeks ago. Took a 320 mile round trip this weekend and am now getting a 2a98 and 2a99 shadow codes. Starting to wonder if I might have a bearing ledge issue. If so I am screwed since it will be impossible for me to come up with the money fix. Can someone advise?
__________________
Regards,
SnyperX

Last edited by Snyperx; 03-23-2013 at 11:12 PM.
Snyperx is offline   United_States
0
Reply With Quote
      03-24-2013, 12:34 AM   #7
Volasko
Major
 
Volasko's Avatar
 
Drives: 2006 E90 330i BSM 6MT ZSP
Join Date: Dec 2010
Location: Toronto

Posts: 1,082
iTrader: (2)

Garage List
I think the solenoids can go bad not matter how well you clean them out. After a few cleanings and swapping I couldn't get rid of the 2A98/99 code. Even thought I didn't have a CEL light, the code would would come up. Eventually I just bought a new VANOS solenoid and it is good as new.
Volasko is offline   Canada
0
Reply With Quote
      03-24-2013, 12:20 PM   #8
Snyperx
Lieutenant
 
Drives: 2006 BMW 325i
Join Date: Oct 2011
Location: Stoughon, WI

Posts: 506
iTrader: (3)

Garage List
2006 BMW 325i  [0.00]
Quote:
Originally Posted by Volasko View Post
I think the solenoids can go bad not matter how well you clean them out. After a few cleanings and swapping I couldn't get rid of the 2A98/99 code. Even thought I didn't have a CEL light, the code would would come up. Eventually I just bought a new VANOS solenoid and it is good as new.
Well I hope $220 in new solenoids will fix the issue. I hope I am not just throwing money at my car. I did send an email to Bav Auto and a Bentley Publishers to try and get additional input before I order the solenoids.
__________________
Regards,
SnyperX

Last edited by Snyperx; 03-25-2013 at 10:23 AM.
Snyperx is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:12 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST