E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY - Replacing Camshaft VANOS Solenoid



Reply
 
Thread Tools Search this Thread
      10-11-2012, 08:02 PM   #133
gzim335
Captain
gzim335's Avatar
Montenegro
17
Rep
691
Posts

Drives: 07 e90n54-08 zx10r-lci328ix
Join Date: Feb 2011
Location: staten island ny

iTrader: (4)

Garage List
2007/1 e90 335i  [1.00]
Quote:
Originally Posted by GoRomeo
I swapped/cleanned my vanos a few weeks ago along with an injector cleaner (Chevron) fill and my car's idle is very smooth now. Not sure if was due to the vanos swap or the injector cleaning...either way I am happy with results. Next is task is changing spark plugs.
I also had occasional limp mode on my 335i and it was faulty intake solenoid.I took it out n cleaned it and switched positions with the exhaust solenoid and limp mode was occurring more often than before cleaning like almost every wot.
bought new solenoid n never had a problem again.for some people the cleaning/swapping works but not for my car
__________________
2007/1 e90 335i jet black

jb4 g5 iso/race flash--rb turbos/rb pcv--bms occ--dci/scoops--cpe dp's corsa race full system--cpe ic--er cp/hks bov--trunk mount meth cm7/cm10--inline lpfp--kw v2/stoptech bbk f&r--m3 bits f&r,m3 fsb,wavetrack lsd--f14s nitto invo--lci conversion
Appreciate 0
      10-18-2012, 10:44 PM   #134
daMau
Second Lieutenant
daMau's Avatar
17
Rep
237
Posts

Drives: F80 M3
Join Date: Dec 2010
Location: Minneapolis, MN

iTrader: (0)

Very helpful! Was throwing an exhaust limp code occassionally after running the car hard in 3-4th gears. Cleaned and swapped the noids, and even after trying to trigger them, the limp codes have stopped.
Appreciate 0
      10-21-2012, 11:46 AM   #135
Volasko
Lieutenant Colonel
Volasko's Avatar
Canada
103
Rep
1,607
Posts

Drives: 2006 E90 330i BSM 6MT ZSP
Join Date: Dec 2010
Location: Toronto

iTrader: (2)

Garage List
I just finished swapping and cleaning my solenoids out today and thanks to this thread I fixed my check engine light! My error codes were as follows:

2A98: NOT present crankshaft-inlet camshaft, reference
2A82: NOT present VANOS intake (Sticky/jammed vanos code)

The car is now running like it should and I am back to being a happy camper!! Originally it wasn't pulling as hard and I was getting inconsistent idling.

See my original thread in the N52 engine section:
http://www.e90post.com/forums/showthread.php?t=755010
Appreciate 0
      11-06-2012, 07:02 PM   #136
sparkyblue
Captain
sparkyblue's Avatar
United_States
18
Rep
692
Posts

Drives: E82 135i
Join Date: Jan 2011
Location: USA

iTrader: (7)

Garage List
2008 BMW 135i  [0.00]
Thanks for the DIY! I threw the code a few weeks back and have been meaning to take care of it.

I used MAF cleaner, and followed your guide. Did the bottom one first, then the top one. Not sure if its placebo but the car seems to pull harder.
Appreciate 0
      11-15-2012, 05:29 PM   #137
martyp
Canada Eh!
Canada
6
Rep
222
Posts

Drives: 2012 F30
Join Date: Feb 2008
Location: Moncton, NB, Canada

iTrader: (1)

I took my solenoids out and cleaned them but it seems like the o-ring is preventing them from going back in far enough. There is still a 1/4 inch gap. Anyone experience this?
Appreciate 0
      11-15-2012, 05:32 PM   #138
GoRomeo
Colonel
GoRomeo's Avatar
42
Rep
2,599
Posts

Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Use some force. push as you turn sideways thats all. I did this a couple of months ago.
Appreciate 0
      01-12-2013, 03:57 PM   #139
MetzgerMeister
New Member
0
Rep
8
Posts

Drives: 335i
Join Date: Aug 2012
Location: Ireland

iTrader: (0)

I did this today. It took longer to get off the engine cover, cowl etc. as I had never done that before! Although the engine cover doesn't need to come off, it gives you loads more room to work with it off.

Tip: Use cable ties to hold the pipes up and out of your way
Tip: The O-rings on mine didn't come out with the solenoid. Make sure that if this happens you, remove them from the seal before trying to put in the new solenoid.
Tip: Use fresh engine oil to lube new O-rings to make it easier to pop them back in.

Thank you OP for this DIY as it helped me a lot!
Appreciate 0
      02-22-2013, 11:27 AM   #140
Snyperx
Lieutenant
United_States
35
Rep
514
Posts

Drives: 2006 325i (SOLD)
Join Date: Oct 2011
Location: Stoughon, WI

iTrader: (3)

Garage List
2006 BMW 325i  [0.00]
So I found a 2a99 code this morning only because I decided to scan my car. It is the only code being stored. No limp or CEL lights. Plan on cleaning the solenoids using this DIY. Should their be anything else I need to be looking at?
__________________
Regards,
SnyperX
Appreciate 0
      03-10-2013, 09:02 PM   #141
chris097
Registered
0
Rep
1
Posts

Drives: 2007 530xi TiAg Steptronic
Join Date: Jan 2013
Location: Reston, VA, USA

iTrader: (0)

Thank You for this DIY- I had a P1554 generic OBD-ii code and by taking the 30 minutes to pull my VANOS solenoids and clean them I went from 22MPG to over 29MPG Highway in my N52 Powered E60.
I used brake clean and canned air to clean out the varnish that had built up over the 73,000 miles this car has on the clock.
Appreciate 0
      03-19-2013, 12:44 PM   #142
Greatdane84
Leeeroy Jankins
Greatdane84's Avatar
United_States
12
Rep
417
Posts

Drives: 335i e90 LCI
Join Date: Jan 2013
Location: SW Florida

iTrader: (1)

Garage List
2009 335i  [5.00]
So what's the consensus on a n54... Do I need to remove the cowling and engine cover to do this or can I get away with just removing the snorkel?
__________________
e90 LCI w/ -= VRSF 7" FMIC =-
-= Cobb: Stg1 +FMIC Aggressive ST =-
Last Install: BMS DCI + Caliper/Drum Paint

"If you're not 1st, you're last" -Ricky Bobby
Appreciate 0
      03-19-2013, 01:24 PM   #143
DarkNemesis
Major
Canada
45
Rep
1,269
Posts

Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Quote:
Originally Posted by Greatdane84
So what's the consensus on a n54... Do I need to remove the cowling and engine cover to do this or can I get away with just removing the snorkel?
Greatdane, I have never done plugs before in my life or Vanos Solenoids.

I just did them on Saturday, my plugs and Vanos Solenoids.
Scale of 1-10.
I give it a 3, max 4.

I used the follow videos on you tube.
Look them up:
AskCOBB Episode 2 - BMW Misfire Diagnosis and Repair

And

BMW Vanos Solenoid Replacement Intake and Exhaust N51, N52, N52K, N54 Faults 2A87 2A82 2A9A 2A98

My notes:
For the vanos, take the cover off only helps and just gets it out if the way.
When pushing the new Solenoids in, requires more force to sit flush.
The new o ring on the solenoid, I just used some of my engine oil to lubricate it.
Put a towel under the solenoid before removing to prevent oil from landing on the belts and what not.
Engine must be cold, like over night.
When you lose the solenoid bolts, then use your hands so there is no chance of the falling.

If you have the proper tools.
Should take you 10 min to get the cover off, if that.

I got the Solenoids from BMW dealer on eBay.
I even called them to verify that they were new and oem, factory sealed.

Hope this helps.
DN
__________________
Bash Shah
Sutton Premier Realty
Appreciate 0
      03-24-2013, 02:12 AM   #144
Greatdane84
Leeeroy Jankins
Greatdane84's Avatar
United_States
12
Rep
417
Posts

Drives: 335i e90 LCI
Join Date: Jan 2013
Location: SW Florida

iTrader: (1)

Garage List
2009 335i  [5.00]
Thanks OP for this guide and everyone's experience & suggestions on installing!

Now I can do a proper WOT log! Looks like it was good practice taking engine cover off since ill be doing that for a spark plug.

NOTES:
For me engine cover came completely off, and needed to, for space. All about having the right tools. I completely replaced the solenoids and new orings came with them. I will be keeping the old ones and cleaning up to add to the parts collection.

Took pics to create my own guide
__________________
e90 LCI w/ -= VRSF 7" FMIC =-
-= Cobb: Stg1 +FMIC Aggressive ST =-
Last Install: BMS DCI + Caliper/Drum Paint

"If you're not 1st, you're last" -Ricky Bobby
Appreciate 0
      03-29-2013, 06:51 PM   #145
chinna_n
Enlisted Member
2
Rep
47
Posts

Drives: 2007 BMW 328i Auto
Join Date: Jan 2013
Location: Bellevue, WA

iTrader: (0)

I have rough idle (no misfires, no codes) both in park, neutral and drive. Idle RPM is around 660. I was wondering if cleaning vano solenoids help in anyways.?
Appreciate 0
      03-29-2013, 07:18 PM   #146
DarkNemesis
Major
Canada
45
Rep
1,269
Posts

Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Quote:
Originally Posted by chinna_n
I have rough idle (no misfires, no codes) both in park, neutral and drive. Idle RPM is around 660. I was wondering if cleaning vano solenoids help in anyways.?
How many km do you have?
And what e90 do you have?
Year, model, milage?

Ps: I did my spark plugs, coils, and Solenoids. No more rough idle, and a walnut blast....now better responsive ride.
Like new.
__________________
Bash Shah
Sutton Premier Realty
Appreciate 0
      03-31-2013, 07:58 AM   #147
martyp
Canada Eh!
Canada
6
Rep
222
Posts

Drives: 2012 F30
Join Date: Feb 2008
Location: Moncton, NB, Canada

iTrader: (1)

Quote:
Originally Posted by chinna_n View Post
I have rough idle (no misfires, no codes) both in park, neutral and drive. Idle RPM is around 660. I was wondering if cleaning vano solenoids help in anyways.?
I would start with vanos cleaning, then try to find out if you have a bad coil.
Appreciate 0
      03-31-2013, 09:47 AM   #148
chinna_n
Enlisted Member
2
Rep
47
Posts

Drives: 2007 BMW 328i Auto
Join Date: Jan 2013
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by DarkNemesis View Post
How many km do you have?
And what e90 do you have?
Year, model, milage?

Ps: I did my spark plugs, coils, and Solenoids. No more rough idle, and a walnut blast....now better responsive ride.
Like new.
I have 2007 -328i with N52k engine with 95k miles. Yesterday I cleaned and swapped solenoids, now the idle is settling at 730RPM.

Not sure why idle changed after swapping soleniods, any idea?

Thanks
Appreciate 0
      04-01-2013, 01:53 AM   #149
DarkNemesis
Major
Canada
45
Rep
1,269
Posts

Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Chinna. When did you replace your coils or spark plugs last?

I bought mine from eBay seller: germanautosupply

His coils were dated 12-11-15
The latest.
Plugs were best priced for a full set.

Not sure what regular idle should be on a n52, but seems slightly high.
Should be 600ish.
Could be wrong.

If your coils or plugs have never been changed, then that's where I would start. 95k miles is very high.

Check you coolant level.

Also, look on eBay for a BMW dealer selling these Solenoids for 109 each.
I replaced both of mine, but it didn't do much. Have had any solenoid errors at all ever?

Also, clean your injectors.
How?
eBay again look for BG 44k.
Buy 2 cans. Product number 208.
This should be written on each can.

I put 1 in 1 full tank.
Then when tank was nearly empty I put 1 more in the next tank. Just to be sure injectors got really clean.
Strongly recommend this.

Also download Bmwlogger.
Reset all you DME.
Follow the directions after DME resetting. The instruction on a sticky thread under coding section.
Keep in mind, it will not log, but you can reset dme adaptions.

95k mikes is a lot,
What oil are you using?

DN
__________________
Bash Shah
Sutton Premier Realty
Appreciate 0
      04-02-2013, 01:38 AM   #150
chinna_n
Enlisted Member
2
Rep
47
Posts

Drives: 2007 BMW 328i Auto
Join Date: Jan 2013
Location: Bellevue, WA

iTrader: (0)

Things I tried

Quote:
Originally Posted by DarkNemesis View Post
Chinna. When did you replace your coils or spark plugs last?

I bought mine from eBay seller: germanautosupply

His coils were dated 12-11-15
The latest.
Plugs were best priced for a full set.

Not sure what regular idle should be on a n52, but seems slightly high.
Should be 600ish.
Could be wrong.

If your coils or plugs have never been changed, then that's where I would start. 95k miles is very high.

Check you coolant level.

Also, look on eBay for a BMW dealer selling these Solenoids for 109 each.
I replaced both of mine, but it didn't do much. Have had any solenoid errors at all ever?

Also, clean your injectors.
How?
eBay again look for BG 44k.
Buy 2 cans. Product number 208.
This should be written on each can.

I put 1 in 1 full tank.
Then when tank was nearly empty I put 1 more in the next tank. Just to be sure injectors got really clean.
Strongly recommend this.

Also download Bmwlogger.
Reset all you DME.
Follow the directions after DME resetting. The instruction on a sticky thread under coding section.
Keep in mind, it will not log, but you can reset dme adaptions.

95k mikes is a lot,
What oil are you using?

DN
Thanks for detailed reply. Really appreciate that.

Spark plugs: Changed couple of weeks ago with NGK Laser iridium (same as OEM). One twist to that is, one of the plug is defective(cold start misfire). Old plugs are still in pretty good shape, so replaced that with old one, and now misfire is gone.

Coils: I have not changed any coils. But when I checked the coils, it seems some of coils are newer(inside the coil which connect to plug is different. Probably has been replaced previously. BMW folks says it is unusual for coils to cause rough idle(Except if it has misfire which can be detected).

Coolant: I just replaced thermostat because I have thermostat heater open circuit error. During this replacement, I drained coolant almost completely (2 gallons) and refilled with BMW coolant+distilled water. So coolant is not an issue.

Idle speed: Here are some changes from yesterday. After cleaning and swapping VANOS solenoid, the idle speed went up to 730. Never had any VANOS solenoids errors, not even in history. But by today evening it settle back to 660RPM again, back to original idle speed.
Like you said, It seems idle should be around 600ish. I felt now engine is somewhat smoother, but it may be simply placebo effect. When compared to my friends 2006 325i, it is rougher.

Injector cleaning: I ran several bottles of fuel system cleaner, in this order sofar.(pretty much back to back).
1. 1 bottle of Techron Fuel injector cleaner
2. 1 bottle of Techron fuel system cleaner
3. 1 bottle of Techron Fuel injector cleaner
4. 1 bottle of Redline fuel system cleaner

But no change in rough idle. Now I got GAMUT with REGANE. I will try that tomorrow.

Meanwhile I also got MAF cleaner which I have not used yet. so MAF is next in line...

Also, please see the carbon on the pistons(via spark plug holes). Not sure if this is normal or not. How was yours when you changed sparkplugs?

Thanks

Last edited by chinna_n; 04-02-2013 at 03:47 PM.
Appreciate 0
      04-02-2013, 12:04 PM   #151
DarkNemesis
Major
Canada
45
Rep
1,269
Posts

Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Run 1 tank of BG 44k
I didn't find a single negative review.

This is the ultimate stuff.
Highly recommend it.

Glad to see your idle settling.
This could have been an adaptation take place.

DN
__________________
Bash Shah
Sutton Premier Realty
Appreciate 0
      04-16-2013, 03:07 PM   #152
shata
Captain
shata's Avatar
United_States
16
Rep
824
Posts

Drives: 06 330i 6MT-ZPP/ZSP/ZCW
Join Date: Apr 2012
Location: VB, VA

iTrader: (0)

I doubt anyone will read this but I have theory. Some of that oil gunk stuff on solenoids is caused by long change intervals like ones recommended by bmw. Keep it between 6-7.5k miles and you wont have this happen. I pulled mine today just to see how they look for first time. Clean as a whistle...Just saying good oil change interval as per mike millers bmw maint guide will go long way.
__________________
/// OEM ///
Appreciate 0
      04-16-2013, 07:30 PM   #153
bchuong58
Enlisted Member
United_States
1
Rep
45
Posts

Drives: Black E90
Join Date: May 2011
Location: San Jose, ca

iTrader: (0)

Quote:
Originally Posted by ENINTY View Post
Just to catch up on this, I really think it is better to just remove them, clean them with electronics cleaner and shop air, then reinstall them in the opposite locations. I really can't see these parts being subject to wear to the point where they become defective; I think they just get dirty. I cleaned and swapped mine over 5,000 miles ago and have not had the codes reocurr. If it doesn't work, then go get the new parts and replace. The work is so easy it's worth trying the cleaning procedure first before spending the $210 for new parts. My car has 149K on it by the way. Just my 2 cents.
How are the Vanos doing so far?
Appreciate 0
      04-16-2013, 10:08 PM   #154
Efthreeoh
Major General
United_States
699
Rep
6,482
Posts

Drives: E90 & Z4 Coupe
Join Date: May 2012
Location: MARLAND

iTrader: (0)

Quote:
Originally Posted by bchuong58 View Post
How are the Vanos doing so far?
I've been cleaning and swapping mine every 50,000 miles and have not had a problem since. I think the clean and swap works great.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:52 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST