E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Possible rough idle question - N54



Reply
 
Thread Tools Search this Thread
      03-13-2013, 10:46 AM   #1
Blubaron79
Colonel
Blubaron79's Avatar
United_States
99
Rep
2,673
Posts

Drives: '15 335 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

Possible rough idle question - N54

I am right at 89k miles. Had spark plugs changed for 2nd time 800 miles ago per maint. requirement. Change my oil every 7,500 miles, and had my intakes cleaned about 17k miles ago. (I also have the PPK1 softwate installed) I have noticed when my car is idling when warm or cold there is almost a slight 'shake' maybe once a minute or less, however the RPMs don't dip nor does the exauhst sound like the car is missing.

Could this be due to the recent spark plug change? I know the N54 never runs 100% smooth, but curious if anyone has any ideas what this may be. My dealer will never really look at anything unless it throws a code, and I have no check engine light. Any input would be appreciated!
__________________
'15 335 XDrive: Glacier Silver, MSport, 19's, every option (except ACC and DAP), MPPK, MPE, black grille, splitter, side sills, CF Spoiler, clear bra.
Previous: '14 435 F32 xDrive; '09 335 E92 xDrive
Appreciate 0
      03-13-2013, 11:18 AM   #2
slingxshot
Second Lieutenant
17
Rep
205
Posts

Drives: BMW 2014 528i xDrive
Join Date: Dec 2011
Location: Long island

iTrader: (0)

My car has a slight different situation. With temps below 40 degrees (no sun), the car shakes after a 1 mile drive at IDLE. The RPM jumps back and forth.. sometimes violently. Recently I had engine light come in and I brought the car in, they replaced 4 coils and 4 spark plugs. I thought that would fix the car. The only thing it did was make the driver at highway speeds more sensitive. It is getting warm and I am lazy and I don't want to fight the dealer since there are no error codes. I might just wait till next winter till it gets into 20's and bring the car to the dealer.
Appreciate 0
      03-13-2013, 01:43 PM   #3
EricP3
Private First Class
1
Rep
175
Posts

Drives: 335i coupe
Join Date: Aug 2012
Location: Cincinnati

iTrader: (6)

I have been told that this is just normal for N54 but I would like to see some more responses on here also. My 335i definitely has a rough idle with the car shaking at stops. It is a little but annoying and just causes me to worry that something is wrong more than anything.
Appreciate 0
      03-13-2013, 01:45 PM   #4
Blubaron79
Colonel
Blubaron79's Avatar
United_States
99
Rep
2,673
Posts

Drives: '15 335 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

Quote:
Originally Posted by EricP3 View Post
I have been told that this is just normal for N54 but I would like to see some more responses on here also. My 335i definitely has a rough idle with the car shaking at stops. It is a little but annoying and just causes me to worry that something is wrong more than anything.
Yea. I hear it is normal too. The car still runs wonderful for 89k miles and consumes little to no oil at all. I can't beleive how well this car has held up. Minus a fuel pump and injectors needing replaced.
__________________
'15 335 XDrive: Glacier Silver, MSport, 19's, every option (except ACC and DAP), MPPK, MPE, black grille, splitter, side sills, CF Spoiler, clear bra.
Previous: '14 435 F32 xDrive; '09 335 E92 xDrive
Appreciate 0
      03-14-2013, 01:52 AM   #5
fazi13
Private
United_States
0
Rep
80
Posts

Drives: 2008 335i Manual
Join Date: Feb 2013
Location: SF Bay Area

iTrader: (0)

Garage List
2008 BMW 335i  [0.00]
maybe the bolts holding the engine into place have come loose? that could cause a bit of a rattling noise.. not sure about when the RPMs violently change
Appreciate 0
      03-15-2013, 03:11 PM   #6
Blubaron79
Colonel
Blubaron79's Avatar
United_States
99
Rep
2,673
Posts

Drives: '15 335 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

Fresh tank of gas and it went away. Maybe it was fuel?
__________________
'15 335 XDrive: Glacier Silver, MSport, 19's, every option (except ACC and DAP), MPPK, MPE, black grille, splitter, side sills, CF Spoiler, clear bra.
Previous: '14 435 F32 xDrive; '09 335 E92 xDrive
Appreciate 0
      03-17-2013, 11:10 PM   #7
mxa121
Captain
mxa121's Avatar
64
Rep
845
Posts

Drives: M
Join Date: Apr 2012
Location: Atlanta, United States

iTrader: (1)

I mentioned the car ran really rough (one instance where it drove like crap) to the dealer at last service and they immediately thought of fuel. I have switched to QT gas so we will see if the idle clears up.

My idle symptoms are exactly like others here. It has a rough spot once a minute or so that results in a bit of a shake. I feel like it is worse since they replaced my plugs and oil, but I do not really know.
I saw another post that mentioned possible walnut blasting to rid this, anyone else do this with good results?

It is not too bad and doesn't bother me too much, I am just concerned like the rest.
__________________
Jerez Schwarz M3 Coupe | Megan Racing Exhaust | Test Pipes | Eibach Pro Kit | Yokohama AD-08R | BPM Tune | Alufelgen SF-71 | Euro LCIs |
Appreciate 0
      03-17-2013, 11:30 PM   #8
Blubaron79
Colonel
Blubaron79's Avatar
United_States
99
Rep
2,673
Posts

Drives: '15 335 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

Quote:
Originally Posted by mxa121
I mentioned the car ran really rough (one instance where it drove like crap) to the dealer at last service and they immediately thought of fuel. I have switched to QT gas so we will see if the idle clears up.

My idle symptoms are exactly like others here. It has a rough spot once a minute or so that results in a bit of a shake. I feel like it is worse since they replaced my plugs and oil, but I do not really know.
I saw another post that mentioned possible walnut blasting to rid this, anyone else do this with good results?

It is not too bad and doesn't bother me too much, I am just concerned like the rest.
I just had mine walnut blasted less than a year ago. I have only bed running Shell and Exxon fuels since then too.
__________________
'15 335 XDrive: Glacier Silver, MSport, 19's, every option (except ACC and DAP), MPPK, MPE, black grille, splitter, side sills, CF Spoiler, clear bra.
Previous: '14 435 F32 xDrive; '09 335 E92 xDrive
Appreciate 0
      04-05-2013, 09:13 AM   #9
AndyR83
Major
AndyR83's Avatar
17
Rep
1,025
Posts

Drives: E92 335i FBO
Join Date: Oct 2011
Location: PA

iTrader: (5)

I am trying to figure this problem out at the moment. It feels like my car is misfiring. At idle, there is a bit of sputter and the RPM's dip. you can feel the shake, to the point that passengers that aren't normally in the car have asked about it.

I had walnut blasting done at Helix last month (they were awesome by the way!) I had read threads on here leading me to believe that would fix it, but there was no change in the problem. I am going to get spark plugs done next week, but this thread also leads me to wonder if that will fix it. What else could it be?

I can't accept that this is "normal" because it just started a few weeks ago. I've had the car for a year and a half and it was never like this before.
Appreciate 0
      04-05-2013, 12:44 PM   #10
DarkNemesis
Major
Canada
30
Rep
1,121
Posts

Drives: 2007 BMW 335i Sedan AT, US Car
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

Blubarron79.
In your post, seems like the car is well maintained.
I had a shake also at idle.
Did the following:
1. Walnut blast. You said you cleaned your 17k ago,..
2. Change out all plugs.
3. Both vanos Solenoids; this didn't much that I could notice... I did it, cause it threw a code for the intake..,.but only once, never repeated for 2 month before I changed them out.
4. Changed the plugs, no major change, but changed all coils, and wow....car is much smoother.
Still a slight shake, but way better than before, car drives like new.
Got the coils and plugs from eBay user: germanpartsonly
His coils were dated the latest, that's what I wanted.

6. Intake and cabin filter along with oil change.

7. This is the first thing I did. 2 tanks back to back with BG44k.
Just to make sure injectors are clean. This stuff is the best.

Try changing all coils, make sure they are not different from each other. Mine 5 were something nobody seen before, but still oem Bosche.

Regards,
DN
Appreciate 0
      04-05-2013, 01:46 PM   #11
MCoupeInsanity
Lieutenant
MCoupeInsanity's Avatar
7
Rep
503
Posts

Drives: E90 335i | F30 328i
Join Date: Oct 2011
Location: Los Angeles, CA

iTrader: (0)

I just had all the coil packs, injectors and spark plugs replaced for a rough idle on my N54. Cleared it up. http://www.e90post.com/forums/showth...2#post13768492
__________________
Appreciate 0
      04-06-2013, 02:10 PM   #12
Blubaron79
Colonel
Blubaron79's Avatar
United_States
99
Rep
2,673
Posts

Drives: '15 335 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

Quote:
Originally Posted by DarkNemesis View Post
Blubarron79.
In your post, seems like the car is well maintained.
I had a shake also at idle.
Did the following:
1. Walnut blast. You said you cleaned your 17k ago,..
2. Change out all plugs.
3. Both vanos Solenoids; this didn't much that I could notice... I did it, cause it threw a code for the intake..,.but only once, never repeated for 2 month before I changed them out.
4. Changed the plugs, no major change, but changed all coils, and wow....car is much smoother.
Still a slight shake, but way better than before, car drives like new.
Got the coils and plugs from eBay user: germanpartsonly
His coils were dated the latest, that's what I wanted.

6. Intake and cabin filter along with oil change.

7. This is the first thing I did. 2 tanks back to back with BG44k.
Just to make sure injectors are clean. This stuff is the best.

Try changing all coils, make sure they are not different from each other. Mine 5 were something nobody seen before, but still oem Bosche.

Regards,
DN
Thank for the help. Weirdly enough the shake went away... I really think I went through a tank of bad fuel. The car seems like it is pulling harder than ever now too. I think I was just getting bad gas from a shady Shell station in the hood..
__________________
'15 335 XDrive: Glacier Silver, MSport, 19's, every option (except ACC and DAP), MPPK, MPE, black grille, splitter, side sills, CF Spoiler, clear bra.
Previous: '14 435 F32 xDrive; '09 335 E92 xDrive
Appreciate 0
      04-06-2013, 02:44 PM   #13
Sadiebuc
New Member
0
Rep
5
Posts

Drives: 2006 330i
Join Date: Apr 2013
Location: FL

iTrader: (0)

Sounds like a Coil problem.
Appreciate 0
      04-07-2013, 12:18 AM   #14
Bimmertech113
Private
0
Rep
68
Posts

Drives: None
Join Date: Mar 2013
Location: TN

iTrader: (0)

Carb clean usually helps with this issue. I'm in the Nashville area and can take care of it for anyone that doesn't want to pay dealer prices. Just pm or email me
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:39 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST