E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Urgent help needed, extreme power loss



Reply
 
Thread Tools Search this Thread
      04-08-2013, 07:52 AM   #1
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

Urgent help needed, extreme power loss

I have a e92 335d and each time im on the moterway, after going over 50mph the car suddenly gets this dashlight (shown below) and then losses all its power.

This problem has left me stuck on the moterway 3 times, i have to pull over an switch the car off and then its ok again.

Im going to get it diagnoses but could anyone before hand give me clues on what it might be so that i know abit about it before the mechanic feeds me a bunch of stories.
Attached Images
 
Appreciate 0
      04-08-2013, 08:09 AM   #2
nicktyler
Major
United Kingdom
13
Rep
1,185
Posts

 
Drives: 335i (sadly gone)
Join Date: Jan 2012
Location: Essex

iTrader: (3)

Garage List
Sounds like it vould be something to do with low boost like boost flap not working properly or a leak causing the limp mode.

Have you had it mapped? If so it could be sensing too much torque or something. Not sure if that can happen though.

Try reading here:

http://www.e90post.com/forums/showthread.php?t=791239
Appreciate 0
      04-08-2013, 08:35 AM   #3
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

Hello nick, iv never had it mapped, iv had a
diagnostics b4 which should glowplugs, iv also changed all the vacuum hoses to new ones and the divertor valve, and still this problem continues.
The cars speed on normal driving is also not as fast as it use to be
Appreciate 0
      04-08-2013, 09:26 AM   #4
nicktyler
Major
United Kingdom
13
Rep
1,185
Posts

 
Drives: 335i (sadly gone)
Join Date: Jan 2012
Location: Essex

iTrader: (3)

Garage List
It could be many things I would think. get it to a garage you trust and have them pull the codes and look at it.

Does sound like a turbo/boost issue more than the transmission though (which all could throw that warning light)
Appreciate 0
      04-08-2013, 11:07 AM   #5
djgandy
Major
12
Rep
1,096
Posts

 
Drives: E92 335i MT
Join Date: Aug 2012
Location: London

iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
Quote:
Originally Posted by nicktyler View Post
Sounds like it vould be something to do with low boost like boost flap not working properly or a leak causing the limp mode.

Have you had it mapped? If so it could be sensing too much torque or something. Not sure if that can happen though.

Try reading here:

http://www.e90post.com/forums/showthread.php?t=791239
Lol the OP made that thread
Appreciate 0
      04-08-2013, 11:08 AM   #6
nicktyler
Major
United Kingdom
13
Rep
1,185
Posts

 
Drives: 335i (sadly gone)
Join Date: Jan 2012
Location: Essex

iTrader: (3)

Garage List
Oh yeah! Shows how urgent it is...
Appreciate 0
      04-09-2013, 04:05 PM   #7
rsmallwo
Captain
rsmallwo's Avatar
14
Rep
923
Posts

 
Drives: 335d
Join Date: Jan 2010
Location: hull

iTrader: (0)

car going into "limp mode" when it encounters a gearbox issue. limp mode cuts lots of power to preserve components etc.

If its auto tranny issues i'd be bricking it. Bit naughty but.....time to part ex?

Hope it turns out for the best.
Appreciate 0
      04-10-2013, 03:37 AM   #8
335DEE
Captain
335DEE's Avatar
England
7
Rep
734
Posts

 
Drives: 335d
Join Date: Feb 2009
Location: England

iTrader: (1)

what year is it
Appreciate 0
      04-10-2013, 04:02 AM   #9
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
Just take it to a good independant BMW place and get it checked out.

I'd recommend BW Chiptune of course
__________________
Previously: 2003 Peugeot 206 1.6 8v | 2006 E90 320d M-Sport, 19" BBS CH, Full Ice-cold JL audio install, August 2010 Total BMW 6 page feature car. | 2003 Nissan 350Z GT Coupe 286BHP
Now:2010 E92 LCI 335d M-Sport
Appreciate 0
      04-10-2013, 08:22 AM   #10
nicktyler
Major
United Kingdom
13
Rep
1,185
Posts

 
Drives: 335i (sadly gone)
Join Date: Jan 2012
Location: Essex

iTrader: (3)

Garage List
Or if your on the East side of London take it to Prestige Veichle Repairs
Appreciate 0
      04-10-2013, 12:13 PM   #11
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

Update guys on what my mechanic has told me after having the car for a day at his place, hes said his checked all over an there is something (cant remember what) which is broken and all oil is gushing out, rather then going to the gearbox, so he said that needs to either be repaired or changed.
Appreciate 0
      04-11-2013, 11:20 AM   #12
nicktyler
Major
United Kingdom
13
Rep
1,185
Posts

 
Drives: 335i (sadly gone)
Join Date: Jan 2012
Location: Essex

iTrader: (3)

Garage List
What? Gushing out? so you have oil all over your drive and under the car when you park or stop then?
Appreciate 0
      04-13-2013, 02:40 PM   #13
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

The car has been sent by my mechanic, to where you recommended nick, Prestige Vehicle Repairs to get a 2nd opinion on the matter

Yeh nick, apparently there is a fault with the amount of oil not going to the gearbox (or pressure not going to the gearbox?) didnt understand too much.

And the problem it was having on the moterway is the car would get stuck on the 4th gear an not change after that, they said they will inform me this monday.
Appreciate 0
      04-13-2013, 02:45 PM   #14
335DEE
Captain
335DEE's Avatar
England
7
Rep
734
Posts

 
Drives: 335d
Join Date: Feb 2009
Location: England

iTrader: (1)

Hydraulic pressure pump gone, 3k to get your box rebuilt.
Unless you are lucky enough to have a post mar 2007 build car where you can maybe get hold of a scrap box. Less than March 2007 your only chance is a rebuild as pre March scrap boxes are beyond impossible to get hold of and are incompatible with post mar 07 boxes. The very best of luck fella
Appreciate 0
      04-13-2013, 02:57 PM   #15
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

HUH???
Appreciate 0
      04-13-2013, 03:02 PM   #16
335DEE
Captain
335DEE's Avatar
England
7
Rep
734
Posts

 
Drives: 335d
Join Date: Feb 2009
Location: England

iTrader: (1)

If your problem is the hydraulic pressure pump as your mech has kinda pointed too , the above info will bypass a lot of shit and stress as I have been through this myself. Hence asking what year your car was earlier on this week (u didn't answer)
Appreciate 0
      04-13-2013, 04:04 PM   #17
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

Oh sorry, it is a 2008 (08) 335d
Appreciate 0
      04-15-2013, 08:59 AM   #18
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

Ok an update on my car is i rang my mechanic to ask what is going on as its still at prestige moters, an he said there working on it an i asked a rough idea on what the price will be (bcause of the earlier comment suggesting around 3k which had me shitting my pants) an the mechanic said around 300-500 :S which was a some what relief, he said the sensors needed changing
so im alittle confused as each time the story is changing
Appreciate 0
      04-15-2013, 09:02 AM   #19
335DEE
Captain
335DEE's Avatar
England
7
Rep
734
Posts

 
Drives: 335d
Join Date: Feb 2009
Location: England

iTrader: (1)

fingers crossed for you fella !
Appreciate 0
      04-15-2013, 12:56 PM   #20
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

Thanks Timbo, he said the car will be ready to be picked up tomorow, so hopefully will learn more on what the exact problem was an post it on here
Appreciate 0
      04-16-2013, 03:37 PM   #21
mistikempire
Second Lieutenant
mistikempire's Avatar
United Kingdom
7
Rep
299
Posts

 
Drives: Bmw e92 335d
Join Date: Dec 2011
Location: London, UK

iTrader: (2)

PROBLEM SORTED! (Touch wood)
Got it back from the mechanic today, costed me 500, drove it on the moterway, went upto 130mph an no problem at all, didnt have no sudden power loss or any lights appearing on the dash.
The car also feels much responsive at normal speeds on the road.

I think next i am going to completly clean out the engine, give it a good service and i also want to get into the egr an give that a good clean.
If anyone has any links on diy guides on how to access the egr valve for the e92 please would you be so kind to post for me, i know its not easy as the manifold has to be removed.
Appreciate 0
      04-16-2013, 03:49 PM   #22
djgandy
Major
12
Rep
1,096
Posts

 
Drives: E92 335i MT
Join Date: Aug 2012
Location: London

iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
You got it fixed in Germany right?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:25 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST