E90Post
 


Evolve Automotive
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Cosmetic and Lighting Modifications (exterior/interior) > E93 LCI tails - issue with retrofit harness



Reply
 
Thread Tools Search this Thread
      09-13-2012, 11:15 PM   #1
zamba0321
Private First Class
 
zamba0321's Avatar
 
Drives: '09 BMW 328i convertible
Join Date: Nov 2009
Location: Sunnyvale, CA

Posts: 137
iTrader: (0)

E93 LCI tails - issue with retrofit harness

Howdy

I have an may 2009 builddate E93 and installed LCI tails with retrofit harness.
Drivers side works fully but passengers side nothing works, no lights at all.

When I look at the harness, it has a separate part number 2181308 drivers side and 2181307 passengers side.
But when I look which wire connects with what then both sides have identical connections (though using different colors) did I get a bad set ?

I can use any one on the drivers side and it works. See picture, what's wrong ?

Name:  cable.JPG
Views: 1691
Size:  777.9 KB-
__________________
09 328i Blue water E93 | M-Sport | Step | Prem | Nav | ipod | Lux H8 | BMS PBX | Remotekey+ | MFD scoops | LED turn signals and sidemarkers | MTEC Fogs | Black BMW performance grills | LCI Paddle shifters
zamba0321 is offline  
0
Reply With Quote
      09-15-2012, 11:46 AM   #2
zamba0321
Private First Class
 
zamba0321's Avatar
 
Drives: '09 BMW 328i convertible
Join Date: Nov 2009
Location: Sunnyvale, CA

Posts: 137
iTrader: (0)

can anyone check their wiring harness connections or take a picture of it.

I would like to know passengers tail light harness connections, like pin one on large connector goes to pin 4 on small one etc etc

thanks
__________________
09 328i Blue water E93 | M-Sport | Step | Prem | Nav | ipod | Lux H8 | BMS PBX | Remotekey+ | MFD scoops | LED turn signals and sidemarkers | MTEC Fogs | Black BMW performance grills | LCI Paddle shifters
zamba0321 is offline  
0
Reply With Quote
      09-15-2012, 04:47 PM   #3
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

Posts: 18,274
iTrader: (5)

Send a message via Yahoo to cn555ic
You need to re-arrange the wires on the passenger side. Also the trunk lights needs to be re wired also. Basically it has to mirror the drivers side.
__________________
917-939-4980 CODING E and F Series New York Area

cn555ic is offline   United_States
0
Reply With Quote
      09-15-2012, 04:54 PM   #4
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

Posts: 18,274
iTrader: (5)

Send a message via Yahoo to cn555ic
here is the wiring for passenger side...make sure you see the pins it suppose to connect to the original harnass on passenger side...from pins 1-6 and then re wire the lci harnass to the exact colors I just posted that way when it mates with the oem harnass the wiring is exactly as I posted below

After its wired correctly, you are going to need some coding done to the car to make the lci work correctly...You will have super fast blinking blinkers and possible a turn signal malfunction.
Attached Images
 
__________________
917-939-4980 CODING E and F Series New York Area

cn555ic is offline   United_States
0
Reply With Quote
      09-15-2012, 10:25 PM   #5
zamba0321
Private First Class
 
zamba0321's Avatar
 
Drives: '09 BMW 328i convertible
Join Date: Nov 2009
Location: Sunnyvale, CA

Posts: 137
iTrader: (0)

thanks yes I had to rewire the small light in the trunk, and that one now works.

It makes sense that it would be a mirror of the other side, mine currently is the same for passenger and driver.
Thanks for the info and I'll give it a shot

appreciate the time you took to write it down
__________________
09 328i Blue water E93 | M-Sport | Step | Prem | Nav | ipod | Lux H8 | BMS PBX | Remotekey+ | MFD scoops | LED turn signals and sidemarkers | MTEC Fogs | Black BMW performance grills | LCI Paddle shifters
zamba0321 is offline  
0
Reply With Quote
      09-17-2012, 11:34 PM   #6
zamba0321
Private First Class
 
zamba0321's Avatar
 
Drives: '09 BMW 328i convertible
Join Date: Nov 2009
Location: Sunnyvale, CA

Posts: 137
iTrader: (0)

just an update. So I had the drivers side mostly working, and the passengers side not at all. Then I mirrored the passengers side from the pinout from the drivers side. With your chart I noticed three wires were still not right, after correcting them on both sides I now have everything working. Still a mistory to me why two shipped sets of retrofit harnesses didn't work...

Anyways thanks for the help and happy LCI user here now.
__________________
09 328i Blue water E93 | M-Sport | Step | Prem | Nav | ipod | Lux H8 | BMS PBX | Remotekey+ | MFD scoops | LED turn signals and sidemarkers | MTEC Fogs | Black BMW performance grills | LCI Paddle shifters
zamba0321 is offline  
0
Reply With Quote
      11-10-2012, 02:12 AM   #7
unrealii
Second Lieutenant
 
Drives: '09 335 E93 6MT
Join Date: Mar 2011
Location: SoCal

Posts: 218
iTrader: (0)

Garage List
2009 BMW 335I  [5.00]
This thread has been super helpful.

I snapped off the cover of my connector and was able to pull all the pins out of the passenger harness. For reference above, I connected black with blue strip on pins 2 and 4, and purple and bluestrip on pin 3.

Working on driver's side then passenger side trunk.
unrealii is offline  
0
Reply With Quote
      11-14-2012, 08:29 PM   #8
moreno1
Lieutenant
 
moreno1's Avatar
 
Drives: BMW 335i E93
Join Date: May 2009
Location: Montreal

Posts: 581
iTrader: (13)

good to know...can't wait to get my set and install it!
Thanks cn555ic!
__________________
2009 335i E93 /// BSM /// Sport /// Premium /// Codings : bmwmtlcode@hotmail.com /// 313 Performance wheels /// M6 winter set /// 35% Tint /// Gloss Black Grills /// Painted reflectors /// Lux H8 V3 /// Interior LEDs /// JB4-DCI /// Combox & CIC Retrofit /// Aero lip & M3 side skirts ///
moreno1 is online now   Canada
0
Reply With Quote
      04-07-2013, 01:56 PM   #9
Puzon
Registered
 
Drives: E93
Join Date: May 2011
Location: PL

Posts: 2
iTrader: (0)

I see that you were using an adapter from the E92 coupe, not convertible

Is the adapter on the driver's side was ok, and the adapter on the passenger side had to replace only 2 pins or something else?
Puzon is offline   Poland
0
Reply With Quote
      04-17-2013, 09:24 PM   #10
3seriespower
New Member
 
3seriespower's Avatar
 
Drives: 2009 BMW 335I Coupe
Join Date: Apr 2013
Location: South Miami

Posts: 13
iTrader: (0)

wow, its very woth it, i just got the same problem on my LCI just got today, everything works fine except the bars, let me know work in moving the cables the way it supose to be.
thank you
3seriespower is offline   United_States
0
Reply With Quote
      01-01-2014, 08:01 AM   #11
E93MAC
Major
 
E93MAC's Avatar
 
Drives: E93 328i Convertible
Join Date: Feb 2012
Location: San Jose

Posts: 1,031
iTrader: (5)

Quote:
Originally Posted by 3seriespower
wow, its very woth it, i just got the same problem on my LCI just got today, everything works fine except the bars, let me know work in moving the cables the way it supose to be.
thank you
I moved my cables just the way the car cable had them and it worked flawlessly.

The problem I'm still having is to know the correct pin out on the passenger side for the big light.

I have tried the listed 1-6 pins in this thread, it didn't work. I have tried to lay them out the same as the pins coming from my car cable. Didn't work. My LCI tail lights are also the Euro version. Not sure if that makes a difference or not.

Can anyone assist?

Thanks!
__________________

################[Mac's '07 E93 328i]################
E93MAC is offline   United_States
0
Reply With Quote
      01-01-2014, 08:46 AM   #12
gaza01
Lieutenant Colonel
 
gaza01's Avatar
 
Drives: E92 335i
Join Date: Dec 2010
Location: London

Posts: 1,813
iTrader: (3)

The e93 lights are different in their wiring arrangements compared to the e92. And the conversion actually needs 4 harnesses as opposed to just 2 on the e92. The little lights on the boot need harnesses on the e93. Im telling you this from experience. You'll need to order a news set of harnesses from you dealer.
gaza01 is offline   United Kingdom
0
Reply With Quote
      01-01-2014, 10:48 AM   #13
Dark_Knight_335
Came to the N55 Darkside
 
Dark_Knight_335's Avatar
 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

Posts: 10,108
iTrader: (26)

I remember vaguely having this done on my 2009 328 coupe and each side needed an additional special conversion harness- beyond that I can't be very much more helpful - sorry.
Dark_Knight_335 is online now   United_States
0
Reply With Quote
      02-22-2014, 01:07 AM   #14
BigMacSmallFries
Second Lieutenant
 
Drives: '15 M3, '11 GT3 RS
Join Date: Aug 2010
Location: Toronto, Ontario

Posts: 245
iTrader: (1)

Quote:
Originally Posted by cn555ic View Post
here is the wiring for passenger side...make sure you see the pins it suppose to connect to the original harnass on passenger side...from pins 1-6 and then re wire the lci harnass to the exact colors I just posted that way when it mates with the oem harnass the wiring is exactly as I posted below

After its wired correctly, you are going to need some coding done to the car to make the lci work correctly...You will have super fast blinking blinkers and possible a turn signal malfunction.
Quote:
Originally Posted by zamba0321 View Post
just an update. So I had the drivers side mostly working, and the passengers side not at all. Then I mirrored the passengers side from the pinout from the drivers side. With your chart I noticed three wires were still not right, after correcting them on both sides I now have everything working. Still a mistory to me why two shipped sets of retrofit harnesses didn't work...

Anyways thanks for the help and happy LCI user here now.
Quote:
Originally Posted by unrealii View Post
This thread has been super helpful.

I snapped off the cover of my connector and was able to pull all the pins out of the passenger harness. For reference above, I connected black with blue strip on pins 2 and 4, and purple and bluestrip on pin 3.

Working on driver's side then passenger side trunk.
Quote:
Originally Posted by 3seriespower View Post
wow, its very woth it, i just got the same problem on my LCI just got today, everything works fine except the bars, let me know work in moving the cables the way it supose to be.
thank you
Quote:
Originally Posted by E93MAC View Post
I moved my cables just the way the car cable had them and it worked flawlessly.

The problem I'm still having is to know the correct pin out on the passenger side for the big light.

I have tried the listed 1-6 pins in this thread, it didn't work. I have tried to lay them out the same as the pins coming from my car cable. Didn't work. My LCI tail lights are also the Euro version. Not sure if that makes a difference or not.

Can anyone assist?

Thanks!


Hey guys,

I'm having this problem right now with the E93. The taillights are lighting up randomly. Is the photo of the sheet stating how to connect the colours right or not? It seems like it didn't work for everyone. Hoping to correct this tomorrow on my own.
BigMacSmallFries is offline  
0
Reply With Quote
      02-22-2014, 01:10 AM   #15
BigMacSmallFries
Second Lieutenant
 
Drives: '15 M3, '11 GT3 RS
Join Date: Aug 2010
Location: Toronto, Ontario

Posts: 245
iTrader: (1)

Quote:
Originally Posted by gaza01 View Post
The e93 lights are different in their wiring arrangements compared to the e92. And the conversion actually needs 4 harnesses as opposed to just 2 on the e92. The little lights on the boot need harnesses on the e93. Im telling you this from experience. You'll need to order a news set of harnesses from you dealer.
Do you know what the part number is for the four of them? Unfortunately I had the E92 harnesses sent to me.
BigMacSmallFries is offline  
0
Reply With Quote
      02-22-2014, 09:17 AM   #16
Modded328FTW
Private First Class
 
Drives: 328
Join Date: Jan 2013
Location: Canada

Posts: 110
iTrader: (0)

Quote:
Originally Posted by BigMacSmallFries View Post
Do you know what the part number is for the four of them? Unfortunately I had the E92 harnesses sent to me.
The P/N is
61122181311
Modded328FTW is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:54 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST