E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Can a failing hpfp have an effect on the lpfp?? Please help!



Reply
 
Thread Tools Search this Thread
      04-22-2013, 07:47 PM   #1
racerg35335
Private First Class
4
Rep
101
Posts

 
Drives: Space gray 335i coupe
Join Date: Feb 2012
Location: Greenwood, SC

iTrader: (0)

Can a failing hpfp have an effect on the lpfp?? Please help!

PLEASE HELP!! I have been having low lfp for some time now and codes associated with it. Supposed to be 72psi and has been getting worse over time. Now it basically sits at 32psi and lowers under WOT. I have basically replaced the entire low fuel pressure system. First I replaced the lpfp with the walbro 455 (yes I have run e85.. but only about 3 tanks of an e30 mix). Problem persisted but car ran fine and trims were in check but then the car went into limp due to low fuel pressure. I thought maybe it was the lfp sensor so I replaced that. Still the proplem persisted so I replaced the fuel pressure regulator/filter. Still no change. This is about to drive me crazy. I have replaced fuses as well just to be sure. Does anybody have any idea what else this could be. The low pressure system is all new. Could the hpfp or the injectors cause the lfp to be low if one of them are failing. Also according to logs. The car is not running lean and hfp is at target. Although I was not logging the few times the car threw the injector shutdown code and went into limp. Please help if you have any idea. I am out of warranty and really don't wanna be raped by a dealer but I am about to that point. Thanks for your time
__________________
Space Gray 6mt e92, coral red,Cobb tuned, custom e30 map, bms DCI, ETS FMIC, walbro 455 lpfp.
Appreciate 0
      04-22-2013, 08:51 PM   #2
deadmn1337
Captain
United_States
8
Rep
622
Posts

 
Drives: '08 JB E92 335xi
Join Date: Mar 2010
Location: Long Beach

iTrader: (9)

I just got my HPFP replaced, before it was replaced i was getting code for lpfp fail and lpfp sensor fail. Dealer only change the hpfp and everything is working now with no codes. so quite possible. I was getting hpfp codes at the same time though.
Appreciate 0
      04-22-2013, 08:59 PM   #3
racerg35335
Private First Class
4
Rep
101
Posts

 
Drives: Space gray 335i coupe
Join Date: Feb 2012
Location: Greenwood, SC

iTrader: (0)

Quote:
Originally Posted by deadmn1337 View Post
I just got my HPFP replaced, before it was replaced i was getting code for lpfp fail and lpfp sensor fail. Dealer only change the hpfp and everything is working now with no codes. so quite possible. I was getting hpfp codes at the same time though.
Yea I have gotten both lp sensor and pump failure codes as well. I have had nothing on the hp side yet. Were you getting long cranks and the usual hpfp symptoms? I have yet to experience any of the usual symptoms which, in combination with the codes, made me fell sure the problem was in the low pressure system. Thanks for the reply. That atleast lets me know of another possibility...and hopefully a warranty fix.
__________________
Space Gray 6mt e92, coral red,Cobb tuned, custom e30 map, bms DCI, ETS FMIC, walbro 455 lpfp.
Appreciate 0
      04-22-2013, 09:01 PM   #4
deadmn1337
Captain
United_States
8
Rep
622
Posts

 
Drives: '08 JB E92 335xi
Join Date: Mar 2010
Location: Long Beach

iTrader: (9)

yeah i had semi long cranks and a lot of stumbling when the car was cold.
Appreciate 0
      04-22-2013, 09:03 PM   #5
racerg35335
Private First Class
4
Rep
101
Posts

 
Drives: Space gray 335i coupe
Join Date: Feb 2012
Location: Greenwood, SC

iTrader: (0)

Quote:
Originally Posted by deadmn1337 View Post
I just got my HPFP replaced, before it was replaced i was getting code for lpfp fail and lpfp sensor fail. Dealer only change the hpfp and everything is working now with no codes. so quite possible. I was getting hpfp codes at the same time though.
Btw. Do you remember if you were getting 2A2D codes.. low fuel pressure. Thanks again.
__________________
Space Gray 6mt e92, coral red,Cobb tuned, custom e30 map, bms DCI, ETS FMIC, walbro 455 lpfp.
Appreciate 0
      04-22-2013, 10:19 PM   #6
deadmn1337
Captain
United_States
8
Rep
622
Posts

 
Drives: '08 JB E92 335xi
Join Date: Mar 2010
Location: Long Beach

iTrader: (9)

I believe that is the code, ill check the paperwork from the Dealer tomorrow cuz its at work.
Appreciate 0
      04-22-2013, 11:17 PM   #7
jdbretz
Captain
jdbretz's Avatar
9
Rep
794
Posts

 
Drives: '07 E92 335i, '07 E70 X5 4.8i
Join Date: Dec 2010
Location: Florida

iTrader: (9)

Check out this thread. It may be related to what you are experiencing:

http://www.e90post.com/forums/showthread.php?t=821304

It may not be related, but something else you could check.
Appreciate 0
      04-22-2013, 11:27 PM   #8
Jeller
Lieutenant
United_States
5
Rep
497
Posts

 
Drives: 2007 335i E90 ZSP
Join Date: Oct 2008
Location: Buffalo NY

iTrader: (5)

Send a message via AIM to Jeller
Quote:
Originally Posted by jdbretz View Post
Check out this thread. It may be related to what you are experiencing:

http://www.e90post.com/forums/showthread.php?t=821304

It may not be related, but something else you could check.
Or possibly a line burst? did you use the correct submersible fuel line?
Appreciate 0
      04-23-2013, 09:20 AM   #9
dfv2
Lieutenant
dfv2's Avatar
United_States
7
Rep
474
Posts

 
Drives: 2009 CTS-V
Join Date: Apr 2010
Location: Upstate NY

iTrader: (3)

Replacing my HPFP cured my LPFP under-target issues completely. I thought my LPFP was going for a while. Logs of HPFP and LPFP seamed to indicate the LPFP was the culprit. I finally starting hitting limp mode under WOT, and popped codes associated with the HPFP recall, so I had it replaced under that campaign just to rule it out. I have not had an LPFP issue since, it's good to go with ~E45 FBO.
__________________
//ecg//
Appreciate 0
      04-23-2013, 03:49 PM   #10
racerg35335
Private First Class
4
Rep
101
Posts

 
Drives: Space gray 335i coupe
Join Date: Feb 2012
Location: Greenwood, SC

iTrader: (0)

Quote:
Originally Posted by deadmn1337 View Post
I believe that is the code, ill check the paperwork from the Dealer tomorrow cuz its at work.
Thanks. If ayou have a list of the codes you were throwing that would be helpful. I appreciate it.

Quote:
Originally Posted by jdbretz View Post
Check out this thread. It may be related to what you are experiencing:

http://www.e90post.com/forums/showthread.php?t=821304

It may not be related, but something else you could check.
Quote:
Originally Posted by Jeller View Post
Or possibly a line burst? did you use the correct submersible fuel line?
Thanks guys. Yea I have seen that thread. I am using the proper line and hae checked connections a few times. I was having the same issue with the stock pump so I don't think it has anything to do with the walbro.

Quote:
Originally Posted by dfv2 View Post
Replacing my HPFP cured my LPFP under-target issues completely. I thought my LPFP was going for a while. Logs of HPFP and LPFP seamed to indicate the LPFP was the culprit. I finally starting hitting limp mode under WOT, and popped codes associated with the HPFP recall, so I had it replaced under that campaign just to rule it out. I have not had an LPFP issue since, it's good to go with ~E45 FBO.
That sounds like my problem exactly. Everything points to thelp side. Car ran fine for a while with lp under target but I am now getting limp mode with fuel pump. Lp sensor. Injector shutdown codes. Do you remeber off hand the codes you had?? I will have to uninstall my cobb and hope they pop up again. Only thing I haven't had is long cranks which steared me away from the hpfp.. but that's the only thing I can see the problem being at this point. Thanks for your input!
__________________
Space Gray 6mt e92, coral red,Cobb tuned, custom e30 map, bms DCI, ETS FMIC, walbro 455 lpfp.
Appreciate 0
      04-23-2013, 04:20 PM   #11
Ænema
Captain
10
Rep
961
Posts

 
Drives: BMW
Join Date: Aug 2012
Location: Arizona Bay

iTrader: (0)

Wishing you luck on getting this fixed!!!
__________________
"I'm not surprised you get along well with all the other neighbours. If you put fifty children with Down's syndrome in a room there is going to be a lot of hugging." David Thorne
Appreciate 0
      04-23-2013, 04:31 PM   #12
deadmn1337
Captain
United_States
8
Rep
622
Posts

 
Drives: '08 JB E92 335xi
Join Date: Mar 2010
Location: Long Beach

iTrader: (9)

Just looked at my paperwork, i did have a 2A2D code which they replaced the low fuel pressure sensor along with the hpfp.

Sounds like hpfp is your culprit if you haven't changed it yet.
Appreciate 0
      04-23-2013, 04:33 PM   #13
racerg35335
Private First Class
4
Rep
101
Posts

 
Drives: Space gray 335i coupe
Join Date: Feb 2012
Location: Greenwood, SC

iTrader: (0)

Quote:
Originally Posted by Ænema View Post
Wishing you luck on getting this fixed!!!
Thanks man. Its driving me crazy not to mention a lot of time and $500+ so far. Luckily I have another vehicle. Probably gonna have to go to the stealership and suck it up. Hopefully its the hpfp under warranty.
__________________
Space Gray 6mt e92, coral red,Cobb tuned, custom e30 map, bms DCI, ETS FMIC, walbro 455 lpfp.
Appreciate 0
      04-23-2013, 04:36 PM   #14
racerg35335
Private First Class
4
Rep
101
Posts

 
Drives: Space gray 335i coupe
Join Date: Feb 2012
Location: Greenwood, SC

iTrader: (0)

Quote:
Originally Posted by deadmn1337 View Post
Just looked at my paperwork, i did have a 2A2D code which they replaced the low fuel pressure sensor along with the hpfp.

Sounds like hpfp is your culprit if you haven't changed it yet.
Hopefully so. I know the car was on its third hpfp when I bought over a year ago. My pump has a part number on it ending with -02 and from what I have seen the newest version is ends with -03. Thanks for taking the time to look for me.
__________________
Space Gray 6mt e92, coral red,Cobb tuned, custom e30 map, bms DCI, ETS FMIC, walbro 455 lpfp.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:24 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST